Sign in to follow this  
RedAV8R

[0.25] Realism Overhaul w/ RedAV8R [Terminated]

Recommended Posts

I just installed the latest realfuels as per your advice, going to test it. Something I did notice in my own limited-modding-knowledge digging, I downloaded both 5.2.1 and 5.2 and compared the .cfg files included in both. I noticed in 5.2 there is a whole lot more in your RedAV8R folder. Did things get moved around, or did I lose some files in extraction/download? Specifically, the realengines cfg's from 5.2 are absent in my 5.2.1 folder.

Notice there are folders now in the RedAV8R folder...those in the RedAV8R folder were distributed as required to those folders, because some new parts are created...with PartCatalog they'd end up in the RO tab...those folders now make it easy for a person to simply cut and paste them to the GameData folder if they want so that new parts appear in the respective mod tab...FASA parts in the FASA tab...Yes I know one could move them within PartCatalog, but this is easier to do once, rather than every time as things are swapped in and out while developing and testing. A little organization never hurt anyone:)

EDIT:::OH CRAP...well that about does it...since functionally speaking 6.0alpha isn't missing anything I'm going to make that release. You are right, missed some files...

EDIT:::UM...maybe I didn't...well, so there won't be any more confusion I'm going to release 6.0 alpha so at least the file structure is the same, and makes my life easier when troubleshooting.

Edited by RedAV8R

Share this post


Link to post
Share on other sites
Notice there are folders now in the RedAV8R folder...those in the RedAV8R folder were distributed as required to those folders, because some new parts are created...with PartCatalog they'd end up in the RO tab...those folders now make it easy for a person to simply cut and paste them to the GameData folder if they want so that new parts appear in the respective mod tab...FASA parts in the FASA tab...Yes I know one could move them within PartCatalog, but this is easier to do once, rather than every time as things are swapped in and out while developing and testing. A little organization never hurt anyone:)

Oh neat. I didn't even realize that! You should tell us these things lol. As a user of PartCatalog, that is some nice info.

Share this post


Link to post
Share on other sites

Yalin Hawk: I see no evidence of RealEngines at all. I'm guessing the file situation is in flux as RedAV8R says. Sorry!

Other log notes: 1. Update KM_Gimbal

2. Planetfactory is causing exceptions. Quite possibly that is breaknig some orbits.

Share this post


Link to post
Share on other sites

Agathorn...yeah...that should be put into the ReadMe, I know I had mentioned it once or twice here, but just like any of us...we miss things.

Share this post


Link to post
Share on other sites
I just installed the latest realfuels as per your advice, going to test it. Something I did notice in my own limited-modding-knowledge digging, I downloaded both 5.2.1 and 5.2 and compared the .cfg files included in both. I noticed in 5.2 there is a whole lot more in your RedAV8R folder. Did things get moved around, or did I lose some files in extraction/download? Specifically, the realengines cfg's from 5.2 are absent in my 5.2.1 folder.

Edit:

Just tried it with the latest RealFuels 6.3, still have the same specific bug with the RL10B-2 from Aerojet Kerbodyne and also the RD-0146 from SovietEngines.

EditEdit:

Also, none of the other engines have any sort of updated stats. KW Vesta has same stats from a vanilla KW install. I'm going to take a leap and assume it has something to do with my missing the rss_realengines_x.cfg's?

Give me 10min and OP will be updated with new v6.0 alpha release with fixes to the Aerojet and RD-0146 from Bobcat.

Share this post


Link to post
Share on other sites

Woo, works fine now guys. Well...sorta... I have a new problem :confused: when I launch my rockets every engine on the ship activates at once, regardless of staging. But the engine config issue is fixed!

Share this post


Link to post
Share on other sites
Problem confirmed with the Aerojet Kerbodyne Orion SM engine and the RL-10B engine (the non-Aerojet one).

What problem?

Also, I've noticed the K2-X and its multiple-mount sister aren't getting the realfuels and realengines stats.

They don't have them yet:)

Share this post


Link to post
Share on other sites
What problem?

They don't have them yet:)

Ahhh okay, that'd explain it :D

The issue with stage-ignoring? At launch those engines activate regardless of what stage they're in.

Share this post


Link to post
Share on other sites

Could you use

@MODULE[ModuleEngines*]

instead of

@MODULE[ModuleEngines]

So that both ModuleEngines and ModuleEnginesFX can be supported?

Share this post


Link to post
Share on other sites
Could you use

@MODULE[ModuleEngines*]

instead of

@MODULE[ModuleEngines]

So that both ModuleEngines and ModuleEnginesFX can be supported?

I believe I missed responding to this similar question in the other thread. Hot Rockets is on my list to support, I'm not there yet.

Share this post


Link to post
Share on other sites
Ahhh okay, that'd explain it :D

The issue with stage-ignoring? At launch those engines activate regardless of what stage they're in.

Get your main game folder out of the Program Files directory, move it to C: or C:\games or something.

Share this post


Link to post
Share on other sites

The top post says ModuleFixer is required but the link only goes to source with no compiled mod. What does this do, and where can I get it?

Share this post


Link to post
Share on other sites
The top post says ModuleFixer is required but the link only goes to source with no compiled mod. What does this do, and where can I get it?

No the OP says it's best with...it's not required...hopefully with 0.24 nobody has to mess with it.

Share this post


Link to post
Share on other sites

Oooh! Another question! There are two re-releases of B9: REPACK and Repaired. Any recommendations on which is the correct one to use? I just noticed yesterday that whatever version I have installed doesn't have rescaled landing gear, but I don't remember which one I downloaded last time. (I cleared out my "installed mods folder" since it was building up a lot of cruft, and lost the .zip I used.)

Share this post


Link to post
Share on other sites
Oooh! Another question! There are two re-releases of B9: REPACK and Repaired. Any recommendations on which is the correct one to use? I just noticed yesterday that whatever version I have installed doesn't have rescaled landing gear, but I don't remember which one I downloaded last time. (I cleared out my "installed mods folder" since it was building up a lot of cruft, and lost the .zip I used.)

Well...what is in here now is for the original...a lot has happened since then...I will be repairing it, just not there yet. I'd honestly forgo the B9 until I can ensure RO standards.

Share this post


Link to post
Share on other sites
I believe I missed responding to this similar question in the other thread. Hot Rockets is on my list to support, I'm not there yet.

As long as you replace all ModuleEngines or ModuleEnginesFX with ModuleEngines* I believe it's fine

Share this post


Link to post
Share on other sites

Hi there!

This is my first time trying to install this, but my game it gets stuck on Squad/parts/engine/engineLargeSkipper/part/engineLargeSkipper

I didnt do anything to the squad folder so Ive god no idea on this one Im only trying to get it to work with RSS, Overhaul, DRE, FAR, the toolbar, KJR, TAC life support, and module manager right now. Module manager says 402 patches applied and 2 hidden items. Any ideas? Im not sure what I could be doing wrong.

Share this post


Link to post
Share on other sites
Hi there!

This is my first time trying to install this, but my game it gets stuck on Squad/parts/engine/engineLargeSkipper/part/engineLargeSkipper

I didnt do anything to the squad folder so Ive god no idea on this one Im only trying to get it to work with RSS, Overhaul, DRE, FAR, the toolbar, KJR, TAC life support, and module manager right now. Module manager says 402 patches applied and 2 hidden items. Any ideas? Im not sure what I could be doing wrong.

Really need logs to have any hope of helping with this.

- - - Updated - - -

No the OP says it's best with...it's not required...hopefully with 0.24 nobody has to mess with it.

What the heck IS ModuleFixer?

Share this post


Link to post
Share on other sites
The game doesnt load, I dont think I have a log. If I do can ya tell me where to find it? :D Ill post it to my dropbox :D Thanks for the quick reply :D

Two files, and they should both get filled in at least up to the point it hangs. One is KSP.log in your KSP install directory. The other is output_log.txt in the KSP\KSP_Data directory. Assuming Windows.

Share this post


Link to post
Share on other sites
[ModuleManager] compiling list of loaded mods...

Mod DLLs found:

Assembly-CSharp v1.0.0.0

ModuleManager v2.1.5.0

aaa_Toolbar v1.0.0.0

DeadlyReentry v2.1.5232.37351

FerramAerospaceResearch v1.0.0.0

ferramGraph v1.0.0.0

RealSolarSystem v1.0.0.0

Non-DLL mods added:

RealismOverhaul

Mods by directory (subdirs of GameData):

000_Toolbar

NASAmission

Squad

Kerosene not found in resource database. Propellant Setup has failed.

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

NullReferenceException: Object reference not set to an instance of an object

at ModuleEngines.SetupPropellant () [0x00000] in <filename unknown>:0

at ModuleEngines.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Did you install RealFuels?

Share this post


Link to post
Share on other sites

Ok! Ill track down the other log :D I edited my post above with the output log :D

EDIT: I was originally getting help here http://forum.kerbalspaceprogram.com/threads/84711-Intimidated-by-RSS-Realism-Overhaul-Help-anyone?p=1245092#post1245092 and was told a lot of those mods were not "strict requirements" I do not have real fuels installed, only the ones I mentioned above. I am now assuming that Real fuels is one that is a strict requirement?

Here is the KSP.log if you still need it :)https://www.dropbox.com/s/otakh0cv0hmn937/KSP.log Thanks for the help :D

Edited by Rassa Farlander

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this