Jump to content

[1.1] BDArmory v0.11.0.1 (+compatibility, fixes) - Apr 23


BahamutoD
 Share

Recommended Posts

13 minutes ago, Thingymajigy said:

Umm...is there any way to lock on to a moving ground vehicle or do you have to just manually adjust the targeting pod? So far I've only got a HARM to try hit a moving radar and it missed.

It would be possible if we got ground radar, as pods can track locked radar signatures.

Otherwise, you'll be shafted and have to rely on the AIM-9.

 

@Aerolfos The problem with most cruise missiles is that they tend to require in-flight adjustment for flying under the radar/"sea skimming". Launching one to 30m or even 160m cruise altitude causes them to splash down more often than not, and their ability to correct for that is limited (manual correction is a bit of a gamble, with adjusting a slider on a moving object.)

Not to mention ground-hugging, which is flat out impossible in the current state - the missiles keep their altitude ASL, not above ground.

 

@BahamutoD Is getting cruise missiles to automatically terrain mask at all possible, by the way? If yes, do you have plans?

Edited by Angstinator
Link to comment
Share on other sites

2 hours ago, Thingymajigy said:

Umm...is there any way to lock on to a moving ground vehicle or do you have to just manually adjust the targeting pod? So far I've only got a HARM to try hit a moving radar and it missed.

Enable "CoM" track.

Link to comment
Share on other sites

I encountered a bug.  I loaded KSP (1.0.4) went into the Space Plane Hanger and put some parts from your beautiful mod onto a stock plane, i then clicked the launch button only to see a blank part of space where prograde retrograde etc. markers were all on the same place on the Nav ball.  moving the camera is impossible and the only way out is to restart KSP.  before installing the mod KSP worked fine, (I am on a 2009 iMac, if anyone is interested) I hope there is an easy fix or to see it fixed in the next update.  I have to say beautiful mod love the textures and mod all together, my favorite mod. :)

Link to comment
Share on other sites

1 hour ago, Amazn1234 said:

I encountered a bug.  I loaded KSP (1.0.4) went into the Space Plane Hanger and put some parts from your beautiful mod onto a stock plane, i then clicked the launch button only to see a blank part of space where prograde retrograde etc. markers were all on the same place on the Nav ball.  moving the camera is impossible and the only way out is to restart KSP.  before installing the mod KSP worked fine, (I am on a 2009 iMac, if anyone is interested) I hope there is an easy fix or to see it fixed in the next update.  I have to say beautiful mod love the textures and mod all together, my favorite mod. :)

Is it a fully stock install aside from bdarmory? If so, then upload your ksp log file (found inside the main ksp folder) to dropbox or pastebin when it happens so we can see what is going on. Also, you could try redownloading and reinstalling bdarmory and see if the problem still occurs.

Welcome to the forums! :)

Edited by Whizzkid
Link to comment
Share on other sites

3 hours ago, SlabGizor117 said:

Hey Baha, I'm sure this has been asked before, but I don't wanna go through 25 pages looking for the answer.  Is there an ETA for updating to 1.0.5?  It hasn't seemed to work for me in its current state.

What isn't working? It works great for most of us. Did you do a full clean install? Or did you overwrite anything? Also window, Linux....

Link to comment
Share on other sites

10 hours ago, SlabGizor117 said:

Hey Baha, I'm sure this has been asked before, but I don't wanna go through 25 pages looking for the answer.  Is there an ETA for updating to 1.0.5?  It hasn't seemed to work for me in its current state.

Don't ask ETA for anything on these forums, it's impossible to put a date on anything created in free time.

 

As for you having issues, you could try replacing the plugin with the one on github and see if that fixes it.

Edited by Bovan
Link to comment
Share on other sites

Hi! I've been using this mod for awhile now, and it has always been flawless (as far as I'm concerned :D ), but recently I downloaded the Kerbin on Fire Contract pack. Now, the first six targets were fine (though sometimes challenging), but the 7th target was in the mountains to the west of Kerbin. I figured I should go ahead and use some laser guided missiles, like I had for several other targets. However, these missiles refused to go to the designated target. They just went more or less straight ahead. I have no idea why they would suddenly stop working. Does the designator have some height limit? Was it aiming at the ground behind them? I'm not really sure. I have a video here to show exactly what had happened to me. If anyone knows whats going on, that would be great if you shared :) 

https://youtu.be/LY5hDfRWGBY

Link to comment
Share on other sites

On 14.12.2015, 08.35.42, Thingymajigy said:

Aaaand? Nothing happened

It should lock on to the center of mass of vehicles you lock on to then. It can be a bit finicky, but if you just go the normal way of locking something with it enabled, it should at some point "snap" to the vehicle. It will then follow it around. Works for me.

Link to comment
Share on other sites

is there any way to use the planned patriot missile launcher before its officially released? i have no idea whats going on with the github, it looks nothing like what youd download from kerbalstuff, and id LOVE to try out a feature like this :3

 

Link to comment
Share on other sites

1 hour ago, kavi said:

Could you develop a fly by wire system for space fighters and ai, mabye assigning action groups to diferent axes.

That's a lot to ask for.^^

Luckily, there is already a true Fly By Wire mod that interprets your input (not to be confused with Advanced FBW, which is a joystick mod):

That said, Boris' FBW mod is still best for making impractical planes fly well. It has a similar - if lesser - problem like BDA with how it doesn't yet reach the capability of real life FBW, which is ofc to control deliberatly super instable planes. Still a very interesting and usefull mod!

Link to comment
Share on other sites

Alrighty... so im on KSP 1.0.4 and for me the newest version of the mod does not work at all (after checking the location and confirming the actual location of where its supposed to be). So I downloaded the first version for 1.0.4 and the parts do load in but the weapon manager does not work. I cannot fire any gun/missles, the action groups dont even work so now there just stock models that make it look purty.

 

If someone could give me a tutorial that could be swell

 

-L33t327

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...