Jump to content

[1.1] BDArmory v0.11.0.1 (+compatibility, fixes) - Apr 23


BahamutoD
 Share

Recommended Posts

36 minutes ago, harpwner said:

I looked at the code and simply can't find the culprit. Granted I only saw the parts directly involved with the tab, but the memory leak (which is what I believe this is) doesn't make sense code-wise. I'm not an expert with code though, still kinda working on my skills with it.

Nevertheless, I couldn't find the problem and just don't have the time to comb through all of the code, sorry guys :/

I'll keep taking the occasional look but I'm quite busy.

I've looked through it some as well, and I have absolutely no idea why it's doing what it's doing. I made it write the contents of the Unity scene to the debug log, and it seems to create copies of all the textures and models for any part that has a WeaponModule or a MissileLauncher, which means all guns, bombs, and missiles.

Link to comment
Share on other sites

1 hour ago, gajbooks said:

I've looked through it some as well, and I have absolutely no idea why it's doing what it's doing. I made it write the contents of the Unity scene to the debug log, and it seems to create copies of all the textures and models for any part that has a WeaponModule or a MissileLauncher, which means all guns, bombs, and missiles.

That explains alot, maybe there's a line of code somewhere that copies textures but continuously loops out of control instead of stopping at a single copy?

Link to comment
Share on other sites

On 5/18/2016 at 9:45 AM, Wood_Worm said:

is there a version of BD armoury that works for ksp 1.0.4?

it wold help me if there was, and if there is can you send me the link?

1. update ksp(duh!)

2. I think you should chesk on Github. he may have it on there. Check on the first page of this topic

 

Link to comment
Share on other sites

This thread is being locked under BahamutoD's consent.

Please bear in mind that BDArmory is NOT YET PORTED to 1.1.2, every issue that comes from using a mod at an unsuported version is none of the content creator's business, if you face any issue whilst using this mod on KSP 1.1.2 DO NOT REPORT IT ANYWHERE.

So, if you want to use BDArmory v0.11.0.1 on KSP 1.1.2 you are on your own.

If you want to help, you can find BDArmory's GitHub repository linked on the first post of this thread, and make pull requests. Other than that there is nothing that can be done for now.

Reported issues that come up from using the aforementioned version of this mod on the current KSP version will also be shut down for that reason.

This thread will be unlocked as soon as the mod development continues.

 

Edit: The mod is now being maintained by @Papa_Joe and others, you can find it here: 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...