Jump to content

[1.1] NavUtilities, ft. HSI & Instrument Landing System


Recommended Posts

hi,so i just installed this mod on a 1.1.3 ksp, it seems to not be working, i do have RPM,  installed (along with a LOT of other mods) and when i go into cockpit view, click on the RPM monitor (a button) and it goes to the NAVball, the other one, and then, i click, and it makes the sound, but no screen change, if i click again it does the same thing, but at the third time, it changes to the NAVball, so my thoughts are, it is there, it is loaded, but it isnt correctly loaded, i've already tried to activate the toolbar option, and when i go to the "show icons" menu, it isnt there... has it happen to anyone? does anyone knows how to fix it
i already tried to delete most mods, and no luck...

Link to post
Share on other sites
On 9/2/2016 at 8:19 PM, Ser said:

I just assume that the log was not complete. So I ask you to make sure the bug is reproduced and post the output_log.txt right after that again. Of course, if you launch 64 bit version the file should be from KSP_x64_Data folder, just in case. The thing is that every time I saw a similar issue there was a clear error message in the log. If it's a conflict with some mod it most likely result in exception too. So it should be there if the log is correct.

Please do take the time to read the thread a bit. You'll find a suggested fix by Ser. Also, you will find out that using RSS along with its dependencies will cause another breakdown. 

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
19 hours ago, Kevlarburrito said:

Is there a fix for the game getting stuck on loading analogHSI?

I've tried the previously mentioned fixes:

replacing the .dll file
and ensuring the file structure is correct

If you're using the dll I've posted on 29 June then it is for KSP 1.1.3 and most likely won't work for 1.2 as majority of mods don't. @kujuman seems to visit forum time to time so may be he'll update the mod soon. If not, I'll try to help him but not earlier than FAR gets updated.

Link to post
Share on other sites

I figured it out. 

I had to uninstall the game, delete the data folder with existing mods, reinstall the game, then install one mod at a time launching the game to the main start screen each time. Seems to have fixed THAT issue.

Now I appear to have encountered a memory leak issue. Appears to be the old Squad issue. 

Link to post
Share on other sites

this seems to be whats keeping this from working in 1.2 or at least loading anyway. halts loading on the HSI. is there some reason for both the tga and png files? i would think you would only need the PNG's now. 

[LOG 14:28:52.055] PartLoader: Compiling Internal Prop 'KerbalScienceFoundation/NavInstruments/Props/prop/analogHSI'
[ERR 14:28:52.066] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[ERR 14:28:52.067] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[EXC 14:28:52.068] FileNotFoundException: Could not load file or assembly 'KSPUtil, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    NavUtilLib.GlobalVariables.Settings.loadNavAids ()
    NavUtilLib.Analog.AnalogHSI.OnAwake ()
    InternalModule.Load (.ConfigNode node)
    InternalProp.AddModule (.ConfigNode node)
    InternalProp.Load (.ConfigNode node)
    PartLoader.LoadInternalProp (.UrlConfig urlConf)
    PartLoader+<CompileInternalProps>c__Iterator63.MoveNext ()
    UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)
[EXC 14:56:48.179] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
    System.Collections.Generic.List`1[LoadingScreen+LoadingScreenState].get_Item (Int32 index)
    LoadingScreen+<UpdateLoadingScreen>c__Iterator5E.MoveNext ()
    UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)
 

Link to post
Share on other sites

It isn't my thing to publish anything that isn't tested enough so I cannot guarantee if it works right. For some reason it doesn't show up in the Blizzy's toolbar and I have no idea if it is visible in RPM. 

But hence people suffer you can download a dll recompiled for KSP 1.2.1 as a temporary fix here: https://www.dropbox.com/s/m0awajz3uilyycr/NavUtilLib.dll?dl=1

Replace NAVUtilLib.dll in the mod's folder with this to get at least the separate HSI window working.

Link to post
Share on other sites
On 2016/11/5 at 7:04 PM, Ser said:

It isn't my thing to publish anything that isn't tested enough so I cannot guarantee if it works right. For some reason it doesn't show up in the Blizzy's toolbar and I have no idea if it is visible in RPM. 

But hence people suffer you can download a dll recompiled for KSP 1.2.1 as a temporary fix here: https://www.dropbox.com/s/m0awajz3uilyycr/NavUtilLib.dll?dl=1

Replace NAVUtilLib.dll in the mod's folder with this to get at least the separate HSI window working.

I can confirm this recompilation also works nicely in RPM. Thanks for your effort!

cjzadQ6.jpg

Link to post
Share on other sites
On 5.11.2016 at 0:04 PM, Ser said:

It isn't my thing to publish anything that isn't tested enough so I cannot guarantee if it works right. For some reason it doesn't show up in the Blizzy's toolbar and I have no idea if it is visible in RPM. 

But hence people suffer you can download a dll recompiled for KSP 1.2.1 as a temporary fix here: https://www.dropbox.com/s/m0awajz3uilyycr/NavUtilLib.dll?dl=1

Replace NAVUtilLib.dll in the mod's folder with this to get at least the separate HSI window working.

Oh, Ser, let me kiss you!

a010.gif

- Isabelle

Link to post
Share on other sites
1 hour ago, Isabelle.V.Fuchs said:

Oh, Ser, let me kiss you!

a010.gif

- Isabelle

Oh God, that's the best appreciation I ever had at this forum, Isabelle

Ah... boys, you may just give some rep though :lol:

Link to post
Share on other sites
  • 3 weeks later...
  • 4 weeks later...

Hey there I've been kitbashing Hyomoto's MFD and have successfully made it work. I'm hoping to create a release of it and I was thinking of combining it with your mod in one complete working package of all the things that we love about seeing these mods work together.

I was wondering if I could package the HSIL RPM patch or the mod as well together and distribute with credits?

Edited by jackellice
Link to post
Share on other sites

Could it be possible to implement Gael's runway from the very popular Galileo's Planet Pack into NavUtilities since it is another planet? At the moment it is headed at 61 by 241 degrees, but the next update to soon come will change it to 90 by 270

Edited by SkyKaptn
Link to post
Share on other sites
4 minutes ago, SkyKaptn said:

Could it be possible to implement Gael's runway from the very popular Galileo's Planet Pack into NavUtilities since it is another planet? At the moment it is situated at 61 by 241 degrees, but the next update to soon come will change it to 90 by 270

Looking at the mod itself, it seems rather easy to add runways.

There's a CFG file with all the runways called defaultRunways.


They look like this:

{
    ident = Island 27
        shortID = IS27
        hdg = 269.2451 
    identOfOpposite = Island 09
    body = Kerbin
    altMSL = 134
    gsLatitude = -1.516002
    gsLongitude = 288.1434
    locLatitude = -1.517254
    locLongitude = 288.0485
    
    outerMarkerDist = 10000
    middleMarkerDist = 2000
    innerMarkerDist = -1000
}

Try adding a new config file that contains a Runway structure following the same format as shown.
Or if that doesn't work, just write it into the defaultRunways.cfg and see if it comes up.

Edited by jackellice
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...