PrivateFlip

[1.4] Routine Mission Manager [v032]

Recommended Posts

Hello @PrivateFlip, I'm really enjoying the mod update for 1.1.2.  I'm having an issue, and I cannot tell if it is working as intended, or a bug.  Specifically, a vessel without crew capacity, but with a docking port, will cause the RM^2 menu icon to disappear after fully loading.  I.e. it will be there when I click on the launch button, but by the time I can pass controls and the Kerbal picture would load, it's gone.  If I add a simple pod with Kerbal, the problem goes away.  Any insight?

Share this post


Link to post
Share on other sites

OK in absence of any response I have answered my own question. This mod does NOT work with RSS/RO.

Edited by John FX

Share this post


Link to post
Share on other sites
On 5/29/2016 at 10:13 PM, panarchist said:

Hi @PrivateFlip, it's still /GameData/RoutineMissionManager,  but the path should be [installdirectory]/GameData/RoutineMissionManager, and what it's actually currently pointing to is [installdirectory]/KSP.app/GameData/RoutineMissionManager.  KSP.app is the equivalent to KSP.exe, so the root being used is one level too low.

latest version might fix this. Could you let me know either way?

20 hours ago, sirreality said:

Hello @PrivateFlip, I'm really enjoying the mod update for 1.1.2.  I'm having an issue, and I cannot tell if it is working as intended, or a bug.  Specifically, a vessel without crew capacity, but with a docking port, will cause the RM^2 menu icon to disappear after fully loading.  I.e. it will be there when I click on the launch button, but by the time I can pass controls and the Kerbal picture would load, it's gone.  If I add a simple pod with Kerbal, the problem goes away.  Any insight?

Thank you for reporting this. For some reason unmanned rockets are registered as "landed" when brought to the launchpad instead of "prelaunch" which makes the vessel fail a check to allow the start of check. I altered this check to accomodate this behaviour.

8 hours ago, John FX said:

OK in absence of any response I have answered my own question. This mod does NOT work with RSS/RO.

Sorry to hear that. I don't use those mods myself but they are pretty popular. Compatibility is always an issue when dealing with multiple mods. To be honest, I'm somewhat reluctant to invest a lot of effort into these type of issues.

There is a file "AllowedBodies.txt" in the mod folder which is used to determine for which planets the mod is enabled. If RSS also renames planets, under the hood, from say "Kerbin" to "earth", you could try finding the names RSS uses and adding these names to the file. 

 

 

Update version 019

-fixed bug where unmanned probes could not start tracking on launchpad

-possible fix for issues using mod on mac

Edited by PrivateFlip

Share this post


Link to post
Share on other sites
14 hours ago, PrivateFlip said:

There is a file "AllowedBodies.txt" in the mod folder which is used to determine for which planets the mod is enabled. If RSS also renames planets, under the hood, from say "Kerbin" to "earth", you could try finding the names RSS uses and adding these names to the file. 

Ah, that might help. I found weird stuff was happening though, life support tanks would start to float upwards at 0.2m/s eventually pulling apart the rocket or if launched then it would act like a sky hook and hang the rocket from that part in the air. I know RSS used to rename all planets except kerbin `under the hood` as kerbin was hard coded although IIRC that changed in 1.1.0 and now all planets are renamed.

Shame, the mods looks really handy.

EDIT : Also, RSS on it`s own might work as it seemed to be an incompatibility with the RO mods, life support particularly.

EDIT 2 :

14 hours ago, PrivateFlip said:

-fixed bug where unmanned probes could not start tracking on launchpad

 

Hmmm, this also was one of the issues I had. I was not getting the menu option with a probe. Might try again. ;)

Edited by John FX

Share this post


Link to post
Share on other sites
18 hours ago, PrivateFlip said:

latest version might fix this. Could you let me know either way?

Looks like that fixed it - no more error in the log, and everything looks ok.  Thanks!

Share this post


Link to post
Share on other sites
21 hours ago, PrivateFlip said:

 

Thank you for reporting this. For some reason unmanned rockets are registered as "landed" when brought to the launchpad instead of "prelaunch" which makes the vessel fail a check to allow the start of check. I altered this check to accomodate this behaviour.

 

Update version 019

-fixed bug where unmanned probes could not start tracking on launchpad

-possible fix for issues using mod on mac

Excellent! Thanks for the swift fix and update, I'm glad I could help in a small way. I love me some unmanned supply missions when playing with Life Support and Kolonization mods, and this will make it run so smoothly. Keep up the great work!

Share this post


Link to post
Share on other sites
On 5/31/2016 at 0:49 PM, John FX said:

Ah, that might help. I found weird stuff was happening though, life support tanks would start to float upwards at 0.2m/s eventually pulling apart the rocket or if launched then it would act like a sky hook and hang the rocket from that part in the air. I know RSS used to rename all planets except kerbin `under the hood` as kerbin was hard coded although IIRC that changed in 1.1.0 and now all planets are renamed.

Shame, the mods looks really handy.

EDIT : Also, RSS on it`s own might work as it seemed to be an incompatibility with the RO mods, life support particularly.

EDIT 2 :

 

Hmmm, this also was one of the issues I had. I was not getting the menu option with a probe. Might try again. :wink:

Which life support mod do you use?

On 5/31/2016 at 4:38 PM, panarchist said:

Looks like that fixed it - no more error in the log, and everything looks ok.  Thanks!

 

On 5/31/2016 at 8:14 PM, sirreality said:

Excellent! Thanks for the swift fix and update, I'm glad I could help in a small way. I love me some unmanned supply missions when playing with Life Support and Kolonization mods, and this will make it run so smoothly. Keep up the great work!

 

You're welcome! Thank you both for reporting the issues. 

Share this post


Link to post
Share on other sites
3 hours ago, PrivateFlip said:

Which life support mod do you use?

whichever one installs as part of RO. Not at my PC until friday but I`ll look then.

Share this post


Link to post
Share on other sites

HMM...

Tell me this is possible:

Someone posted a guide on reddit about creating a Kerbin/Duna Aldrin Cycler: https://www.reddit.com/r/KerbalSpaceProgram/comments/2xd3u4/kerbal_aldrin_cycler_i_did_the_math/
Super cool, lot o math, ok perfect. So we get that up and running, let's assume that goes successful.

NOW...

When the Cycler craft's crosses into Kerbin's SOI, we schedule a Routine Mission to dock with it (the ferry vessel).
It docks, and then that ferry and the Cycler exit Kerbin's SOI on its normal trajectory onwards to Duna.

THEN...

Maybe we're feeling extra special super duper cool and we automate all of this with a kOS script.

SO...

Will
That
Work?

 

 

someone.plz.say.yes.k.thx.doing.now.anyways.

Share this post


Link to post
Share on other sites

The 

On 6/9/2016 at 9:30 AM, Skrypter said:

HMM...

Tell me this is possible:

Someone posted a guide on reddit about creating a Kerbin/Duna Aldrin Cycler: https://www.reddit.com/r/KerbalSpaceProgram/comments/2xd3u4/kerbal_aldrin_cycler_i_did_the_math/
Super cool, lot o math, ok perfect. So we get that up and running, let's assume that goes successful.

NOW...

When the Cycler craft's crosses into Kerbin's SOI, we schedule a Routine Mission to dock with it (the ferry vessel).
It docks, and then that ferry and the Cycler exit Kerbin's SOI on its normal trajectory onwards to Duna.

THEN...

Maybe we're feeling extra special super duper cool and we automate all of this with a kOS script.

SO...

Will
That
Work?

 

 

someone.plz.say.yes.k.thx.doing.now.anyways.

One of the restrictions is that the craft is in orbit around Kerbin. From what I gather the cycler will be on what would be on an escape trajectory as it passes kerbin, preventing a resupply mission from being ordered. 

Share this post


Link to post
Share on other sites

I had to manually place the AllowedBodies.txt file into the actual KSP.app (and make the folders) because I was getting exceptions (on Mac), seems its still not fixed.

Share this post


Link to post
Share on other sites

I like the idea of your mod, and you gave nice instructions on how to set it up, but I think I'm doing something wrong and I would appreciate if you could help me.

When my ordered mission arrives and I switch to the vessel from tracking station, it only shows the orbit map. I can't switch to the ship view and it spams this error:

Spoiler

MissingMethodException: Method not found: 'Vessel.SetPosition'.
  at CommercialOfferings.RMMModule.dockStage4 () [0x00000] in <filename unknown>:0
  at CommercialOfferings.RMMModule.handleArrivalCompletion () [0x00000] in <filename unknown>:0
  at CommercialOfferings.RMMModule.OnFixedUpdate () [0x00000] in <filename unknown>:0
  at Part.ModulesOnFixedUpdate () [0x00000] in <filename unknown>:0
  at Part.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)


When switching back to tracking station it shows two ships. Then I switch to one of them and I get the same error as above. It doesn't matter if I switch to the normal or the ordered ship.

Ksp: 1.1.3 64bit on Windows 7

Mods installed: Routine Mission Manager

Log: output_log.txt

EDIT: Reproduced it after reinstalled KSP and RMM and with a new save. Same error again.

Edited by TheMrSeq

Share this post


Link to post
Share on other sites
On 6/26/2016 at 0:17 PM, Skrypter said:

I had to manually place the AllowedBodies.txt file into the actual KSP.app (and make the folders) because I was getting exceptions (on Mac), seems its still not fixed.

Sorry for the late responds, I will take another look at this.

 

On 7/10/2016 at 10:28 PM, TheMrSeq said:

I like the idea of your mod, and you gave nice instructions on how to set it up, but I think I'm doing something wrong and I would appreciate if you could help me.

When my ordered mission arrives and I switch to the vessel from tracking station, it only shows the orbit map. I can't switch to the ship view and it spams this error:

  Reveal hidden contents

MissingMethodException: Method not found: 'Vessel.SetPosition'.
  at CommercialOfferings.RMMModule.dockStage4 () [0x00000] in <filename unknown>:0
  at CommercialOfferings.RMMModule.handleArrivalCompletion () [0x00000] in <filename unknown>:0
  at CommercialOfferings.RMMModule.OnFixedUpdate () [0x00000] in <filename unknown>:0
  at Part.ModulesOnFixedUpdate () [0x00000] in <filename unknown>:0
  at Part.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)


When switching back to tracking station it shows two ships. Then I switch to one of them and I get the same error as above. It doesn't matter if I switch to the normal or the ordered ship.

Ksp: 1.1.3 64bit on Windows 7

Mods installed: Routine Mission Manager

Log: output_log.txt

EDIT: Reproduced it after reinstalled KSP and RMM and with a new save. Same error again.

I'm now installing 1.1.3 to see if that broke something.

EDIT: could not reproduce this. I tried this also on 1.1.3. 64 bit Windows 7. Method "Vessel.SetPosition" is an method of the game itself. Maybe the ship fails to load, I'll have to investigate this further.

Edited by PrivateFlip

Share this post


Link to post
Share on other sites
7 hours ago, PrivateFlip said:

Upadate version 020:

-made directory path logic more os indepedent
-compiled against KSP version 1.1.3

and updated the forum title....?:D

Thanks!

Share this post


Link to post
Share on other sites
On 5/31/2016 at 3:49 AM, John FX said:

Ah, that might help. I found weird stuff was happening though, life support tanks would start to float upwards at 0.2m/s eventually pulling apart the rocket or if launched then it would act like a sky hook and hang the rocket from that part in the air. I know RSS used to rename all planets except kerbin `under the hood` as kerbin was hard coded although IIRC that changed in 1.1.0 and now all planets are renamed.

Shame, the mods looks really handy.

EDIT : Also, RSS on it`s own might work as it seemed to be an incompatibility with the RO mods, life support particularly.

EDIT 2 :

 

Hmmm, this also was one of the issues I had. I was not getting the menu option with a probe. Might try again. :wink:

Did you ever try modifying the txt file to add earth and see if that worked?

 

On 6/8/2016 at 4:35 PM, John FX said:

whichever one installs as part of RO. Not at my PC until friday but I`ll look then.

It installs TACLS tac life support systems.

Share this post


Link to post
Share on other sites

It does not work in 1.2. When installed the docking ports do not show up in the vab/sph or on the tech tree. Uninstalling fixed the problem. 

This is mod is incredible! It makes the late game so much more enjoyable and less repetitive. I hope it finds its way back in 1.2.  

Share this post


Link to post
Share on other sites

Update:

-adapted for 1.2
-support for contracts has been removed for the moment

Somethings going wrong with the contract support which makes the mod non functional. I decided to release a 1.2 version without contract support now, instead of waiting until I found the time to figure out what is going wrong.

Share this post


Link to post
Share on other sites
13 minutes ago, PrivateFlip said:

Update:

-adapted for 1.2
-support for contracts has been removed for the moment

Somethings going wrong with the contract support which makes the mod non functional. I decided to release a 1.2 version without contract support now, instead of waiting until I found the time to figure out what is going wrong.

Awesome!

Share this post


Link to post
Share on other sites
19 minutes ago, PrivateFlip said:

Update:

-adapted for 1.2

And I'm just about to start a new career.  Looks like a perfect time to try this out.

 

Thanks!

Share this post


Link to post
Share on other sites

I cant get the mission to run.  I recorded the inbound, docked and all seemed good.  Registered a docking port then tried to order the mission, it seems to work but the ETA doesnt change and the ship does not appear.  Any suggestions?  Do I have to stay with the vessel until the time elapses or can I do other things?

Edited by funkcanna

Share this post


Link to post
Share on other sites
On 11/15/2016 at 3:09 PM, funkcanna said:

I cant get the mission to run.  I recorded the inbound, docked and all seemed good.  Registered a docking port then tried to order the mission, it seems to work but the ETA doesnt change and the ship does not appear.  Any suggestions?  Do I have to stay with the vessel until the time elapses or can I do other things?

 

On 11/17/2016 at 7:59 AM, funkcanna said:

Anyone?

 

Hi funkcanna, trick is the ship won't arrive if you stick around the station. If you switch to another ship and come back later the ship should have spammed at your station.

 

Share this post


Link to post
Share on other sites
1 hour ago, PrivateFlip said:

 

 

Hi funkcanna, trick is the ship won't arrive if you stick around the station. If you switch to another ship and come back later the ship should have spammed at your station.

 

Ok ill give it a try, thanks!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.