MrHappyFace

[1.0.5] BetterTimeWarp v2.2 - Customizable Time Warp, and Lossless Physics Warp

Recommended Posts

Is there a way to make anything other than "Standard Warp" be the default when a ship is loaded? (like Orbital Warping)

Share this post


Link to post
Share on other sites

This is amazing, finally i can warp 4x physically lossless, without being afraid of the game breaking apart. Using 8x physical lossless in atmosphere with FAR makes everything stutter and flicker, but hey it still works. You saved me so much time waiting for my reusable boosters to aerobreak back to KSP. Thank you!

Share this post


Link to post
Share on other sites

For the next version: Could you make it so we can set the physics loss different for each step without having to change the mode?

So we could do something like:

IE: 1- Normal flight. 2- 5x with no physics loss. 3- 15x with 1/4 physics loss. 4. 50x with 1/2 physics loss

Share this post


Link to post
Share on other sites
Since RealSolarSysten is going away this would make a nice replacement.

what do you mean by going away?????? is it ceasing to exist???? why?!?

Share this post


Link to post
Share on other sites

Does the Background Processing mod work with this?

Share this post


Link to post
Share on other sites
For the next version: Could you make it so we can set the physics loss different for each step without having to change the mode?

So we could do something like:

IE: 1- Normal flight. 2- 5x with no physics loss. 3- 15x with 1/4 physics loss. 4. 50x with 1/2 physics loss

Not sure that would be a good idea, for performance reasons. Also, more settings like that would break backwards-compatibility and clutter up the UI.

Does the Background Processing mod work with this?

I imagine it most likely would, because this mod just hijacks the stock TimeWarp system, but I haven't actually tested it.

Share this post


Link to post
Share on other sites
Is there a users guide for this? I just got it and I just can not figure out how to make it work.

After installing, there should be a little arrow beside the warp speed at the top left. Click that arrow, and you can change the set of warp levels, or even make your own if you fancy.

Once you change it, just use warp like you usually would, but recognize each step will be different. (Eg: 1x - 5x - 10x might become 1x - 25x - 100x) The set you choose will show you what each step will become.

Share this post


Link to post
Share on other sites

Would love to hear if it works with mods that interrupt time warp, such as kerbal alarm clock.

Thanks.

Share this post


Link to post
Share on other sites
Would love to hear if it works with mods that interrupt time warp, such as kerbal alarm clock.

Thanks.

Can confirm. I use Kerbal Alarm Clock myself, and have not seen any issues. I also use SafeChute, and it interacts exactly as expected - although at high physical time-warp, SafeChute can activate a bit.... late.

Share this post


Link to post
Share on other sites

Hi, i want to "control" my vessel/rover/etc while in Warp (specialy rover...), is there a solution ? I tryed to using this mod but, it's seem to dont have that.

Any idea ?

Share this post


Link to post
Share on other sites
After installing, there should be a little arrow beside the warp speed at the top left. Click that arrow, and you can change the set of warp levels, or even make your own if you fancy.

Once you change it, just use warp like you usually would, but recognize each step will be different. (Eg: 1x - 5x - 10x might become 1x - 25x - 100x) The set you choose will show you what each step will become.

Ya, that's exactly what I did... It will let me change the warp rate but it absolutely refuses to let me warp while accelerating no matter what configuration I have. I have no idea what could possibly be wrong.

Share this post


Link to post
Share on other sites
Hi, i want to "control" my vessel/rover/etc while in Warp (specialy rover...), is there a solution ? I tryed to using this mod but, it's seem to dont have that.

Any idea ?

Ya, that's exactly what I did... It will let me change the warp rate but it absolutely refuses to let me warp while accelerating no matter what configuration I have. I have no idea what could possibly be wrong.

The answer for both of you may be the same: when you're in space, you can start physical time warp by holding Shift and pressing the ">" key (or whatever key increases warp speed for you). If you don't hold Shift, it thinks that you want "on-rails" warp, which doesn't let you accelerate. Physical time warp, on the other hand, does.

Share this post


Link to post
Share on other sites

How does this handle boundary transitions from very high on-rails warp in low space to atmosphere? Imagine you are returning from Minmus with periapsis set for lithobraking and use max warp all the way. Does it terminate at the boundary or does it "skip" through to the next update, essentially embedding the craft deep within Kerbin?

Share this post


Link to post
Share on other sites
The answer for both of you may be the same: when you're in space, you can start physical time warp by holding Shift and pressing the ">" key (or whatever key increases warp speed for you). If you don't hold Shift, it thinks that you want "on-rails" warp, which doesn't let you accelerate. Physical time warp, on the other hand, does.

Still not working. Are there any known mod conflicts?

Share this post


Link to post
Share on other sites
The answer for both of you may be the same: when you're in space, you can start physical time warp by holding Shift and pressing the ">" key (or whatever key increases warp speed for you). If you don't hold Shift, it thinks that you want "on-rails" warp, which doesn't let you accelerate. Physical time warp, on the other hand, does.

I dont understand, it don't work with me, I rebind Shift, what is the command associated by default ?

Share this post


Link to post
Share on other sites
I dont understand, it don't work with me, I rebind Shift, what is the command associated by default ?

My apologies. I play on Linux, the keys are all different on other platforms. For instance:

You don't hold shift, you hold alt (or command on Mac)

So: Alt for Windows, Command for Mac, and right-Shift for Linux.

Share this post


Link to post
Share on other sites

Ok, so alt and < or > works to go between a maximum of 4 times warp while under acceleration, which having been away from KSP since .25 was a new thing to me, but yet still nothing I do will change the time acceleration rate to allow higher physics warping. Also clicking on the arrows on the top left to initiate warp while throttled up now shuts off my engines. But I suspect that may just be a new KSP feature.

I think I may have genuinely found a bug or some sort of mod conflict. Would my log file help? What is the directory location for that?

**I have no idea what I did but it works now. Thanks for bearing with me.

Edited by Bignumbers

Share this post


Link to post
Share on other sites

Just trying out BetterTimeWarp. I notice it doesn't change the warp values in either the KSC or the Tracking Centre views. As well, ever time I go to Flight mode with a new rocket, I need to reselect the custom warp settings for both on-rails and physics warp.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.