Jump to content

[1.0] LCARS Mark II - Dev and Support - Beta Release (29.04.2015)


Recommended Posts

Welcome to the forums :-)

Let me clear up some misconception

Parts: things you can use in editor to build stuff

Plugins: .dll files that extend the functionality of KSP

and now the little specialty of LCARS..

=> One Part Vessels: It's technicaly also a part, but can not be used to build other stuff in editor..

no connection nodes!

LCARS does not offer any "Parts" as you know them - LCARS is a Plugin with additionally provided but completely unnecessary OnePartVessels..

They look like Space Ships and are finished as they are..

not combinable with other KSP parts as you would expect..

So - if you want LCARS in any other part than the OnePartVessels, you would have to edit the cfg file of an other part.

Simply include the LCARS module code (in the cfg file) from one of my OnepartVessels into a cfg file of a part of your liking. (I suggest one of the command pods)

=> done..

(Can also be done by creating a Module Manager config - MM is also a plugin, that is able to change part cfg files on the fly..)

That LCARS Module Code from the cfg file, does occationally change, when I make changes to the code..

So it's bound to be updated after every LCARS update..

currently that code looks about like this:

MODULE
{
name = LCARSMarkII
engine_type = 0.1 // valid settings: 0.1,0.25,0.5,1,2,3,4,5
CrewQuartiers_MaxCrewSpace = 0 // int seat number; set to a reasonable value for this model
// resource options
max_resource_tanks = 1 // int tank number; set to a reasonable value for this model
max_resource_amount = 0.5 // float in tons; set to a reasonable value for this model
TractorAssembly_GameObjects = BackLight,FrontLight // a list of GameObects, that are actually present in the model. If you don't know the exact name(s), leave it empty.
}

You will also need those two modules:

RESOURCE
{
name = ElectricCharge
amount = 50000000
maxAmount = 50000000
}
RESOURCE
{
name = CondensedDeuterium
amount = 100
maxAmount = 500
}

It's the battery and the fuel for LCARS Impulse Drive..

Hint: visit one of the LCARS Stations - there you can refuel..

Hope that helps..

Link to post
Share on other sites

If the LCARS window does not open on it's own, then there is something wrong..

We can try to debug it..

If you tried the following:

- confirm, that your KSP version is still 1.00 and not 1.02 (..as the thread title states :-) )

- launch several times

- check logs for LCARS related errors

and found nothing, then..

then, my best guess would be

you have something wrong with the installation..

To make sure, launch one of the included LCARS ships - if they do not work, your install is screwed..

If they do work, please upload a usable(*) KSP.log file and post a link here..

maybe then, I'm able to help you further..

* you make my live easier, if you follow this procedure:

- start KSP

- load your LCARS part in editor

- launch it

- confirm, that there is no LCARS

- close KSP

=> go to: /[..]/KSP_win/KSP.log

upload this..

Thanks in advance..

I know it sucks, that it's still on 1.0..

I'm just kind of buisy these days..

..it'll be updated soon..

I promise..

So if the version is your cause, it's just a temporary thing..

Link to post
Share on other sites
Hey dose anyone know how to install this? i just cant understand how to install it and the instructions make no sense to me :/ any help?

also which is the latest Lcars Version

Hey i need your help :/ im sorry for being a pain coz im sure you've already been over this, I'm having trouble with 2 things

1st thing is the Lcars Mark II, i know you have a tutorial showing how to do it but i still don't understand it :( im new to all this and ive tried, when you say

- open the config file of your part

- add this

I'm not sure where the config is and what im putting in, im trying to get it to work for Voyager

and the 2nd thing is, when i downloaded the ship yards that worked all good until i tried to construct Voyager... i cant put the ship together because the parts wont join up properly, the only time they'll let me join them is if they are the wrong way around, here is a picture to show you ?ui=2&ik=638bf3ec53&view=att&th=14df4d828540ac56&attid=0.1&disp=safe&zw

Again im sorry to do this to you but i cant think of any other way of getting this to work unless i talk to someone who knows,

one last thing im not sure ive downloaded your most recent Lcars or Impules drive mod i dunno im so confused :blush: i saw a guy using it on youtube and he was using a teleporter and torpedoes and everything, that's how i found out about you, but i don't know what mod i need for that, or if i already have it but not your most recent one

if you can spare the time to help me id be extremely grateful :(

Hi, welcome to the forums :-)

How to install LCARS to a custom part - well - read above :-)

If you have trouble with CFG-Files, you might wanna check the KSP wiki, the KSP guids, the KSP new players forums etc..

I'd say it makes no sence, if I re-type the whole available KSP docs and forums..

Just browse the forums, the wiki and maybe use google to get your info..

We all had to do it at the beginning - now it's your turn :-)

It's an easy thing to understand - just go and read the beginners guids and stuff..

I don't know what video you talk about - there are many on youtube.

The video you saw, was probbably made with the old version of LCARS - it had weappons!

The new one does currently not have weappons.. Teleporters are there though..

LCARS Mark II is made available "as is" and currently only works with KSP 1.0.0!

See link in first post titled "Download" (intuitive isn't it :-D )

Update is on the way - but has to wait until the new weapon system is written and tested..

be patient.

About SciFi ShipYard..

It is customary to ask such question those guys who actually made a mod - I have no ties to scifi ship yards and I have downloaded it the last time in Sept.2014 - that is outdated by now..

In the first post, you will find a link to StarVision's Thread - there you should get expert help..

(the picture never showed up btw)

Well I hope that was somewhat helpull and good luck

LLAP

Link to post
Share on other sites

Alright so ive been for for awhile with this and still cant seem to get it to work, ive looked up instructions and everything and this is what i have so far try to get Lcars to work for Voyager, dunno if thats right tho, well it still dosent work so guess im missing something :blush:

PART

{

name = voy_saucer

module = Part

author = Starvision

// --- asset parameters ---

mesh = model.mu

scale=1

rescaleFactor=36

// --- node definitions ---

node_stack_bottom01 = 0.0, -2.33518, 0.0, 0.0, 0.0, 1.0, 30

node_stack_top01 = 0.0, 0.0, 0.0, 0.0, 0.0, 1.0, 30

node_stack_top02 = 0.0, -3.08451, 0.0, 0.0, 1.0, 0.0, 6

// --- sounds ---

sound_warp = running

// --- editor parameters ---

TechRequired = experimentalRocketry

entryCost = 25000

cost = 100000

category = Pods

subcategory = 0

title = Voyager Hull

manufacturer = Starfleet

description = The main section of Voyager. Creates plasma for the warp drive and also includes thrusters for VTOL activities.

// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision

attachRules = 1,0,1,1,0

// --- standard part parameters ---

mass = 100

dragModelType = Default

maximum_drag = 0.6

minimum_drag = 0.25

angularDrag = 0.25

crashTolerance = 800

maxTemp = 5000

fuelCrossFeed = True

breakingForce = 1000000

breakingTorque = 1000000

// --- SAS parameters ---

// --- internal setup ---

CrewCapacity = 7

vesselType = Ship

INTERNAL

{

name = Voyager

}

MODULE

{

name = ModuleCommand

minimumCrew = 1

}

MODULE

{

name = ModuleLight

lightName = light2

useAnimationDim = true

lightBrightenSpeed = 2.5

lightDimSpeed = 2.5

animationName = LightAnimation

useResources = true

}

// --- Engine Stuff ---

RESOURCE

{

name = Warp Plasma

amount = 500000

maxAmount = 500000

}

MODULE

{

name = ModuleGenerator

isAlwaysActive = true

OUTPUT_RESOURCE

{

name = Warp Plasma

rate = 500000000

}

}

MODULE

{

name = ModuleGenerator

isAlwaysActive = true

OUTPUT_RESOURCE

{

name = ElectricCharge

rate = 80000

}

}

RESOURCE

{

name = ElectricCharge

amount = 50000000

maxAmount = 50000000

}

MODULE

{

name = ModuleSAS

}

MODULE

{

name = ModuleReactionWheel

PitchTorque = 120000

YawTorque = 120000

RollTorque = 120000

RESOURCE

{

name = ElectricCharge

rate = 0.01

}

}

MODULE

{

name = FSengineSounds

engage = SciFi/Sounds/sound_warpstart

power = SciFi/Sounds/sound_voy_bridge

flameout = SciFi/Sounds/sound_warning

powerPitchBase = 1.0

thrustAddedToPitch = 0.0

powerFadeInSpeed = 0.7

powerFadeInDelay = 0.0

powerVolume = 2.0

engageVolume = 1.8

}

MODULE

{

name = ModuleEngines

thrustVectorTransformName = thrustTransform

exhaustDamage = False

ignitionThreshold = 0.1

minThrust = 0

maxThrust = 5000

heatProduction = 100

fxOffset = 0, -8.51542, -1.49597

PROPELLANT

{

name = Warp Plasma

ratio = 0.1

DrawGauge = True

}

atmosphereCurve

{

key = 0 500

key = 1 500

}

}

MODULE

{

name = LCARS_ImpulseDrive

RESOURCE

{

name = ElectricCharge

rate = 0.1

}

}

MODULE

{

name = ModuleRCS

thrusterTransformName = RCSthruster

thrusterPower = 450

resourceName = Warp Plasma

atmosphereCurve

{

key = 0 75

key = 1 75

}

}

MODULE

{

name = ModuleScienceExperiment

experimentID = surfacescan

experimentActionName = Scan Area

resetActionName = Delete Scan Data

reviewActionName = Review Scan Data

useStaging = False

useActionGroups = True

hideUIwhenUnavailable = True

rerunnable = True

xmitDataScalar = 10.0

}

MODULE

{

name = ModuleScienceExperiment

experimentID = enterprisestatus

experimentActionName = Captain's Log

resetActionName = Delete Log

useStaging = False

useActionGroups = True

hideUIwhenUnavailable = True

resettable = True

xmitDataScalar = 10.0

FxModules = 0

}

MODULE

{

name = ModuleScienceContainer

reviewActionName = Review Mission Data

storeActionName = Log Data

evaOnlyStorage = False

storageRange = 1000.0

}

MODULE

{

name = ModuleDataTransmitter

packetInterval = 0.01

packetSize = 0.5

packetResourceCost = 1000.0

requiredResource = ElectricCharge

DeployFxModules = 0

}

MODULE

{

name = LCARS_ShuttleBay

volume = 450

}

MODULE

{

name = LCARS_CargoBay

maxTonnage = 200

}

MODULE

{

name = LCARS_CloakingDevice

}

MODULE

{

name = LCARS_StructuralIntegrityField

}

MODULE

{

name = LCARS_FuelTransfer

}

MODULE

{

name = LCARS_CrewQuartier

}

MODULE

{

name = LCARS_TransporterSystem

}

MODULE

{

name = LCARS_WeaponSystems

}

MODULE

{

name = LCARS_PhotonTorpedo

}

MODULE

{

name = LCARS_TractorBeam

}

MODULE

{

name = LCARS_SensorArray

}

}

Link to post
Share on other sites

LOL

I have to ask it..

did you even read this post..

http://forum.kerbalspaceprogram.com/threads/86169-1-0-LCARS-Mark-II-Dev-and-Support-Beta-Release-%2829-04-2015%29?p=2010262&viewfull=1#post2010262

Oh wait - it's probbably my fault..

The old LCARS wiki on github is NOT FOR MARK II!!!!!

It seems I have not removed that old link to that old wiki in first post - my bad - sorry for the confusion..

link is gone now..

Mark II does not have an own wiki by now..

only the infos in this forum thread are relevant.

To be clear this time:

What you have in this cfg is outdated stuff from last years LCARS version beta 9.

Beta 9 is no longer supported and does no longer work. it will work on KSP version 0.24 - but not for 1.0.0 and above!

You MUST use the cfg noted in the post above (follow link)..

nothing else will work..

LCARS is in developpment and CFGs are subject to change...

Since last august, those CFGs have changed quite a bit.

That is why the old wiki is outdated..

I just have no time to write a new one..

Since no one (except you) did read it anyway..

So - only follow those instructions and you are good to go..

http://forum.kerbalspaceprogram.com/threads/86169-1-0-LCARS-Mark-II-Dev-and-Support-Beta-Release-%2829-04-2015%29?p=2010262&viewfull=1#post2010262

good luck..

Edit: PS:

when I said "read the wiki" in my last responses, I was talking about this one..

http://wiki.kerbalspaceprogram.com/wiki/Main_Page

The official KSP wiki - it explains most things to know about installing mods and changing CFG files..

Edited by philotical
Link to post
Share on other sites
Welcome to the forums.. :-)

It's in progress - please bear with me a little longer..

Yes, a welcome for someone who had joined the forum about 3 to 4 years ago. But thanks. Ok, i hadn't done anything in these years, so it is late although appropriate. ;)

Link to post
Share on other sites

Hey thanks philotical for replying and have the patients to help :P must think im the biggest idiot by now but ill check out those links you sent :kiss:

- - - Updated - - -

Oh and one last thing to sort out my confusion, if you can (no biggy) can you please send me the link to the latest version of LCARS :wink:

Link to post
Share on other sites
Hey thanks philotical for replying and have the patients to help :P must think im the biggest idiot by now but ill check out those links you sent :kiss:

- - - Updated - - -

Oh and one last thing to sort out my confusion, if you can (no biggy) can you please send me the link to the latest version of LCARS :wink:

the last version dont work with the newest version of KSP you would need the 1.0.0 version

Edited by flori1994
Link to post
Share on other sites

Sorry for the delay guys, I was in hospital

Had to undergo a severe imergency lung operation last week

they said, 2 days later I would have been dead..

Hail medicine..

I know LCARS is cool but to live is actually also cool (if you know what I mean)

I'm still officially on sick leave for an other 3 weeks - I can't give you any eta right now..

..but at least I'm sitting at my desk right now - so it can only get better..

thta's the news for now..

bye

Link to post
Share on other sites

My God. Well, I'm glad you still find yourself among the living. Real Life of course has priority.

But is there a way to downgrade back to 1.0.0 from 1.0.4 to use your last version until you have competed the update?

Edited by flori1994
Link to post
Share on other sites

yes my ksp is bought via steam

ok i can downgrade but only to version 0.90<---solved

how does i install the mod to the voyager from the [1.0.4] SciFi Shipyards [v3.0]?<--solved but no weapons

by the way i found out why lcars is not working in 1.0.4. it was the wrong ship, when i use every ship from you it works

does this works?

TractorAssembly_GameObjects = BackLight,FrontLight PhaserBanks_GameObjects = thrustTransform

TorpedoTubes_GameObjects = thrustTransform// a list of GameObects, that are actually present in the model. If you don't know the exact name(s), leave it empty.

Edited by flori1994
Link to post
Share on other sites
  • 4 weeks later...
Sorry for the delay guys, I was in hospital

Had to undergo a severe imergency lung operation last week

they said, 2 days later I would have been dead..

Hail medicine..

I know LCARS is cool but to live is actually also cool (if you know what I mean)

I'm still officially on sick leave for an other 3 weeks - I can't give you any eta right now..

..but at least I'm sitting at my desk right now - so it can only get better..

thta's the news for now..

bye

Woah, sorry to hear that Philotical. Hope you make a speedy recovery. As you say, updating this mod (awesome though it is) has to take a back seat while you recover. Take care, dude.

Link to post
Share on other sites
  • 3 weeks later...
  • 4 weeks later...
  • 2 months later...
  • 7 months later...
  • 3 months later...
4 hours ago, HUCrazy said:

How do I install this Plugin? I click on the download link and it just takes me right back here. It's annoying.

As you can see the Thread is old and not yet updatet (last Version for 0.90!?). So I think the downloads are broken and this isn`t working in KSP 1.2.x

Link to post
Share on other sites
  • Snark locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...