Jump to content

[1.11.x] USI Exploration Pack - Small parts, big adventure! [v 0.6.0]


Recommended Posts

Does USI exploration pack work with KSP 1.3.1?

I just want the floats and airbags, nothing else, so I downloaded v0.9.0 from here:

https://github.com/BobPalmer/ExplorationPack/releases

...and added the folders UmbraSpaceIndustries\SrvPack\Airbag and UmbraSpaceIndustries\SrvPack\Floats to \GameData.

I have no other mods installed.

The parts appear in the game, but have no actions associated with them - nothing happens if I right-click on the part and the action groups are empty.

How do I get them to work please?

Link to post
Share on other sites

For some reason, whenever I use a DERP pod and drop it in the atmosphere, it gets CRAZY rotation as soon as the parachute opens. It keeps accelerating, faster than the SAS can keep up with. It gets fast enough to make the parts pull apart of each other visually. This happens to me even if the pod is the only part in the vessel. Has anyone else experienced this?

Link to post
Share on other sites
1 hour ago, Samapico said:

For some reason, whenever I use a DERP pod and drop it in the atmosphere, it gets CRAZY rotation as soon as the parachute opens. It keeps accelerating, faster than the SAS can keep up with. It gets fast enough to make the parts pull apart of each other visually. This happens to me even if the pod is the only part in the vessel. Has anyone else experienced this?

Yeah, thats why I was trying to figure out adding a real chute module to the pod, but have so far not been able to get it to work.  

 

Link to post
Share on other sites

Quick question.. Im in 1.3.1 and the Otter reactor doesn't seem to be cooling down. The otter cabin doesn't take thermal panels either, and in any event, I had thought that the cooling was integral. Am I doing something wrong here? I only have a ballast tank, some dive planes and experiments and an inline float installed.

Link to post
Share on other sites
2 hours ago, Dr.LoveJoy said:

Quick question.. Im in 1.3.1 and the Otter reactor doesn't seem to be cooling down. The otter cabin doesn't take thermal panels either, and in any event, I had thought that the cooling was integral. Am I doing something wrong here? I only have a ballast tank, some dive planes and experiments and an inline float installed.

https://github.com/BobPalmer/ExplorationPack/issues/136

Link to post
Share on other sites
  • 4 weeks later...
47 minutes ago, coolguy8445 said:

Kinda surprised this hasn't been asked...Has anyone made this mod compatible with Community Category Kit (CCK)? I hate having all my rover parts just dumped in "Utility", but apparently can't figure out the right MM incantation to add them to the rover filter group.

https://github.com/BobPalmer/CommunityCategoryKit/blob/master/FOR_RELEASE/GameData/CommunityCategoryKit/common-filters.cfg

Link to post
Share on other sites
47 minutes ago, coolguy8445 said:

<sarcasm> Helpful, thanks. </sarcasm>
I'm well aware of that file. Also well aware that this mod isn't listed in the common filters, and, as I said, *I don't know how to get them there*. 

CCK operates through tags (I believe). Add cck-rover (cck-rovers?) as a tag to a given part and it will possibly show up under Rovers.

Link to post
Share on other sites
1 hour ago, AccidentalDisassembly said:

CCK operates through tags (I believe). Add cck-rover (cck-rovers?) as a tag to a given part and it will possibly show up under Rovers.

Precisely. All parts with cck-rovers in the tag should appear in that category. So if you were to add cck-rovers to the tag of the parts via MM config or by directly editing the cfg file, they should appear in that category. I would start by looking at the cfg files for parts already in the category to confirm. 

Link to post
Share on other sites
On 2/12/2018 at 10:52 PM, Tarheel1999 said:

Precisely. All parts with cck-rovers in the tag should appear in that category. So if you were to add cck-rovers to the tag of the parts via MM config or by directly editing the cfg file, they should appear in that category. I would start by looking at the cfg files for parts already in the category to confirm. 

Hmm, that's what I thought. And yet, I don't see them there. Still lumped into Utility. Here's the config I'm trying to use:

EDIT: also of note, I'm able to successfully reassign parts from other mods in the same way: 

// Doesn't work
@PART[PackRat*]:FINAL {
  @tags = cck-rovers
}

// does work
// Life Support containers
@PART[US_1R3*|US_2R3*|US_Radial_R30_Water|US_Radial_R40_Food]:FINAL {
  @tags = cck-lifesupport
}

 

Edited by coolguy8445
additional context
Link to post
Share on other sites

'@tags' is 'edit tags' - the PackRat parts don't *have* a tags field, so they can't be edited.  :wink:   Try '%tags' or just 'tags'.

 

That said, tags are tricky to edit with Module Manager, because it's a list and the most common commands just replace the entire list.  To do it right without messing anything else up, you really need to work with indexes or more convoluted methods.

Best to write a PR and add them to the main file.  :wink:

Link to post
Share on other sites
On 2/14/2018 at 6:51 PM, DStaal said:

'@tags' is 'edit tags' - the PackRat parts don't *have* a tags field, so they can't be edited.  :wink:   Try '%tags' or just 'tags'.

 

That said, tags are tricky to edit with Module Manager, because it's a list and the most common commands just replace the entire list.  To do it right without messing anything else up, you really need to work with indexes or more convoluted methods.

Best to write a PR and add them to the main file.  :wink:

Bah of course. It'd be nice if there were an easier way to debug issues like this than "look at the part file". Yeah, I'll write up a PR for these and maybe the Universal Storage life support parts. Thanks for all the help.

Link to post
Share on other sites
4 minutes ago, coolguy8445 said:

Bah of course. It'd be nice if there were an easier way to debug issues like this than "look at the part file". Yeah, I'll write up a PR for these and maybe the Universal Storage life support parts. Thanks for all the help.

Welcome to KSP. That is just how it works. 

Link to post
Share on other sites
  • 2 weeks later...

I'll preface this by saying that I think I'm asking this in the right place, but if not, feel free to berate me and send me elsewhere.

I'm trying to figure out if the placement of some of the parts from this pack within the Community Tech Tree (CTT) are placed as intended or erroneously and, if the latter, how I can best help correct it. 

One such example is the DERP Concentrated Photovoltaic array, which currently appears within the Enhanced Survivability (ES) node of CTT. From what I can tell, this is because the CTT configuration file (CTT.CFG) is using a wildcard for all parts starting with "DERP_" and assigning them to the ES node. Looking at the part configuration file, however, shows the original TechRequired parameter was for "advElectronics". Another example is the DERP MonoPropellant Fuel Cell which shows up in the ES node, but looks like perhaps it should be in the High-Power Electronics node instead.

I only noticed this because after 1000 hours I decided to start playing around with using mods and have fallen in love with the concepts of the USI mods.  When I installed CTT it struck me as strange that the DERP Concentrated Photovoltaic array appeared in the 45 science tier, when it's contemporaries didn't show up until the 160 science tier; it even appears before the basic OX-STAT Photovoltaic panels in the 90 science tier making it heck of a deal as-is. I couldn't think of a good reason why it would appear in one place in the stock tech tree, but further up when using CTT and figured maybe it was just a result of doing a quick wildcard to get things working.

I realize I could probably go in and adjust my CTT.CFG to move this around, but I guess I'm curious whether anyone else had noticed this and thought it was a bit off.  I'm happy to provide screenshots or more details if any of this is unclear. Thanks!

Link to post
Share on other sites
12 hours ago, Dead Tree Pride said:

I'll preface this by saying that I think I'm asking this in the right place, but if not, feel free to berate me and send me elsewhere.

I'm trying to figure out if the placement of some of the parts from this pack within the Community Tech Tree (CTT) are placed as intended or erroneously and, if the latter, how I can best help correct it. 

I think you're in the right place, and make good points.  :wink:  I've noted in the past that some of the parts seem to come in at odd times, and haven't really done much with the thought - you've obviously done a lot more.  May I suggest you make your edits and the submit them as a PR to RoverDude on Github?  That's really the best way to get this fixed...

Link to post
Share on other sites

@RoverDude PR issued!

If I've mucked something up I'd be happy to take any critique available as this is my first experience using git/github.  Spent the better part of the day reading/researching to avoid wasting anyone's time, so hopefully that paid off and I've made it easy on you.

For anyone wondering what the process was like, the gist of making a change like this was:

  1. Fork repo on GitHub
  2. Clone repo locally
  3. Make changes locally
  4. Commit changes locally
  5. Sync commits back to GitHub
  6. Issue PR through GitHub
  7. Cross fingers :confused:

I've omitted a lot of smaller steps that were also necessary, such as figuring out the best method for using git locally on my specific machine, setting up SSH keys to use with GitHub, etc. Those were mostly initial efforts that I don't expect to need to repeat in the future.  All-in-all, as @DStaal said above, it was amazingly easy to mod the game and test my changes in the game to make sure it was behaving as expected. Don't be afraid to jump in and contribute when you see something worth doing! 

Edited by Dead Tree Pride
Apparently I can't spell fork properly
Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...