Jump to content

[1.12.x] USI Exploration Pack - Small parts, big adventure! [v 0.6.0]


RoverDude
 Share

Recommended Posts

If you are using the Crowd Sourced Science Logs, make sure you only have one copy in GameData\Squad\Resources

I had the same problem, when I wanted to save my original science definitions (rather than overwrite them). I saved the sciencedefs.cfg as sciencebak.cfg, but the file will still load, causing the magnetometer (from Interstellar) to (not) work in a similar manner that you described.

Renaming the original science log file so that the extension is something different (e.g. scienceoriginal.bak) will resolve this error.

You can just rename the original sciencedefs to "ScienceDefs.cfg_" and leave it in the folder but it won't load. I always do this without any problems with science reports.

Edited by Olympic1
Link to comment
Share on other sites

You can just rename the original sciencedefs to "ScienceDefs.cfg_" and leave it in the folder but it won't load. I always do this without any problems with science reports.

Good to know. As long as the extension is changed, it will not load, was what I was trying to get at.

Link to comment
Share on other sites

I love this rover! :) Because of the game bug with chairs sometimes causing Kerbals to no longer respond I miniaturized and modified a Lander Can to work in place of the chair. That's to get around a bug in KSP not with your mod though :)

Link to comment
Share on other sites

Thanks for such nice mod:)

It works on my Mac, but when I try to start the game on Windows (both x86 and x64) it gets stuck here:

https://www.dropbox.com/s/6h6dlgeac4c1ycx/kerbal_freeze.png

I have this in the log file:

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


Load(Model): UmbraSpaceIndustries/PackRat/Seat/model

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I tried to delete the mod, but it it gets frozen again when loading UmbraSpaceIndustries/OKS/Assets/StationTube

Load(Model): UmbraSpaceIndustries/OKS/Assets/StationTube

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Do you have any idea how to fix this?

Link to comment
Share on other sites

Thanks for such nice mod:)

It works on my Mac, but when I try to start the game on Windows (both x86 and x64) it gets stuck here:

https://www.dropbox.com/s/6h6dlgeac4c1ycx/kerbal_freeze.png

I have this in the log file:

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


Load(Model): UmbraSpaceIndustries/PackRat/Seat/model

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I tried to delete the mod, but it it gets frozen again when loading UmbraSpaceIndustries/OKS/Assets/StationTube

Load(Model): UmbraSpaceIndustries/OKS/Assets/StationTube

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Do you have any idea how to fix this?

Honestly, absolutely none. I'd try a reinstallation of the different mods.

Link to comment
Share on other sites

Thanks for such nice mod:)

It works on my Mac, but when I try to start the game on Windows (both x86 and x64) it gets stuck here:

https://www.dropbox.com/s/6h6dlgeac4c1ycx/kerbal_freeze.png

I have this in the log file:

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


Load(Model): UmbraSpaceIndustries/PackRat/Seat/model

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I tried to delete the mod, but it it gets frozen again when loading UmbraSpaceIndustries/OKS/Assets/StationTube

Load(Model): UmbraSpaceIndustries/OKS/Assets/StationTube

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


NullReferenceException: Object reference not set to an instance of an object
at UrlDir+.MoveNext () [0x00000] in <filename unknown>:0


at GameDatabase+ .MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Do you have any idea how to fix this?

i had the same problem, if you have realchutes, update it

Link to comment
Share on other sites

Really nice mod.

However, are controls inverted intentionally (both steering & thrust) when there's no kerbonaut in control chair? Is it possible to make it uncontrollable when there's no kerbonaut onboard?

Still need to hone the configs. But the idea's totally nice.

Edited by Horus
correction
Link to comment
Share on other sites

Honestly, absolutely none. I'd try a reinstallation of the different mods.
i had the same problem, if you have realchutes, update it

The issue is solved - there were old (copied from my mac) folders Parts and Ships in the root directory

Now it works, thanks for your assistance:)

Link to comment
Share on other sites

Fun little rover, took me a few minutes to figure out how to build it. Any plans for some TAC Supplies?

You can actually attach the smallest TAC supplies (the .625) one to the same attachment nodes that the Science boxs go on, Basically you can attach any .625 item to these nodes :) so its pretty useful

Link to comment
Share on other sites

You can actually attach the smallest TAC supplies (the .625) one to the same attachment nodes that the Science boxs go on, Basically you can attach any .625 item to these nodes :) so its pretty useful

But it does not help if your building it with KAS.

Link to comment
Share on other sites

Really nice mod.

However, are controls inverted intentionally (both steering & thrust) when there's no kerbonaut in control chair? Is it possible to make it uncontrollable when there's no kerbonaut onboard?

Still need to hone the configs. But the idea's totally nice.

It's on my bug fix list :)

Fun little rover, took me a few minutes to figure out how to build it. Any plans for some TAC Supplies?
But it does not help if your building it with KAS.

Pick up the KAS extensions - it lets you attach the little TAC-LS cans

Link to comment
Share on other sites

Jeb took a DIY rover kit to Mun and had a blast! He did run into some trouble with the default KSP rover physics treating the Mun like an ice rink, but with a bit of tweaking was able to get some good traction on the slopes. If you have KAS installed, your wheels can grab the ground too!

Just add this to the bottom of "KSP\GameData\UmbraSpaceIndustries\PackRat\MiniWheel\MiniWheel.cfg" and you'll find that you will have better traction, and as an added bonus you'll be able to park on slopes without sliding downhill.

MODULE{
name = KASModuleAnchor
groundDrag = 0.05
bounciness = 0
dynamicFriction = 0.6
staticFriction = 0.8
}

Link to comment
Share on other sites

Erm got a link, search comes up with nothing.

https://github.com/dankeller/KSP-Tweaks

- - - Updated - - -

Jeb took a DIY rover kit to Mun and had a blast! He did run into some trouble with the default KSP rover physics treating the Mun like an ice rink, but with a bit of tweaking was able to get some good traction on the slopes. If you have KAS installed, your wheels can grab the ground too!

Just add this to the bottom of "KSP\GameData\UmbraSpaceIndustries\PackRat\MiniWheel\MiniWheel.cfg" and you'll find that you will have better traction, and as an added bonus you'll be able to park on slopes without sliding downhill.

MODULE{
name = KASModuleAnchor
groundDrag = 0.05
bounciness = 0
dynamicFriction = 0.6
staticFriction = 0.8
}

Nice! I may steal this ;)

Link to comment
Share on other sites

I love love love this mod!

The ability to actually bring along a rover in KAS containers and then assemble it on the Mun is something I've wanted for a really long time.

Two issues I've noticed, however:

1) when the rover flips and Kerbals get knocked out of their seats, I can't control them and they're considered to be debris. Is this a common issue? (I don't use rovers much)

2) on the Mun at least, this thing has an almost TOTAL inability to go up hills. This is a huge problem especially considering how hilly the Mun is now. Am I doing something wrong? (brakes are definitely off).

Link to comment
Share on other sites

Jeb took a DIY rover kit to Mun and had a blast! He did run into some trouble with the default KSP rover physics treating the Mun like an ice rink, but with a bit of tweaking was able to get some good traction on the slopes. If you have KAS installed, your wheels can grab the ground too!

Just add this to the bottom of "KSP\GameData\UmbraSpaceIndustries\PackRat\MiniWheel\MiniWheel.cfg" and you'll find that you will have better traction, and as an added bonus you'll be able to park on slopes without sliding downhill.

MODULE{
name = KASModuleAnchor
groundDrag = 0.05
bounciness = 0
dynamicFriction = 0.6
staticFriction = 0.8
}

NICE! any idea if this works with ALL wheels, or just these?

Link to comment
Share on other sites

Jeb took a DIY rover kit to Mun and had a blast! He did run into some trouble with the default KSP rover physics treating the Mun like an ice rink, but with a bit of tweaking was able to get some good traction on the slopes. If you have KAS installed, your wheels can grab the ground too!

Just add this to the bottom of "KSP\GameData\UmbraSpaceIndustries\PackRat\MiniWheel\MiniWheel.cfg" and you'll find that you will have better traction, and as an added bonus you'll be able to park on slopes without sliding downhill.

MODULE{
name = KASModuleAnchor
groundDrag = 0.05
bounciness = 0
dynamicFriction = 0.6
staticFriction = 0.8
}

I've not tested it but it should work on all wheels.

Does anyone know how to wrap this up in a mm config that gets applied to all rover wheels?

Link to comment
Share on other sites

@dak180

Maybe try:

@PART
[*]:HAS[@MODULE[ModuleWheel]]
{
MODULE {
name = KASModuleAnchor
groundDrag = 0.05
bounciness = 0
dynamicFriction = 0.6
staticFriction = 0.8
}

}

Afaik Gear Bay (spaceplane wheel) has different module so it will not apply. If it will work at all, can't test atm.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...