Jump to content

[1.12.x] USI Exploration Pack - Small parts, big adventure! [v 0.6.0]


RoverDude
 Share

Recommended Posts

  • 1 month later...

I wanted to pass on my compliments for a brilliant mod. The rover is fantastic and fun to drive. I disable the steering for the rear wheels and that prevents potentially problematic super-tight turns. It is still pretty nimble without the rear steering. I ran it around KSC and took it over to LC-34. There is an earthen ramp there meant to protect some fuel tanks. I used to to catch some air with the rover! There thing is practically indestructable. I have only one minor quibble: I am on 1.10 and using KAS to assemble the two frame pieces and it proved quite frustrating to get them to line up properly at the right node. It required a great deal of manipulation, but I eventually got it once I figured out how to shift the nodes around. The rest of the rover assembled like a dream. 
 

One more minor observation: do the science packs actually hold anything? If so I couldn’t figure out how to open their inventory. 
 

Thanks again for the great work! 

Link to comment
Share on other sites

I'm a bit confused by the terminology. Science pack? In Exploration Pack's latest version there is a 'science pack' which is a collection of 12 new experiments. They do not hold any inventory. If you mean the "A cardboard box stuffed with science" those are actually from another mod (Sounding Rockets) and they are also simply new experiments. Older versions of Exploration Pack had just one experiment IIRC (the data camera) but I don't recall a science pack there either...

Edit: if you mean the old "science crate" that's just another experiment storage container like the stock Experiment Storage Unit.

Edited by Grimmas
Link to comment
Share on other sites

47 minutes ago, DaveyJ576 said:

I am on 1.10 and using KAS to assemble the two frame pieces and it proved quite frustrating to get them to line up properly at the right node. It required a great deal of manipulation, but I eventually got it once I figured out how to shift the nodes around. The rest of the rover assembled like a dream. 
 

The new version of the packrat (WIP) can be assembled with stock  EVA assembly.  FYI

Link to comment
Share on other sites

17 hours ago, Grimmas said:

I'm a bit confused by the terminology. Science pack? In Exploration Pack's latest version there is a 'science pack' which is a collection of 12 new experiments. They do not hold any inventory. If you mean the "A cardboard box stuffed with science" those are actually from another mod (Sounding Rockets) and they are also simply new experiments. Older versions of Exploration Pack had just one experiment IIRC (the data camera) but I don't recall a science pack there either...

Edit: if you mean the old "science crate" that's just another experiment storage container like the stock Experiment Storage Unit.

I apologize if I was not clear. I meant the experiment storage lockers. The tan colored ones. How are they used?

Link to comment
Share on other sites

11 minutes ago, Grimmas said:

Well, I'm stumped. Pretty sure there's no such part as an 'experiment storage locker' in any version of any USI mod I'm familiar with, apart from what I listed above. Maybe it's from another mod?

There are pictures of it on the first and second pages of this thread, mounted to the back of the Packrat rover. They are mentioned in the OP.

Link to comment
Share on other sites

 

30 minutes ago, DaveyJ576 said:

There are pictures of it on the first and second pages of this thread, mounted to the back of the Packrat rover. They are mentioned in the OP.

If you mean the one from the video then yea, that would be the science crate I mentioned in my previous post. It doesn't exist in the current pre-release of USI but it still exists in the old 1.4.0 version. 

20 hours ago, Grimmas said:

Edit: if you mean the old "science crate" that's just another experiment storage container like the stock Experiment Storage Unit.

Works exactly like the stock part - use its PAW in flight to collect all science experiments' results in one place after running some experiments.

Link to comment
Share on other sites

Part of the confusion may come from the fact that I am running 1.10. CKAN downloaded the compatible version which apparently has the original Packrat. I didn’t realize that until today. Anyway, I still love the mod. The Packrat is awesome!

Link to comment
Share on other sites

Nah, the new stuff hasn't really been released and isn't on CKAN yet. But you can check it out in the constellation download from Github. The new packrat is pretty cool too and has way more parts.

Btw the thing about disabling steering on the rear wheels - I do this on every rover I build, no matter if stock or modded. Helps a lot with stability. Adjusting the traction and friction and spring/dampening settings manually can help too (and helps getting up inclines).

Link to comment
Share on other sites

  • 1 month later...
On 4/16/2019 at 1:55 AM, ChrisF0001 said:

I think I worked around it with this MM patch:

@PART[AES_RCS]
{
	!MODULE[ModuleRCS] {}
	EFFECTS
	{
		running
		{
			AUDIO_MULTI_POOL
			{
				channel = Ship
				clip = sound_rocket_mini
				volume = 0.0 0.0
				volume = 0.02 0.1
				volume = 0.5 0.1
				volume = 1.0 0.1
				pitch = 0.0 0.75
				pitch = 1.0 1.5
				loop = true
			}
			MODEL_MULTI_PARTICLE
			{
				modelName = Squad/FX/Monoprop_small
				transformName = RCSTransform
				emission = 0.0 0.0
				emission = 0.1 0.0
				emission = 1.0 1.0
				speed = 0.0 0.8
				speed = 1.0 1.0
				localRotation = -90, 0, 0
			}
		}		
	}
	MODULE
	{
		name = ModuleRCSFX
		stagingEnabled = False
		thrusterTransformName = RCSTransform
		thrusterPower = 0.25
		resourceName = MonoPropellant
		resourceFlowMode = STAGE_PRIORITY_FLOW
		runningEffectName = running
		atmosphereCurve
		{
			key = 0 240
			key = 1 100
			key = 4 0.001
		}
	}
}

...It's been a while though, so I can make no guarantees! :)  ...In fact, since I can't remember which versions of KSP and USI caused this, you may need to do something different.  In any case, find the effects module from a thruster that's working, patch it over the affected one like so, and hopefully it will work!

I can confirm for anyone looking in 2021 (ksp 1.11.2, usi exploration 1.4.0) that yes, this patch fixes the bug of RCS thrust plumes visually going the opposite direction expected, and it tones down the plumes to be actual reasonable sizes. Just save this text to a .cfg file anywhere inside GameData and you're all set. Thanks for this, @ChrisF0001.

Link to comment
Share on other sites

  • 2 weeks later...

i'm happy to see this usefull mod updated, but i've seen the missing parachute on "Derp" pod.
i've added the "parachute module" into the cfg of one previous release, and it works... quite works:
it can be deployed but with the weird problem as in previous versions... the parachute seems to be deployed in "horizontal"

i've asked an year ago if something can be done, and the only thing i've seen in this updated release is the erased parachute module...
so, is there any way to mod the parachute module to obtain a fully functional Derp pod?

Link to comment
Share on other sites

another thing:

i'm trying to create another "inline inflatable float" with 0,625m diameter
i've copied the "small float" cfg, i've managed inside (maybe with wrong values, i think it will be 0,3m diameter) for creating a "micro float", saved the cfg as "USI_Float_06" (asdefault there are only 5 part cfg)
i've updated the patches cfg...

but inside the game  cant find the new part...
i missed something?

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
4 minutes ago, g_BonE said:

The PackRat v2 included in yesterdays USI BleedingEdge release pack seems to have an untextured (all white) seat. Is there something i can do to fix it? Maybe copy a texture from the old PackRat ?

Likely you just need the texture from the stock command seat

Link to comment
Share on other sites

On 8/19/2021 at 10:28 PM, Crimor said:

Can't remember my github password right now so it's gonna have to be this way:

The microduct fan starts with elPart instead of Part, making it obviously not exist.

https://github.com/UmbraSpaceIndustries/ExplorationPack/blob/master/FOR_RELEASE/GameData/UmbraSpaceIndustries/ExpPack/AES/AES_DuctedFan.cfg

I spent quite a while tracking down and fixing this issue myself today, and on removing the "el", the part appears and functions perfectly normally as it always has done. I don't understand why this change was made, since it doesn't seem to serve a purpose and has no changelog entry in either the folder or the git. Was it intentionally disabled (weird way to do it, and for an unknown reason?), some new syntax that didn't work (exclusively done on this part?) or was it just an error (but being the only edit to the file?) that somehow made it all the way to release and wasn't spotted for over a year (I assume the issue the person from a couple of pages back had with being unable to find the fan was this). Maybe RD could shed some light on this oddity?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...