raidernick

[1.6.x, 1.7.x] Soviet Probes & Soviet Rockets - R7/N1/Soyuz/Proton/Zenit/Kosmos - 7-14-19

Recommended Posts

nailed it down to the DNEPR sub-directory, removing just this sub directory allows all of your stock craft to work, I'm not sure which craft the DNEPR parts are required for, haven't researched, I have not tried to nail it to a specific part as it is not quite trivial to identify the file sets for each part and then add them one by one... 

Share this post


Link to post
Share on other sites

Oh, and I need some Realism Overhaul configs for Fasa and this. (along with most of your other mods)

Edited by TheKSPBeginner
Sorry for the double post.

Share this post


Link to post
Share on other sites
On 3/14/2018 at 8:48 PM, TheKSPBeginner said:

Oh, and I need some Realism Overhaul configs for Fasa and this. (along with most of your other mods)

Then get RO/RSS? My stuff as it is, is already fully supported....

Also, no I'm not making an N1 for the 5000th time, nor anything else.

Edited by raidernick

Share this post


Link to post
Share on other sites
9 hours ago, raidernick said:

Then get RO/RSS? My stuff as it is, is already fully supported....

Also, no I'm not making an N1 for the 5000th time, nor anything else. As I said in the other thread, I'm done with ksp and modding because of the direction this game is taking.

Ok, but here's my problem: The rockets are still Kerbal scale.

Another problem: all of the engines still use LF/O instead of the correct fuels.

Share this post


Link to post
Share on other sites
9 hours ago, TheKSPBeginner said:

Ok, but here's my problem: The rockets are still Kerbal scale.

Another problem: all of the engines still use LF/O instead of the correct fuels.

Then ask the RSS/RO guys.

Share this post


Link to post
Share on other sites

UPDATE Soviet Probes v2.4.1

Changelog:

  • Update gold, silver and black foil texture. These texture now use reflections and specular and should look way better than before
  • Update craft files for changes to proton scale and new parts

Required Dependencies below:

https://github.com/KSP-RO/SovietProbes/releases/tag/v2.4.1

 

 

UPDATE Soviet Rockets v2.7

Changelog:

  • Major proton overhaul. Proton has been totally rescaled to be more accurate and more parts/adapter have been added
  • Update gold, silver and black foil texture. These textures now use reflections and specular and should look way better than before
  • Update craft files for changes to proton scale and new parts

Required Dependencies below:

https://github.com/KSP-RO/SovietRockets/releases/tag/v2.7

Share this post


Link to post
Share on other sites

I have a problem with the Dnepr rocket, when it launches, whether it's in a silo or i'm using launch clamps, as soon the the first stage engines fire, the rocket tumbles and crashes. I've followed at the steps building it and I've tried several time to fix it during launch, but they don't work

Share this post


Link to post
Share on other sites
11 hours ago, ChickenBot448 said:

I have a problem with the Dnepr rocket, when it launches, whether it's in a silo or i'm using launch clamps, as soon the the first stage engines fire, the rocket tumbles and crashes. I've followed at the steps building it and I've tried several time to fix it during launch, but they don't work

Never seen that happen ever in stock or rss/ro, and with that level of information, I can give you no help at all.

4 hours ago, Russekof71 said:

Hello, I use RSS / RO and my rocket effect spaghetti
 

english? KJR?

Share this post


Link to post
Share on other sites

Decided to work on something I had started years ago and never finished. It has all 4 color schemes from all 4 of the test flights and animated grid fins. For realism I decided to keep the engines as separate parts, this causes some pretty bad lag in RSS/RO with all the particles even if you reduce them. Nothing much can be done about it. In stock the lag is not nearly as bad, I'm not sure why.

vHzuaD8.png

Edited by raidernick

Share this post


Link to post
Share on other sites

I tried to recreate the Sputnik 2 mission in RSS/RO using the craft file. I set apogee to 1660 km and inc to 65.3°

So the launch went well, the fuel lasted to an apogee of 1673 km (so overshoot slightly) but the perigee is still -720 km - did I just have the wrong gravitational turn parameters set? But how can the apogee be so accurate (nearly) when the perigee is so totally wrong?

Share this post


Link to post
Share on other sites

Fly it manually/better, I don't know what you are using to control it, but things like MJ/PEG, if you don't have them tuned 100% perfectly, will waste a ton of DV. Soviet rockets, especially earlier ones, are known to have almost no margin for error when flying. I know the rocket works, I test fly everything myself many, many times before releasing parts. Other than that I can't help you.

Edited by raidernick

Share this post


Link to post
Share on other sites
16 hours ago, raidernick said:

Finished the L3 stage of the N1. It contains the LOK spacecraft, LK lander, Block D and Block G.

63pySzu.png

You sir, are awesome. Beautiful work again

Share this post


Link to post
Share on other sites

N-1 and configs are 100% done now. I had to fix some issues with how the l3 block and block d decoupled and stuff. There was limited information on how exactly the internals of this block functioned but I think I have it as good as I'm going to get it. I am not ready to release it though. The rocket causes SO MUCH LAG in RO that it's insane. I don't think KSP in RSS/RO can handle this many engines and moving parts simultaneously. Even on my best pc, which I use for 3d rendering, I am getting 5-10fps on launches until I get rid of the first stage. I've been playing around with making all the engines 1 part, but that would break things like testflight. I need more time to think about any solutions if there are any.

In the meantime here is a picture of the completed N1-6L next to a Saturn V on the pad.

sJCuhkK.png

Share this post


Link to post
Share on other sites
2 hours ago, raidernick said:

N-1 and configs are 100% done now. I had to fix some issues with how the l3 block and block d decoupled and stuff. There was limited information on how exactly the internals of this block functioned but I think I have it as good as I'm going to get it. I am not ready to release it though. The rocket causes SO MUCH LAG in RO that it's insane. I don't think KSP in RSS/RO can handle this many engines and moving parts simultaneously. Even on my best pc, which I use for 3d rendering, I am getting 5-10fps on launches until I get rid of the first stage. I've been playing around with making all the engines 1 part, but that would break things like testflight. I need more time to think about any solutions if there are any.

In the meantime here is a picture of the completed N1-6L next to a Saturn V on the pad.

sJCuhkK.png

Can't wait, looks amazing.

Share this post


Link to post
Share on other sites
8 hours ago, raidernick said:

N-1 and configs are 100% done now. I had to fix some issues with how the l3 block and block d decoupled and stuff. There was limited information on how exactly the internals of this block functioned but I think I have it as good as I'm going to get it. I am not ready to release it though. The rocket causes SO MUCH LAG in RO that it's insane. I don't think KSP in RSS/RO can handle this many engines and moving parts simultaneously. Even on my best pc, which I use for 3d rendering, I am getting 5-10fps on launches until I get rid of the first stage. I've been playing around with making all the engines 1 part, but that would break things like testflight. I need more time to think about any solutions if there are any.

In the meantime here is a picture of the completed N1-6L next to a Saturn V on the pad.

sJCuhkK.png

What mod used for Saturn V/Apollo?

Share this post


Link to post
Share on other sites
8 hours ago, raidernick said:

N-1 and configs are 100% done now. I had to fix some issues with how the l3 block and block d decoupled and stuff. There was limited information on how exactly the internals of this block functioned but I think I have it as good as I'm going to get it. I am not ready to release it though. The rocket causes SO MUCH LAG in RO that it's insane. I don't think KSP in RSS/RO can handle this many engines and moving parts simultaneously. Even on my best pc, which I use for 3d rendering, I am getting 5-10fps on launches until I get rid of the first stage. I've been playing around with making all the engines 1 part, but that would break things like testflight. I need more time to think about any solutions if there are any.

In the meantime here is a picture of the completed N1-6L next to a Saturn V on the pad.

sJCuhkK.png

The N1 looks amazing. I have an older machine running Ubuntu with a i7-3770 w/ 16gb of ram and an Nvidia 1060 3gb and this flies perfectly in stock with very little lag. 1080 resolution, realplume, scatterer, environmental visual enhancements just some of my mods running.

Share this post


Link to post
Share on other sites
3 hours ago, wm1248 said:

The N1 looks amazing. I have an older machine running Ubuntu with a i7-3770 w/ 16gb of ram and an Nvidia 1060 3gb and this flies perfectly in stock with very little lag. 1080 resolution, realplume, scatterer, environmental visual enhancements just some of my mods running.

If you are using stock parts, in stock, it's not a very good example of performance. RO/RSS makes everything perform a little worse and my parts have a much higher poly count than the stock ones. While poly count doesn't generally matter, there IS an upper limit at which the game slows to a crawl. I've experienced this with the Vostok/Voskhod models and had to reduce the counts there to make the game actually run. It could also be an issue with the models and FAR, causing calculation problems with voxels and such(I've had this problem with the Titan IV engines which was related to scaling). I will need to look into it.

Share this post


Link to post
Share on other sites
3 hours ago, raidernick said:

If you are using stock parts, in stock, it's not a very good example of performance. RO/RSS makes everything perform a little worse and my parts have a much higher poly count than the stock ones. While poly count doesn't generally matter, there IS an upper limit at which the game slows to a crawl. I've experienced this with the Vostok/Voskhod models and had to reduce the counts there to make the game actually run. It could also be an issue with the models and FAR, causing calculation problems with voxels and such(I've had this problem with the Titan IV engines which was related to scaling). I will need to look into it.

I’m running 1.4.2, RO isn’t up and running for that version as far as I know. I did have to add some struts to the block g for added stability during launch on the final assembly. Nonetheless, I think this is an amazing start. All your mods are working beautifully in stock 1.4.2 BTW.

Share this post


Link to post
Share on other sites
1 hour ago, wm1248 said:

I’m running 1.4.2, RO isn’t up and running for that version as far as I know. I did have to add some struts to the block g for added stability during launch on the final assembly. Nonetheless, I think this is an amazing start. All your mods are working beautifully in stock 1.4.2 BTW.

None of them are balanced for stock so I find that hard to believe. They must be REALLY overpowered for their size since I fudged the values, and the rockets I DID spend time on, I did before the aero changes in (1.1 or 1.0?), so they have way more DV than required for the new atmosphere.

Edited by raidernick

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.