[b]Do you use the [u]Desaturated Texture Pack?[/u][/b]  

270 members have voted

  1. 1. [b]Do you use the [u]Desaturated Texture Pack?[/u][/b]

    • Yes, the grey textures are more stock-like
      134
    • No, the green-orange textures are fine
      39


Recommended Posts

5 hours ago, Haifi said:

Hey allista

I have an issue with my asteroid mining base, which uses the equipment you provide.

Im using Version 3.2.1 of Hangars, a heap of other mods, including USI, KSPIE...
 

  Hide contents

It mines ore perfectly fine, but it creates no room in the asteroid. It stays on available volume 0L. 

hMWjctD.jpg

 And if i try to add a tank to it (clicking on the type selector), the tank edit window goes blank while throwing an ArgumentNullException

KSnCsJa.jpg

Here's a link to the log file on dropbox:

https://www.dropbox.com/s/gd9cmygoxevf6k1/output_log.txt?dl=0

As it seems it has something to do with AT_Utils

  Hide contents

This is the block which is spammed repeatedly:

ArgumentNullException: Argument cannot be null.
Parameter name: key
  at System.Collections.Generic.SortedList`2[System.String,AT_Utils.SwitchableTankType].TryGetValue (System.String key, AT_Utils.SwitchableTankType& value) [0x00000] in <filename unknown>:0 
  at AT_Utils.SwitchableTankType.GetTankTypeInfo (System.String tank_type) [0x00000] in <filename unknown>:0 
  at AT_Utils.SwitchableTankManager.add_tank_gui () [0x00000] in <filename unknown>:0 
  at AT_Utils.SwitchableTankManager.TanksManagerGUI (Int32 windowId) [0x00000] in <filename unknown>:0 
  at UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID) [0x00000] in <filename unknown>:0 
  at UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style) [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Any Ideas as to why it behaves this way?

Thx in advance

Haifi

Thanks for the report! This is definitely a bug. I'll investigate and fix this ASAP.

Sorry for the mess.

1 hour ago, drdeath said:

So I'm trying to excavate an asteroid, I've got tons of radiators on my asteroid mining factory, but it still gets terribly hot and stops doing anything. Either I'm doing something wrong or the thermal code on this thing is seriously broken. Can anyone give me a few pointers?

@Haifi: Having the same Problem here. I'm also using ART, which also has trouble with the tanks, does it perchance have similar dependencies?

Thanks, I'll check the config. Maybe something was changed in 1.2.2 with this regard.

Share this post


Link to post
Share on other sites
7 minutes ago, allista said:

Thanks for the report! This is definitely a bug. I'll investigate and fix this ASAP.

Sorry for the mess.

Thanks, I'll check the config. Maybe something was changed in 1.2.2 with this regard.

One more point on this: KSP itself seems to think it is quite cool, 300-some K surface temperature. The surface gets hot eventually (and the radiators kick in), but only after it shows 800-something K. I can't make all that much sense from the thermal debug, but I don't see the heat figures provided by the part menu anywhere in the thermal debug.

Share this post


Link to post
Share on other sites
5 hours ago, drdeath said:

Having the same Problem here. I'm also using ART, which also has trouble with the tanks, does it perchance have similar dependenci?

I Have no idea mate, I'm not using ART tho. 

Because allista stated on the first page:

On 31.7.2014 at 9:39 AM, allista said:

Unsupported Mods

  • Asteroid Recycling Technologies is not compatible with the Asteroid Hangars framework. Both mods can be installed at the same time, but you cannot use the same asteroid both as a hangar and by ART machinery

I'm not sure but I thought this to be valid still.

Share this post


Link to post
Share on other sites

Nonono, that's not it. It's not about the asteroids, it's about the configurable tanks. Technically speaking, ART tanks are part of the fuel hatches, not the asteroid. That compartmentalisation tech looks very similar to the configurable containers mod, so I figured if both are broken, that could indicate some kind of shared problem.

Share this post


Link to post
Share on other sites

Hangar v3.2.1.2 for KSP 1.2.2 (2017.01.04)

!!! HOTFIX !!!

ChangeLog:

Spoiler
  • Fixed initialization of Configurable Containers within the Asteroid Hatch from a savegame.
  • Fixed Asteroid Drill.
  • Fixed Asteroid Hatch. Moved it to the Coupling category.
  • Rebalanced Asteroid Drill:
    • Fixed heat production and thermal efficiency.
    • Made the Drill twice more efficient.
    • Increased RCS power.
  • Rebalanced Mobile Smelter:
    • Changed productivity and thermal configuration.
    • Disabled SpecialistBonus; the thing is fully automatic and should work without kerbals.

 

Edited by allista
Published a hotfix. Updated the link.

Share this post


Link to post
Share on other sites
9 hours ago, allista said:

Hangar v3.2.1.2 for KSP 1.2.2 (2017.01.04)

!!! HOTFIX !!!

ChangeLog:

  Hide contents
  • Fixed initialization of Configurable Containers within the Asteroid Hatch from a savegame.
  • Fixed Asteroid Drill.
  • Fixed Asteroid Hatch. Moved it to the Coupling category.
  • Rebalanced Asteroid Drill:
    • Fixed heat production and thermal efficiency.
    • Made the Drill twice more efficient.
    • Increased RCS power.
  • Rebalanced Mobile Smelter:
    • Changed productivity and thermal configuration.
    • Disabled SpecialistBonus; the thing is fully automatic and should work without kerbals.

 

Not showing up in CKAN right now?

Share this post


Link to post
Share on other sites

Since I don't see anything about it in search, can I load multiple of the same craft file into a single hanger for launch into orbit? I have 4 identical arms I want to attach to my station, and would like to make a single launch with a hanger module holding them all. It's not letting me do that though, so I'm going to do a workaround of launching multiple hangers on a single craft and toss in some spare craft to add to the station.

Share this post


Link to post
Share on other sites
10 hours ago, Jivaii said:

Not showing up in CKAN right now?

You meaning the last version? It should be. If it it's not, the CKAN probably just being slow again. Wait a little.

10 hours ago, Jivaii said:

Since I don't see anything about it in search, can I load multiple of the same craft file into a single hanger for launch into orbit? I have 4 identical arms I want to attach to my station, and would like to make a single launch with a hanger module holding them all. It's not letting me do that though, so I'm going to do a workaround of launching multiple hangers on a single craft and toss in some spare craft to add to the station.

This is definitely possible: for that you have the "+1" button in the list of stored vessels when you change hangar's content in Editor. If this button "doesn't work", an on-screen message should appear, explaining why: there's not enough room in the hangar for the second (third.. whichever) ship. Resize the hangar to fit in more of them. And bear in mind that the percent of volume used indicates only how well the ships are packed inside a hangar, not the useful volume still left. Like when you fit a cylinder or a sphere in a cube, there's always some space left.

 

Edit: yep, CKAN definitely has problems right now.

Edited by allista

Share this post


Link to post
Share on other sites

Thx for the hotfix, everything seems to be working like a charm now :D

Share this post


Link to post
Share on other sites
On 4.1.2017 at 6:26 PM, allista said:

Hangar v3.2.1.2 for KSP 1.2.2 (2017.01.04)

!!! HOTFIX !!!

Thanks for the quick work! I wish I were allowed to shoot up hotfixes that fast...

Share this post


Link to post
Share on other sites

@allista Now I'm curious: when I excavate an asteroid with the asteroid mining factory from the hangars mod, the "available space" stat added by ART starts going up. Do you share any game mechanics with ART after all?

Share this post


Link to post
Share on other sites
7 hours ago, drdeath said:

@allista Now I'm curious: when I excavate an asteroid with the asteroid mining factory from the hangars mod, the "available space" stat added by ART starts going up. Do you share any game mechanics with ART after all?

Well, no. So I guess ART just saves the initial asteroid mass and calculates the amount of space from the current mass.

BTW, this is the reason I say they "not compatible". There's no technical conflicts per-se (both mods could work on the same install independently), but there's no interface between them, so the results of mining the same asteroid with both mods is unpredictable. You're doing this at your own risk :sticktongue:

Share this post


Link to post
Share on other sites
7 hours ago, allista said:

BTW, this is the reason I say they "not compatible". There's no technical conflicts per-se (both mods could work on the same install independently), but there's no interface between them, so the results of mining the same asteroid with both mods is unpredictable. You're doing this at your own risk :sticktongue:

That's one risk I'm willing to take :cool:, at least for some experiments. Point duly noted though, so I'm not gonna complain to you about any lost asteroid bases.

What piqued my interest is the fact that ART obviously correctly interprets that the asteroid is being hollowed out, even though it's being done by an excavator from the Hangar mod, which, as you just pointed out, is not using ART code. Maybe we can get @RoverDude to comment on this? Something interesting is definitely going on here, and I think all kinds of useful things could come from it.

Last night for example I attached two hatches to one asteroid and noted the fact that the asteroid hatch has a space stat independent of the one the ART gives the asteroid, and that it is per-hatch. Maybe if a certain percentage of the asteroid mass (say 50%, as ART calculates it) has been mined, the asteroid could be considered hollowed-out and any asteroid hatch where SOME mining was done at some point (gotta mill a hole into the wall) could share that internal space. Now I have no idea what that would do to your code, but it would definitely feel very asteroid-basey.

Edit: what I'm also going to try is what happens if I mine ALL of the asteroid as ART calculates it from one hatch and then continue mining from the other :P

Edited by drdeath

Share this post


Link to post
Share on other sites

ART uses the stock mass management system for it's stuff :)  

When I made stock asteroids, I track both the original mass as well as excavated mass (which is used by stock to handle how much you can pull out in resources).  Odds are, the worst case scenario is both mods think they have access to the same mass pool.  But that is something that can definitely be sorted.

@allista - maybe what we do is set up a shared interface like an IAsteroidSpaceConsumer or something so multiple mods can have awareness of and consume from a common 'space' pool (which is essentially the difference between the original mass and the adjusted mass expressed in liters deduced from the volume).

Share this post


Link to post
Share on other sites

Has anyone tried to make a vessel with multiple hangers? I tried to do that, but can't access the second hanger.

Share this post


Link to post
Share on other sites
2 hours ago, Jivaii said:

Has anyone tried to make a vessel with multiple hangers? I tried to do that, but can't access the second hanger.

When you open the Hangar's UI window there should be a chooser for hangars existing on the ship. Right below storage info pane, above stored vessel chooser.

Share this post


Link to post
Share on other sites
6 hours ago, allista said:

When you open the Hangar's UI window there should be a chooser for hangars existing on the ship. Right below storage info pane, above stored vessel chooser.

I tried that, but it'd auto swap back to the first hanger

Share this post


Link to post
Share on other sites
6 minutes ago, Jivaii said:

I tried that, but it'd auto swap back to the first hanger

Maybe both hangars are just named the same? I'll check it out though.

Share this post


Link to post
Share on other sites

I named them Hanger 1 and Hanger 2, so I don't know. I did manage to get my stuff up though. I don't recall seeing anything saying that the fairing hanger is a single vessel hanger though, I found that out by trying to load multiple of the same vessel in it.

Share this post


Link to post
Share on other sites
8 minutes ago, Jivaii said:

I named them Hanger 1 and Hanger 2, so I don't know. I did manage to get my stuff up though. I don't recall seeing anything saying that the fairing hanger is a single vessel hanger though, I found that out by trying to load multiple of the same vessel in it.

Ah, fairings! Yes, fairings is a single-vessel hangar (which is stated in the extended part-tooltip in Editor). You can only launch once from it, because its hull (the panels) is destroyed in the process. How would you like it if an empty space in front of your rocket would spit away ships? :confused:

As for Hangar-1/Hangar-2, have you managed to switch between them in flight, or have you found some workaround?

Edited by allista

Share this post


Link to post
Share on other sites

I did a workaround of launching another vessel. I was quite proud of that hanger vessel, using two radial hangers for storing ships. It could successfully get into orbit! I would love to get it working again, I'd send you the craft file, but I'm using maybe....5 different heavy mods for it.

Share this post


Link to post
Share on other sites

I can't find the heavy recycler? And yes I do have EL installed and am using the latest versions of both without any other mods. Was it removed?

Edited by Idelacio

Share this post


Link to post
Share on other sites
1 hour ago, Idelacio said:

I can't find the heavy recycler? And yes I do have EL installed and am using the latest versions of both without any other mods. Was it removed?

Sorry, but it was indeed removed. I had to focus on getting the mod running again after the long pause between KSP 0.90 and 1.2, so most of the non-essential parts were left behind :(

You can still find the models and part configs in the repo's history, though.

Share this post


Link to post
Share on other sites

Got something strange here: All of a sudden, all stats on the Asteroid hatch read NaN, Volume and size both, and also in the tank editor. It was working fine this afternoon, I built and tested a mono tank in the hatch. some time after I destroyed the tank again, it seems to have gone wahoonie-shaped on me. @allista, have you ever experienced something like that?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.