[b]Do you use the [u]Desaturated Texture Pack?[/u][/b]  

270 members have voted

  1. 1. [b]Do you use the [u]Desaturated Texture Pack?[/u][/b]

    • Yes, the grey textures are more stock-like
      134
    • No, the green-orange textures are fine
      39


Recommended Posts

21 minutes ago, Haifi said:

Ok, thats understandable. But that's exactly the point, because of the partdrift I lost a hatch. And therefore all the space the drill had dug out. I guess stored vessels and tanks would also be lost if a hatch got destroyed?

They would. And that is also partly by design (the hatch is a part of the structure, reaping it away or blowing it would damage the insides...); but mostly because I cannot actually make a hole in an asteroid so that stored ships could be launched out of it. The whole asteroid-hangar thing is pretty restricted (and as you've shown bugged :blush:), but asteroids, being as the are just solid parts, don't provide much to work with.

Still, as the work on interoperability with USI's ART progresses we may come up with a more robust solution for usable storage space...

54 minutes ago, etmoonshade said:

I admit, I love the turns of phrase that non-native speakers come up with when using English. It's a terribly silly and confusing language at times, even to those who speak it well.

Just for the record (and to actually be helpful,) a better choice there probably would have been "Hey, it works!" or "Amazing, it works!" :)

Or "Surprisingly, it worked." as would, no doubt, be written in a scientific paper :confused:

Share this post


Link to post
Share on other sites

What also could be a possibility for the hatch; something like your ground construction mod does. Surface connect some package on the asteroid with KIS and build the hatch "in situ".

Share this post


Link to post
Share on other sites

I'm getting some strange behavior with the Fairing Hangar. I have procedural parts and realfuels installed, and when I put a very heavy part in the hangar (105.62t ballast tank for testing), the hangar total mass is shown as 214.04t. It's not subtracting the mass of the fuel that is stored on the hangar part itself? The "Inline Hangar" is OK, seems like the mass isn't doubled.

 

Also getting weird behavior with the inline hangar. The base mass of the hangar when the size is 3 and aspect is 1.5 appears to be 6.67t. I think the acutal mass is correct (at least based on MechJeb's DV end mass readout), but the display is wrong. 

Edited by westamastaflash

Share this post


Link to post
Share on other sites

Introducing Developer Builds!

From now on I will publish developer builds in my Dropbox.

The builds are compiled with DEBUG flag and are marked by automatic build number (the last number in version string).

I cannot promise any particular release rates, but these builds will be coming much more often than normal releases.

They will also contain all the latest features. 

For instance, current build features the ability to load subassembly directly into a hangar and the new asteroid-attachment mechanics.

Obviously, these should not be considered stable and should not be used for your main game!

But if you want to help the project, you are very welcome to play with them, test them, break them and tell me all about it! :cool:

 

Seriously, folks, I need you! :wink: Even if I had the time to test everything, I know the system too well and subconsciously evade most of the bugs :confused: 

 

In particular: 

  • @Haifi, could you, please, test the new grapple nodes? I made them backward-compatible with the old ones, so any AsteroidHatch or StructuralGrapple that were in-flight or already attached to an asteroid will work just fine. For your convenience I made temporary part-menu button "Force Decouple" that will decouple even a Fixed hatch, so that you could reattach it if it has slided too far.
  • @etmoonshade, you can test the subassembly loading in Editor. It works just like the vessel loading: through the hangar's UI window, "Select Subassembly" button.

Share this post


Link to post
Share on other sites
44 minutes ago, westamastaflash said:

I'm getting some strange behavior with the Fairing Hangar. I have procedural parts and realfuels installed, and when I put a very heavy part in the hangar (105.62t ballast tank for testing), the hangar total mass is shown as 214.04t. It's not subtracting the mass of the fuel that is stored on the hangar part itself? The "Inline Hangar" is OK, seems like the mass isn't doubled.

 

Also getting weird behavior with the inline hangar. The base mass of the hangar when the size is 3 and aspect is 1.5 appears to be 6.67t. I think the acutal mass is correct (at least based on MechJeb's DV end mass readout), but the display is wrong. 

Thanks for the reports. I'll check them.

Share this post


Link to post
Share on other sites

@allista I'll set up a test install tomorrow and get back to you after some testing. The grapple will work as the standard one does? 

 

Share this post


Link to post
Share on other sites
55 minutes ago, Haifi said:

@allista I'll set up a test install tomorrow and get back to you after some testing. The grapple will work as the standard one does? 

More or less: you arm it, you aim it and slowly approach. There're two differences though:

  1. There's no pivoting. As soon as the grapple is attached it stays that way until you decouple. As far as I understand, it's the pivoting that caused the sliding.
  2. To compensate the lack of pivoting, I have added a new feature: when the grapple is close to the surface and relatively level with it it starts to pull the ship gently towards it, like weak magnet. This helps not to bounce back and to orient the ship closer to the normal of the surface.
Edited by allista

Share this post


Link to post
Share on other sites
17 hours ago, allista said:

Thanks for the reports. I'll check them.

Note the inline hangar mass for the same values (size 3, aspect 1.5) seems to change when i switch up the aspect back and forth from 1 to 1.5 and 1.5 to 2. It's like it's missing an update call somewhere.

Share this post


Link to post
Share on other sites
On 1/31/2017 at 9:36 PM, westamastaflash said:

I'm getting some strange behavior with the Fairing Hangar. I have procedural parts and realfuels installed, and when I put a very heavy part in the hangar (105.62t ballast tank for testing), the hangar total mass is shown as 214.04t. It's not subtracting the mass of the fuel that is stored on the hangar part itself? The "Inline Hangar" is OK, seems like the mass isn't doubled.

Also getting weird behavior with the inline hangar. The base mass of the hangar when the size is 3 and aspect is 1.5 appears to be 6.67t. I think the acutal mass is correct (at least based on MechJeb's DV end mass readout), but the display is wrong. 

Thanks again. Found and fixed both issues.

On 1/31/2017 at 10:42 PM, Haifi said:

@allista I'll set up a test install tomorrow and get back to you after some testing. The grapple will work as the standard one does? 

Sorry to bother, but I'm interested: have you checked anything yet? :blush:

I'm planning to make a release of all the mods later today, so your results will be very valuable :wink:

Share this post


Link to post
Share on other sites

Hi allista

No drifting so far, but Im not sure how conclusive this is. In the last version, the hatches did not start to drift right off the bat. I had a feeling that using more claws ( also stock ones on the same asteroid) did accelerate the drifting... Save Idle and load cycles will also matter. As of now, everything looks stable. 

Edit: I loaded a save with a drift  into the test game and it seems I cannot "unclaw" the Hatch for repositioning it will do the animations for "try fix" and "try arm" but no actual undocking option shows up.

Regards Haifi

Edited by Haifi

Share this post


Link to post
Share on other sites

I found a "cheat" to make millions using this Hangar mod and the Extraplanetary Launchpads mod.

1. Build a craft with expansive resources in it
2. Store this craft in a hangar craft
3. Build the hangar craft using Extraplanetary Launchpads
4. Release the craft out of the hangar craft
5. Enjoy your nearly free expansive resources

Fixing this is only possible, I think, if the hangar itself stores all the resources of the craft and the dry craft separate.

Share this post


Link to post
Share on other sites

All Hangar needs to do is bundle the costs of the vessel it stores with its own, and report that total to EPL.

Share this post


Link to post
Share on other sites
4 hours ago, Kolago said:

I found a "cheat" to make millions using this Hangar mod and the Extraplanetary Launchpads mod.

1. Build a craft with expansive resources in it
2. Store this craft in a hangar craft
3. Build the hangar craft using Extraplanetary Launchpads
4. Release the craft out of the hangar craft
5. Enjoy your nearly free expansive resources

Fixing this is only possible, I think, if the hangar itself stores all the resources of the craft and the dry craft separate.

3 hours ago, 0111narwhalz said:

All Hangar needs to do is bundle the costs of the vessel it stores with its own, and report that total to EPL.

The costs of stored vessels are added to hangar's cost via IPartCostModifier interface.

So the problem here should be somewhere on EPL side. @taniwha, would you care to look at this?

 

Share this post


Link to post
Share on other sites

EPL builds by the dry mass of the craft if I remember right. Is resource or part cost really involved?

Edited by Kolago

Share this post


Link to post
Share on other sites

@allista: EL needs to know what's in the hangar (it tries for KIS containers, and does a reasonable job for the first layer (having containers in containers causes problems with accuracy)). This means that everything needs to be setup in one of OnStart, OnLoad, or OnInitialize* (EL calls vessel.Initialize() when determining the part cost). With access to information on what is inside the hangar, EL can then cause any contained resources to become required for the build.

@Kolago: EL uses dry mass for determining the base cost in RocketParts, but certain resources will add to the cost (by requiring some resource to "build" the resource (SolidFuel, Ablator) or themselves becoming required due to being inside a KIS container).

* Order seems to be OnLoad, OnInitialize (twice), OnStart, then OnInitialize again, going by my logs. My recommendation is OnStart.

Share this post


Link to post
Share on other sites

Er, actually, what I meant to say is that EL needs to be able to get at the relevant information just after it calls vessel.Initialize() (but before any Update or OnUpdate calls occur).

EL loads the .craft file via ShipConstrucgt.LoadShip, adds a Vessel component to the root part, calls Vessel.Initialize, pokes at b9 pwings and FAR, calculates the build cost (including interrogating KIS containers), then destroys the vessel.

Ideally, EL needs a list of parts (parts can have part-specific recipes), their dry masses, and their current resource amounts.

Share this post


Link to post
Share on other sites

Hi @allista, playing KSP again and trying out Hangar, which is an excellent mod. I'm having some trouble with an in-flight hangar not letting me transfer a vessel and I'm wondering if I'm doing something wrong. I'm playing with the community tech tree and I don't know if I need an upgrade somewhere, if there's a bug, or if I'm just messing something up.

In the editor, I added an inline hangar and a hangar extension, both size 2 and aspect 1. I added a vessel, transferred it to the extension, and then added another copy to the inline hangar again.

In flight, I launched the first vessel no problem. Now the 2nd vessel still seems to be in there, but I can't figure out how to do anything with it. Here's a screenshot:

http://imgur.com/a/FMQk3

Clicking relocate vessels doesn't do anything. Am I missing something or is there something wrong?

 

Share this post


Link to post
Share on other sites
24 minutes ago, drhay53 said:

Hi @allista, playing KSP again and trying out Hangar, which is an excellent mod. I'm having some trouble with an in-flight hangar not letting me transfer a vessel and I'm wondering if I'm doing something wrong. I'm playing with the community tech tree and I don't know if I need an upgrade somewhere, if there's a bug, or if I'm just messing something up.

In the editor, I added an inline hangar and a hangar extension, both size 2 and aspect 1. I added a vessel, transferred it to the extension, and then added another copy to the inline hangar again.

In flight, I launched the first vessel no problem. Now the 2nd vessel still seems to be in there, but I can't figure out how to do anything with it. Here's a screenshot:

http://imgur.com/a/FMQk3

Clicking relocate vessels doesn't do anything. Am I missing something or is there something wrong?

This is definitely a bug :(

I'll check it right away, thanks!

I'm going to release a new version tonight, so if I fix it fast, I'll include the fix.

5 hours ago, taniwha said:

Er, actually, what I meant to say is that EL needs to be able to get at the relevant information just after it calls vessel.Initialize() (but before any Update or OnUpdate calls occur).

EL loads the .craft file via ShipConstrucgt.LoadShip, adds a Vessel component to the root part, calls Vessel.Initialize, pokes at b9 pwings and FAR, calculates the build cost (including interrogating KIS containers), then destroys the vessel.

Ideally, EL needs a list of parts (parts can have part-specific recipes), their dry masses, and their current resource amounts.

OK, so is there some interface EL expects to find to gather the needed information?

Share this post


Link to post
Share on other sites
3 minutes ago, allista said:

This is definitely a bug :(

I'll check it right away, thanks!

I'm going to release a new version tonight, so if I fix it fast, I'll include the fix.

One quick note, in the editor, after I moved the vessel to the extension, I played around with the shape of the extension to see what would happen. I believe I even shrunk it enough so that if the vessel had been in the main hangar, it would have been kicked out for not fitting. However, I don't think anything happened when it was in the extension. I resized it back to a size where I knew it fit, but it's possible I initiated some bug in that whole procedure. If you can't find something easy, maybe this will set you on the path to bug-finding bliss.

Edited by drhay53

Share this post


Link to post
Share on other sites
55 minutes ago, drhay53 said:

One quick note, in the editor, after I moved the vessel to the extension, I played around with the shape of the extension to see what would happen. I believe I even shrunk it enough so that if the vessel had been in the main hangar, it would have been kicked out for not fitting. However, I don't think anything happened when it was in the extension. I resized it back to a size where I knew it fit, but it's possible I initiated some bug in that whole procedure. If you can't find something easy, maybe this will set you on the path to bug-finding bliss.

Thanks again! I think I've fixed both issues.

The latter being merely the information on part menu not updating properly.

Share this post


Link to post
Share on other sites

Hey Folks,

maybe i'm getting something wrong but in my Carrer-Playthrough i just unlocked General Rocketry and wanted to use the fairing hangar to launch 2 little sat's at once. But whenever i click the +1 button to add the same vessel again it says "Payload is already stored". The same happens when i try to add another vessel, even when i'd size the fairing up a lot.

In the tech tree i couldn't find any upgrade that would allow me to store more vessels nor could i find any answer in this forum.

If this is not a know issue nor has anybody an answer it may be related to a conflict with another mod and i'll see if i can figure out which mod it is.

Greetings, Sinza.

Share this post


Link to post
Share on other sites
Just now, Sinza said:

Hey Folks,

maybe i'm getting something wrong but in my Carrer-Playthrough i just unlocked General Rocketry and wanted to use the fairing hangar to launch 2 little sat's at once. But whenever i click the +1 button to add the same vessel again it says "Payload is already stored". The same happens when i try to add another vessel, even when i'd size the fairing up a lot.

In the tech tree i couldn't find any upgrade that would allow me to store more vessels nor could i find any answer in this forum.

If this is not a know issue nor has anybody an answer it may be related to a conflict with another mod and i'll see if i can figure out which mod it is.

Greetings, Sinza.

The Fairing hangar can only store one vessel, you can see it in the right-click menu of the part in the editor under "Single Use Hangar Storage"

Share this post


Link to post
Share on other sites
3 minutes ago, drhay53 said:

The Fairing hangar can only store one vessel, you can see it in the right-click menu of the part in the editor under "Single Use Hangar Storage"

Thank you very much drhay53!

I didn't think of this when i read "Single Use Hangar Storage". Maybe the meaning of this sentence should be noted on the front page or the description could be changed to be more clear. When reading "Single Use Hangar Storage"  i'd rather think of "using the fairing a single time" even if that is more or less obvius...

Greeting, Sinza

Share this post


Link to post
Share on other sites
1 minute ago, Sinza said:

Thank you very much drhay53!

I didn't think of this when i read "Single Use Hangar Storage". Maybe the meaning of this sentence should be noted on the front page or the description could be changed to be more clear. When reading "Single Use Hangar Storage"  i'd rather think of "using the fairing a single time" even if that is more or less obvius...

Greeting, Sinza

Read the description underneath the title, it says "Can store only 1 vessel"

Edited by drhay53

Share this post


Link to post
Share on other sites

Hangar v3.3.0 for KSP 1.2.2 (2017.02.06)

ChangeLog:

Spoiler
  • Implemented subassembly loading into hangars in Editor.
  • Converted both Asteroid Hatch and Structural Grapple to use the new SingleUseGrappleNode that fixes the sliding-hatch problem. Moved both to Coupling category.
  • Moved Hatch Port Adapter to Coupling category.
  • Fixed doubling mass by Hangar Fairings.
  • Fixed the bug that prevented modification of StoredVessel resources.
  • Fixed TotalStoredMass display.
  • Fixed the issues with vessel transfer window.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.