[b]Do you use the [u]Desaturated Texture Pack?[/u][/b]  

270 members have voted

  1. 1. [b]Do you use the [u]Desaturated Texture Pack?[/u][/b]

    • Yes, the grey textures are more stock-like
      134
    • No, the green-orange textures are fine
      39


Recommended Posts

6 hours ago, allista said:

OK, so is there some interface EL expects to find to gather the needed information?

Not as such: I cobble something together based on what's available, thus my vague comments. My main point is I'm quite willing to do my part in getting things to work nicely.

How does Hangar store its stowed vessels, and how early is that information available?

Share this post


Link to post
Share on other sites
1 hour ago, allista said:

Hangar v3.3.0 for KSP 1.2.2 (2017.02.06)

ChangeLog:

  Hide contents
  • Implemented subassembly loading into hangars in Editor.
  • Converted both Asteroid Hatch and Structural Grapple to use the new SingleUseGrappleNode that fixes the sliding-hatch problem. Moved both to Coupling category.
  • Moved Hatch Port Adapter to Coupling category.
  • Fixed doubling mass by Hangar Fairings.
  • Fixed the bug that prevented modification of StoredVessel resources.
  • Fixed TotalStoredMass display.
  • Fixed the issues with vessel transfer window.

 

since I figured the easyness of the asteroid hangar I abandoned ART. I can't complain about both tho, but your hangars make things just easier by having just 1 hatch instead of 1 per resource.

ty for that update :)

Share this post


Link to post
Share on other sites
6 hours ago, taniwha said:

Not as such: I cobble something together based on what's available, thus my vague comments. My main point is I'm quite willing to do my part in getting things to work nicely.

How does Hangar store its stowed vessels, and how early is that information available?

It stores the vessel in editor as a full ShipConstruct node, so in principle it's possible to read that node and load a ShipConstruct from it and examine it as you do with the top-most vessel.

Here's an example .craft file with stock+Hangar only parts:

https://www.dropbox.com/s/dg0mhzab65uw5os/Hangar Extension Test.craft?dl=0

And an excerpt from it:

Spoiler

	...
	MODULE
	{
		name = HangarStorage
		isEnabled = True
		stagingEnabled = True
		EVENTS
		{
		}
		ACTIONS
		{
		}
		PACKED_CONSTRUCTS
		{
			STORED_VESSEL
			{
				name = Jumping Flea
				flag = ThrottleControlledAvionics/Flags/TCAFlag
				id = cdf84c92-3c4c-41e1-b1b9-c44c672a151a
				VESSEL
				{
					ship = Jumping Flea
					version = 1.2.0
					description = The Jumping Flea was originally named after the carnival ride that we salvaged most of its parts from. It might not get us all the way to space, but it will definitely get us started there with a bang!
					type = VAB
					size = 2.02643776,3.03346634,1.80881047
					PART
					{
						part = mk1pod_4292424136
						partName = Part
						pos = 0,15,0
						attPos = 0,0,0
						attPos0 = 0,15,0
						...

 

 

Share this post


Link to post
Share on other sites
2 hours ago, stali79 said:

Thanks for the update man, any update on the sabres?

Not yet, sorry; with all the work on GC+MKS integration. But I haven't forgot.

Share this post


Link to post
Share on other sites
2 hours ago, allista said:

It stores the vessel in editor as a full ShipConstruct node, so in principle it's possible to read that node and load a ShipConstruct from it and examine it as you do with the top-most vessel.

In that case, it should be easy enough to do something with it, as a "ShipConstruct" node is what EL uses :)

Sadly, a bit busy, so I can't say when it will be, but the next version of EL will support hangar properly.

Share this post


Link to post
Share on other sites
5 minutes ago, taniwha said:

In that case, it should be easy enough to do something with it, as a "ShipConstruct" node is what EL uses :)

Sadly, a bit busy, so I can't say when it will be, but the next version of EL will support hangar properly.

Glad to hear it! :D

Meanwhile, every involved user is urged to take advantage of this cheat while it still exists to make trillions of funds! :cool:

Share this post


Link to post
Share on other sites

I've loved the idea of Hangars  for quite a while, but my last few playthroughs never advanced far enough for me to make any use of it. Last night, however, it saved my mission. I'd designed a moon lander that wasn't very aerodynamic at all. However, I'd neglected to unlock the tech nodes with large enough fairings. That's, however, when I noticed the fairing hangar. It worked wonders, and this mod just earned a spot on my must-have list, alongside your other mods. (I haven't gotten a chance to try out GC yet, I haven't teched up enough yet, but it comes with MKS now so it automatically included. :-) )

http://imgur.com/a/GdjUV

Edited by Fobok

Share this post


Link to post
Share on other sites

Looks pretty good to me. :) I've been wanting to learn to do 3D modelling myself, but Blender's interface just confuses me to no end so I haven't been able to bring myself to sit down, settle in, and figure it out. 

Share this post


Link to post
Share on other sites
9 minutes ago, Fobok said:

Looks pretty good to me. :) I've been wanting to learn to do 3D modelling myself, but Blender's interface just confuses me to no end so I haven't been able to bring myself to sit down, settle in, and figure it out. 

There are quite a few good video tutorials on Blender's interface and basics on youtube :)

And once you've learned it you cannot stop wondering: why other software does not use interface like this?! :confused:

Share this post


Link to post
Share on other sites
1 minute ago, allista said:

And once you've learned it you cannot stop wondering: why other software does not use interface like this?! :confused:

Seriously this. The Blender guys have done a great job. Context sensitive, hotkeys for damn near everything, highly configurable for whatever stage of your project.

Share this post


Link to post
Share on other sites

Hi allista

Grapple nodes seem to be stable still :)

Now that the drift seems sorted out, I did try to get a asteroid hangar up and running. But the hangar refuses to store even a small craft.

I tried to fit this:

Spoiler

xlXUDty.png

Into this hangar:

Spoiler

gPOVAtK.png

But I always get the standard message:

Spoiler

gu0Kppm.jpg

Am I stupid again and missed something?

I have some tanks in the hatch that hangar is using, does this prevent the hangar from working with that hatch?

The ship should fit through the ( 5.x by 5.x meters, I think it was? ) entrance. And the Inside volume should be more than enough...

Edited by Haifi

Share this post


Link to post
Share on other sites

@Haifi, nah, it's one more bug courtesy of me, I'm afraid :/

Thanks for the report!

Oh, brother testers, where are you? :confused:

Share this post


Link to post
Share on other sites

great update, loading subassemblies works great and without loading time compared to vessel loading... just a few ms but noticeable :)

however, i get this

Spoiler

Coroutine couldn't be started because the the game object 'SurfaceTail' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarStationHub' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SquareHeatshield2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SquareHeatshield' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SpaceportRCS' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarRadialAdapter2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarRadialAdapter1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarProcAdapter' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarDockingPort' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtensionXL' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtensionL' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtension' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'StructuralGrappleNode' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'MobileSmelter' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SmallVTOLHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'Hangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'RoverLanderHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'RadialHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InlineHangar2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InlineHangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableSpaceHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableHangar2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableHangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'FairingsOcto' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'Hangar2' is inactive!
 
(Filename:  Line: 738)

everytime i click a part in editor

Share this post


Link to post
Share on other sites
1 minute ago, eLDude said:

great update, loading subassemblies works great and without loading time compared to vessel loading... just a few ms but noticeable :)

however, i get this

  Hide contents

Coroutine couldn't be started because the the game object 'SurfaceTail' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarStationHub' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SquareHeatshield2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SquareHeatshield' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SpaceportRCS' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarRadialAdapter2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarRadialAdapter1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarProcAdapter' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarDockingPort' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtensionXL' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtensionL' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'HangarExtension' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'StructuralGrappleNode' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'MobileSmelter' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'SmallVTOLHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'Hangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'RoverLanderHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'RadialHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InlineHangar2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InlineHangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableSpaceHangar' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableHangar2' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'InflatableHangar1' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'FairingsOcto' is inactive!
 
(Filename:  Line: 738)

Coroutine couldn't be started because the the game object 'Hangar2' is inactive!
 
(Filename:  Line: 738)

everytime i click a part in editor

Are you getting any strange behavior, or are you just see these lines in the log?

Anyways, thanks for the report, I'll be checking this out, as it shouldn't be happening.

Share this post


Link to post
Share on other sites

nothing strange noticed except a short lag as i click the part or the vessel

Share this post


Link to post
Share on other sites

@allistaI have another question, is it possible to tune down or turn off the dust effect on the asteroid drill? It's causing more and more lag as my asteroid base grows, so I would want to save some performance by at least reducing the effect...

Share this post


Link to post
Share on other sites
3 minutes ago, Haifi said:

@allistaI have another question, is it possible to tune down or turn off the dust effect on the asteroid drill? It's causing more and more lag as my asteroid base grows, so I would want to save some performance by at least reducing the effect...

Are you sure it's the dust causing the lag? It seems very unlikely. Anyways... there's no way to control it. Even more, I'm not currently sure which module controls the emitter O_o

 

Share this post


Link to post
Share on other sites
31 minutes ago, allista said:

Are you sure it's the dust causing the lag? It seems very unlikely.

Its either the dust, or the digging itself. Because the lag hits, as soon as I turn on the drill. And it fades as soon as I turn the drill off.

Edit: As for the module, it should be

MODULE
    {
        name = ModuleAnimationGroup
        activeAnimationName = drill-animation
        moduleType = Drill
        autoDeploy = true
    }    

because you can start several animations concurrently with it. Just a guess tho...:wink:

Edited by Haifi

Share this post


Link to post
Share on other sites
36 minutes ago, Haifi said:

Its either the dust, or the digging itself. Because the lag hits, as soon as I turn on the drill. And it fades as soon as I turn the drill off.

Edit: As for the module, it should be

MODULE
    {
        name = ModuleAnimationGroup
        activeAnimationName = drill-animation
        moduleType = Drill
        autoDeploy = true
    }    

because you can start several animations concurrently with it. Just a guess tho...:wink:

Why, of course! The AnimationGroup, not AnimatiorGeneric! Indeed, it controls the emitters. But it is private:

private void ToggleEmmitters(bool state) 
{
        KSPParticleEmitter[] componentsInChildren = base.part.GetComponentsInChildren<KSPParticleEmitter>();
        int i = 0;
        int num = componentsInChildren.Length;
        while (< num)
        {
            componentsInChildren[i].emit = state;
            componentsInChildren[i].enabled = state;
            i++;
        }
} 

So the only thing I can do is to remove the effect from the model completely :(

Share this post


Link to post
Share on other sites
13 minutes ago, allista said:

Why, of course! The AnimationGroup, not AnimatiorGeneric! Indeed, it controls the emitters. But it is private:


private void ToggleEmmitters(bool state) 
{
        KSPParticleEmitter[] componentsInChildren = base.part.GetComponentsInChildren<KSPParticleEmitter>();
        int i = 0;
        int num = componentsInChildren.Length;
        while (< num)
        {
            componentsInChildren[i].emit = state;
            componentsInChildren[i].enabled = state;
            i++;
        }
} 

So the only thing I can do is to remove the effect from the model completely :(

Ah, sh...! Ok, too much hassle. Don't bother for now. If you're bored someday, you know what you could have a look at :wink:

 

Any news on the asteroid Hangar? Just curious if you located the problem.

Edited by Haifi

Share this post


Link to post
Share on other sites
On 2/10/2017 at 3:14 AM, eLDude said:

nothing strange noticed except a short lag as i click the part or the vessel

I'm having this issue too. Can't be sure it's the source of the lag entirely, but I am pretty sure it isn't helping. Get a major lag spike every time I click any part to place in editor, same log spam as mentioned above.

Share this post


Link to post
Share on other sites

I don't know why but the textures have gone a bit mad in my save(ie. the docking port is a solid, uniform, eye-searing, neon green)

I admit to being very new to KSP modding, so any advice on what's gone wrong would be appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.