Biff Space

[1.2] Biomatic biome sensor

Recommended Posts

Biomatic biome identifier - V 1.3 for KSP 1.2

The Biomatic sensor identifies the biome that the ship is in / above, and shows the information in a small text window. Optionally the ship's situation (high / low space, high / low flight, landed, splashed) can be shown as well. Biomes where science has been done can be added to a list, which is used together with a kill warp option to de-warp the ship when entering an un-listed biome. The list of biomes can be per-vessel, or global.

It is integrated with the stock toolbar by default, but can be configured to use blizzy's. (Change 'stock' to 'blizzy' in the config file).

The Biomatic Part

The Biomatic part is found under the science tab. In career or science mode, it is found in the 'Space Exploration' node of the tech tree - this must be researched before Biomatic will work, either as a part or as a Module Manager add-on to command pods.

ModuleManager will add Biomatic to any command module or probe core, so the separate part does not have to be used.

Download

The Biomatic folder needs to be unzipped and put in your KSP\GameData folder:

Biomatic v1.3 at SpaceDock

Feedback

Any comments and suggestions for improvements are welcome, as are reports of bugs / problems - please let me know what you think.

Code

The source code is included in the download

Version History

UPDATED (2016-10-14), v1.3.0.0
- Recompiled with KSP 1.2 binaries
- Added option for per-vessel or global biome list

UPDATED (2016-06-23), v1.2.0.0

- Recompiled with KSP 1.1.3 binaries 
- Available in map mode

UPDATED (2016-06-09), v1.1.0.8

- Added sounds (on entering unticked biome, on entering any biome, or no sound options)
- Removed log file debug info

UPDATED (2016-05-18), v1.1.0.6

- Window now disappears with the rest of the UI on F2
- If the part config file is edited to move the part to a different tech tree node, it will now behave sensibly rather than requiring 'spaceExploration' to be unlocked
 

UPDATED (2016-05-02), v1.1.0.1

- If Module Manager is used to add Biomatic functionality to command pods and probe cores, Biomatic is still unavailable until it has been researched
- New look for stock buttons
- Recompiled with KSP 1.1.2 binaries.

Licence

Biomatic, its associated files and the source code are all released under the GPL 3 licence, text here: http://www.gnu.org/licenses/gpl.txt.

Screenshot

TrdnPPU.jpg

YouTube

 

 

Edited by Biff Space
+updated to v1.3.0.0

Share this post


Link to post
Share on other sites

Great idea, will save me having to get out and eva every time i think im over a new biome! Installing and trying it out now.

Share this post


Link to post
Share on other sites

Had a good go with it. Simple, small, and unobtrusive. Doesnt take up much mod space, and makes life getting science around the mun and minmus SO much easier. 10/10!

Share this post


Link to post
Share on other sites

Maybe you should do some of the Chatterer sound logs too given that you have the proper mic ! Lol

Share this post


Link to post
Share on other sites

Thanks, Stevie_D, glad it's useful.

nismobg, for any other purpose I'd have to get a different mic, but for space-themed stuff it works quite well. :)

Share this post


Link to post
Share on other sites

Now updated for 1.1.2. The images and youtube clip above are of the old version, and the new one looks slightly different, but not much.

Share this post


Link to post
Share on other sites

I like the idea of this mod, but I'm having a slight issue.  Is there a way to get the panel off the screen?  No matter what I click, it's always visible, even if I press F2 to remove the UI entirely.

Share this post


Link to post
Share on other sites

When you click the toolbar button it doesn't work? Is this the stock toolbar (along with the buttons to show resources, funds, and missions in the vertical strip to the right) or are you using blizzy's floating toolbar mod?

There isn't a button in the control panel itself to remove the whole thing, the On/Off toggle just affects whether the biome list is diplayed - if it isn't you still see the settings controls in the window. The whole thing should be toggled with the separate toolbar button.

I am not surprised that the F2 toggle doesn't work, I overlooked that (I don't use it much) and will have to look into that for next release. I will put that on the To Do list.

Share this post


Link to post
Share on other sites

This is the stock toolbar.  I haven't bothered to reconfigure it to Blizzy's.  It would be nice to be able to take the window off the screen completely, as it can get cluttered and my monitor/tv's resolution isn't enormous.  I know the button in the stock toolbar does hide some information, but not the whole thing, and I end up tucking the window mostly off the screen at the bottom when I don't need it. 

Good to know that you're putting the F2 on the TODO list.  This game is so pretty sometimes that I just have to take a screenshot, and it always looks better without the UI cluttering up the screen.

Share this post


Link to post
Share on other sites

Hmm. If the toolbar button has installed itself and is hiding some of the settings, it is doing its job correctly. Is it possible that you aren't turning the sensor off in the settings part of the panel? (The button at the very bottom right. The red-on-grey text was probably a poor choice on my part, it isn't very readable.) 

I guess that the way the different bits of the GUI work together is not very intuitive, so here is how it should work. 

There are (at most) two things displayed in the one-and-only Biomatic window. The settings buttons, and the biome/situations list. The biome/situations list is the useful stuff, displayed in one to five lines at the top. This will (should) disappear when the 'switch off' button in the bottom right of the Biomatic window is clicked. The button text changes to 'switch on' and the text in the bottom left changes to 'Biomatic OFF'. The green blob on the toolbar button icon also turns from green to red. 

The settings part of the window is shown or hidden when the toolbar button is used. This changes the appearance of the toolbar button, going from colourful, if the settings are hidden, to greyed, if they are shown.

To get the window to disappear altogether, you need to switch off the sensor (bottom right of settings in the actual Biomatic window), and then close the settings panel using the toolbar button. The toolbar icon should then be colourful, with a little red blip in the bottom right, and the window (having nothing to display) should not draw itself at all. 

If something else is going on I would like to know about it. Is there a title-bar-only window which flickers? That has happened when two or more windows both have the same ID.  

 

 

Share this post


Link to post
Share on other sites

Yup, that does it.  I didn't think to turn it off from both locations.  The readability isn't a problem (at least for me), I just didn't do enough diagnostics on my end.  Must learn to press more buttons. :-D  Thanks.

Share this post


Link to post
Share on other sites

if i move the biomatic part to the start of the tech tree will command pods without the biomatic part (but with the MM patch adding the biomatic module) get the biomatic functions from start too?

Share this post


Link to post
Share on other sites
10 hours ago, frango9000 said:

if i move the biomatic part to the start of the tech tree will command pods without the biomatic part (but with the MM patch adding the biomatic module) get the biomatic functions from start too?

At the moment biomatic is dependent on having the spaceExploration tech tree node unlocked (and the part bought in career mode), so just changing the techRequired field in the cfg file (to 'start' in this case) won't work. I should have time in the next few days to find a better way to examine the tech tree. I would like to make it so that moving the part to a different node will make part availability and command pod functionality dependent on that node being available.

Share this post


Link to post
Share on other sites
1 hour ago, Biff Space said:

At the moment biomatic is dependent on having the spaceExploration tech tree node unlocked (and the part bought in career mode), so just changing the techRequired field in the cfg file (to 'start' in this case) won't work. I should have time in the next few days to find a better way to examine the tech tree. I would like to make it so that moving the part to a different node will make part availability and command pod functionality dependent on that node being available.

thx to your source i managed to modify the dll to enable the module from start. 

again thx for this mod!

Share this post


Link to post
Share on other sites
2 hours ago, frango9000 said:

thx to your source i managed to modify the dll to enable the module from start. 

again thx for this mod!

Glad you found a way to get it to work the way you want.

I have changed the way it checks for available tech, and in the next release, it will be possible to move the part to any tech tree node and have it behave as you would expect (ie adding itself to command pods and probe cores when the appropriate tech tree node is unlocked). I want to do a little further testing, but I will release a new version in the next couple of days. This will also include the hide-GUI-on-F2 feature.

 

Share this post


Link to post
Share on other sites
On 5/12/2016 at 4:48 PM, Nartur Arkano said:

Good to know that you're putting the F2 on the TODO list.  This game is so pretty sometimes that I just have to take a screenshot, and it always looks better without the UI cluttering up the screen.

On 5/16/2016 at 11:35 PM, frango9000 said:

if i move the biomatic part to the start of the tech tree will command pods without the biomatic part (but with the MM patch adding the biomatic module) get the biomatic functions from start too?

OK, the To Do list is now a Ta Daa! list. 

Both of these features are in today's release:

F2 shows/hides the GUI, and if the cfg file is edited to move the part to a different tech tree node, it will behave as expected.

Share this post


Link to post
Share on other sites

This is both incredibly simple and of incredibly utility - you are an awesome person, and should feel awesome.

Immediately downloaded within minutes of learning it exists.

Share this post


Link to post
Share on other sites

I can't find the config to change to blizzy's toolbar because my stock one is so crowded since I run lots of other mods.

Share this post


Link to post
Share on other sites
6 hours ago, Combatsmithen said:

I can't find the config to change to blizzy's toolbar because my stock one is so crowded since I run lots of other mods.

The config file is 

(Your KSP folder)\GameData\Biomatic\Plugins\PluginData\Biomatic\config.xml

Note that it isn't included in the download, it is generated when the game runs. (I think it is saved when you exit flight mode, to be precise.)

To change to Blizzy's toolbar, the line

    <string name="Toolbar">stock</string>

should be changed to

    <string name="Toolbar">blizzy</string>

 

Share this post


Link to post
Share on other sites
4 hours ago, Biff Space said:

The config file is 

(Your KSP folder)\GameData\Biomatic\Plugins\PluginData\Biomatic\config.xml

Note that it isn't included in the download, it is generated when the game runs. (I think it is saved when you exit flight mode, to be precise.)

To change to Blizzy's toolbar, the line

    <string name="Toolbar">stock</string>

should be changed to

    <string name="Toolbar">blizzy</string>

 

 

ah, that would be why, i didnt have a chance to run the game when i installed it

Share this post


Link to post
Share on other sites

So I had this issue where I couldn't get rid of the UI for Biomatic, for a few versions. I finally got rid of it by going Switch Off ---> Click Button. Now I can't get it back. The button is grey, and clicking it does nothing.

I see in the config there is an on/off switch, but that will likely just start the cycle all over again.

I can get you a log if you'd like, but I don't remember seeing anything related to it in there (or with Exception Detector popups). Might be a bit however, as KSP is currently being retarded.

It's on Linux 64 bit.

Cheers.

Share this post


Link to post
Share on other sites
5 hours ago, Deimos Rast said:

So I had this issue where I couldn't get rid of the UI for Biomatic, for a few versions. I finally got rid of it by going Switch Off ---> Click Button. Now I can't get it back. The button is grey, and clicking it does nothing.

I see in the config there is an on/off switch, but that will likely just start the cycle all over again.

I can get you a log if you'd like, but I don't remember seeing anything related to it in there (or with Exception Detector popups). Might be a bit however, as KSP is currently being retarded.

It's on Linux 64 bit.

Cheers.

I have the exact same problem, I can't figure out how to get this back.  I've even tried deleting my config and reinstalling the plugin.

Share this post


Link to post
Share on other sites
9 hours ago, Deimos Rast said:

So I had this issue where I couldn't get rid of the UI for Biomatic, for a few versions. I finally got rid of it by going Switch Off ---> Click Button. Now I can't get it back. The button is grey, and clicking it does nothing.

I see in the config there is an on/off switch, but that will likely just start the cycle all over again.

I can get you a log if you'd like, but I don't remember seeing anything related to it in there (or with Exception Detector popups). Might be a bit however, as KSP is currently being retarded.

It's on Linux 64 bit.

Cheers.

There was a change in the last version released about when Biomatic would work. It now requires that the Space Exploration tech node is researched before it works, and until this is researched the toolbar button is greyed out and does nothing. (Previous versions made the part unavailable until the node was researched, but Biomatic still worked if it was added to command pods by Module Manager.)

I think that this is probably what is happening here. If you have researched the space exploration node and the button is still greyed out, there is a problem - please let me know

If you want Biomatic functionality available from the start of the game, you can edit the part config file:

(KSP folder)\GameData\Biomatic\Parts\Biomatic\part.cfg

Change the line reading

TechRequired = spaceExploration

to

TechRequired = start

 

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.