jsimmons

[1.2.2] 10x Kerbol system development for Kopernicus: Version 6.3.0.1 - Update: April 14 2017

Recommended Posts

Just now, MatterBeam said:

Does this mean that the current 10x Kerbol mod works with the latest kopernicus in KSp 1.1?

I haven;t tried 10x but the version of 64k meant for 1.0.5 is working for me.

Share this post


Link to post
Share on other sites

Sorry about the delay of the release. Currently I'm finding that the latest KSP 1.1.2 version is not very stable on linux platforms. I'm seeing lots of

RenderTexture.Create failed: requested size is too large.

 

[ERR 12:58:18.966] HighlightingSystem : UpdateHighlightingBuffer() : Failed to create highlightingBuffer RenderTexture!

 

Also for the case of the 1 in 20 start up attempts that KSP does starting running no fonts show up. I have tried the various

work arounds but those haven't worked for me. So sorry I haven't been able to get this out. I hope this issues will be resolved soon. 

Share this post


Link to post
Share on other sites
2 hours ago, NathanKell said:

Turn PPFX off?

Will that help with the missing font issue? As for the other problem I found work arounds in the linux compatibility thread. It appears Unity 5.2 doesn't know how to query the screen resolutions so it get confused and sets the resolutions to things like 1920x0. So you have to go into the Pref file and manually set it. Still have the missing fonts but I managed to test this mode with out them. I found the missing font issues to be a common problem. Sigh.

Hello folks.

    Release 6.1.0 has been released. If you plan to use the visual enhancements you will need to use Scatter 0.0245 since earlier version has the ocean rebuild problems. Also EVE 1.1 is needed as well if you want clouds. As for features its  at the same level as the previous release. Just with newer versions of everything. Enjoy.

Share this post


Link to post
Share on other sites

Ah, no, I saw the render texture and the highlighter stuff. Doubt it'll help fonts, sorry.

Share this post


Link to post
Share on other sites

Time to report on a update of what I'm working on. The next update will need the latest version of Eve. I addd some tweaks posted in the Eve form to make the clouds look a lot more real. Also looking at changing Kerbin surface textures to match closer to what RVE uses. This can be done with Kopernicus but I discovered using this exposes a bug in the Scatter mod. I also will added small improvements to the rim handling for Kerbin as well.

On May 9, 2016 at 6:18 PM, NathanKell said:

Ah, no, I saw the render texture and the highlighter stuff. Doubt it'll help fonts, sorry.

Yeah I have had no luck fixing that problem ;.;

Share this post


Link to post
Share on other sites

Nathan I have one question that you most likely know the answer. Is their a way to know the terrain altitude above sea level based on the coordinates on a planet? I see normally mods use the ActiveVessel altitude to determine distance above the terrain. In this case I like to be able to determine this based on a global position instead. Is this possible? 

Share this post


Link to post
Share on other sites

Yeah, you can ask the pqscontroller what the terrain altitude is at a given location. Forget the exact syntax tho.

Share this post


Link to post
Share on other sites
On May 17, 2016 at 8:00 PM, NathanKell said:

Yeah, you can ask the pqscontroller what the terrain altitude is at a given location. Forget the exact syntax tho.

Found it. This is a idea for EVE at this time.

      Vector3d rad = new Vector3d (Math.Cos (lat) * Math.Cos (lon) , Math.Sin (lat) , Math.Cos (lat) * Math.Sin (lon));
        double elevation = b.pqsController.GetSurfaceHeight (rad) - b.pqsController.radius;

Share this post


Link to post
Share on other sites

New 6.2.0 release. Didn't wait for the next EVE release so if you want pretty clouds you need the latest EVE which is the pre-release 1.1-3 for this to work. This is the eye candy update. Better clouds and we are back to using the RVE terrain textures for Kerbin so it looks so much better.

Share this post


Link to post
Share on other sites

@jsimmons just a heads up, the latest (6.2.1.0) version returns a 404 error when you try to download it (previous versions are fine).

Edited by Phineas Freak
Spacing...

Share this post


Link to post
Share on other sites

Just thought I would try this mod - Is the terrain texture supposed to be lime green?  I think I did something wrong.

Share this post


Link to post
Share on other sites

The terrain textures near the ksc looks quite stretched, and I am also getting lime green ground colors. I tweaked with planetshine a bit and the color did fade away a bit(ambient light settings) but it's still relatively lime green. Other than that, this is a really fun mod. Cheers!

 

I actually don't know how to upload screenshots to the forums :( I do have some screenshots of it, though.

Share this post


Link to post
Share on other sites

Sorry I have been busy with work and 1.1.3 didn't work well on my Linux system. Almost finished updated this mod to KSP 1.2.

Still missing KSCSwitcher as well but will not delay the upcoming release.

Edited by jsimmons

Share this post


Link to post
Share on other sites

Hey great work on this mod, however I realized Duna's atmosphere goes all the way until 180-ish kilometres which seems a bit weird.

Is that intentional?

Share this post


Link to post
Share on other sites
On 11/8/2016 at 11:16 AM, Simon91 said:

Hey great work on this mod, however I realized Duna's atmosphere goes all the way until 180-ish kilometres which seems a bit weird.

Is that intentional?

It's not at all weird. Mars has an atmosphere that extends out about that far (I think it's actually more like 150 though)

Share this post


Link to post
Share on other sites
On 10/11/2016 at 2:38 AM, Starwaster said:

It's not at all weird. Mars has an atmosphere that extends out about that far (I think it's actually more like 150 though)

EDIT: Sadly I'm pretty sure it's off, the atmosphere starts at 200kms and is literally as violent as the stock Eve.

I wouldn't expect a pretty shallow entry, at 4km/s to literally eat up my ablator in a minute or so.

Edited by Simon91

Share this post


Link to post
Share on other sites
On 11/9/2016 at 2:35 PM, Simon91 said:

EDIT: Sadly I'm pretty sure it's off, the atmosphere starts at 200kms and is literally as violent as the stock Eve.

I wouldn't expect a pretty shallow entry, at 4km/s to literally eat up my ablator in a minute or so.

Probably a heat shield issue. The stock shields are configured for smaller planets with slower orbital (and therefore reentry) velocities.

RO or DRE would recalibrate the shields for real sized solar system but neither one is updated for KSP 1.2 yet...

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.