Jump to content

[1.8.x] Contracts Window + [v9.4] [11/1/2019]


Recommended Posts

@cicatrix You are missing the ContractParser dependency from your GameData/DMagicUtilities folder. I'm not sure how that could have happened when installing through CKAN, as it is set as a dependency there. You could try deleting Contracts Window + and reinstalling, or just manually install Contract Parser, or manually install Contracts Window + from Space Dock, which includes all of its dependencies.

Link to post
Share on other sites
  • 2 months later...

Uhm. After reading the first few and last few pages I have what may be an odd question:

Could it be (made?) possible to remove the bar above contracts? I really dig the idea behind the mod, but it throws so much in my face I find myself using the stock window more despite it being frustrating as well. 
So many buttons, and the orange text, and the see-through background, it's too much going on at once :/

The very first screenshots of this mod missed a lot of features, sure, but they were a lot less 'loud'. :(

Ps. I realize that it may sound petty or spoiled, but for my brain it would make a world of difference.:/

Link to post
Share on other sites
  • 5 weeks later...

I searched the thread for posts regarding performance issues and some seem to highlight that performance has been improved. Even with only one contract visible in the window (I made a custom mission list and that's what I'm displaying) is lags like crazy. My FPS when sitting on the KSC screen (all buildings visible) drops from around 135 FPS to 50 FPS when I drag the window around. If I display all my contracts (only 29 currently active) and drag the window around I watch the FPS drop to 20 and it keeps dropping. Is there anything wrong with my game/mods/install? Or is the performance still an issue?

Something else I noticed when making custom missions and adding contracts to those missions - after the first 5 missions in the list, the dropdown menu doesn't have a texture anymore. Present with both stock and non-stock UIs. Images of the issue here.

I'm running on 1.7.2. Log file is here. Thanks. 

Edited by madindehead
Link to post
Share on other sites
  • 1 month later...

Contracts Window 9.3 is out; get it on Space Dock.

This update includes French translations by don-vip. It also fixes a few bugs related to the mission list popup windows not accommodating more than 4 or 5 missions. It also fixes some weird behavior when you apply the stock game settings while Contracts Window + is closed, along with behaving better when switching between the two different UI styles.

Link to post
Share on other sites

@DMagic thanks for this mod. I only installed it a few days ago, but it already so useful.  As a question or possibly a feature request... is there any way to filter the list of contracts to only see those that have not been assigned to any mission?

 

Again... thank you for all you do.

Link to post
Share on other sites
  • 2 months later...
  • 1 month later...

Pretty sure it's me just being a bit dense (VoidSquids are not famous to be known as the universe's smartest creatures), but: what is the benefit of this mod when I'm using CapCom - Mission Control On The Go already?

Edited by VoidSquid
Link to post
Share on other sites
  • 1 month later...

Curious, I just ran into an issue with this. After completing a set of about five part test contracts in one mission, now no contracts are showing in the window anymore. I double checked and I have active contracts, but the mod's window shows none of them. I tried accepting some new contracts to see if it was something to do with the existing contracts, but the new ones are also not showing up. I've used CW+ since I started playing KSP way back at 1.0 and I've never seen this happen. Any ideas? I tried searching but not finding this issue. Any suggestions? I use this extensively in part testing contracts to make sure I've met all the needed conditions.

Link to post
Share on other sites
  • 3 months later...
On 1/7/2020 at 2:11 AM, kananesgi said:

Curious, I just ran into an issue with this. After completing a set of about five part test contracts in one mission, now no contracts are showing in the window anymore. I double checked and I have active contracts, but the mod's window shows none of them. I tried accepting some new contracts to see if it was something to do with the existing contracts, but the new ones are also not showing up. I've used CW+ since I started playing KSP way back at 1.0 and I've never seen this happen. Any ideas? I tried searching but not finding this issue. Any suggestions? I use this extensively in part testing contracts to make sure I've met all the needed conditions.

Were you able to fix the issue or did you uninstall the mod? Is it bugged?

Link to post
Share on other sites
  • 1 month later...
On 4/8/2020 at 11:46 AM, Krzeszny said:

Were you able to fix the issue or did you uninstall the mod? Is it bugged?

My apologies, I didn't see this till just now. I simply stopped using the mod and started using the default contracts toolbar button. Less convenient than CW+, but it works well enough. I haven't tried CW+ in months now.

Link to post
Share on other sites
On 4/8/2020 at 11:46 AM, Krzeszny said:

Is it bugged?

I've been using it mostly successfully in 1.9.1. The only issue I run into is that periodically the window resets to default sorting. All contracts are open and any mission sets are gone and hidden contracts are back on the main list.

I gave up on mission sets as setting them up again is a nuisance.  Usually I just hide contracts not actively waiting on me to do something like survey contracts just waiting out a number of days in orbit. I haven't noticed what circumstance triggers a reset and looking through this thread it's been a reported problem in the past, but hadn't been commented on in a couple years.

Link to post
Share on other sites
  • 5 months later...

Seeing a start-up error with v9.4 on KSP 1.10.1. 

[ERR 23:09:41.374] ADDON BINDER: Cannot resolve assembly: ContractsWindow.Unity, Culture=neutral, PublicKeyToken=null

[ERR 23:09:41.420] ADDON BINDER: Cannot resolve assembly: ContractsWindow.Unity, Culture=neutral, PublicKeyToken=null

https://github.com/DMagic1/KSP_Contract_Window/issues/50

Link to post
Share on other sites
  • 4 weeks later...
  • 2 months later...

Missing contract details?

Please compare the details provided for the "Explore Minmus" contract in the pictures below. The part of the contract that says: "At least one scientist assures us that we won't bring back any harmful contaminants"  is missing in the VAB or on the launchpad but is shown in the Space Center window. Am I missing a setting or option somewhere?

x9xgxXH.png9B2OmN9.png

 

Link to post
Share on other sites
On 3/4/2021 at 4:05 PM, Kranvagn said:

So is this working fine with 1.11 ? 

Seems OK for 1.11.1. I believe addon binder errors at startup can all be ignored (based on some discussion with Lisias). I got a "key not found in dictionary" exception with 1.11.0 but I got that once with KAC too. So I guess Squad must have fixed whatever caused that.

Link to post
Share on other sites
  • 4 weeks later...

If anyone is having issues trying to cycle thru created missions and back to all contracts i believe it's fixed if you go to the settings and check the option "Use Stock UI Style", i am unable to say if this is a bug i caused myself due to other mods, or if it comes from this one... but if it works, it works!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...