DasPenguin85

[1.0.4] BoxSat vA.02f - Updated 09/16/2015

Which days & time are you more likely to watch a BoxSat development stream on Twitch?  

120 members have voted

  1. 1. Which days & time are you more likely to watch a BoxSat development stream on Twitch?

    • Day: Friday
      15
    • Day: Saturday
      49
    • Day: Sunday
      29
    • Time: Afternoon
      31
    • Time: Evening
      51


Recommended Posts

KSP BoxSat Streaming on Twitch Tonight!

Myself and Orcmaul will be streaming this evening in about 20 minutes with the A.02 release candidate - join us for our late-night (hopeful) release party on Twitch. You'll likely be joined by 2 other people at this hour of the night, but it offers a unique chance to talk with the developers and get a sneak preview prior to release.

Twitch Steam Link

Edited by DasPenguin85

Share this post


Link to post
Share on other sites

will you be adding a part for 0-500km range antenna for RT2? because as it stands now, i would need to use the DP10 antenna from RT2 to get your boxsat to work while going through the atmo... and the DP10 is really ugly( doesnt fit well aesthetically with your awesome parts)

also, i would suggest changing the MP500 and XDP2500 to omni, as having a cone angle at 500km and 2.5mm is.....derp.

....and changing the MP500 range to 2.5mm and XDP2500 to 5mm too.

Edited by XkaOnslaught

Share this post


Link to post
Share on other sites

We'll be investigating the non-omni functionality of the tape antennas today. I assume it'll be a pretty quick fix if there is a problem. Just waiting for Orcmaul to wake up so we can get that issue hotfixed soonâ„¢. We were both up really late testing and getting the release out last night, so he might sleep until Tuesday.

I'll also ask him about the low-range antenna for launching, though I think the probecore acts as an omni antenna up to a short range for that purpose. Don't quote me just yet!

As always, if you enjoy the work we put into the mod & the new update, consider visiting our "Tip Jar" in the OP. :)

Share this post


Link to post
Share on other sites

After using this mod im just amazed at the amount of detail and work put into this! Its just amazing and well worth the amount of space it takes up RAM wise. I mean its been ages since iv been this amazed at a mod and if i could donate, I would :)

Share this post


Link to post
Share on other sites
will you be adding a part for 0-500km range antenna for RT2? because as it stands now, i would need to use the DP10 antenna from RT2 to get your boxsat to work while going through the atmo... and the DP10 is really ugly( doesnt fit well aesthetically with your awesome parts)

also, i would suggest changing the MP500 and XDP2500 to omni, as having a cone angle at 500km and 2.5mm is.....derp.

....and changing the MP500 range to 2.5mm and XDP2500 to 5mm too.

DasPenguin should be posting the update to Kerbal Stuff soon.

Here is a corrected modulemanager config for remotetech.

RemoteTech_BoxSat.cfg

Attach the DP10 to the upper stage you use for circularizing and deploy your boxsat antenna once you're out of the atmosphere but before you decouple. We'll definitely consider including an antenna for launches in a future release.

Share this post


Link to post
Share on other sites

Update A.02a Released

This is a hotfix for the Remote Tech 2 support, where we changed the config to make the tape antennas omni-directional. See original post for download!

Happy BoxSat launching!

Share this post


Link to post
Share on other sites

I think you removed the goo experiment from the "Parts planned for next update" section, even though they haven't been added.

Share this post


Link to post
Share on other sites

A couple of the parts (sorry I forgot exactly which two) just have generic "this is an empty box for putting stuff in" descriptions, but they actually do stuff.

Is is there anything that could be done to make placing a panel/antenna on the top easier? It's very dodgy with a radial attachment.

Share this post


Link to post
Share on other sites

I am trying to launch with RT2 and it says "Warning: no control! This vessel has no remote-controlled or manned modules. It won't be controllable." I have a probe core installed. I have two small antennas and a RT2 dish on the satellite. What am I doing wrong?

Share this post


Link to post
Share on other sites
I am trying to launch with RT2 and it says "Warning: no control! This vessel has no remote-controlled or manned modules. It won't be controllable." I have a probe core installed. I have two small antennas and a RT2 dish on the satellite. What am I doing wrong?

Are you using RSS or a mod that puts base's everywhere ?

Share this post


Link to post
Share on other sites
A couple of the parts (sorry I forgot exactly which two) just have generic "this is an empty box for putting stuff in" descriptions, but they actually do stuff.

Well look at that. Both of the tanks failed to get a good description. Sorry about that. Instead of starting with a blank text file and building the entire configuration from scratch each time, I start from a known working part and tweak the values and add the appropriate bits. So that's how I got the wrong description on a part. I'll fix it and it'll get updated when we release our next build. Thank you for reporting it.

Is is there anything that could be done to make placing a panel/antenna on the top easier? It's very dodgy with a radial attachment.

As far as I can tell this is actually a KSP issue. There are a couple ways to deal with this. You can rotate the frame temporarily and use angle snap to give you some better control. The other option is to set your symmetry to 4 and move the part around until all 4 copies are completely overlapping then press x three times without moving your mouse to get your symmetry back to 1 and place the part.

Share this post


Link to post
Share on other sites
I am trying to launch with RT2 and it says "Warning: no control! This vessel has no remote-controlled or manned modules. It won't be controllable." I have a probe core installed. I have two small antennas and a RT2 dish on the satellite. What am I doing wrong?

OK, so I'm working with some assumptions here.

Assumption 1: you are playing career mode

Assumption 2: you've listed all the antennas you are using

Assumption 3: you are launching a new vehicle

Assumption 4: you have no control as soon as you put it on the launch pad

Assumption 5: you haven't unlocked the technology "Unmanned Tech"

Assumption 6: you are not using launch clamps

This set of assumptions suggests you are starting on the launch pad and you don't have an active antenna. The solution is to add a reflectron dp-10 to your launch vehicle. Your other option is to add launch clamps and activate an antenna that won't fall off in-flight before launching.

If one or more of these assumptions is incorrect let me know.

Share this post


Link to post
Share on other sites
I think you removed the goo experiment from the "Parts planned for next update" section, even though they haven't been added.

Yeah. There was some miscommunication between daspenguin and myself about what parts we would be including in the next update and those were mistakenly included in the list. I apologize for the miscommunication. We also said we'd be adding a Yagi-Uda antenna and regrettably there were issues that cropped up during design of the part that would delay our release. Instead of delaying the release for two weeks we decided to include a second short range tape antenna to compensate and released the update. I apologize that the promised Yagi-Uda antenna was not included in the update.

As far as the next update is concerned we are just beginning the early planning phase of what parts will be included in the next update. Our current thinking is that alpha.03 will be have a primary focus on propulsion. As we get further along in planning and designing alpha.03 I'll be posting about what parts we have selected to develop.

Share this post


Link to post
Share on other sites
OK, so I'm working with some assumptions here.

Assumption 1: you are playing career mode

Assumption 2: you've listed all the antennas you are using

Assumption 3: you are launching a new vehicle

Assumption 4: you have no control as soon as you put it on the launch pad

Assumption 5: you haven't unlocked the technology "Unmanned Tech"

Assumption 6: you are not using launch clamps

This set of assumptions suggests you are starting on the launch pad and you don't have an active antenna. The solution is to add a reflectron dp-10 to your launch vehicle. Your other option is to add launch clamps and activate an antenna that won't fall off in-flight before launching.

If one or more of these assumptions is incorrect let me know.

I installed the mm cfg from the last page, problem disappeared?

Share this post


Link to post
Share on other sites
I installed the mm cfg from the last page, problem disappeared?

Ah the one assumption I didn't think of. You needed to update your install to the A.02a version. The update fixed the tape antennas not being omnidirectional. Then again, that's assuming you installed the mm cfg I provided and not one of the other ones. However it happened I'm glad it is working for you now.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.