Jump to content

[0.24.2] Interstellar Lite - Tweakscale Integration [v0.12.3][Sept 7]


WaveFunctionP
 Share

Recommended Posts

For ORS, MKS/Karbonite/etc. use explicitly the one in the USI folder.

so i should remove the ORS 1.2.1 in my ORS folder and replace it with 1.2.0? sorry if im being obtuse i just wanna be absolutely clear so as not to mess up your moddy goodness

Edited by Jagzeplin
Link to comment
Share on other sites

I would also be very interested in an explanation to installing MKS/OKS/Karbonite side by side with Interstellar Lite and SCANSat and have them all working.

Put the ORS DLL that comes with KSPi-Lite in the ORS folder, remove all others from that folder. Leave the ORS 1.2.0 DLL in the USI folder, and leave the ORS 1.1.0 DLL in the scansat folder.

That should get you running with all USI / KSPi-Lite / SCANsat

Link to comment
Share on other sites

I'm new to this mod and having trouble getting some features to work. To troubleshoot I uninstalled all mods and only running with the files from Interstellar. I still can't seem to mine resources. For example, there is no button to mine water on the refinery. There is a button to mine Uranium, but it appears to do nothing. I have no idea what I'm doing wrong, or are these features not implemented yet?

Link to comment
Share on other sites

I'm new to this mod and having trouble getting some features to work. To troubleshoot I uninstalled all mods and only running with the files from Interstellar. I still can't seem to mine resources. For example, there is no button to mine water on the refinery. There is a button to mine Uranium, but it appears to do nothing. I have no idea what I'm doing wrong, or are these features not implemented yet?

You need to be in certain locations to extract water like an ocean or an icy moon like minmus.

Link to comment
Share on other sites

You need to be in certain locations to extract water like an ocean or an icy moon like minmus.

Ok I'm floating in the Ocean of Kerbin and there is an extract Water option. However, the water tank on the refinery and the radial water storage containers never fill.

Link to comment
Share on other sites

Ok I'm floating in the Ocean of Kerbin and there is an extract Water option. However, the water tank on the refinery and the radial water storage containers never fill.

You may need to use fuels lines, but you should be able to extract water into the refinery and process it onboard, I never use the water tanks.

If it does not work, you may have a faulty installation.

Link to comment
Share on other sites

Intersteller is awesome, and this is extra awesome. I really like the tidying-up of the parts that TweakScale allows for, this makes navigating the menus so much faster. Thanks for putting this together!

One question* though; are the Thermal Rocket Nozzles significantly nerf'd as compared to the standard Interstellar values? The same ship designs I am familiar with launching with silly-high TWR are now of poor performance.

Specifically: I slap together a 1.25m Antimatter Reactor with a generator on top, some radiators, and a thermal rocket on the bottom. Where I had TWR >10 before, I have ~0.3 now.

* Sorry, have not read the full thread yet, I'm off to RTFM now, and I'll edit out my question when I find out.

Link to comment
Share on other sites

Intersteller is awesome, and this is extra awesome. I really like the tidying-up of the parts that TweakScale allows for, this makes navigating the menus so much faster. Thanks for putting this together!

One question* though; are the Thermal Rocket Nozzles significantly nerf'd as compared to the standard Interstellar values? The same ship designs I am familiar with launching with silly-high TWR are now of poor performance.

Specifically: I slap together a 1.25m Antimatter Reactor with a generator on top, some radiators, and a thermal rocket on the bottom. Where I had TWR >10 before, I have ~0.3 now.

* Sorry, have not read the full thread yet, I'm off to RTFM now, and I'll edit out my question when I find out.

The thermal nozzles themselves still calculate thrust and Isp from heat source temperature, thermal power, and fuel multipliers the same way you're used to, with at most a couple of fuel-specific multipliers changing. But since the high-end reactors are not as powerful in Lite as they were in 0.11, you'll find some configurations producing lower thrust.

Link to comment
Share on other sites

The current FULL version of tweakscale contains configurations for interstellar modules. You will need to manually remove those settings until it is updated and those files are removed. There is a configuration file called warp_tweakscale.cfg and more settings located in scaleexponents in the tweakscale download. Delete all scaleexponents from solarsail to fnfusionreactor. Or wait until tweakscale is updated to remove those settings if you do not know how to do this. Yes, I know it sucks, but it is a temporary transition period.

Has this been fixed? I looked in warp_tweakscale.cfg and I can't find any values for "solarsail" or "fnfusion".

(Yes I have the full version of tweakscale)

Link to comment
Share on other sites

Has this been fixed? I looked in warp_tweakscale.cfg and I can't find any values for "solarsail" or "fnfusion".

(Yes I have the full version of tweakscale)

warp_tweakscale.cfg is the file you just delete in its entirety. The values you're looking for are in ScaleExponents.cfg in the same folder.

Link to comment
Share on other sites

12.3 seems to break the reactors badly, the fission reactor module doesn't load

My Reactors work fine.

Reactors%20Demo.jpg?dl=1

is it possible you have parts left over for KSPi? KSPiLite (wave's version, in the Interstellar folder) is is a comprehensive replacement for KSPi (FractalUK's version, in the WarpPlugin folder). Make sure you delete the old one; having both makes a mess.

Link to comment
Share on other sites

I've just had a look and the Interstellar Lite package doesn't have a .version file yet. KSP-AVC works based on .version files for update checking, so if a mod doesn't contain one, then it cannot be checked... If anyone has any mods that are not supported and wish they were, just give the author a nudge to include one :)

this was in the avc thread but i thought it would be prudent to bring it up here

Link to comment
Share on other sites

I'm gonna ask again because the problem is still there: I'm unable to transmit power from an antimatter reactor. There's enough antimatter on board, the reactor + generator is active, transceiver is set to transmit, radiators are deployed etc. but no power is transmitted. Am I doing something wrong?

Link to comment
Share on other sites

I have a problem: Nothing works. Parts do not animate, and nothing seems to function beyond storing resources. Additionally, some parts expand uncontrollably when moused over in the parts menu in the VAB. Any idea which mod conflicts are known to cause this?

Sounds like nothing in the Interstellar plugin is loading. First thing to try: Remove GameData/OpenResourceSystem and any other copies of ORS that a particular mod hasn't instructed you to keep, and install the ORS that's packaged with the version of KSPI you're trying to run. If you have both GameData/Interstellar and GameData/WarpPlugin, you're mixing versions of Interstellar. Remove whichever one you're not trying to use. If that doesn't fix it, post an output log so we can see why the plugin isn't loading.

Link to comment
Share on other sites

I don't know about the feasibility of this, but it'd be nice to have a config for magnetic fields. So if you have custom planets, you can add a magnetic field to it and have antimatter collectors work.

Every planet has a magnetic field based on its rotation rate. Some bodies have multipliers in the plugin (weakening the field around small moons and increasing it around Moho, Jool, and Eve), but custom planets should already get the default magnetic field.

Link to comment
Share on other sites

Hi Guys

I have just done a fresh install on a new game download and I have found that my interstellar parts arent happy... particularly my plasma engine doesn't wanna use anything but liquid fuel - so what am I doing wrong to cause this or have i installed something in the wrong order?

Fresh install, using a few other mods, which all used to get along happily before...

I am unable to switch fuel modes on the engine or to activate the anti matter generators. (so unable to use xenon etc as fuel)

Using sandbox and a brand new save game.

Thanks

The Gecko

Edited by Gecko99
Link to comment
Share on other sites

Sounds like nothing in the Interstellar plugin is loading. First thing to try: Remove GameData/OpenResourceSystem and any other copies of ORS that a particular mod hasn't instructed you to keep, and install the ORS that's packaged with the version of KSPI you're trying to run. If you have both GameData/Interstellar and GameData/WarpPlugin, you're mixing versions of Interstellar. Remove whichever one you're not trying to use. If that doesn't fix it, post an output log so we can see why the plugin isn't loading.

I did a clean reinstall of the /gamedata folder and installed only Interstellar and the IXS mod (also hyperedit for easier testing). Everything works perfectly, am gonna add more mods in batches and see whether it breaks again.

Edited by Voodoomancer
add quote
Link to comment
Share on other sites

[stuff]

Update: Now treeloader won't load the tree, or any tree besides the "Use Stock" button in Career mode :/

EDIT: Also everything is broken again >.< On the upside: I didn't overwrite anything, so some mod is just plain-and-simple breaking the insterstellar plugin itself.

Later edit: I think I've narrowed it down to either Karbonite, Extraplanetary Launchpads, or Part Catalogue. Could be wrong, though.

Edited by Voodoomancer
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...