Athlonic

[1.7.x] Chatterer v.0.9.96 - Just keep talking to me [18 Oct 2018]

Recommended Posts

1 hour ago, Athlonic said:

Got a KSP v1.4 ready devbuild working :wink:

I will upload it when back from work in a few hours.

Thanks!!!

Share this post


Link to post
Share on other sites

Nevermind ...

Why modding at home when you can do it from work (don't tell my boss)

Update out :

Quote

v0.9.94 [12 Mar 2018]
- Recompiled for KSP v1.4.0.2077
- Fixed reverb_filter deprecated function roomRolloff preventing plugin execution in KSP v1.4

:wink:

Share this post


Link to post
Share on other sites

Woohoo! One of my favorite mods! You don’t realize how important it is until you’re playing without it. EVA’s without the ker-PLUNK PSSSSSHHHHHH are just not the same!

Share this post


Link to post
Share on other sites
4 hours ago, Athlonic said:

Got a KSP v1.4 ready devbuild working :wink:

I will upload it when back from work in a few hours.

Sweeet :D Thanks so much man!

Share this post


Link to post
Share on other sites

There's not a lot of chatter. A little bit after an EVA (or ending one) but that's about it (using default settings). After an EVA the debug window shows "initiating chatter" (or something along those lines) and then nothing.

Share this post


Link to post
Share on other sites

Side note:  anyone feel like GameData\Chatterer\Sounds\chatter\valentina\capsuleF\capsule_25.ogg sounds like she's saying "We need to resist them and make them give us the best EVAs"?  :D

Share this post


Link to post
Share on other sites

If I'm going to stay with 1.3.1 for awhile, should I not install this latest update (for 1.4)?

Share this post


Link to post
Share on other sites
52 minutes ago, MikeO89 said:

If I'm going to stay with 1.3.1 for awhile, should I not install this latest update (for 1.4)?

The previous version worked better for me in 1.3.1 than the new version does in 1.4; that’s all I can say.

Share this post


Link to post
Share on other sites
11 hours ago, Kerbart said:

There's not a lot of chatter. A little bit after an EVA (or ending one) but that's about it (using default settings). After an EVA the debug window shows "initiating chatter" (or something along those lines) and then nothing.

Yep, thanks for pointing this out.

I can reproduce the issue : chatter exchanges stop working for some reason (until EVA or vessel swap), no clue for now. I will have a look at this.

Share this post


Link to post
Share on other sites
2 hours ago, Athlonic said:

Yep, thanks for pointing this out.

I can reproduce the issue : chatter exchanges stop working for some reason (until EVA or vessel swap), no clue for now. I will have a look at this.

I read somewhere about a thunderous speech Gene Kerman held in the Austronaut Center about “professional work attitude” and “com lines are for mission updates, not idle banter,” perhaps that’s what’s caused it?

Take your time, your mod is greatly appreciated, but it should be a hobby and not an obligation!

Share this post


Link to post
Share on other sites

Hi I just love Chatterer, it's one of my favorite mods. :-) Though I'm trying to use it with CKAN, and the version file might need some adjusting. I could be wrong but I don't think version .94 works with KSP 1.3.1 or earlier. Though the version file says it does:

{
	"NAME":"Chatterer",
	"URL":"http://ksp-avc.cybutek.net/version.php?id=27",
	"VERSION":
	{
		"MAJOR":0,
		"MINOR":9,
		"PATCH":94,
		"BUILD":2077
	},
	"KSP_VERSION":
	{
		"MAJOR":1,
		"MINOR":4,
		"PATCH":0
	},
	"KSP_VERSION_MIN":
    {
        "MAJOR":1,
        "MINOR":3,
        "PATCH":0
    },
	"KSP_VERSION_MAX":
    {
        "MAJOR":1,
        "MINOR":4,
        "PATCH":99
    },

This means that CKAN will pick the wrong version for 1.3.1.

Thanks checking it out. Oh if there is a bug tracker that you would rather I use, please let me know.  :-)

    Karn

Share this post


Link to post
Share on other sites

theres a male kerbal thats sounds like he says " yer stupid again.....yer stupid again scott manley" 

Share this post


Link to post
Share on other sites

Hey guys i tried to install chatterer, to my new ksp copy (1.4.1), via ckan ,but windows defender block the Chatterer.dll. Any of you have any idea why this happens? Why windows defender recognize this dll as a threat?

6migi6N.png

Share this post


Link to post
Share on other sites

Huh ? That's new.

Just did a scan with Defender on my original .dll and nothing.

Hold on will try to grab via CKAN as well...

Edit : No threat here, I am afraid the dll should have been infected on your machine after the download, do I full scan to be safe.

PS : also avoid to install your KSP in the Program Files folder as Windows protection might prevent some mods from working correctly.

Edited by Athlonic

Share this post


Link to post
Share on other sites
On 16/03/2018 at 3:20 AM, Karn said:

Hi I just love Chatterer, it's one of my favorite mods. :-) Though I'm trying to use it with CKAN, and the version file might need some adjusting. I could be wrong but I don't think version .94 works with KSP 1.3.1 or earlier. Though the version file says it does:


{
	"NAME":"Chatterer",
	"URL":"http://ksp-avc.cybutek.net/version.php?id=27",
	"VERSION":
	{
		"MAJOR":0,
		"MINOR":9,
		"PATCH":94,
		"BUILD":2077
	},
	"KSP_VERSION":
	{
		"MAJOR":1,
		"MINOR":4,
		"PATCH":0
	},
	"KSP_VERSION_MIN":
    {
        "MAJOR":1,
        "MINOR":3,
        "PATCH":0
    },
	"KSP_VERSION_MAX":
    {
        "MAJOR":1,
        "MINOR":4,
        "PATCH":99
    },

This means that CKAN will pick the wrong version for 1.3.1.

Thanks checking it out. Oh if there is a bug tracker that you would rather I use, please let me know.  :-)

    Karn

Nice catch Karn ! thanks a lot

I changed the AVC online version file accordingly.

CKAN seems to pick the old version for 1.3.1 now (not sure if someone fixed the metadata or if my change did it though ^^ ) as v0.94 isn't working with KSP 1.4, 1.4.1 at all (I should have checked this, #mybad)

Share this post


Link to post
Share on other sites
8 hours ago, obrelix said:

Hey guys i tried to install chatterer, to my new ksp copy (1.4.1), via ckan ,but windows defender block the Chatterer.dll. Any of you have any idea why this happens? Why windows defender recognize this dll as a threat?

I'm reproducing the same, Windows Defender identifying both the preexisting DLL and new download from Spacedock as Trojan:Win32/Critet.BS.

Share this post


Link to post
Share on other sites
1 hour ago, Athlonic said:

 

Interesting ...

I reported this same false-positive in the MechJeb thread, as it's affecting that .dll as well. When I discovered this morning that MJ wasn't working, I started digging through my KSP Game Data folder and sure enough, chatterer.dll had been removed too. I manually updated my Windows Defender definitions this afternoon and while Microsoft's definitions file has been updated just since this morning, both MechJeb2.dll and Chatterer.dll are still being flagged as infected files. 

 

Share this post


Link to post
Share on other sites

Well, same here:

Trojan:Win32/Critet.BS

file: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Chatterer\Plugins\Chatterer.dll

Soooo....do I trust that these files are safe, or did this get compiled with an infected dependency?  I'm going to err on the side of caution for this one.  Pity, as everything feels eerily quiet now.

Share this post


Link to post
Share on other sites

It appears other apps are having issues as well, and it seems to be connected to the Unity engine somehow.  Here's the Reddit thread:

 

Share this post


Link to post
Share on other sites

I manually load all my mods, and run chatter just fine. I also Use ESET on the strict levels where it scans everything.

Edited by viperwolf

Share this post


Link to post
Share on other sites
2 hours ago, macr0t0r said:

Well, same here:

Trojan:Win32/Critet.BS

file: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Chatterer\Plugins\Chatterer.dll

Soooo....do I trust that these files are safe, or did this get compiled with an infected dependency?  I'm going to err on the side of caution for this one.  Pity, as everything feels eerily quiet now.

It's a false-positive hit from Defender. I even manually uploaded the file to Microsoft's Windows Defender security page and it was scanned as safe, but the latest downloadable malware definitions file as of this evening STILL marked it as it as infected, along with the MechJeb2.dll file and ModuleManager.3.0.6.dll. 

 

Share this post


Link to post
Share on other sites
On 3/12/2018 at 8:46 PM, Kerbart said:

There's not a lot of chatter. A little bit after an EVA (or ending one) but that's about it (using default settings). After an EVA the debug window shows "initiating chatter" (or something along those lines) and then nothing.

Interestingly this seemed a 1.4.0 bug; in 1.4.1 Chatter seems to work just fine.

Share this post


Link to post
Share on other sites

I just downloaded the latest version off Spacedock and got the "Trojan:Win32/Critet.BS" warning as well. Is there any chance one of your dependencies has been infected? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.