Athlonic

[1.7.x] Chatterer v.0.9.96 - Just keep talking to me [18 Oct 2018]

Recommended Posts

Chatterer seems to work even though it gives a warning.

Edited by Quantum Jim
incorrect information corrected

Share this post


Link to post
Share on other sites
7 hours ago, BlackHat said:

I am sticking to 1.5.1 for my game play for at least a couple months just to allow my favorite mods time to be updated. (running about 110+ mods)

Just so you know, the new update cycle is intended to run every 3 months... If you wait for everything to get updated, the next patch will have been released before then ;)

Share this post


Link to post
Share on other sites

This update has been pretty smooth for me and my mods (other than having some warnings throw at beginning). I can say this. 1.6 runs noticeable smoother for me than 1.5.1 did. I won't ever run 1.5.1 again, it ran like a dog.

Share this post


Link to post
Share on other sites
On ‎12‎/‎23‎/‎2018 at 10:56 PM, BlackHat said:

First, Don't do that.... 

Practical the #1 rule in the Add-on category, is Dont poke the bears... in other words ... dont pester the mod creators for updates.

1.6 has only been out for about 4 days. Give the mod makers time to enjoy the holidays, and then wait until the mod creator has been inactive for at least 3-6 months before asking if someone can do anything.

Second, Chatterer is not a mod that is usually effected by version changes. Have you tried it?

Just set CKAN to allow 1.5.1 (or 1.5) as a compatible version. This will let CKAN install the mod. Install it and try it. I suspect it will work.

Just don't forget to delete the check, setting 1.5.1 (or 1.5) as compatible when you finish installing it, until you want to try to see if another favorite 1.5.1 mod is still working in 1.6.

Third, I would test it myself as Chatterer is one of my favorite mods, but I have not even downloaded 1.6 yet. I am sticking to 1.5.1 for my game play for at least a couple months just to allow my favorite mods time to be updated. (running about 110+ mods)

Apologies, I have been running vanilla KSP up until short time ago, and Chatterer was the first mod I chose to install. Also, I was a bad KSP player and stopped playing for a while. during that time KSP apparently went to 1.6. I wasn't aware how long 1.6 had been out when I made my post. Once again, sorry for breaking etiquette rules.

Share this post


Link to post
Share on other sites

I on the other hand WANT this mod displayed using the stock toolbar. But it was not showing up until I installed the blizzy toolbar and associated toolbar control. I after telling toolbar control to show the button, I went into chatterer settings and turned off the blizzy toolbar only setting. the button immediately showed up in the interface. I had to change the settings twice. once for the third person (rocket) view and once more for the map view. afterwards I uninstalled the blizzy toolbar and toolbar control mods.

Share this post


Link to post
Share on other sites

I'd just like to say, if I haven't said it before (and if I have, it deserves many more, anyway), this is a great mod, and thank you for providing it.  It's one that adds so much immersion to the game that it's more noticeable when it's not installed.

Share this post


Link to post
Share on other sites

Thanks for feedbacks and kind words guys.

I will have a look at the stock toolbar issue, it shouldn't behave like this.

Share this post


Link to post
Share on other sites
On ‎12‎/‎30‎/‎2018 at 12:46 AM, Athlonic said:

Thanks for feedbacks and kind words guys.

I will have a look at the stock toolbar issue, it shouldn't behave like this.

most appreciated. I should note, that after uninstalling blizzy toolbar and toolbar control, the chatterer mod icon (using the stock toolbar) stayed active. so, for whatever reason under ksp 1.6 the mod is defaulting to blizzy toolbar only, even if the blizzy toolbar had not ever been installed (yet)

Share this post


Link to post
Share on other sites
8 hours ago, Iannic-ann-od said:

So happy you are still maintaining this for more than 5 years now! 

Hey !

Nice to see you still around as well ;)

5 years you say ?  Oh ... my ... ^^ 

Yep, Chatterer is still alive, yet it deserves more time I can give it for now, but I still got some nice ideas and plans for the future ... just got lack of free time :(

 

7 hours ago, MikeO89 said:

Can you update this for 1.6.1 so warnings at startup go away?

I feel KSP 1.7 is just around the corner, recompile will come with it and updates some times later.

I updated KSP AVC numbers for 1.6.1, this should help with CKAN and warnings in the meantime  ;)

Share this post


Link to post
Share on other sites

The newest version give a warning when starting KSP.

q34X6Ko.png

KSP Version: 1.7.0.2483

Installed Modules:

Chatterer 0.9.96
A MakingHistory-DLC 1.7.0

Share this post


Link to post
Share on other sites
5 hours ago, MaltYebisu said:

The newest version give a warning when starting KSP.

It still works though. :)

Share this post


Link to post
Share on other sites

Yes, but since it might be confusing and easy to fix I thought I should mention it. ;)

Share this post


Link to post
Share on other sites
3 minutes ago, MaltYebisu said:

Yes, but since it might be confusing and easy to fix I thought I should mention it. ;)

It is. Go into your GameData \Chatterer\Plugins folder and edit the Chatterer.version file (it's a text file) to specify KSP version. :)

Share this post


Link to post
Share on other sites

This "unsupported" message shouldn't show up anymore though, as I have updated the remote version file to KSP1.7.

Unless you didn't allow AVC to check online ?

Share this post


Link to post
Share on other sites
On 5/23/2019 at 11:14 PM, Athlonic said:

This "unsupported" message shouldn't show up anymore though, as I have updated the remote version file to KSP1.7.

Unless you didn't allow AVC to check online ?

All I did was to install the mod using CKAN on a new install of KSP. 

Maybe this is a bug with CKAN? I'll try again later to confirm.

 

Share this post


Link to post
Share on other sites

@Athlonic I tried it again just now. I installed the mod from CKAN on a new install like last time. You were right, if I answer 'yes' to the check-for-updates-prompt it starts without any message. If I answer 'no', I get the same message I showed you. :)

Share this post


Link to post
Share on other sites

Weird crash on scene change. Any clues. Looks like a unhappy combo between scatterer and chatterer.

Spoiler

Unhandled Exception: System.NullReferenceException: 
  at (wrapper managed-to-native) UnityEngine.GameObject:get_transform ()
  at scatterer.AtmosphereProjector.Finalize () [0x00000] in <filename unknown>:0 
Stacktrace:

  at (wrapper managed-to-native) UnityEngine.Object.FindObjectsOfType (System.Type) <0x00062>
  at (wrapper managed-to-native) UnityEngine.Object.FindObjectsOfType (System.Type) <0x00062>
  at Chatterer.chatterer.destroy_all_beep_players () <0x0003c>
  at Chatterer.chatterer.load_shared_settings (ConfigNode) <0x0007f>
  at Chatterer.chatterer.load_plugin_settings () <0x00589>
  at Chatterer.chatterer.Awake () <0x01059>
 

 

Share this post


Link to post
Share on other sites

No clues.

Maybe scatterer tried to scatter some chatter :unsure:

Anyways ... I am 100% sure it's scatterer fault :lol:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.