Athlonic

[1.7.x] Chatterer v.0.9.96 - Just keep talking to me [18 Oct 2018]

Recommended Posts

Maybe I'm not understanding how to set up Chatterer right, but in some fairly old versions, I remember that it would 'remember' what kind of ship you were launching and apply sounds based on that. All of my probe-driven ships automatically applied beeps, all of my crew-driven ships automatically applied chatter. Now when I launch a crewed vessel I typically get beeps AND chatter, because it's applying some sort of default (despite using 'unique per ship' setting).

How can I restore the old hands-off painless functionality? It's annoying as hell having to reconfigure it every damn time.

Share this post


Link to post
Share on other sites

Hi all!

I've made some more chattering nonsense with my microphone and thought it can be of interest to someone.

Feel free to use it, and maybe add it to the first post if you find that's worth it.

Here is the download link: https://mega.co.nz/#!s05RELBS!1a8XeFo0e3U4_OtJDpPHAlyqVeLifIpnKJdotz3ffFk

(Installation instructions are also included in the .rar file)

Installation

1. Just put the gamedata folder into your KSP root folder and merge folders

In-game:

2. You must go to the "settings" tab of chatterer and activate "show advanced options"

3. Go to "chatter" tab and click on "ChatterSets"

4. Here you must add the directory name "cendartalk" and click load

5. Tadaaa! Now you have more stupid chattering!

Share this post


Link to post
Share on other sites

Hi, I'm getting these super annoying beeps like a fax machine every 15 minutes or so. I tried settings but when I click on "beeps" or "SSTV" I just get a blank box. How do I turn this off? Thanks.

Share this post


Link to post
Share on other sites
Hi, I'm getting these super annoying beeps like a fax machine every 15 minutes or so. I tried settings but when I click on "beeps" or "SSTV" I just get a blank box. How do I turn this off? Thanks.

You got 3 solutions here :

- be sure to set SSTV to "No SSTV" (bar to the far left) in beep settings

or

- be sure to not have a Hotkey for SSTV you use for other thing

or

- set SSTV volume to 0% (if the two above didn't work)

;)

Share this post


Link to post
Share on other sites
You got 3 solutions here :

- be sure to set SSTV to "No SSTV" (bar to the far left) in beep settings

or

- be sure to not have a Hotkey for SSTV you use for other thing

or

- set SSTV volume to 0% (if the two above didn't work)

;)

Thanks but as I said when I click on beeps:

screenshot485_zps1e1e8e1c.png

I get a blank box with no adjustments:

screenshot486_zps97234a70.png

I don't see where I can set SSTV volume separately.

Share this post


Link to post
Share on other sites

Ok I see the problem here.

You are using a really old version of Chatterer (0.5.9), update to the latest 0.8.0 and all should be fine.

Share this post


Link to post
Share on other sites

Thanks. I thought I downloaded the most recent version (I did this when 0.90 came out) but obviously I messed up somewhere.

Share this post


Link to post
Share on other sites

Ok so I'm not crazy. I downloaded the latest version. I deleted old folder and moved new folder into gamedata. VERSION file says 0.8 but I still get the blank box saying version 0.5. I did have the latest version all along it seems.

screen1_zps2cfeb22c.jpg

screen2_zps6a020278.jpg

screen3_zps628eaeb0.jpg

Strange huh? Any suggestions?

Thanks in advance.

Share this post


Link to post
Share on other sites

Maybe you are using another mod which includes an old Chatterer version.

Search for chatterer.dll inside your gamedata folder to see if you find multiple ones.

Otherwise this looks like a what the f.. situation Indeed.

Share this post


Link to post
Share on other sites

hey I want to add some space x style chats, commentary to chatter, how can I do this ? So far what ive tried does not work......

Made a folder called spacex along with the 2 default directories from apollo and sts

Apollo

-capcom

-capsule

STS

-capcom

-capsule

SPACEX

-capcom

--XXXX.ogg

-capsule

--XXXX.ogg

Share this post


Link to post
Share on other sites

I know this might be a bit far out there, but I've been playing with a dualshock 4 for a while now, loving the trackpad for camera movement (frees up an entire stick for more analogue goodness while docking) and I'm wondering of chatterer could be made to support the little built in speaker.

Probably not, but thought I'd give er' a try, worst you guys could say is "no; that's impossible."

They used to say that about landing on the moon too though...

Edited by Errol

Share this post


Link to post
Share on other sites

Ok how do you get this to work, I've got karbonite, toolbar (blizzy), and scansat 9.1 installed, but chatterer isn't showing up with the toolbar, I deleted the toolbars setting and put chaterer into the data folder.

Share this post


Link to post
Share on other sites

As suggested in this thread...

I think a round of applause and cheering over the coms/radio from mission control would be a cool 'contract completed' sound

Is this doable? Perhaps even one sound for a sub-goal completion and the applause for full contract completion? :D

Share this post


Link to post
Share on other sites

Would you please add a bit more information to the first post about what the RemoteTech integration in the settings menu does?

Share this post


Link to post
Share on other sites
hey I want to add some space x style chats, commentary to chatter, how can I do this ? So far what ive tried does not work......

Made a folder called spacex along with the 2 default directories from apollo and sts

Apollo

-capcom

-capsule

STS

-capcom

-capsule

SPACEX

-capcom

--XXXX.ogg

-capsule

--XXXX.ogg

Should work, can you post your audio set somewhere so I can try to load it myself ?

I know this might be a bit far out there, but I've been playing with a dualshock 4 for a while now, loving the trackpad for camera movement (frees up an entire stick for more analogue goodness while docking) and I'm wondering of chatterer could be made to support the little built in speaker.

Probably not, but thought I'd give er' a try, worst you guys could say is "no; that's impossible."

They used to say that about landing on the moon too though...

Sounds interesting, unfortunately I have no clue how dualshock 4 audio system works.

Ok how do you get this to work, I've got karbonite, toolbar (blizzy), and scansat 9.1 installed, but chatterer isn't showing up with the toolbar, I deleted the toolbars setting and put chaterer into the data folder.

Double check your installation path, seems you have something like "chattererX.X.X/gamedata/chatterer/gamedata/..." which is not good, you want to only have "/chatterer/gamedata/..."

As suggested in this thread...

Is this doable? Perhaps even one sound for a sub-goal completion and the applause for full contract completion? :D

This is just an awesome idea and it fits perfectly with my plan to reduce the random chatter in favor of a more logical connection with game's events.

Would you please add a bit more information to the first post about what the RemoteTech integration in the settings menu does?

For now this is it :

* signal delay is added to chatter response delay

* signal loss will disable chatter capcom's responses, beeps and SSTV transmissions

I still need to tweak it a bit because delay is already at something like +30 seconds when at Duna orbit and it seems this already mess up chatter exchange a bit.

I am thinking about adding local ship chatter (when kerbal present >1) beside capcom/capsule chatterer to avoid chatter to be too quite when far far away from kerbin.

Regarding beeps, it helps knowing if you have a connection with KSC very handy when you are waiting for connection to transmit science data (which will eventually trigger SSTV sequence WIP)

;)

Share this post


Link to post
Share on other sites

Chatterer is not connecting to the remotetech spu or KSC for me any Ideas? Im useing up to date versions of both. (.90)

Edit: It's working though! (no kerbals=no chatter) But they still chat when not connected.

Edited by Woodstar

Share this post


Link to post
Share on other sites
Chatterer is not connecting to the remotetech spu or KSC for me any Ideas? Im useing up to date versions of both. (.90)

Edit: It's working though! (no kerbals=no chatter) But they still chat when not connected.

Chatterer v0.8.0 isn't linking to RemoteTech 1.6.0 for now (they changed namespace ... again).

I got it already fixed in devbuild, update will arrive soon (need some more testing first)

Share this post


Link to post
Share on other sites

Done.

Changelog v0.8.1 [16 Jan 2015]

- Fixed RemoteTech v1.6.0 support (update RT first if you are still using v1.5.2!)

- Removed RT delay before capsule initiating chatter exchange (silly me)

- optimized code by using game events for EVA airlock sound [thanks to Davorin]

- Fixed internal ambient sounds playing when focusing Flags [thanks to Davorin]

;)

Share this post


Link to post
Share on other sites
Done.

;)

Okay, love this mod. Hate playing without it... BUT... still have no beeps with RT 1.6 and Chatterer 0.8.1... suggestions? What do you need from me to help figure out what's wrong?

And again, thank you for making this!

Share this post


Link to post
Share on other sites
Okay, love this mod. Hate playing without it... BUT... still have no beeps with RT 1.6 and Chatterer 0.8.1... suggestions? What do you need from me to help figure out what's wrong?

And again, thank you for making this!

Hi, do you see this green text under settings tab ?

HNXCi5ql.jpg

What would help is this :

- turn debug option on

- reload a game session

- reproduce the issue

- post log files

:wink:

Share this post


Link to post
Share on other sites
Hi, do you see this green text under settings tab ?

http://i.imgur.com/HNXCi5ql.jpg

What would help is this :

- turn debug option on

- reload a game session

- reproduce the issue

- post log files

:wink:

Never mind, I am an idiot. I had apparently switched presets at some point, and had beeps not enabled in the one I switched to. :blush:

Again, thank you for this mod. I really missed it when I thought it wasn't working!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.