magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

1 hour ago, Gordon Dry said:

Which cases trigger that I cannot recover a vessel from the launchpad with KCT?

Are you talking about recovering direct to storage? As long as you can recover the vessel normally you should see the recover to storage option in the KCT UI. Otherwise you might need to elaborate a bit more on what you're asking.

Share this post


Link to post
Share on other sites
Posted (edited)

I could recover it normally, it's on the launchpad.

But I can't recover to KCT storage. The option is there but a window pops up and says I can't.

Edit:

Excerpt, nothing special:

[KCT] Attempting to recover active vessel to storage.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Flight State Captured
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Saving Achievements Tree...
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Saving Achievements Tree...
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

saved
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Saving FAR Data
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FAR: save AG actionGroupSpoiler as Brakes
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FAR: save AG actionGroupIncreaseFlapDeflection as None
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FAR: save AG actionGroupDecreaseFlapDeflection as None
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KCT] Writing to persistence.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KCT] Saving KSC us_cape_canaveral
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KCT] Saving KSC kz_baikonur
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KCT] Saving KSC cn_wenchang
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: saving hall of fame scenario module (at 119456265.07039)
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: saving hall of fame (0 logbook entries)
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: hall of fame saved in 0ms
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

4/11/2018 6:20:52 AM,BackgroundResources,OnSave: 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[SpaceAge] SpaceAgeScenario.OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[SpaceAge] 49 nodes saved.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[SpaceAge] 16 achievements saved.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.TacLifeSupport[FFD06E3E][1627.87]: OnSave: SCENARIO
{
	scene = 5, 6, 7, 8
	name = TacLifeSupport
	SavedGameSettings
	{
		IsNewSave = False
		Version = 0.13.6
	}
	LifeSupportMonitoring
	{
		height = 300
		width = 300
		y = 75
		x = 810
		visible = False
	}
	LifeSupportCrewRoster
	{
		height = 200
		width = 370
		y = 440
		x = 775
		visible = False
	}
}

 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

AmpYear Scenario OnSave completed.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[PR] Saving Data.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[MessageSystem] Save Messages
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: AddLifeSupport Constructor
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Adding resources to kerbalEVA/
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Adding life support to the EVA part succeeded as expected.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource EVA Propellant
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource ElectricCharge
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Food
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Water
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Oxygen
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource CarbonDioxide
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Waste
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource WasteWater
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Adding resources to kerbalEVAfemale/
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Adding life support to the EVA part succeeded as expected.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource EVA Propellant
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource ElectricCharge
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Food
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Water
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Oxygen
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource CarbonDioxide
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource Waste
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.AddLifeSupport[2F9FD680][1627.87]: Resource WasteWater
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Game State Saved to saves/Gordon Dry RO RSS UbM/KCT_Backup
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

RemoteTech: ModuleRTDataTransmitter::OnSave
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KCT] Error while recovering craft into inventory.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

 

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
1 hour ago, magico13 said:

Are you talking about recovering direct to storage? As long as you can recover the vessel normally you should see the recover to storage option in the KCT UI. Otherwise you might need to elaborate a bit more on what you're asking.

Was there something in Oh Scrap! that did something with recovering without staging?

Share this post


Link to post
Share on other sites

Can you tell me what the 1728 in "Reconditioning Effect" means? I have set my overall multiplier higher to take longer to build rockets, but I want to bring the reconditioning down some.

Share this post


Link to post
Share on other sites
On 4/10/2018 at 11:49 PM, Gordon Dry said:

I could recover it normally, it's on the launchpad.

But I can't recover to KCT storage. The option is there but a window pops up and says I can't.

Well that log snippet says that there was an error when trying to save the craft. That can happen when the conversion from Vessel to craft file fails and there isn't usually much that can be done about it. If the craft is stock parts (or only one or two mods) I can try to modify the recovery code to support it, but sometimes there are things that can't be converted back to a craft file automatically.

 

On 4/11/2018 at 12:44 AM, strudo76 said:

Was there something in Oh Scrap! that did something with recovering without staging?

That's within Oh Scrap! and ScrapYard. Oh Scrap doesn't recover parts into the ScrapYard inventory if you haven't staged them.

34 minutes ago, Kwebib said:

Can you tell me what the 1728 in "Reconditioning Effect" means? I have set my overall multiplier higher to take longer to build rockets, but I want to bring the reconditioning down some.

It gets tossed into the formula below (pulled from the wiki, which is slightly out of date) as "E" and by default defines the BP per ton (rates are in BP/s). So at a rate of 1 BP/s it's the total number of seconds per ton of craft being launched. At 2 BP/s it'd be half that. Note that the current launchpad level plays into that as well, with lower level launchpads requiring less refurbishment time. This also affects the rollout time since the total for the formula below is divided among reconditioning and rollout per the slider in the settings (formula is computed, then 25% of that is rollout and 75% is reconditioning, for instance).

Hopefully that makes sense, but let me know if you need a better explanation :)

ReconditioningFormula = "min([M]*[O]*[E], [X])*abs([RE]-[S]) / (3-[L])"
Purpose: Defines the BP value of reconditioning, rollout, and recovery items.
Variables: O=overall multiplier, E=reconditioning effect setting, X=maximum reconditioning setting, M=loaded vessel mass, m=empty vessel mass, C=loaded vessel cost, c=empty vessel cost, VAB=1 if a VAB vessel (useless currently), BP=total vessel BP, L=launch facility upgrade level, EL=Editor upgrade level, RE=1 if reconditioning or 0 if rollout/rollback/recovery, S=Rollout/Recon split (between 0 and 1), All "Crew Variables"

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Ahh yes, that helps. Looks like by the formula, the reconditioning effect is directly proportional to the reconditioning time. So halving [E] halves reconditioning time. Also, I didn't realize that a higher launchpad level increases reconditioning time. Thanks!

Edit: Don't know why I missed this on the wiki. For anyone reading, here are the variables for the formulas:

Variables

Edited by Kwebib

Share this post


Link to post
Share on other sites
42 minutes ago, Gordon Dry said:

@magico13 In OP you say "Recommended Companion Mod: Crew R&R" - in Crew R&R OP @linuxgurugamer says "Most likely NOT compatible with KCT"

Old comment, i need to update it

  • Like 1

Share this post


Link to post
Share on other sites

Hey @magico13-- a future KCT feature request:

A fun KCT observation: contracts are generated for science experiments in tech nodes that are unlocked, but not yet "researched" or purchased.

This isn't a bug caused by KCT, and obliviously the contracts should be checking for "component is purchased" rather than tech node being unlocked. Yet another time-management wrinkle that gets added by the KCT process. :) It's pretty easy to role-play this as public awareness of current research, and even some corporate demand for info once we're able to integrate the parts in new craft, but contract deadlines are often far quicker than the research timers, and there's no way to pour money into research and shorten individual timers like there is with construction queues. Can this be considered for individual node research? There's probably no reasonable way to single out a specific part for availability/testing.

I guess the current solution is to spend money on R&D upgrades and nudge the speed overall, but I'm now hesitant to unlock nodes too soon, since I'll get a bunch of contracts for things I won't be able to do for weeks/months.

Share this post


Link to post
Share on other sites

While I think about it, and since this is a pretty active time for development, thought I might bring up an issue that's been around a long time. Might have been fixed already, but haven't played for a while and waiting for 1.4.3 to be ready to play/mod before starting a new career.

If you take a parts testing contract for a tech node you don't have, you get access to the part as an experimental part. If you then select that node to unlock, the experimental part then becomes unavailable to use until the tech node research is completed. Not game breaking, but can be a little annoying if you forget that you need to do a contract and then have to wait many days before the part becomes available again. Especially at the start of the game when contract slots are limited.

If it hasn't been fixed yet, hopefully you'll get some time to look at it while you're working on other stuff for current patches.

Thanks.

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, Beetlecat said:

A fun KCT observation: contracts are generated for science experiments in tech nodes that are unlocked, but not yet "researched" or purchased.

 

12 hours ago, strudo76 said:

If you take a parts testing contract for a tech node you don't have, you get access to the part as an experimental part. If you then select that node to unlock, the experimental part then becomes unavailable to use until the tech node research is completed. Not game breaking, but can be a little annoying if you forget that you need to do a contract and then have to wait many days before the part becomes available again. Especially at the start of the game when contract slots are limited.

The experimental parts issue is something I tried to fix once a long time ago and couldn't quite get working correctly. I think a solution to both of these would be similar to how KSC upgrades work now where the button press is intercepted so that the upgrade doesn't occur until KCT requests it. For nodes I could intercept the button press so the node isn't actually unlocked and then the contracts and experimental parts shouldn't be affected. I'd have to either update the UI or not allow you to start researching nodes after the current ones you can see (which is possibly a fair change). I don't think I'll do that in KCT, but when I start working on KCT2 I'll likely try to implement it this way.

Oh, one thing about the experimental parts. KCT will let you launch vessels with parts you don't have unlocked specifically because of that issue. If you remember to put one of the experimental parts on a craft then you should be able to copy it around as needed and still launch it. Or start up a sandbox game, make a vessel with that part, then copy that craft file into your save.

Edited by magico13
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, magico13 said:

Oh, one thing about the experimental parts. KCT will let you launch vessels with parts you don't have unlocked specifically because of that issue. If you remember to put one of the experimental parts on a craft then you should be able to copy it around as needed and still launch it. Or start up a sandbox game, make a vessel with that part, then copy that craft file into your save.

That's a clever way to "save" some top-secret parts, for sure.

Craft stuck above the ceiling in SPH:

  • The new toggle button to switch to VAB allows you to grab the craft, lower it to the floor, then switch back to the SPH.

Command Seats / Take Command:

Loading+launching with kerbals in command seats (via Take Command) does seem to work, but the kerbal will wind up standing on the seat, so you may need to re-board them. Seems like Kraken bait, though.

 

A few (hopefully) helpful hints for future KCT development, or any other new players.

Edited by Beetlecat
need my vision checked...

Share this post


Link to post
Share on other sites
1 hour ago, Beetlecat said:

Save your edits:

I was just about to come back and ask about "saving" the designs for edited vehicles, since we're not given access to the load/save buttons in the VAB/SPH.

Craft stuck above the ceiling in SPH:

  • The new toggle button to switch to VAB allows you to grab the craft, lower it to the floor, then switch back to the SPH.

Command Seats / Take Command:

Loading+launching with kerbals in command seats (via Take Command) does seem to work, but the kerbal will wind up standing on the seat, so you may need to re-board them. Seems like Kraken bait, though.

Regarding saving edits, the Save button is actually still available when editing, but the load button isn't. Specifically for the cases where you forget an antenna or something, edit it on, and don't want to forget about that in the future.

Are vessels still getting stuck in the ceiling in the SPH? I thought I had set it low enough that when that happens some of the parts would still be sticking out and you can use Shift to grab the whole vessel. If not then I need to adjust the cutoff again.

I still haven't gotten around to testing Take Command, sorry about that.

Share this post


Link to post
Share on other sites
7 minutes ago, magico13 said:

Regarding saving edits, the Save button is actually still available when editing, but the load button isn't. Specifically for the cases where you forget an antenna or something, edit it on, and don't want to forget about that in the future.

Are vessels still getting stuck in the ceiling in the SPH? I thought I had set it low enough that when that happens some of the parts would still be sticking out and you can use Shift to grab the whole vessel. If not then I need to adjust the cutoff again.

I still haven't gotten around to testing Take Command, sorry about that.

Oh shoot. Just re-loaded to see if I was crazy, and yes-- I was. Save is totally active -- you *did* think of that already. :wink: (it's just the color of the save button slightly matching the "disabled" shade of the other buttons...)

So far the ones that have gotten stuck on *Edit are some pretty small cars I've made with the "Grounded" mod. (They look like the SXT/stock vehicle models that are parked around the KSC)  At first I was able to grab one, and drag it back down, but they often appear out of reach. The method of swapping to the VAB and back works fine and is pretty quick.

A couple of my favorite command pods are fancy external seats, so I'll so some testing with those and see if anything truly breaks.

Share this post


Link to post
Share on other sites

@magico13 I have a question for you, I'm getting an interesting bug, and I'm not saying KCT is responsible, but when I launch from the woomerang launch site my craft are spawning close to 1000-2000 meters up over the launch site and plummeting to the ground {unless I use launch clamps and then it spawns up there, but the launch clamps hold it in place and the whole thing just hovers}, and I have no idea what's causing it, nor any idea how to begin investigating it. KCT is the only mod I can think of that, I'm using,  that really impact vessel launching, so I'm starting here. D you know of anything in KCT that might have, or be causing it? I'm fully willing to provide any logs you need, but they seem to have been moved from where they used to be saved, so I have no idea where to look now.

Share this post


Link to post
Share on other sites

@vardicd KCT only tells KSP to use the site, it doesn't do any of the actual launch logic, so I don't know that KCT would be causing it. I saw that in the past with Kopernicus and timewarping in the KSC scene.

Share this post


Link to post
Share on other sites
Just now, magico13 said:

@vardicd KCT only tells KSP to use the site, it doesn't do any of the actual launch logic, so I don't know that KCT would be causing it. I saw that in the past with Kopernicus and timewarping in the KSC scene.

Okay, thanks for the reply. I'm not using kopernicus, and this is a direct roll-out and launch, so I'm not time warping while it's on the Launchpad. Thanks i'll poke around try removing mods and see if I can narrow down what mod is causing it.

Share this post


Link to post
Share on other sites

Regarding this
https://forum.kerbalspaceprogram.com/index.php?/topic/172840-141-vabreorienter-v11-pick-a-different-vab-orientation-not-just-north/&do=findComment&comment=3358861
and following:

[VABReorienter] Setting VAB orientation to East
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Exception handling event onEditorStarted in class <>c:System.InvalidCastException: Cannot cast from source type to destination type.
  at KerbalConstructionTime.KCT_Utilities.GetMemberInfoValue (System.Reflection.MemberInfo member, System.Object sourceObject) [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.TypeExtensions.GetPrivateMemberValue (System.Type type, System.String name, System.Object instance, Int32 index) [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_Utilities.HandleEditorButton () [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_Events+<>c.<addEvents>b__3_1 () [0x00000] in <filename unknown>:0 
  at EventVoid.Fire () [0x00000] in <filename unknown>:0 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

InvalidCastException: Cannot cast from source type to destination type.
  at KerbalConstructionTime.KCT_Utilities.GetMemberInfoValue (System.Reflection.MemberInfo member, System.Object sourceObject) [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.TypeExtensions.GetPrivateMemberValue (System.Type type, System.String name, System.Object instance, Int32 index) [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_Utilities.HandleEditorButton () [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_Events+<>c.<addEvents>b__3_1 () [0x00000] in <filename unknown>:0 
  at EventVoid.Fire () [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventVoid:Fire()
EditorLogic:StartEditor(Boolean)
<Start>c__Iterator0:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename:  Line: -1)

Log:
https://www.dropbox.com/s/9a17da9srl6adw0/2018-04-20_1 KSP.log.7z?dl=1

 

Share this post


Link to post
Share on other sites
22 hours ago, Gordon Dry said:

That exception has to do with overriding the launch button in the editor. Not sure why it's failing but it shouldn't affect VAB reorienter. Easy way to check would be to disable overriding the editor button in the KCT settings, which should avert that exception. KCT doesn't do anything with the orientation in the VAB, though using the recover to storage option might make an assumption about vessel orientation when it converts to a craft file.

Share this post


Link to post
Share on other sites

Hi!

Witch version mod i can install on KSP 1.3.1?

Needed start new carrier?

Share this post


Link to post
Share on other sites
On 4/22/2018 at 2:53 PM, nickicool said:

Hi!

Witch version mod i can install on KSP 1.3.1?

Needed start new carrier?

I believe build 44 is the last for 1.3.1 (get it here). You don't need to start a new career game, it should work fine with an existing game.

  • Like 1

Share this post


Link to post
Share on other sites

So, I'm having a strange issue with vessel recovery (Running RO/RP-1 in 1.3.1): I land my aircraft on the runway, hit the "recover active vessel" in the KCT menu, the vessel recovers, I get the usual menus, I get the KCT recovery timer, warp to after recovery, the aircraft gets added to the "hangar" list with the option to relaunch. So far so good, but it would be unfueled and pointed straight up. So, I click in the edit the aircraft to realign and refuel it. However, once it pulls up in the SPH, rather than saying Original: 100% / Edited: 100% and a build time of 0, I get Original: 100% / Edited: 0% and a build time of ~16 days. 

 

Upon closer inspection, the RO Conic Cockpit and all of the Procedural Tanks (so, most of the aircraft) show TimesRecovered: 0. They do show up in inventory, but when I try to apply them, they don't stick or have any impact on build time. The parts themselves say Inventoried: False

 

Any suggestions on how to fix this?

Share this post


Link to post
Share on other sites

I suspect that is a mod interaction issue. Make a quick plane with stock parts and try a quick flight/recovery/edit with that. If it is an issue interacting with PT, it should behave normally instead of making you do a full rebuild time with a recovered vessel.

Share this post


Link to post
Share on other sites

So I'm starting my 1.3.1 RO/RP1 game but I'm having some trouble right off the bat.  I did notice that I was using KCT 1.4.0.69 but I've since corrected that.  I'm now using build 44 from the link magico13 provided above.  But still, when I click on the Launch button in the VAB, nothing shows up on my build list.  I noticed in the log that I'm getting spammed with an error: "Exception: TypeLoadExcpetion: Could not load type 'KSP.UI.BaseCrewAssignmentDialog' from assembly 'KerbalConstructionTime'.  I'm not sure if this has anything to do with the problem I'm encountering or not.  Assistance would be appreciated.

Share this post


Link to post
Share on other sites
24 minutes ago, chrisl said:

So I'm starting my 1.3.1 RO/RP1 game but I'm having some trouble right off the bat.  I did notice that I was using KCT 1.4.0.69 but I've since corrected that.  I'm now using build 44 from the link magico13 provided above.  But still, when I click on the Launch button in the VAB, nothing shows up on my build list.  I noticed in the log that I'm getting spammed with an error: "Exception: TypeLoadExcpetion: Could not load type 'KSP.UI.BaseCrewAssignmentDialog' from assembly 'KerbalConstructionTime'.  I'm not sure if this has anything to do with the problem I'm encountering or not.  Assistance would be appreciated.

Can you send me the log file? I've not seen that specific error before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now