magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

37 minutes ago, HaydenTheKing said:

How do I pull up that menu?

I found the button, it says parts are stored. Is there a way to find a repository of all the parts I have?

I'm sorry what menu?

I don't know if there's a list of stored parts . I've never tried to look and see. I'll play around with that next chance I get and see if I can find anything. The game/mod obviously has to track that somewhere but if that's visible to the player or not, :/ Asking in scrapyard thread may get you an answer faster.

Edited by vardicd
  • Like 1

Share this post


Link to post
Share on other sites
Just now, vardicd said:

That.... I don't know. I've never tried to look and see. I'll play around with that next chance I get and see if I can find anything. The game/mod obviously has to track that somewhere but if that's visible to the player or not, :/ Asking in scrapyard thread may get you an answer faster.

Thank you so much! I thought for sure my mod was broken. I guess it was the old PEBCAK error.

Share this post


Link to post
Share on other sites
15 hours ago, HaydenTheKing said:

How do I pull up that menu?

I found the button, it says parts are stored. Is there a way to find a repository of all the parts I have?

On the part menu in the left, there's a category that looks like a crane -- this is the scrapyard "pile."  You may need to expand the part list with the right-arrow button at the top left. You still have to "apply" a used part using the previously described button/menu.  It's pretty clunky, especially if you have multiple generations and ratings of parts, but it *does* keep track! :D

Edited by Beetlecat

Share this post


Link to post
Share on other sites
19 hours ago, HaydenTheKing said:

Is there a way to find a repository of all the parts I have?

if you right klic on a part it will show parts of this type in the inventory

 

Share this post


Link to post
Share on other sites
6 hours ago, Beetlecat said:

On the part menu in the left, there's a category that looks like a crane -- this is the scrapyard "pile."  You may need to expand the part list with the right-arrow button at the top left. You still have to "apply" a used part using the previously described button/menu.  It's pretty clunky, especially if you have multiple generations and ratings of parts, but it *does* keep track! :D

This ^

Once you grab a part from that list the ScrapYard UI should update to show all stored variations of that part. You can either put the part in your hand back and select a new one from ScrapYard or you can take the one in your hand and click the apply button (while still holding the part) and it'll apply it to that part. At least, that's how it worked when I left it :P

Share this post


Link to post
Share on other sites
On 11/27/2018 at 7:43 AM, magico13 said:

This ^

Once you grab a part from that list the ScrapYard UI should update to show all stored variations of that part. You can either put the part in your hand back and select a new one from ScrapYard or you can take the one in your hand and click the apply button (while still holding the part) and it'll apply it to that part. At least, that's how it worked when I left it :P

Nothing has changed with the scrapyard integration, and nothing probably will for awhile.

Share this post


Link to post
Share on other sites
9 hours ago, westamastaflash said:

Nothing has changed with the scrapyard integration, and nothing probably will for awhile.

That's ScrapYard specific behavior anyway, so any KCT changes wouldn't affect that functionality. I'm not up to date on if anything has changed within KSP or ScrapYard with that specific functionality, which required a bit of trickery internally to get working, that's the only reason I said "that's how it worked when I left it" :)

Share this post


Link to post
Share on other sites

I am playing ksp 1.3.1
Should I use version 1.3.0.83 or version 1.3.5.91 ? Because in github it says that the first one was published later than the second one so I am confused as to which one is the newest one for my RSS/RP1 build...

Share this post


Link to post
Share on other sites
On 11/30/2018 at 8:53 AM, Agustin said:

I am playing ksp 1.3.1
Should I use version 1.3.0.83 or version 1.3.5.91 ? Because in github it says that the first one was published later than the second one so I am confused as to which one is the newest one for my RSS/RP1 build...

think that the last version for KSP 1.3.1 is this one: http://magico13.net:8080/job/Kerbal Construction Time/61/

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Agustin said:

Version file says that's for 1.4.1 min

Crap, you're right. I saw "Update to 1.4.0" and thought it was referring to KSP 1.4.0. Based on dates, I think this would be the correct one. I believe the version file is out of date and still was saying 1.2.2. You might just have to try it to see if it works correctly.

  • Like 1

Share this post


Link to post
Share on other sites

I just came back after a year+ away, and have restarted my career from scratch with 1.5.1.  Most of the mods I need are either current, or the 1.4.5 version seems to work OK.

I am still early in the career, so I want to explore adding this suite to my game before I get much farther.   Is there a likelhood this will update for 1.5.1 in the next couple of weeks? If so, I'll wait.  But if not, (mod authors are overloaded busy etc), can I safely use the latest version from CKAN, (which I think is 1.4.1), along with Scrapyard and Recovery which also look to be for version 1.4.1 - in 1.5.1 with all the expansions installed?  I have seen posts about experimental version, and using these with older version (1.3?), but no explicit 1.5.1 info

Edited by Murdabenne

Share this post


Link to post
Share on other sites
On 12/7/2018 at 12:01 PM, Murdabenne said:

I just came back after a year+ away, and have restarted my career from scratch with 1.5.1.  Most of the mods I need are either current, or the 1.4.5 version seems to work OK.

I am still early in the career, so I want to explore adding this suite to my game before I get much farther.   Is there a likelhood this will update for 1.5.1 in the next couple of weeks? If so, I'll wait.  But if not, (mod authors are overloaded busy etc), can I safely use the latest version from CKAN, (which I think is 1.4.1), along with Scrapyard and Recovery which also look to be for version 1.4.1 - in 1.5.1 with all the expansions installed?  I have seen posts about experimental version, and using these with older version (1.3?), but no explicit 1.5.1 info

Given the holiday season here in the states and my current load @ work I cannot promise a stable release for awhile yet. I've been working on it when I get the time, sorry! You can try the experimental version on the build server posted further up, it was compiled against 1.5.1. There is still a problem with launch sites that I haven't got sorted. I need to figure out how KSP does their new launch sites and put it all together.

  • Like 2

Share this post


Link to post
Share on other sites

Thanks, that's exactly what I needed to know. I will give it a go with 1.4.x versions, and if I run into problems I'll go to the experimental version.  Please don take time away from holiday activity and family, this can always wait.

Share this post


Link to post
Share on other sites
21 hours ago, Murdabenne said:

Thanks, that's exactly what I needed to know. I will give it a go with 1.4.x versions, and if I run into problems I'll go to the experimental version.  Please don take time away from holiday activity and family, this can always wait.

So far, I'm having no issues with Kerbal_Construction_Time-1.4.0.69 on KSP 1.5.1.  I've not tried to launch from desert/woomer yet (keep forgetting).

I run a very slow preset. 8-12 day roll-outs, dozens to hundreds of days for builds and research.

Spoiler

KCT_Preset
{
	name = SYB Slower
	shortName = SYBSlower
	description = Vastly slower science & build, with costlier upgrades.

	// It will probably take 4-8 years before you reach orbit.
	// Expect to spend the first 20-30 years in the Kerbin SOI.

	author = WuphonsReach
	allowDeletion = True
	career = True
	science = True
	sandbox = True
	KCT_Preset_General
	{
		Enabled = True
		BuildTimes = True
		ReconditioningTimes = True
		ReconditioningBlocksPad = True
		TechUnlockTimes = True
		KSCUpgradeTimes = True
		TechUpgrades = True
		SharedUpgradePool = False
		StartingPoints = 15,15,90
		MaxRushClicks = 0
	}
	KCT_Preset_Time
	{
		OverallMultiplier = 16
		BuildEffect = 1.0 // Lower is longer
		InventoryEffect = 60
		ReconditioningEffect = 1250
		MaxReconditioning = 29500000
		RolloutReconSplit = 0.40
	}
	KCT_Preset_Formula
	{
		NodeFormula = (1.2^([N]+[R]) / 86400) * 1/([I]+1) / 3.5
		UpgradeFundsFormula = min(2^([N]+4) * 1000, 4096000)
		UpgradeScienceFormula = min(2^([N]+2) * 1.0, 4096)
		ResearchFormula = [N]*0.05/86400
		EffectivePartFormula = min([c]/([I] + ([B]*([U]+1))), [c])*[MV]*[PV]
		ProceduralPartFormula = (([c]-[A]) + ([A]*10/max([I],1))) / max([B]*([U]+1),1) *[MV]*[PV]
		BPFormula = ([E]^(1/2))*2000*[O]
		KSCUpgradeFormula = ([C]^(1/2))*1000*[O]
		ReconditioningFormula = (min([M]*[O]*[E], [X])*abs([RE]-[S]) / ([LM]-[L]+1)) + 150000
		BuildRateFormula = (([I]+1)*0.05*[N] + max(0.1-[I], 0))*sign(2*[L]-[I]+1)
		UpgradeResetFormula = 2*([N]+1)
		InventorySaleFormula = ([V]+[P] / 10000)^(0.5)
		RolloutCostFormula = 0
		NewLaunchPadCostFormula = 250000*([N]^2.5)
	}
	KCT_Preset_Part_Variables
	{
		Part_Variables
		{
		}
		Module_Variables
		{
		}
		Global_Variables
		{
		}
	}
}

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Using the experimental build #20181103.6 on a 1.5.1 modded install, I'm getting the following log spam and and the VAB build list isn't working. Interesting enough, it does display the SPH and R&D menus. 

Quote

[EXC 21:50:29.959] NullReferenceException: Object reference not set to an instance of an object
    KerbalConstructionTime.KCT_GUI.DrawBuildListWindow (Int32 windowID)
    UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, Int32 instanceID, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

 

Edited by thunder175

Share this post


Link to post
Share on other sites
5 hours ago, thunder175 said:

Using the experimental build #20181103.6 on a 1.5.1 modded install, I'm getting the following log spam and and the VAB build list isn't working. Interesting enough, it does display the SPH and R&D menus. 

 

I get the same errors, but I think it may be due to an interaction between KCT and another mod, but I havent figured out which one yet.

Share this post


Link to post
Share on other sites
15 hours ago, thunder175 said:

Using the experimental build #20181103.6 on a 1.5.1 modded install, I'm getting the following log spam and and the VAB build list isn't working. Interesting enough, it does display the SPH and R&D menus. 

 

What you may have to do is start a new save with version 1.4.0.69 of the mod.  I did that, and the errors so far have gone away, with all of the same mods loaded.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/13/2018 at 10:00 PM, thunder175 said:

Using the experimental build #20181103.6 on a 1.5.1 modded install, I'm getting the following log spam and and the VAB build list isn't working. Interesting enough, it does display the SPH and R&D menus. 

 

I'm getting something very similar too:

Quote

NullReferenceException: Object reference not set to an instance of an object
  at KerbalConstructionTime.KCT_GUI.GUIVABBuildList_LaunchPad () [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_GUI.GUIVABBuildList (Int32 butW, Int32 width1, Int32 width2) [0x00000] in <filename unknown>:0 
  at KerbalConstructionTime.KCT_GUI.DrawBuildListWindow (Int32 windowID) [0x00000] in <filename unknown>:0 
  at UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID) [0x00000] in <filename unknown>:0 
  at UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, Int32 instanceID, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style) [0x00000] in <filename unknown>:0 

I'm also getting a lot of "block entry/execution/exit"s in the log from KCT. Is there some way to fix this? I'm getting it at the Space Center scene too.

Edited by BobTheRocketeer

Share this post


Link to post
Share on other sites
12 minutes ago, BobTheRocketeer said:

I'm getting something very similar too:

I'm also getting a lot of "block entry/execution/exit"s in the log from KCT. Is there some way to fix this? I'm getting it at the Space Center scene too.

I wasn't able to fix it on the experimental build, but on a new save, with version 1.4.0.69 of KCT installed, it seems to work just fine on 1.5.1.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Jade_Falcon said:

I wasn't able to fix it on the experimental build, but on a new save, with version 1.4.0.69 of KCT installed, it seems to work just fine on 1.5.1.

Is there some difference in the save CFGs between a new save and an old one? I'll go ahead and test later to see if an old save can be made to work.

Oh yeah, I should probably mentioned that installing the current official version (through CKAN) worked for an existing save that never had the experimental version loaded.

Edited by BobTheRocketeer

Share this post


Link to post
Share on other sites
On 12/13/2018 at 10:00 PM, thunder175 said:

Using the experimental build #20181103.6 on a 1.5.1 modded install, I'm getting the following log spam and and the VAB build list isn't working. Interesting enough, it does display the SPH and R&D menus. 

 

Yep. I know about this and am working on a fix but it will be until after the holiday season.

  • Like 4

Share this post


Link to post
Share on other sites

It feels like I'm cheating when I play the game without KCT... I'm using KAC to delay launches by x days to simulate the effect.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.