magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

On 12/29/2018 at 11:07 AM, New Horizons said:

Do you have knowledge about any experimental version younger than from march?

It's from Nov - YYYYMMDD is the naming convention since it sorts correctly on computers. 

Share this post


Link to post
Share on other sites

Does this work ok in 1.6?  I've seen conflicting reports throughout various forum topics, and figured I'd ask here.

Share this post


Link to post
Share on other sites

It does not fully work for 1.5 yet, so 1.6 is still a ways off.

Share this post


Link to post
Share on other sites
On 1/4/2019 at 3:27 PM, Tybot said:

It does not fully work for 1.5 yet, so 1.6 is still a ways off.

I have been playing a heavily moded career in 1.5 with no issues that i have noticed. Can you give me some stuff to look out for?

  • Like 2

Share this post


Link to post
Share on other sites
3 hours ago, Skyrunner84 said:

I have been playing a heavily moded career in 1.5 with no issues that i have noticed. Can you give me some stuff to look out for?

Same here. I haven't noticed any issues with KCT at all with KSP 1.5, but I haven't played 1.6 yet.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/4/2019 at 6:27 PM, Tybot said:

It does not fully work for 1.5 yet, so 1.6 is still a ways off.

As others have mentioned, it does seem to work fine in 1.5. Im using KCT 1.4.0.69.

  • Like 3

Share this post


Link to post
Share on other sites

It seems like the RO folx are looking into this mod, though.

Share this post


Link to post
Share on other sites
On 1/7/2019 at 7:56 AM, garwel said:

Same here. I haven't noticed any issues with KCT at all with KSP 1.5, but I haven't played 1.6 yet.

Interesting. I'm playing in 1.4.5 and although KCT seems to work largely OK I am unable to use KCT to 'Recovery Active Vessel'. I get the error "There was an error while recovering the ship. Sometimes reloading a scene and trying again works. Sometimes a vessel just can't be recovered this way and you must use the stock recovery system'

Can anyone else using KCT with 1.4.5 or above successfully use 'Recover Active Vessel' ?

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/6/2019 at 11:13 PM, Skyrunner84 said:

I have been playing a heavily moded career in 1.5 with no issues that i have noticed. Can you give me some stuff to look out for?

I was using the experimental build for 1.5, which I thought (apparently erroneously) would be more functional than the 1.4 build was, even if i was incomplete. I guess I could have stuck with the stable release.

7 hours ago, DC said:

Can anyone else using KCT with 1.4.5 or above successfully use 'Recover Active Vessel' ?

That has been hit or miss for a while, something hopefully high on the todo list to overhaul since being taken over by westamastaflash.

Edited by Tybot

Share this post


Link to post
Share on other sites

Does KCT correctly check for unavailable parts when you add to the construction list? It seems if I have a ship with a part I only had access to due to a test contract I can continue to construct that using KCT. I'm not 100% sure what the default behaviour is, but I strongly suspect it would prevent me from launching.

Share this post


Link to post
Share on other sites
43 minutes ago, TGApples said:

Does KCT correctly check for unavailable parts when you add to the construction list? It seems if I have a ship with a part I only had access to due to a test contract I can continue to construct that using KCT. I'm not 100% sure what the default behaviour is, but I strongly suspect it would prevent me from launching.

From my experience -- you "hang onto" that part for as long as you don't fully recover a craft with it on. I seem to remember getting an engine or other part early, then continued to use it after completing the contract, and before unlocking the node. I may be misremembering this...

Share this post


Link to post
Share on other sites

Ahh KSP is now 1.6? I will try to find some time this weekend to work on this. It's been touch and go with a ton of crap at work right now...

Share this post


Link to post
Share on other sites
1 hour ago, westamastaflash said:

Ahh KSP is now 1.6? I will try to find some time this weekend to work on this. It's been touch and go with a ton of crap at work right now...

yes. 1.6.1 was released on the 9th, good news is there doesn't seem to be any major code changes, so just a recompile should work.

Share this post


Link to post
Share on other sites

What is the criteria for recovering a vessel/plane to VAB/SPH through KCT? I have always just used the Game's Stock Recover button before, but after seeing someone on a YouTube video do recoveries through KCT, I tried it a couple times but got warning messages Cant recover through KCT use the stock recovery.

SO, What are the advantages of doing a KCT recovery, and what are the limits? (ie do you have to be within xx distance from Pad or Runway?)

Edited by BlackHat

Share this post


Link to post
Share on other sites
13 hours ago, BlackHat said:

What is the criteria for recovering a vessel/plane to VAB/SPH through KCT? I have always just used the Game's Stock Recover button before, but after seeing someone on a YouTube video do recoveries through KCT, I tried it a couple times but got warning messages Cant recover through KCT use the stock recovery.

SO, What are the advantages of doing a KCT recovery, and what are the limits? (ie do you have to be within xx distance from Pad or Runway?)

Stock recovery simply tidies everything up, returns kerbals and science and gives you funds based on the vessel and how close you are to the KSC.

KCT recovery recovers the vessel intact and adds it back to your list of ready ships (after a suitable time delay to allow for recovery) meaning you don't have to built a new one from scratch. I don't know about limitations in terms of distance etc, I've mostly used it from the Launchpad because I've suddenly realised something is wrong (wrong crew, missing equipment etc) just before I launch !

Edited by DC

Share this post


Link to post
Share on other sites

Thanks.

Next Question. :)  Is the Real Chutes Mod by Stupid Chris, supported? I recently noticed that while all my other parts are gaining Generations, the Parachutes from Chris's mod are not (no Gen info or safety info) and are always listed as new parts, and in Scrapyard I have about 30 chutes all with 1 use. When selecting one of these to substitute for the new part on my craft, they stil show as new, with no Gen or Safety info.

Edited by BlackHat

Share this post


Link to post
Share on other sites
21 hours ago, BlackHat said:

Thanks.

Next Question. :)  Is the Real Chutes Mod by Stupid Chris, supported? I recently noticed that while all my other parts are gaining Generations, the Parachutes from Chris's mod are not (no Gen info or safety info) and are always listed as new parts, and in Scrapyard I have about 30 chutes all with 1 use. When selecting one of these to substitute for the new part on my craft, they stil show as new, with no Gen or Safety info.

That is not a KCT or a Scrapyard thing

Its from a different mod

Probably a fail  mod. 

Share this post


Link to post
Share on other sites
23 hours ago, BlackHat said:

Next Question. :)  Is the Real Chutes Mod by Stupid Chris, supported? I recently noticed that while all my other parts are gaining Generations, the Parachutes from Chris's mod are not (no Gen info or safety info) and are always listed as new parts, and in Scrapyard I have about 30 chutes all with 1 use. When selecting one of these to substitute for the new part on my craft, they stil show as new, with no Gen or Safety info. 

That's Oh Scrap! (and no it isn't supported, but I may look into it)

  • Like 1

Share this post


Link to post
Share on other sites
On 1/17/2019 at 10:59 AM, BlackHat said:

Thanks.

Next Question. :)  Is the Real Chutes Mod by Stupid Chris, supported? I recently noticed that while all my other parts are gaining Generations, the Parachutes from Chris's mod are not (no Gen info or safety info) and are always listed as new parts, and in Scrapyard I have about 30 chutes all with 1 use. When selecting one of these to substitute for the new part on my craft, they stil show as new, with no Gen or Safety info.

This is ringing a bell for me--that some form of tracking/integration was added to real chutes configs to make them work properly with KCT/recovery.

Maybe not so much the part failure aspect, though. I'll dig through my old files.

Edited by Beetlecat
  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, Beetlecat said:

This is ringing a bell for me--that some form of tracking/integration was added to real chutes configs to make them work properly with KCT/recovery.

Maybe not so much the part failure aspect, though. I'll dig through my old files.

---I think what was coming to mind may have been Stage Recovery interaction with Realchute, not KCT/Scrapyard -- though * STILL * think that was a thing.

Obviously, this would be great to have :)

Share this post


Link to post
Share on other sites

I had tried the experimental version but ran into the bug where reselecting the VAB queue shows an empty window. Tried to revert to the stable version but I'm still getting the same bug. Has anyone else run into this, and is there a solution to at least get it back to where it was?

Share this post


Link to post
Share on other sites
On 1/18/2019 at 7:57 PM, severedsolo said:

That's Oh Scrap! (and no it isn't supported, but I may look into it)

I second this. Been playing a lot with Oh Scrap/ScrapYard/KCT the last couple of weeks and support for RealChute would be awesome as the chutes really stack up.

 

Keep up the good work!

  • Like 1

Share this post


Link to post
Share on other sites

OK, I need my KSP fix. Where is the current experimental build? I can't seem to find it?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.