magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

23 minutes ago, Avera9eJoe said:

Hello again! I just wanted to double check somehting - Reading your title indicates the most recent version of Kerbal this is compatible for is version 1.1.3, though both in reading comments here and visiting SpaceDock, you have an official release for 1.2.2, as well as a beta release for version 1.3. Is the OP outdated or am I missing something? :blush:

No that's correct. There never was a super official release for 1.2.2 but he put it on SpaceDock so that it could be downloaded with CKAN for the RO people. There are links to the dev build in the op of the dev thread. 

Share this post


Link to post
Share on other sites
7 minutes ago, TheRagingIrishman said:

No that's correct. There never was a super official release for 1.2.2 but he put it on SpaceDock so that it could be downloaded with CKAN for the RO people. There are links to the dev build in the op of the dev thread. 

Ah, I understand then. I don't use CKAN so it would make sense why I'm out of the loop on that portion of info :) in the OP it might be worth noting the 1.2.2 version is semi-beta as well? Only if I'm not the first to ask. :rolleyes:

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites

Without using scrapyard (since I am unsure exactly what that does) Am I able to timewarp through the building in a reasonable amount of real life time? I want to get this mod, but I cant play KSP for large amount of time and I don't want to not be able to launch any rockets if I do happen to install this mod. Also, is this mod able to be turned of on certain saved games?

Share this post


Link to post
Share on other sites
58 minutes ago, Avera9eJoe said:

Hello again! I just wanted to double check somehting - Reading your title indicates the most recent version of Kerbal this is compatible for is version 1.1.3, though both in reading comments here and visiting SpaceDock, you have an official release for 1.2.2, as well as a beta release for version 1.3. Is the OP outdated or am I missing something? :blush:

As far as I know, there hasn't been an official release since 1.1.3, but there has been mostly working dev versions posted. 

Share this post


Link to post
Share on other sites

The other comments are correct, the last official release was for 1.1.3, there are builds for 1.2.2 available on SpaceDock (and only SpaceDock, except for the build server) per the request of the RO/RP-0 folks so that CKAN can install RP-0 that are still Beta builds (these are also occasionally updated with changes from the 1.3 builds), and there are now Beta builds for 1.3. The next release will happen for KSP 1.3.

It's all great and confusing since I hadn't gotten to a point where I was satisfied with calling any particular build a "release" and I should just suck it up and make an official one :P

1 hour ago, nascarlaser1 said:

Without using scrapyard (since I am unsure exactly what that does) Am I able to timewarp through the building in a reasonable amount of real life time? I want to get this mod, but I cant play KSP for large amount of time and I don't want to not be able to launch any rockets if I do happen to install this mod. Also, is this mod able to be turned of on certain saved games?

ScrapYard adds a part inventory that makes it so KCT's build times are shorter when you reuse recovered parts. Even if you don't use recovered parts, ScrapYard also has a part tracker that causes builds to get faster if you use the same types of parts (e.g. you use the same command pod all the time, the command pod adds less to the build time), so it's helpful to install just for that purpose.

You can timewarp through any time constraints in a completely reasonable amount of time, usually just a few seconds. If you choose to only manage one mission at a time then using KCT will just make it so some time passes between launches and you come up on transfer windows (or life support constraints) considerably faster.

KCT is highly customizable on a per-save basis, including turning it on and off. Each save has it's own individual settings (except for a handful of global settings that don't affect balance). You can turn the mod off for a save by opening the Presets selection UI with that save loaded, clicking the "Mod Enabled" button so that it is off, then pressing save.

Share this post


Link to post
Share on other sites
22 hours ago, regex said:

Question about the NodeFormula, I have the equation set to


max(43200,l([S])*86400)*30

which should handle nodes with a cost of 1 (15 days) and anything past, but the unlock time is always 0 seconds (it informs me that the unlock time is 0 seconds and I have confirmed the tech unlock times is enabled). Am I doing anything wrong with the equation?

So I forgot that the NodeFormula is a rate, not the total, since the total is fixed as the science cost times 86400. If/when I rewrite it it'd make way more sense as a total and just a fixed 1 per second kind of thing. All you need to do is put that formula in the denominator and the total science in the numerator, like so:

[S]/(max(43200,l([S])*86400)*30)

or

[S]/(max(0.5, ln([S]))*30*86400)

I tested that out and got the numbers I was expecting.

Share this post


Link to post
Share on other sites

When using ScrapYard, is there a list of the parts available for inventory building? At first I just selected the option to use the inventory parts, then I kept forgetting to do that and now use the auto apply option, but I'd still be curious to see what parts are available for reuse, in case I need to build something in a hurry and want to knock something together out of the leftovers.

Share this post


Link to post
Share on other sites
23 minutes ago, strudo76 said:

When using ScrapYard, is there a list of the parts available for inventory building? At first I just selected the option to use the inventory parts, then I kept forgetting to do that and now use the auto apply option, but I'd still be curious to see what parts are available for reuse, in case I need to build something in a hurry and want to knock something together out of the leftovers.

Not yet, I'm still working on that unfortunately. I was hoping to have it done a while ago but June was super busy for me.

Share this post


Link to post
Share on other sites
17 hours ago, magico13 said:

It's all great and confusing since I hadn't gotten to a point where I was satisfied with calling any particular build a "release" and I should just suck it up and make an official one :P

 

I vote to go ahead and release.   I still haven't seen any issues using the most recent KCT dev build with KSP 1.3.

Share this post


Link to post
Share on other sites

hey guys, didn't play ksp for a while. Now have come back but for some reason the ui of kct bugs out on me. after starting a new game when i click on option one or two i have no potions just blank/not fully showing windows i can't close. any way i can help you help me? Please i don't want to play without kct.

Mods:

[x] Science!

Toolbar

Ablative-Airbrake

BetterBurnTime

Chatterer

CollisionFX

CommunityResourcePack

CommunityTechTree

ConnectedLivingSpace

ContractConfigurator

CrewRandR

CrowdSourcedFlags

CrowdSourcedScience

DistantObjectEnhancement

DMagicOrbitalScience

DMagicUtilities

EnvironmentalVisualEnhancements

FP_DPSoundFX

JanitorsCloset

KAS

KerbalConstructionTime

KerbalEngineer

KIS

KRASH

Docking Port Alignment Indicator

FinalFrontier

RemoteTech

DeepFreeze

AmpYear

SCANsat

scatterer

ShipManifest

StockVisualEnhancements

TextureReplacer

TAC Lifesupport

KSPAlternateResourcePanel

UniversalStorage

DeflatableHeatShield (xyphosAerospace)

 

 

Edited by Schmonzo

Share this post


Link to post
Share on other sites

@Schmonzo you probably have a duplicate MagiCore.dll in GameData. Delete that and only keep the one in GameData/MagiCore/MagiCore.dll

Share this post


Link to post
Share on other sites

I did indeed, but i noticed that yesterday and deleted it, yet still i have the same problem

EDIT:

Im an idiot, I used this built with 1.3

Edited by Schmonzo

Share this post


Link to post
Share on other sites
4 hours ago, Schmonzo said:

Im an idiot, I used this built with 1.3

Yeah, if you use the 1.1.3 build with 1.3 that definitely will not work. Is it working for you now with the latest build for 1.3?

Share this post


Link to post
Share on other sites
On 13.7.2017 at 3:14 PM, magico13 said:

Yeah, if you use the 1.1.3 build with 1.3 that definitely will not work. Is it working for you now with the latest build for 1.3?

yes, thanks!

Share this post


Link to post
Share on other sites

So I'm still playing a 1.2.2 game, and last night I noticed that CKAN had listed an update for KCT, and I also for the first time noticed the Scrapyard Mod, hurray, reusable parts! except now KCT is broken, I'm not exactly sure what happened, CKAN lists the update as being compatible up top 1.2.2, mod version 1.3.5.7. I also installed Scrap Yard version 0.9.4.51 which was listed as 1.2.2 compatible. I've since tried to manually install devbuild #26 but the problem remains, my build list is gone, and the KCT window cannot be interacted with, and I get this very ominous message: http://imgur.com/2OuHeCc

Share this post


Link to post
Share on other sites
59 minutes ago, Katikar said:

So I'm still playing a 1.2.2 game, and last night I noticed that CKAN had listed an update for KCT, and I also for the first time noticed the Scrapyard Mod, hurray, reusable parts! except now KCT is broken, I'm not exactly sure what happened, CKAN lists the update as being compatible up top 1.2.2, mod version 1.3.5.7.

I'm betting there's a duplicate MagiCore.dll at GameData/MagiCore.dll. Delete that one. You should only have one at GameData/MagiCore/MagiCore.dll. The install directory changed during 1.2.2 and apparently CKAN isn't removing the old one.

Share this post


Link to post
Share on other sites

I ended up updating everything to 1.3 and removed the extra magicore, and that seems to all be working, except all of my ships in my build list are gone, and my launch pad is back to level one. alright, that's fine, better than losing everything the rocket production facility probably caught fire or something. err, except there's been another issue. when I went to upgrade my launch pad I first tried to turn off the upgrade times and it wouldn't upgrade, and just said "This is already being upgraded" so then I turned upgrade times back on, requested the upgrade again, and it worked but also then gave me a whole bunch of money. like, it wouldn't stop giving me money, I had to quit the game because it rolled over into thousands of millions. I guess that's a devbuild bug, I'm not sure if it'll keep going when I start it back up.

Share this post


Link to post
Share on other sites
40 minutes ago, Katikar said:

I guess that's a devbuild bug, I'm not sure if it'll keep going when I start it back up.

It might do it again depending on what level it's stuck at in the save file, this issue is related. It's probably because you let the game save after loading the game up with it bugged, so it saved the bugged state. I usually just Alt-F4 right away so it can't save any invalid data. You could try reloading a recent quick save or autosave if you have one.

I'm going to be looking into overriding the KSC upgrades a different way that should prevent the infinite money bug from coming up again.

Share this post


Link to post
Share on other sites

Im also have the same issue as schmonzo. My KCT mod just puts a grex box and im unable to click anything. I have only one Magicore.dll in Gamedata/Magicore.dll? someone help me haha

 

 

Edited by F1RacerDan

Share this post


Link to post
Share on other sites
53 minutes ago, F1RacerDan said:

Im also have the same issue as schmonzo. My KCT mod just puts a grex box and im unable to click anything. I have only one Magicore.dll in Gamedata/Magicore.dll? someone help me haha

You shouldn't have ANY magicore.dll files at GameData/MagiCore.dll. There should be another one at GameData/MagiCore/MagiCore.dll and if you don't have that one then you should grab the latest one from here.

Share this post


Link to post
Share on other sites
21 minutes ago, magico13 said:

You shouldn't have ANY magicore.dll files at GameData/MagiCore.dll. There should be another one at GameData/MagiCore/MagiCore.dll and if you don't have that one then you should grab the latest one from here.

yeah i dont have any Magicore.dll files in Gamedata. I have one in GameData/Magicore though which seems right? so im at a loss why it isnt working

scratch that! ive just updated my magicore and it works! thanks

Edited by F1RacerDan

Share this post


Link to post
Share on other sites
On 7/18/2017 at 7:14 PM, Katikar said:

I ended up updating everything to 1.3 and removed the extra magicore, and that seems to all be working, except all of my ships in my build list are gone, and my launch pad is back to level one. alright, that's fine, better than losing everything the rocket production facility probably caught fire or something. err, except there's been another issue. when I went to upgrade my launch pad I first tried to turn off the upgrade times and it wouldn't upgrade, and just said "This is already being upgraded" so then I turned upgrade times back on, requested the upgrade again, and it worked but also then gave me a whole bunch of money. like, it wouldn't stop giving me money, I had to quit the game because it rolled over into thousands of millions. I guess that's a devbuild bug, I'm not sure if it'll keep going when I start it back up.

I have a, well, similar issue as well, I upgraded my launch pad to level 3, and it went back to level 1, so I cheated in cash to redo the upgrades and eventually it stopped downgrading, only now my roll-out time is "infinite; NaN; NaN; NaN" which is just a little bit save breaking

Share this post


Link to post
Share on other sites
7 hours ago, Rabbit35 said:

I have a, well, similar issue as well, I upgraded my launch pad to level 3, and it went back to level 1, so I cheated in cash to redo the upgrades and eventually it stopped downgrading, only now my roll-out time is "infinite; NaN; NaN; NaN" which is just a little bit save breaking

Edit your save to set the launch pad level to "2" instead of -1 or whatever it's set at right now. The latest build (#34, assuming you're on 1.3. 1.2.2 doesn't have this change yet) overhauled the upgrade process so it probably won't get stuck like this again.

Share this post


Link to post
Share on other sites

Since there is the option of having automatic KAC entries created, would it be possible to allow having them added manually? I don't really want every item to be listed in KAC, but I might want to know when a particular vessel is completed construction. Maybe it could be added to the asterisk options menu for the vessel? Just a thought anyway.

Thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.