Jump to content

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly


Recommended Posts

As someone who has recently contributed to the KSP-RO fork, I can say my personal opinions on this subject. Almost all of the recent commits to that fork are made specifically for RP-0 (now known as RP-1) and there's probably only a few changes that would be of interest to stock players. Although I don't see any reasons why the RO fork wouldn't work on stock installs. It's just that me and anyone else currently contributing to that project do not play stock so we may end up creating unintended compatibility issues with that.

As far as I know we intend to release this fork of KCT on CKAN but updates will probably come along with the releases of RP-1. The issue is that RP-1 releases are usually 2 or lately even 3 KSP updates behind the latest.

Link to post
Share on other sites

For anyone who is brave and adventurous:

I have an ALPHA of a new build of KCT for 1.6.1

***** WARNING - THIS IS ALPHA - BACKUP YOUR SAVES BEFORE USING *****

This is derived from the RO version of KCT, along with a bug fix and some optimization I've done, the changes will be pushed back to RO later.

***** WARNING - THIS IS ALPHA - BACKUP YOUR SAVES BEFORE USING *****

It is available here:

https://github.com/linuxgurugamer/KCT/releases/tag/Alpha-1

***** WARNING - THIS IS ALPHA - BACKUP YOUR SAVES BEFORE USING *****

Dependency

https://github.com/linuxgurugamer/MagiCore/releases/tag/1.3.1.4

Changes from RO

  • Replaced all commented out 1.4 code with #if KSP1_4/#endif blocks
  • Changed the /* 1.4 Addition   to   // 1.4 Addition
  • Added coroutine:  HandleEditorButton_Coroutine() to reset the button  handlers every 1/2 second
  • Added StartCoroutine to end of Start() in KerbalConstructionTime.cs

The following were done to optimize the code a bit, to remove unnecessary code from a FixedUpdate
(I saw a FIXME comment and decided to do so)

  • Created new function which contains the code which was in the FixedUpdate():
    • KerbalConstructionTime.UpdateTechlistIconColor() 
  • Commented out the code in FixedUpdate() which was replaced by new method
  • Changed the TechList from a list to an IList, and in all methods which change the list,  added a call to to each method in the IList which changes the list:
    • KerbalConstructionTime.instance.UpdateTechlistIconColor();

PS: @magico13 I'm adopting this :-)

Edited by linuxgurugamer
Link to post
Share on other sites
2 hours ago, Tybot said:

Whoohoo! linuxgurugamer does it again!

Quick question, what release is this and is this safe to use with my current save without backup? /s :P

Please read the post again:

2 hours ago, linuxgurugamer said:

***** WARNING - THIS IS ALPHA - BACKUP YOUR SAVES BEFORE USING *****

I will not be responsible nor will I care if saves get corrupted by this. 

This may seem harsh, but I don't have the time to deal with issues caused by upgrading without backups.  I don't expect any real problems, but things happen

***** WARNING - THIS IS ALPHA - BACKUP YOUR SAVES BEFORE USING *****

Link to post
Share on other sites
5 hours ago, Tybot said:

Sorry, the above "/s" and emote was intended to denote sarcasm. Believe me, you made it clear enough.

:D

You may have been a bit too on-point with your playful sarcasm. I've done it before...

But, it does show how much we appreciate the ongoing fiddling, tweaking, and fixing of this and many other mods.

Link to post
Share on other sites

New release, 1.4.5

  • Started with latest KSP-RO repo of KCT
  • Replaced all commented out 1.4 code with #if KSP1_4/#endif blocks
  • Changed the /* 1.4 Addition   to   // 1.4 Addition
  • Added coroutine:  HandleEditorButton_Coroutine() to reset the button handlers every 1/2 second
  • Added StartCoroutine to end of Start() in KerbalConstructionTime.cs

    The following were done to optimize the code a bit, to remove unnecessary code from a FixedUpdate

  • Created new function 
    • KerbalConstructionTime.UpdateTechlistIconColor() 
      which contains the code which was in the FixedUpdate()
  • Commented out the code in FixedUpdate() which was replaced by new method
  • Changed the TechList from a list to an IList, and in all methods which change the list, 
    • added a call to 
      • KerbalConstructionTime.instance.UpdateTechlistIconColor();
    • to each method in the IList which changes the list.

    More changes, related to release

  • Renamed .version to KerbalConstructionTime.version
  • Copied KerbalConstructionTime.version to root directory
  • Renamed KerbalConstructionTime.csproj to KerbalConstructionTime-KSP1-4.csproj
  • Put original KerbalConstructionTime.csproj back in place
  • Created stock copy of .version file
  • Copied the assemblyversion.tt to AssemblyVersion-Stock.tt
  • Modified AssemblyVersion-Stock.tt to use the Stock.version file

For right now, I'll be continuing with this thread, but I may eventually want to start a new thread, just so I have control over the OP

@magico13 was gracious enough to add me as a coauthor on Spacedock, it's been updated with the latest release.

 

Edited by linuxgurugamer
Link to post
Share on other sites
14 hours ago, linuxgurugamer said:

New release, 1.4.5

  • Started with latest KSP-RO repo of KCT
  • Replaced all commented out 1.4 code with #if KSP1_4/#endif blocks
  • Changed the /* 1.4 Addition   to   // 1.4 Addition
  • Added coroutine:  HandleEditorButton_Coroutine() to reset the button handlers every 1/2 second
  • Added StartCoroutine to end of Start() in KerbalConstructionTime.cs

    The following were done to optimize the code a bit, to remove unnecessary code from a FixedUpdate

  • Created new function 
    • KerbalConstructionTime.UpdateTechlistIconColor() 
      which contains the code which was in the FixedUpdate()
  • Commented out the code in FixedUpdate() which was replaced by new method
  • Changed the TechList from a list to an IList, and in all methods which change the list, 
    • added a call to 
      • KerbalConstructionTime.instance.UpdateTechlistIconColor();
    • to each method in the IList which changes the list.

    More changes, related to release

  • Renamed .version to KerbalConstructionTime.version
  • Copied KerbalConstructionTime.version to root directory
  • Renamed KerbalConstructionTime.csproj to KerbalConstructionTime-KSP1-4.csproj
  • Put original KerbalConstructionTime.csproj back in place
  • Created stock copy of .version file
  • Copied the assemblyversion.tt to AssemblyVersion-Stock.tt
  • Modified AssemblyVersion-Stock.tt to use the Stock.version file

For right now, I'll be continuing with this thread, but I may eventually want to start a new thread, just so I have control over the OP

@magico13 was gracious enough to add me as a coauthor on Spacedock, it's been updated with the latest release.

 

in the zip ther are 2 KerbalConstructionTime.dll 

1 of size 229376 and the 2ed of size 220160

 

i think it is the reason for an error wen i try to update using ckan

p.s.

i DL  KerbalConstructionTime-Stock-1.6.1-1.4.5.zip

suld have i DL the  KerbalConstructionTime.zip version?

 

edit

https://1drv.ms/u/s!Ag5-muCA90ChkwUtmP2__3Bk724m

i get 4000 sci points wen i reserch

KCT update is the main suspect

 

edit 2

i deleted  KerbalConstructionTime-Stock-1.6.1-1.4.5.zip and installed  

KerbalConstructionTime.zip

now its working correctly

Edited by danielboro
Link to post
Share on other sites
4 hours ago, danielboro said:

in the zip ther are 2 KerbalConstructionTime.dll 

1 of size 229376 and the 2ed of size 220160

 

i think it is the reason for an error wen i try to update using ckan

p.s.

i DL  KerbalConstructionTime-Stock-1.6.1-1.4.5.zip

suld have i DL the  KerbalConstructionTime.zip version?

 

edit

https://1drv.ms/u/s!Ag5-muCA90ChkwUtmP2__3Bk724m

i get 4000 sci points wen i reserch

KCT update is the main suspect

 

edit 2

i deleted  KerbalConstructionTime-Stock-1.6.1-1.4.5.zip and installed  

KerbalConstructionTime.zip

now its working correctly

Something went wrong with the build, I'll get it fixed

Link to post
Share on other sites

@linuxgurugamer, @Angel-125 Not sure, if this should be posted here or on BARIS thread, but integration between these two mods seems broken. Going to start a new campaign, I've just started installing desired mods one-by-one, checking them after each change. After adding BARIS (tried both 1.8.0 and 1.8.2, no difference) to install with working KCT (latest 1.4.5.1), latter stopped to work: click on "Launch" button in VAB brings me to flight scene directly and won't add vessel to build list. After starting new game KCT didn't even offers to select preset.

There's one meaningful exception at log (by KCT, so I'm posting these in this thread):

Spoiler
[EXC 21:15:41.843] NullReferenceException: Object reference not set to an instance of an object
	EventVoid+EvtDelegate..ctor (.OnEvent evt)
	EventVoid.Add (.OnEvent evt)
	KerbalConstructionTime.KCT_Events.SubscribeToEvents ()
	KerbalConstructionTime.KerbalConstructionTime.Start ()

 


Link to the complete log file (started new game, dismissed opened startup windows, closed game, that's all; exception message at line 24810): google drive

I'll gladly provide any other info if needed.

Edited by unclepirog
Link to post
Share on other sites
26 minutes ago, unclepirog said:

inuxgurugamer, @Angel-125 Not sure, if this should be posted here or on BARIS thread, but integration between these two mods seems broken. Going to start a new campaign, I've just started installing desired mods one-by-one, checking them after each change. After adding BARIS (tried both

Has it ever worked?

I dont use Baris, so have no idea

Link to post
Share on other sites
23 minutes ago, unclepirog said:

Yeah, at least ages ago, at times of 1.3.1

I heard back from @Angel-125

There is no recompile needed, the only "integration" is that Baris turns off some features if KCT is installed.

This, and the message from @HawkEngineer, seems to indicate it's a problem in your install

Link to post
Share on other sites

I odnt thing BARIS is the (only) cause of this, i see the same Problem using 1.4.5.1.  but i dont have BARIS installed. 

But isnce i have a metric ton of other mods active i will have to wait for the weekend before i can participate in any bughunt

Link to post
Share on other sites
15 minutes ago, linuxgurugamer said:

I heard back from @Angel-125

There is no recompile needed, the only "integration" is that Baris turns off some features if KCT is installed.

This, and the message from @HawkEngineer, seems to indicate it's a problem in your install

It may be problem with my installation, but I've just checked it two more times. KSP 1.6.1, BARIS 1.8.2, bunch of other mods (haven't touched them) stayed the same.

KCT 1.4.0.69 with MagiCore 1.3.1.0: works as intended (at least starting new game, choosing KCT preset, adding vessel to KCT build list by "Launch" button, launching it).

KCT 1.4.5.1 with MagiCore 1.3.1.4: don't, as I've reported earlier.

I'll try pure unmodded install later, just to be sure.

Link to post
Share on other sites
32 minutes ago, unclepirog said:

It may be problem with my installation, but I've just checked it two more times. KSP 1.6.1, BARIS 1.8.2, bunch of other mods (haven't touched them) stayed the same.

KCT 1.4.0.69 with MagiCore 1.3.1.0: works as intended (at least starting new game, choosing KCT preset, adding vessel to KCT build list by "Launch" button, launching it).

KCT 1.4.5.1 with MagiCore 1.3.1.4: don't, as I've reported earlier.

I'll try pure unmodded install later, just to be sure.

I'll try it out later

Link to post
Share on other sites
6 hours ago, unclepirog said:

It may be problem with my installation, but I've just checked it two more times. KSP 1.6.1, BARIS 1.8.2, bunch of other mods (haven't touched them) stayed the same.

KCT 1.4.0.69 with MagiCore 1.3.1.0: works as intended (at least starting new game, choosing KCT preset, adding vessel to KCT build list by "Launch" button, launching it).

KCT 1.4.5.1 with MagiCore 1.3.1.4: don't, as I've reported earlier.

I'll try pure unmodded install later, just to be sure.

@unclepirog

Is there any chance that you have multiple launch sites disabled?  If so, please enable them and try again

Link to post
Share on other sites
  • Deddly locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...