magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

I'm gonna be really unprofessional for a moment and laugh about the juggling balls comment, then I'm going to thank you for your post.

Hahaha, oh god =) I should have proofread that a little better. Or not - it's good signature fodder ;)

Share this post


Link to post
Share on other sites

I also want to say thank for this mod. Really adds a new dimension to the game and makes me feel a lot closer to running a space program. I hope Squad thinks about this for the release. Of course it could be disabled in the difficulty options.

Share this post


Link to post
Share on other sites

Heya - Love this mod! I'm running into a problem now (after 2+ years in game time) when switching to the Tracking Station screen. Getting spammed with null reference exceptions and the game stops responding. Here is the log: http://filebin.ca/1hkkhCRXsHi6/output_log.txt

Running 32bit, with the mods below:

Blizzy Toolbar

USI Tools

Active Texture Management

Alcor Pod

B9

Baha Configurable Wheels

Environmental Enhancement

Chatterer

CrossFeedEnabler

Custom Biomes

Distant Objects

DMagic Orbital Science

Editor Extentions

Engineer

Firespitter

FTmN

JSI

KAS

Kerbal Construction Time

Kerbal Joint Reinforcement

Nav Utilities

Kerb Quake

KineTechAnimation

Kip's Hubs

Klockeed Martian

KW rockets

MechJeb2

NavyFish Docking Mode

Near Future Propulsion (all packs)

Fine Print

Final Frontier

PlanetShine

PreciseNode

RemoteTech

ResGen (could this be conflicting with USI Tools?)

SCANsat

ShipManifest

SmokeScreen

Station Parts Expansion

Station Science

TAC Life Support

Atmosphere Trajectories

Alternate Resource Panel

TweakScale

Universal Storage

Virgin Kalactic

Module Manager

Share this post


Link to post
Share on other sites

The good news is that I know what the issue is. The bad news is that the fix is implemented in a new update that is currently pretty broken and won't be out for a few days. I believe a majority of KCT users are also StageRecovery users, and while StageRecovery also has this issue present it comes up far less often. If you add StageRecovery you shouldn't have the problem (if you do, you'll have to turn off the "Try Powered Recovery" setting). If you don't want to add another mod you can either 1) wait a few days, 2) remove the vessel that's causing the issue from the save file manually, or 3) remove KCT, load the save and go into the Tracking Station, then exit the game and add KCT back.

In case you want to know precisely what's going on, here's the rundown. A ship is being destroyed by KSP for being too low in the atmosphere while being unloaded. KCT kicks in and checks for parachutes and for a probe core (if there's enough parachutes then the parts get put in the inventory, if there's a probe core you get more funds back). When it checks for the probe core it tries to view some information in the COMMAND module, but since the current scene is the Tracking Station and not flight, that information doesn't exist (aka, the module is NULL). Then it spews out an NRE which causes the rest of the game to go crazy.

StageRecovery avoids the issue most of the time because the default mode doesn't care if the destroyed vessel is controlled. When trying powered recovery it does care though, so there's a chance the issue could appear then. It will be fixed in both mods soon.

Share this post


Link to post
Share on other sites

Exactly that Magico13. You got the idea! good to now that is already planed, will bring more delight to your already great mod.

Thanks by you answer.

Share this post


Link to post
Share on other sites
or 3) remove KCT, load the save and go into the Tracking Station, then exit the game and add KCT back.

Awesome - I actually unchecked "enable KCT for this save", went and deorbited the falling craft, then checked "enable KCT for this save" again :) worked!

Thanks for the help, and I'll definitely echo the sentiment that this mod is a game changer. I was on the fence for a long time, but now that I tried it I will never go back :D

If you're still soliciting feature ideas, a launch timeline would be a neat view. Something that plots vessel launches by name and launch date. This will keep growing over time and would really reinforce the sense of history and progress :)

Thanks again!

Share this post


Link to post
Share on other sites

I remember reading how that VAB upgrades affect launchpad reconditioning time, but I can't find your post describing it. (It's calculated by summing the VAB build speeds, right?) Anyway, that made me think:

Wouldn't it be nice if the launchpad reconditioning rate was visible somewhere in the Upgrade tab? Sure, you can't change it directly, but it is affected by upgrades (and all the other rates can be found there).

Share this post


Link to post
Share on other sites
Awesome - I actually unchecked "enable KCT for this save", went and deorbited the falling craft, then checked "enable KCT for this save" again :) worked!

I don't know why I didn't think of that! :P Sometimes I forget that option exists (and ironically is also bugged in the current released version).

I remember reading how that VAB upgrades affect launchpad reconditioning time, but I can't find your post describing it. (It's calculated by summing the VAB build speeds, right?) Anyway, that made me think:

Wouldn't it be nice if the launchpad reconditioning rate was visible somewhere in the Upgrade tab? Sure, you can't change it directly, but it is affected by upgrades (and all the other rates can be found there).

Like you said, the Reconditioning Rate is the sum of all the VAB rates. That kind of info would definitely be included in the Getting Started Guide. It's generally easy enough to calculate (add a couple numbers at most) that I never thought it to be that useful to be explicitly displayed, but perhaps when I do the GUI and/or upgrade overhauls I'll toss it in somewhere.

Conveniently the Launchpad can be reconditioned while other ships are being built and is progressed at a rate equal to the sum of all the VAB Build Rates. If you’ve got one rate, it’s exactly that one. If you’ve got two rates (say, 1 BP/s and 0.5BP/s) then it’s the combination of the two (1.5 BP/s). If you’ve got 12 rates, it’s all of those bad boys tossed into one big pile of reconditioning goodness.

Share this post


Link to post
Share on other sites

Double posting to announce that I'm opening up the development thread again for the open betas. I just setup a build server that will build new versions automatically whenever I push a github commit. They will update comparatively frequently and it's totally possible that a successful build will not actually be functional. I'll try to mention in the commit messages whether I know they won't work so you can avoid those.

So if you want to try out the latest builds and are totally fine with really unstable builds that will likely break things, then come join the fun in the development thread!

Share this post


Link to post
Share on other sites

I hate to be the Feature-Requestotron, but... :\

Here's a couple more.

*Allow bp costs to be determined by x * mass + y * cost // this is because for RP-0, we'd like crewed craft, which cost a lot more, to take longer to build, for example, or for hydrolox stages, which are lighter but more expensive, to take longer...

*Allow node unlock rate to be configured in settings (did I miss it? Looked through *.txt, didn't see it)

Share this post


Link to post
Share on other sites
I hate to be the Feature-Requestotron, but... :\

Here's a couple more.

*Allow bp costs to be determined by x * mass + y * cost // this is because for RP-0, we'd like crewed craft, which cost a lot more, to take longer to build, for example, or for hydrolox stages, which are lighter but more expensive, to take longer...

*Allow node unlock rate to be configured in settings (did I miss it? Looked through *.txt, didn't see it)

Node unlock rate isn't configurable yet, but I can add that in.

BP for buildings ships is currently entirely cost based, which achieves the goals you indicate. I can also add some mass dependence in there if you really want, but mass is currently only for reconditioning and rollout times.

Share this post


Link to post
Share on other sites

Weird, I thought it was BP/ton. Sorry about that. Great to know it's cost-based then. And thanks re: science!

(For RP-0 we're probably going to go with something like year-long unlock times for nodes...)

Share this post


Link to post
Share on other sites
Weird, I thought it was BP/ton. Sorry about that. Great to know it's cost-based then. And thanks re: science!

(For RP-0 we're probably going to go with something like year-long unlock times for nodes...)

How I implemented it is just a straight multiplier to the rate (so setting it to 2 makes them take half as long, I might swap that around before the actual release though so that a value of 2 makes it take twice as long) but you can still upgrade the rate at the usual doubling each time (currently that's doubling the base rate before the modifier though).

Here, let me make this simpler. How would you prefer it to be done (modify the total BP, the build rate, or something else)? Any way I go about it, it won't actually be difficult to do, and nobody else probably has much preference how it's done just so long as it's adjustable.

Edit: I just swapped it so that a modifier of 2 means it will take twice as long, which corresponds to how the Overall Modifier works (the Overall Modifier is independent of the Node Modifier though, just to keep that in mind).

Edited by magico13

Share this post


Link to post
Share on other sites
Weird, I thought it was BP/ton. Sorry about that. Great to know it's cost-based then. And thanks re: science!

(For RP-0 we're probably going to go with something like year-long unlock times for nodes...)

I guess it's weird to say this because obviously I'm not the only one, but I got excited when you said that. I know Squad has given their official stance on time as a resource, so I'm glad that the modding scene is filling in!

Share this post


Link to post
Share on other sites

We could really use a few more pairs of eyes over in the open beta/development thread, so if you're not afraid of some bugs and want to help out with fixing up the update BEFORE it releases it'd be great if you would come on over and give us a hand. Currently it's just JeffreyCor and I, but the more testers we have the faster we can find bugs (of which there are certainly plenty). The update is reaching a semi-stable point (but it is still untested if old saves will transfer to the new system), so it shouldn't normally break your saves (but old ones likely will break).

This is your chance to help the release come sooner while also influencing the future of KCT far more than you could as a typical user after the release ;) It should be noted that these are only suitable for experienced players and in testing saves. If that doesn't sound like you, I'd wait until the official update (which will be soonTM).

Dev thread

Share this post


Link to post
Share on other sites

Fun bug in the latest stable release.

Having an exploded launchpad does not stop craft already in the build list from launching when they complete. I haven't tested whether I can add further craft to the build list yet.

Share this post


Link to post
Share on other sites

I have a feature request/suggestion.

Would it be possible for KCT to recognise when a user has Kerbinside installed and only activate pad reconditioning on the last launched from site?

Share this post


Link to post
Share on other sites
Fun bug in the latest stable release.

Having an exploded launchpad does not stop craft already in the build list from launching when they complete. I haven't tested whether I can add further craft to the build list yet.

I haven't quite figured out how to actually check if the launchpad is destroyed or not, but when I figure that out I'll fix this. It likely won't be fixed in the next release though.

I have a feature request/suggestion.

Would it be possible for KCT to recognise when a user has Kerbinside installed and only activate pad reconditioning on the last launched from site?

Planned and the initial code required is in the next update. KCT will have individual vessel rollout and reconditioning for each launchpad separately. Until then it is recommended to disable launchpad reconditioning while using Kerbinside/any other Kerbal Konstructs based mod. Full functionality won't be in until version 1.2 as version 1.1 is essentially finished and is just going through additional tweaks+testing.

Share this post


Link to post
Share on other sites

Planned and the initial code required is in the next update. KCT will have individual vessel rollout and reconditioning for each launchpad separately. Until then it is recommended to disable launchpad reconditioning while using Kerbinside/any other Kerbal Konstructs based mod. Full functionality won't be in until version 1.2 as version 1.1 is essentially finished and is just going through additional tweaks+testing.

Ahh, nice.

Cheers for the reply :)

Share this post


Link to post
Share on other sites

Hello, I'm having a bug in 1.0.3 (ksp 0.25) : after editing a craft and returning to space center, my camera get locked toward the sph :

http://steamcommunity.com/sharedfiles/filedetails/?id=350766451

Also the time passes normally and can be warped, but when I pass the cursor over KCT gui, it gets definitely paused.

I can switch to the vessel, but external camera command are locked. I can still switch between map/normal/IVA. IVA works fine, orbital map doesn't : http://steamcommunity.com/sharedfiles/filedetails/?id=350766485

Here is the log :

https://www.dropbox.com/s/7uh6ci6z3xho40n/output_log.txt?dl=0

Similar bugs have already been reported, but I haven't seen any workaround, or log (though I did not searched extensively through the 72 pages of this thread), and it seems to be triggered without apparent reason, but not randomely : I can reproduce this bug ever and ever on my save that I backed up on purpose (I can upload it if you wish)

Also, here are the mods I use (more precisely, I stupidely copy and paste the name of folders in my GameData) :

000_Toolbar

ActionGroupManager

CIT

CommunityResourcePack

Engineer

EnhancedNavBall

FinePrint

JSI

KerbalAlarmClock_2.7.8.2

KerbalConstructionTime

MissionControllerEC

NASAmission

NavyFish

RemoteTech

RSSBuild

Squad

StageRecovery

ThunderAerospace

+ModuleManager (which does not appear in GameData)

I'll try without them

Share this post


Link to post
Share on other sites

Trying again with only KCT and engineer, and can't reproduce the bug. That should not come from kct.

Damn ! I can no more reproduce the bug : tryed with all mods but thre, then with that 3 mods +kct and engineer (the bug was craft specific, and that craft had engineer parts), using always the same save folder, then restore my GameData, and could not reproduce the bug.

If it ever happen again, I'll try to better analyse it, until then, I think you can ignore my previous post.

Edited by Kesa

Share this post


Link to post
Share on other sites

I know the feeling all too well Kesa. So many times have a bug in testing then it just seems to vanish making it impossible to pin down just what the heck is going on. Twice in the update currently in development even. Very annoying! :)

Share this post


Link to post
Share on other sites

I haven't had a chance yet to take a look at those logs, but will during work tomorrow. I suspect an InputLock is active that shouldn't be, likely in another mod and not KCT, but because KCT sometimes has abnormal scene changes some mods won't release locks when they should. Mechjeb used to do this. The log might tell me which locks are active during the scene change and I can hopefully pinpoint the mod that enables it. Next time it happens, open the debug menu (alt-f12) and press the "Show input locks" button. Take a screenshot of that if there's some listed and send that my way. Be very careful to make sure that when clicking a KCT window button (such as the save edits button) there are no other mod windows behind the button (even better, close all other mod windows). That was the issue with mechjeb in the past.

If I find which mod has the issue I can send them a report and suggest that they clear locks when the scene changes away from the editor. It certainly is possible that KCT is at fault alone though. Such is the way of software development: crazy annoying bugs :D

I swear half of the 30 or so commits made for 1.1 so far were just to fix bugs and then caused more unexpected bugs!

Share this post


Link to post
Share on other sites
Trying again with only KCT and engineer, and can't reproduce the bug. That should not come from kct.

Damn ! I can no more reproduce the bug : tryed with all mods but thre, then with that 3 mods +kct and engineer (the bug was craft specific, and that craft had engineer parts), using always the same save folder, then restore my GameData, and could not reproduce the bug.

If it ever happen again, I'll try to better analyse it, until then, I think you can ignore my previous post.

It's actually a stock bug, it's caused by the staging menu going above the exit button in the VAB. When you try and click through this bug happens. It can be fixed by loading a craft on the runway (which you can select from that view) and then exiting back to the Space Centre, that should clear it. (Pro tip: wait for the craft to fully load, physics to click in, and the "this is a simulation" menu to appear for KCT before exiting the flight.) - That should allow you to continue Kerballing.

Edited by severedsolo

Share this post


Link to post
Share on other sites

Apparently the log only outputs the current locks when entering the editor, not when switching to the space center. The only out of the ordinary one I can find is conveniently named "202025866" which is absolutely useless (meaning it definitely could be Stock ;) ) as opposed to KCT's nicely named "KCTKSCLock" and other "KCT${function}" locks. It only appeared active when editing a vessel the third time and had quite a few restrictions it appears based on the bitmask.


bitmask with weird lock 101111101111111111100000000000000000010000000000
bitmask with just KCT 100000000001111000000000000000000000000000000000

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.