magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

I am currently using this mod with the RP-0 config and have a random bug with the upgrades. What seems randomly my upgrade points will be reset, so I still have the same number of points but they are just all unspent. The other bug is that I will randomly lose points and have negative points to spend.

Share this post


Link to post
Share on other sites
What seems randomly my upgrade points will be reset, so I still have the same number of points but they are just all unspent.

That would seemingly only happen if the save file got messed up. Otherwise I can't think of a way for that to happen. If you see it, send me a log file.

The other bug is that I will randomly lose points and have negative points to spend.

That sometimes happens when the Tech Tree can't be properly accessed for some reason. I've got a potential fix in the dev builds but haven't pushed it into the release yet. There's a decent chance it will still happen even with the fix, because for some reason the tech tree data just goes missing for a little while.

Share this post


Link to post
Share on other sites

Magico13, I'd like to make a feature request.

This mod gets me closer and closer to just letting KSP run all the time, in realtime. The only thing is that I have to find *something* to do while I wait for events to happen. I realized that I spend a lot of time tinkering in the VAB and SPH. I'd like it if there were an option to allow time to run while in the VAB or SPH. I don't know if that is possible under the current game (I suspect not), but I can see a hardcore option (time always runs, always counts, etc), a softcore option (time runs at the user's discretion) and the current method (time stands still).

I've said before: this mod is one of the single best mods for KSP. If you never made another change to it, I would still be ever grateful for all the work you've done.

Share this post


Link to post
Share on other sites
Magico13, I'd like to make a feature request.

This mod gets me closer and closer to just letting KSP run all the time, in realtime. The only thing is that I have to find *something* to do while I wait for events to happen. I realized that I spend a lot of time tinkering in the VAB and SPH. I'd like it if there were an option to allow time to run while in the VAB or SPH. I don't know if that is possible under the current game (I suspect not), but I can see a hardcore option (time always runs, always counts, etc), a softcore option (time runs at the user's discretion) and the current method (time stands still).

I've said before: this mod is one of the single best mods for KSP. If you never made another change to it, I would still be ever grateful for all the work you've done.

Keep in mind that if you want time to keep moving, then to be fair, all the celestial mechanics ought to keep running, too. That makes this more complicated. If my recollection of olden times is correct, time didn't advance when you were at KSC until Squad added that feature.

I don't know much about how KSP scenes work internally, but even if this needs to be a Squad change, you might have a way to approximate what you want. You might investigate running a second instance of KSP, either on the same machine or on separate machines. You would use the second instance of KSP for all your design and simulation work, and just move over the craft files.

You'd still have a short pause of time when you are in the VAB/SPH to load the craft files (or when you're in most of the KSC buildings), but you already get pauses in the Kerbal universe each time you change scenes or switch to remote ships, so perhaps that much pausing is acceptable? (Of course, I don't know if this would work, but it's a possible workaround to get close to what you want.)

If my recollection of olden times is correct, time didn't advance when you were at KSC until Squad added that feature.

Share this post


Link to post
Share on other sites
Keep in mind that if you want time to keep moving, then to be fair, all the celestial mechanics ought to keep running, too. That makes this more complicated.

Actually, this is the easy part. KSP doesn't track the planets or any other object, it computes their position from time & orbital parameters. Just change the date in a savegame and see what happens to the planets.

So the proposed mod only needs to keep track of how much time you spend in VAB, and upon scene change, adjust the (solar) system clock. I expect this to be either trivial or virtually impossible. Might have interesting side effects with other mods (*cough* KAC *cough*).

Share this post


Link to post
Share on other sites

So the proposed mod only needs to keep track of how much time you spend in VAB, and upon scene change, adjust the (solar) system clock. I expect this to be either trivial or virtually impossible. Might have interesting side effects with other mods (*cough* KAC *cough*).

It's actually that simple ;) Before you could timewarp in the Space Center scene I made it possible to "jump time" to when a craft was complete. The only issue is craft that are on a collision course, as they'll instead jump through the planet. So I can either do big jumps on scene change (easy) or small jumps while still in the editor (slightly more difficult, and more likely to mess things up with other mods, but potentially better). I could also do a series of jumps on scene change (ie, 10 1 minute jumps instead of 1 10 minute one), which might be the best option.

I can make that as a modlet :)

Share this post


Link to post
Share on other sites

Just thought I'd share the preset (Realism6) I've been tweaking as I think it's quite nice. Based off of the RP-0 config but modified for default Kerbin (6 hour days) as well as a couple other nifty tweaks. Essentially I'm using a bunch of mods to add a bit more realism, but still making it feel quite Kerbal.

I can make that as a modlet :)

That sounds great! :D

Share this post


Link to post
Share on other sites
It's actually that simple ;) Before you could timewarp in the Space Center scene I made it possible to "jump time" to when a craft was complete. The only issue is craft that are on a collision course, as they'll instead jump through the planet.

My main concern were upcoming events in Kerbal Alarm Clock. I can spend hours in VAB and wouldn't want to miss an insertion burn.

And now for something completely different: RP-0 has made me a user of your mod and it's a minor nuisance that I seemingly can only ever warp to the next event. If I don't care about the refurbished launchpad, or the next tech coming up (which is pretty useless on it's own) -- how can I warp to an event that's a little further down the line?

Share this post


Link to post
Share on other sites
My main concern were upcoming events in Kerbal Alarm Clock. I can spend hours in VAB and wouldn't want to miss an insertion burn.

I'm trying to think of some ways to handle that. I'll probably have a little clock window showing the current time, and might have to implement some talking to KAC through the API to see if an alarm is about to trigger, and if so then either trigger it or warn the player.

how can I warp to an event that's a little further down the line?

Most things have a * button, and for most things that have that button there should be a "Warp To" option. Alternatively, a few things just have a "Warp To" option by themselves. If you warp to one of them, it should pass by everything else. Unless you've got automatic KAC alarm creation or the "Force Stop Warp" setting enabled (I may have removed that setting in this update. Can't recall off the top of my head.) in which case timewarp will still stop for every single thing when it finishes.

Share this post


Link to post
Share on other sites

EditorTime now exists! It's super straightforward and just makes time pass while you're in the editor (at a configurable rate of game time : real time). It doesn't support Kerbal Alarm Clock yet, so you should be wary of jumping into the editor if you've got an alarm coming up soon.

I haven't actually tested it with KCT yet, sorry. KCT might need a change for it to work, since KCT relies on the Planetarium time but this modifies the time in the FlightState (modifying the Planetarium time wasn't being kept). KCT might see any elapsed time as all occurring at once, and if it's too large then KCT will ignore that jump.

Share this post


Link to post
Share on other sites

Thanks Magico for a great Mod..

Lately I have been using more spaceplanes to cycle gear and fuel to my kerbal Space Station. Whenever I use KCT's recover active vehicle on the landed plane, it launches pointed straight up. I know this is a known issue, but is there a workaround to keep this from happening?

Share this post


Link to post
Share on other sites
Thanks Magico for a great Mod..

Lately I have been using more spaceplanes to cycle gear and fuel to my kerbal Space Station. Whenever I use KCT's recover active vehicle on the landed plane, it launches pointed straight up. I know this is a known issue, but is there a workaround to keep this from happening?

Known issue. Just edit the craft and grab the root part and it will automatically flip to being correctly oriented (you also can refuel the plane if you edit it). The ships know they're not facing the right way, but they don't want to flip the correct way for some reason. It's a small enough issue (in code that I don't particularly care for in the first place) that I haven't looked into it much. I'm afraid that if I manually rotate it 90 degrees, it'll rotate a further 90 degrees as soon as you click on any parts in the editor, which is almost more annoying since you'll need to refuel more often than not.

Share this post


Link to post
Share on other sites

Great thanks, will give it a try..

PS.. I wish the MOD would unlock my newb account so that my posts are immediate... Hint Hint.. :)

Looks like they did.. This post was up right away.. Thanks Mods..

Edited by Buzz313th

Share this post


Link to post
Share on other sites
Great thanks, will give it a try..

PS.. I wish the MOD would unlock my newb account so that my posts are immediate... Hint Hint.. :)

Looks like they did.. This post was up right away.. Thanks Mods..

It happens as soon as you're no longer a "Curious George", which is either 3 or 5 posts. For me it was 5 posts, but I think they dropped it to 3 somewhat recently. It's to get around all the spambots, and thankfully doesn't last for too long. Looks like you're probably in the clear now :) If you've got any other question, concerns, or feature requests, let me know :D And welcome to the forums, since you're new enough that I should probably say that!

Share this post


Link to post
Share on other sites
It happens as soon as you're no longer a "Curious George", which is either 3 or 5 posts. For me it was 5 posts, but I think they dropped it to 3 somewhat recently. It's to get around all the spambots, and thankfully doesn't last for too long. Looks like you're probably in the clear now :) If you've got any other question, concerns, or feature requests, let me know :D And welcome to the forums, since you're new enough that I should probably say that!

Thanks Magico..

Have a goodun

Share this post


Link to post
Share on other sites

Truth be told, KCT is not what lights my fire. I'm using it in the context of RSS/RO/RP-0 where it makes a lot of sense, though. I thought I had figured it out, but some questions remain.

Alright, I do have points which I can spend on upgrades. The upgrades themselves are quite straightforward, but where do the points come from? I *think* I get most of my points from scheduling science (have science points on hand, go into R&D to spend them, find that I have KCT points to spend on upgrades). But sometimes points appear just out of the blue. And just now, I find myself with -23 points and don't know why.

Also, when upgrading the launchpad, KCT decided to upgrade it twice. That is, I had a 300-day timer, and when it ran out, I still had the same old launchpad and a shiny new 300-day timer. After that second one ran out, the launchpad was finished. Is that how it's supposed to be?

Share this post


Link to post
Share on other sites
Truth be told, KCT is not what lights my fire. I'm using it in the context of RSS/RO/RP-0 where it makes a lot of sense, though. I thought I had figured it out, but some questions remain.

Alright, I do have points which I can spend on upgrades. The upgrades themselves are quite straightforward, but where do the points come from? I *think* I get most of my points from scheduling science (have science points on hand, go into R&D to spend them, find that I have KCT points to spend on upgrades). But sometimes points appear just out of the blue. And just now, I find myself with -23 points and don't know why.

Also, when upgrading the launchpad, KCT decided to upgrade it twice. That is, I had a 300-day timer, and when it ran out, I still had the same old launchpad and a shiny new 300-day timer. After that second one ran out, the launchpad was finished. Is that how it's supposed to be?

The launchpad thing is definitely a bug. Sounds like something didn't save properly. Let me know if you see it again, but unfortunately there are a lot of mods involved with RO and RP-0 so there are quite a few places where things can go wrong (which makes debugging difficult).

Most upgrade points come from researching tech nodes. You'll notice when you purchase one that you're alerted in the top left that an upgrade point has been added (and the amount of time until the node unlocks). Points should never appear out of the blue. If you see that, let me know and send me a log and I'll see if I can figure out what's going on. As for the negative points, that's because for whatever reason KCT can't read the tech tree and assumes you have 0 tech nodes unlocked. It seems to be a KSP issue, and the data I'd like to access to get direct access to the tech tree is locked down by Squad so I have to get at it through other means. I have an attempted fix for that issue in the dev builds (instead of constantly checking for the tech tree, it only does it on scene change), but I'm not sure if it actually fixes the issue or not.

You can also buy points with funds in RP-0. In default KCT you can buy points with funds, science, and by clearing out your inventory (those are Preset controlled options).

Share this post


Link to post
Share on other sites
The launchpad thing is definitely a bug. Sounds like something didn't save properly. Let me know if you see it again, but unfortunately there are a lot of mods involved with RO and RP-0 so there are quite a few places where things can go wrong (which makes debugging difficult).

Yeah, I know. I've come across many oddities and often can't figure out where to look for help. Seeing as RP-0 modifies nearly everything, I wonder if it's fair to pester the original mod authors.

Most upgrade points come from researching tech nodes. You'll notice when you purchase one

Now that you mention it, I did notice it.

Points should never appear out of the blue. If you see that, let me know and send me a log and I'll see if I can figure out what's going on.

I think I found some small amount of additional points after ordering some rockets to be built.

I just went back to a save where most everything was still fine, shortly before I ordered the building upgrades. This time around, the launchpad finished on the first timer. I also remember that yesterday, ordering the buildings gave me a large amount of points, which didn't happen today. Coming to think of it, that may well have been the 23 points that I've been lacking after restarting the game today.

What kind of log do I have to look out for? My KSP.log hasn't changed in 11 days -- or can it be that I disabled logging?

Share this post


Link to post
Share on other sites

Hello Magico13, your mod is fantastic, just that lately is giving me serious problems. I often "Error loading KCT date". I use Ubuntu and of course the 64-bit version. When this happens, it will clear the contracts that were halfway, type asteroid day, if he had found 10 asteroids, after the error goes back to 0.

It also happens sometimes have negative upgrades.

I put my log

https://drive.google.com/file/d/0B_n0DdXfS_EDX2tMWm4yQnVTc2M/view?usp=sharing

Edited by EmpCris

Share this post


Link to post
Share on other sites

What kind of log do I have to look out for? My KSP.log hasn't changed in 11 days -- or can it be that I disabled logging?

Usually the output_log.txt file that gets made in KSP_Data is the file mod authors will ask for (except nightingale, who prefers KSP.log for some reason ;)). Next time you notice something weird, upload that to dropbox/mediafire/etc and post either here or on GitHub and I'll take a look through it to see if anything stands out. KSP bugs are especially fun because minor problems in one mod can lead to huge problems in other ones :P

Hello Magico13, your mod is fantastic, just that lately is giving me serious problems. I often "Error loading KCT date". I use Ubuntu and of course the 64-bit version. When this happens, it will clear the contracts that were halfway, type asteroid day, if he had found 10 asteroids, after the error goes back to 0.

It also happens sometimes have negative upgrades.

I put my log

https://drive.google.com/file/d/0B_n0DdXfS_EDX2tMWm4yQnVTc2M/view?usp=sharing

So the KCT error popup isn't always (and frequently isn't) caused by a KCT issue. If you're having contracts disappear, then some mod is definitely having an error during the OnLoad (which many mods don't check for, which is why I wrote the popup). I'll look through the log and report back in a minute.

Edit: Alright, so it's not super clear what exactly is going on. SCANsat definitely has an error loading the data (thus breaking everything after it, like KCT). Based on what the log was saying in the Flight scene before you went back to the Space Center, it looks like there might be a corrupted Vessel? There's also a NullReferenceException at the start of the Space Center scene in a Vessel.OnDestroy() that makes me think there's a particular vessel at fault.

I've also seen some issues with MissionController Extended encountering issues in the contract system. So that could also be related to the loss of contract data.

Could you please open up the KCT settings (the Preset menu) and turn on Debug Logging. It will make KCT print more data to the log and I might be able to track down the problem slightly easier. The "good" news is that I don't think KCT is causing the problem, it's just reporting it.

SCANsat error:


NullReferenceException: Object reference not set to an instance of an object
at SCANsat.SCANcontroller+<>c__DisplayClass1d.<registerSensor>b__1c (.Vessel a) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.First[Vessel] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable.FirstOrDefault[Vessel] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0
at SCANsat.SCANcontroller.registerSensor (Guid id, SCANtype sensors, Double fov, Double min_alt, Double max_alt, Double best_alt) [0x00000] in <filename unknown>:0
at SCANsat.SCANcontroller.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioRunner.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at ProtoScenarioModule.Load (.ScenarioRunner host) [0x00000] in <filename unknown>:0
at ScenarioRunner+
.MoveNext () [0x00000] in <filename unknown>:0

Error at start of Space Center scene:


NullReferenceException
at (wrapper managed-to-native) UnityEngine.Component:InternalGetGameObject ()
at UnityEngine.Component.get_gameObject () [0x00000] in <filename unknown>:0
at KnowledgeBase.DisposeResourceList () [0x00000] in <filename unknown>:0
at KnowledgeBase.CreateResourceList () [0x00000] in <filename unknown>:0
at KnowledgeBase.OnMapFocusChange (.MapObject target) [0x00000] in <filename unknown>:0
at EventData`1[MapObject].Fire (.MapObject data) [0x00000] in <filename unknown>:0
at PlanetariumCamera.SetTarget (.MapObject tgt) [0x00000] in <filename unknown>:0
at PlanetariumCamera.OnVesselDestroy (.Vessel vessel) [0x00000] in <filename unknown>:0
at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0
at Vessel.OnDestroy () [0x00000] in <filename unknown>:0

Edited by magico13

Share this post


Link to post
Share on other sites

Hmm. Same errors being logged. There's an issue with MissionController upon entering the Flight scene (check to make sure your contracts are still working after loading up the Flight scene), then an issue in a Vessel.OnDestroy() when loading the Space Center, followed by an error while loading the Space Center itself, and then first SCANsat and then the Asteroid spawning code throwing errors that break the OnLoad, followed by thousands of errors in the life support mod (from having the same error during the FixedUpdate step).

I'm still inclined to believe there's a vessel messed up that's causing it, and it appears as if it's Ku-Sentinel. Could you go into your saves folder and make a copy of this save, then load the save and terminate the Sentinel mission? Then load a flight and exit to the Space Center. If it doesn't get messed up, then the Sentinel mission is bugged somehow.

Share this post


Link to post
Share on other sites

I did other tests, as well as the one described by you. Taking destroy a satellite in the atmosphere happened to me the bug. I deleted KCT (use CKAN) and I tried again the scene, yet the bug. Install yet KCT, MissionController2 removed, repeat the scene, and the bug goes away.

Now I can go on the satellite KU-Sentinel and everything works back to KSC , the problem is MC2

Thanks for your help

Share this post


Link to post
Share on other sites
EditorTime now exists! It's super straightforward and just makes time pass while you're in the editor (at a configurable rate of game time : real time). It doesn't support Kerbal Alarm Clock yet, so you should be wary of jumping into the editor if you've got an alarm coming up soon.

I haven't actually tested it with KCT yet, sorry. KCT might need a change for it to work, since KCT relies on the Planetarium time but this modifies the time in the FlightState (modifying the Planetarium time wasn't being kept). KCT might see any elapsed time as all occurring at once, and if it's too large then KCT will ignore that jump.

I just copied in the modlet; just for fun. It didn't synchronize well with the KCT vessel construction, so I removed it again. I have no problem giving KSP a quick warp boost when exiting the editor to 'simulate' time flowing - for KCT users that is probably a better solution than the modlet - for now ;).

Share this post


Link to post
Share on other sites
I just copied in the modlet; just for fun. It didn't synchronize well with the KCT vessel construction, so I removed it again. I have no problem giving KSP a quick warp boost when exiting the editor to 'simulate' time flowing - for KCT users that is probably a better solution than the modlet - for now ;).

It works in the latest dev build of KCT now. I fixed that up last night. EditorTime modifies the UT in the FlightState, which doesn't affect the Planetarium's universal time (which is what KCT reads from). All I had to do was make KCT look at the UT in the FlightState while in the Editor, and the Planetarium everywhere else. It was a little freaky to watch ships being built while in the editor! (for some reason :P)

I did other tests, as well as the one described by you. Taking destroy a satellite in the atmosphere happened to me the bug. I deleted KCT (use CKAN) and I tried again the scene, yet the bug. Install yet KCT, MissionController2 removed, repeat the scene, and the bug goes away.

Now I can go on the satellite KU-Sentinel and everything works back to KSC , the problem is MC2

Thanks for your help

Glad you've determined the source of the error! You might try reporting it on the MC2 thread as well, if you haven't already :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.