magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

9 hours ago, magico13 said:

You need to also install MagiCore. It should already be in the zip file. It goes directly in GameData. Alternatively you can grab it off of CKAN.

 

Fixed! Thank you! :)

Share this post


Link to post
Share on other sites

So I'm not able to recreate any issues with the latest version of KSCSwitcher. I'm going to proceed with the release then.

 

Edit: GitHub and Curse have the update. I need to remake the .netkan file and then I will update SpaceDock.

Edit2: SpaceDock updated. Netkan submitted to CKAN. Should be up on CKAN pending acceptance of the PR.

E3: Most people should be aware of the changes by now, but here's a very brief changelog:

v1.3.3.7 (05/09/16)
 - Update for KSP 1.1.2
 - Now requires MagiCore for math and time parsing
 - Added Part Variables and Module Variables to alter the EffectivePart and ProceduralPart formulas for specific parts/modules
 - Several bug fixes

 

Tagging @NathanKell so he sees.

Edited by magico13

Share this post


Link to post
Share on other sites

@magico13 awesome! :)

Sorry, been AFK since basically the morning here, turns out. Finally got a bit of time and then bed. Woo. But for serious, congrats on the release, and all the excellent stuff you do. :)

Share this post


Link to post
Share on other sites

Sweet. One less mod on the way to realism overhaul :wink:

Thank you for all your hard work on this mod

Share this post


Link to post
Share on other sites

Silly question. I see a part inventory. How do I get things into the part inventory? According to the quick start guide, building using parts in inventory is faster.

Share this post


Link to post
Share on other sites

Seems it was a silly question - is it automatic? Ive discovered that the craft Ive recovered seem to have had their parts added to the part inventory without any interaction from me.

Share this post


Link to post
Share on other sites
15 minutes ago, blu3wolf said:

Seems it was a silly question - is it automatic? Ive discovered that the craft Ive recovered seem to have had their parts added to the part inventory without any interaction from me.

 

Yep, its automatic. Those parts will be automaticly used in your next constructions (if they match) to speed up the building process and reduce costs... unless of course you deactivate inventory use...

 

Share this post


Link to post
Share on other sites

Thanks for the update :) I'm getting an unusual bug, where any time I open any other building than VAB or SPH the KCT config menu pops up and I have to close it/save

Share this post


Link to post
Share on other sites
2 hours ago, kendoka15 said:

Thanks for the update :) I'm getting an unusual bug, where any time I open any other building than VAB or SPH the KCT config menu pops up and I have to close it/save

Are build times disabled (or is the mod disabled)? That code is supposed to make the main window close if it's open when you enter those buildings but it's doing really weird and annoying things despite what I tell it to do. I might disable it if I can't fix it.

Share this post


Link to post
Share on other sites
Just now, magico13 said:

Are build times disabled (or is the mod disabled)? That code is supposed to make the main window close if it's open when you enter those buildings but it's doing really weird and annoying things despite what I tell it to do. I might disable it if I can't fix it.

Everything is disabled except simulations and of course the mod itself

Share this post


Link to post
Share on other sites
Just now, kendoka15 said:

Everything is disabled except simulations and of course the mod itself

Ok thanks, that should make testing pretty easy. On a scale from 1 to 10, how annoying is it? I can put out a dev build for you later with that disabled if it's really annoying.

Share this post


Link to post
Share on other sites
22 hours ago, magico13 said:

Ok thanks, that should make testing pretty easy. On a scale from 1 to 10, how annoying is it? I can put out a dev build for you later with that disabled if it's really annoying.

I'd say about 5, that would be very appreciated but please don't rush :D

Edited by kendoka15

Share this post


Link to post
Share on other sites

When you edit a built craft and add parts from the inventory, the build time decreases but the number of parts in the inventory doesn't.    Clean install, no mods other than KCT 1.3.3.7 and MagiCore.

Edited by StevenV

Share this post


Link to post
Share on other sites

Just a small request, don't remove the simulation out of KCT, i read somewhere that was planned to leave it to KRASH, but KRASH is alot heavier and KCT Simulator is really light and fill the role at least imho. :)

Ty for the great mod.

Share this post


Link to post
Share on other sites

For some reason KRASH drops my FPS to something like 12, so yeah, my vote for KCT simulation. Don't know what benefits in using KRASH anyway... 

Share this post


Link to post
Share on other sites
On 5/15/2016 at 3:39 PM, evileye.x said:

For some reason KRASH drops my FPS to something like 12, so yeah, my vote for KCT simulation. Don't know what benefits in using KRASH anyway... 

I agree.  KRASH does the same thing to me.  I gave it a shot but had to go back to KCT sim, which works beautifully.  It would be nice to leave it as an optional mode.

Share this post


Link to post
Share on other sites
On 11/05/2016 at 8:58 PM, kendoka15 said:

I'd say about 5, that would be very appreciated but please don't rush :D

I'm having the exact same bug, same mod configuration as Kendoka15.

I have to say it feels rather annoying to me ! Not game breaking, but on a scale of 0/10, 10 being annoying to the point I don't want to use the mod, i'd say 7.42/10, calculated with a very precise annoy'o'meter.

Thanks for the mod anyway :)

Edited by deprav

Share this post


Link to post
Share on other sites

Hi, magico13.

During some discussion a new suggestion was born that might fit and extend the functionality of your mod:

A possibility to pre-order some parts and it's up to you (player) to decide which ones. For example, you know that you'll need 5 LV-45 engines, 10 fuel tanks and 100 batteries in the nearest future, so you can order them to be produced while you are on a long mission. As the stock is made up, the next several rockets will be built faster because some of their parts were already produced. The downside of it is that if you research better batteries your stock becomes obsolete and you can choose to forget about the old parts or use them instead of newer and more efficient ones until your stock is emptied and thus save time and funds. That adds more flexibility to the production and should force you to plan accurately research and production as a whole process.

Edited by Ser

Share this post


Link to post
Share on other sites
On 15/05/2016 at 10:39 PM, evileye.x said:

For some reason KRASH drops my FPS to something like 12, so yeah, my vote for KCT simulation. Don't know what benefits in using KRASH anyway... 

Looks like that low FPS bug in KRASH has been fixed.

Share this post


Link to post
Share on other sites

I'm enjoying this mod, good stuff!

One issue: How come I can't introduce a second build rate - neither VAB nor SPH. I'm stuck on one rocket at a time. It is not giving me the +0.05 button for a second rate. Actually had the same problem when I tried it once back in 1.0.5.

See screenshot: dropbox pic

What am I missing?

Setup: RSS RO RP0 + a bunch

Also see this guy at 2:40 https://www.youtube.com/watch?v=lZIoxi9uiPA

Share this post


Link to post
Share on other sites
16 hours ago, deprav said:

I'm having the exact same bug, same mod configuration as Kendoka15.

I have to say it feels rather annoying to me ! Not game breaking, but on a scale of 0/10, 10 being annoying to the point I don't want to use the mod, i'd say 7.42/10, calculated with a very precise annoy'o'meter.

Thanks for the mod anyway :)

I'll try to get you guys a build tonight that fixes it. I've been distracted by Stellaris :P

On 5/15/2016 at 1:16 PM, RickKermen said:

Just a small request, don't remove the simulation out of KCT, i read somewhere that was planned to leave it to KRASH, but KRASH is alot heavier and KCT Simulator is really light and fill the role at least imho. :)

Ty for the great mod.

I'll be keeping the KCT simulations in for as long as they aren't a pain to maintain. If an update causes them to stop working and requires a bunch of work to fix it, then I'll probably not spend the time on it. As long as they work I may as well leave them in as an option.

On 5/11/2016 at 3:15 PM, StevenV said:

When you edit a built craft and add parts from the inventory, the build time decreases but the number of parts in the inventory doesn't.    Clean install, no mods other than KCT 1.3.3.7 and MagiCore.

I'll take a look at this when I get a chance. Only new parts are supposed to be pulled from the inventory. The whole edit mechanic is a bit buggy and I want to spend some time on it in the near future.

49 minutes ago, Gannaf said:

I'm enjoying this mod, good stuff!

One issue: How come I can't introduce a second build rate - neither VAB nor SPH. I'm stuck on one rocket at a time. It is not giving me the +0.05 button for a second rate. Actually had the same problem when I tried it once back in 1.0.5.

See screenshot: dropbox pic

What am I missing?

Setup: RSS RO RP0 + a bunch

Also see this guy at 2:40 https://www.youtube.com/watch?v=lZIoxi9uiPA

If you're using RP-0 it's probably a restriction caused by the RP-0 Preset. Looking at the Preset it seems like RP-0 restricts it to one rate per VAB level. Edit: Also, it's a known bug that in new games the second rate appears when it shouldn't. If you put a point into it, it gets lost until you upgrade the VAB.

Edited by magico13

Share this post


Link to post
Share on other sites
On 5/19/2016 at 1:49 PM, magico13 said:

I'll try to get you guys a build tonight that fixes it. I've been distracted by Stellaris :P

::jealous::  Huge fan of Paradox games.  I'm waiting for a bit after recently dropping a gazillion dollars on Europa Universalis dlcs (and then subsequently getting burned out on it).

SUCH PRETTY MAPS. :P  

Share this post


Link to post
Share on other sites

So I have a slight problem @magico13. When I try a simulation it locks control and camera control and the staging indicator stays purple.  Here's the log.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.