magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

Sorry for my ignorance but what do i do with this?

On 6/24/2016 at 4:18 AM, bos said:

Simple recompile works okay for me (and I'm continuing my ro/rp-0 career in 1.1.3!). I did check in the dll binary so you could grab it from my github if you don't have the tools to rebuild it yourself:

https://github.com/j-bos/KCT/tree/master/Kerbal_Construction_Time/bin/Release

 

 

Share this post


Link to post
Share on other sites
5 hours ago, C3nturionsparta said:

Sorry for my ignorance but what do i do with this?

 

Download the DLL and replace the one in KCT's folder.

Share this post


Link to post
Share on other sites

Uploaded my own recompile. Only did brief testing of it. No real changes, just a recompile. Came home to find my motherboard in my desktop totally dead (it was having issues before I left), replaced that only to now get blue screens. I'm probably going to do a full wipe of the OS and start over. I've got about a week before I start my new job and am trying to decide how best to utilize that time. A few of the options are KSP modding related and include rewriting KCT, fixing up my other mods, or working on some new mod ideas for fun.

Share this post


Link to post
Share on other sites
1 hour ago, magico13 said:

Uploaded my own recompile. Only did brief testing of it. No real changes, just a recompile. Came home to find my motherboard in my desktop totally dead (it was having issues before I left), replaced that only to now get blue screens. I'm probably going to do a full wipe of the OS and start over. I've got about a week before I start my new job and am trying to decide how best to utilize that time. A few of the options are KSP modding related and include rewriting KCT, fixing up my other mods, or working on some new mod ideas for fun.

Rats... I'm sorry to hear that. I've had problems with my PC before but nothing as bad as that. Best of luck with your new job though! Anything that you can do on updating your mods would be a wonderful treat but take care of your real world complications first :)

Share this post


Link to post
Share on other sites

Is there some way to manually fix KCT saved data? I updated my RP-0 save that uses KCT today and it's 'forgotten' the pad upgrade I did. It's also showing the 48 tech upgrades but doesn't show them as being used (the rate is 0.1). I had a ship in building too when I last played but when I warp to the date it finishes it just vanished from the queue.

Share this post


Link to post
Share on other sites

It looks like KCT has disappeared from CKAN since it was updated.

Edited by Awass

Share this post


Link to post
Share on other sites

Hi, weird problem here: my Tracking Station won't upgrade.  It is now in Level 1 (this is an RSS/RO/RP-0 install).  So I click to upgrade and it says that it is already being upgraded.  But that doesn't appear in KCT at all and after two years of building rockets and researching techs, it still continues with the same message.  I made the mistake of using KSCSwitcher and it scrambled a lot of KCT items.  So I removed the Switcher, (it also deleted my VAB and Research upgrades, but after I purchased an upgrade point they magically returned!) but now am in a no-mans-land on upgrading the tracking station.  Is there something I can edit to reset the flag that it is being upgraded? Then I could try it anew, hopefully that will work. 

Edit: It seems it was waiting for a launch pad upgrade that I didn't ask for, but must have had to do with KSCSwitcher.  Once that bogus launch pad upgrade finished (it didn't actually upgrade anything, just went through the motions as if it would), it did in fact place the tracking station in the queue and did upgrade it.  Moral: Don't use KSCSwitcher for now because it does not support KSP 1.1.2 (waiting for all the mods to catch up to 1.1.3 before I update KSP).  Hopefully, all is back to normal with KCT... I don't think it was at fault here at all.

Edited by Parallax59
update

Share this post


Link to post
Share on other sites

I think I also have an issue with KSCSwitcher in my RSS/RO/RP-0 career. I've been launching from Kourou from the start and switched to Plesetsk to test a polar orbit launch. The thing is that simulation does not work properly: I don't have any control from the keyboard (WASDEQ, staging, etc.). Only mouse clicks on parts work. I don't know if non-simulation flights work though.

Switched back to Kourou - simulation is still not working. Reloaded the game, seems to be working again. Started a simulation in orbit - again no keyboard controls. It started to happen just today, for no apparent reason.

Edited by Ixenzo

Share this post


Link to post
Share on other sites

So, I can't control my rocket at all, can't turn on SAS or stage it in any way. I can't even turn on my engine by right clicking it.

Share this post


Link to post
Share on other sites
32 minutes ago, Antonio432 said:

So, I can't control my rocket at all, can't turn on SAS or stage it in any way. I can't even turn on my engine by right clicking it.

and that helps exactly 0.  We need more info:

OS, version of KCT, any other mods installed, log file, etc

Right now, nothing can be done.

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

and that helps exactly 0.  We need more info:

OS, version of KCT, any other mods installed, log file, etc

Right now, nothing can be done.

Sorry, I often just post the issue I have without logs in hope somene already knows what is going on. My log can be found here: https://drive.google.com/file/d/0B8o3_OKhDQ4aQzBqMWFaVVE3cWM/view?usp=sharing 

Also i am getting a purple light on the staging circle thing, ALt + L won't unlock staging.

Edited by Antonio432

Share this post


Link to post
Share on other sites

@Antonio432, are you sure it's not RemoteTech? Its official released version doesn't support 1.1.3, so it may be this (but they have a working dev version in github).

Edited by garwel

Share this post


Link to post
Share on other sites
45 minutes ago, garwel said:

@Antonio432, are you sure it's not RemoteTech? Its official released version doesn't support 1.1.3, so it may be this (but they have a working dev version in github).

Yes, it is remotetech, it even says it in the debug menu.   just got confused since I saw a few people have this exact issue.

Share this post


Link to post
Share on other sites
On 3/22/2016 at 9:16 PM, magico13 said:

I think KCT doesn't work correctly with KK at the moment. I'll see if I can get it fixed for 1.1 but no promises. Compatibility with other mods isn't top priority at the moment. Once May rolls around, definitely, but before then KSP isn't something I've got time to think about too much.

As the changelogs mention KK support back in July 2015 and this was said in March 2016 and I don't see any mention of KK since then in either the changelogs or thread, I'm wondering how compatibility looks between KCT and KK currently? I'm currently using SSRSS and they have a KK config so that I could launch from different sites around Earth, so I just wanted to check here first to make sure that KK is compatible.

Edited by CoriW

Share this post


Link to post
Share on other sites
On 06/27/2016 at 0:10 AM, Awass said:

It looks like KCT has disappeared from CKAN since it was updated.

CKAN bug, mods dont show at all if they are up to date, but a dependency isnt. If the mod and all dependencies are out of date, it shows (just not under the Compatible filter). If the mod and dependencies are all up to date, it shows under Compatible. Its just when the mod is up to date, and the dependencies not, that they hide completely.

Share this post


Link to post
Share on other sites
1 hour ago, CoriW said:

As the changelogs mention KK support back in July 2015 and this was said in March 2016 and I don't see any mention of KK since then in either the changelogs or thread, I'm wondering how compatibility looks between KCT and KK currently? I'm currently using SSRSS and they have a KK config so that I could launch from different sites around Earth, so I just wanted to check here first to make sure that KK is compatible.

I've notice that if I select the different launchpad in the VAB, I have no problems launching from it. but if I build the craft and then change the launchsite via the UI, most often I get a crash.

Share this post


Link to post
Share on other sites
1 hour ago, Adriayn said:

I've notice that if I select the different launchpad in the VAB, I have no problems launching from it. but if I build the craft and then change the launchsite via the UI, most often I get a crash.

Alright so then it's somewhat compatible. I just have to switch before launch? Does the pad reconditioning work on a per site basis? Also if you have multiple assembly bays (or whatever you want to call them, multiple rockets building at once) can you switch to one launchpad and start one vessel building, then switch to another launchpad and start another one building and have them launch from the correct launchpads? (Sorry for all the questions I'm just trying to get an idea of exactly how compatible KCT and KK are.)

Share this post


Link to post
Share on other sites
14 hours ago, CoriW said:

Alright so then it's somewhat compatible. I just have to switch before launch? Does the pad reconditioning work on a per site basis? Also if you have multiple assembly bays (or whatever you want to call them, multiple rockets building at once) can you switch to one launchpad and start one vessel building, then switch to another launchpad and start another one building and have them launch from the correct launchpads? (Sorry for all the questions I'm just trying to get an idea of exactly how compatible KCT and KK are.)

Prior to 1.1 it was working fine. Post 1.1 you have to physically load the launchsite before you can launch from there without issue (through a simulation, for example). So if you're going to launch from a site that isn't the KSC, you have to run a simulation there first each time you start the game.

Reconditioning is on a per-pad basis, so each launchsite has its own reconditioning and rollout.

Edited by magico13

Share this post


Link to post
Share on other sites

Other than that though it sounds like it works fine?

Share this post


Link to post
Share on other sites
1 minute ago, Avera9eJoe said:

Other than that though it sounds like it works fine?

Last I checked, which was in 1.1.2, and was somewhat brief. I'd recommend testing it in a testing save prior to using it in a real game.

Share this post


Link to post
Share on other sites

Does the 1.1.2 compatible version of MagiCore work with KSP 1.1.3 also? This would appear to be why KCT isnt displaying in CKAN presently.

Share this post


Link to post
Share on other sites

Is this mod on CKAN? I was trying to find it but seemed to be unable but wasn't sure if I was missing it. Thanks!

Share this post


Link to post
Share on other sites
On 02/07/2016 at 9:53 AM, blu3wolf said:

Does the 1.1.2 compatible version of MagiCore work with KSP 1.1.3 also? This would appear to be why KCT isnt displaying in CKAN presently.

13 minutes ago, Bandus said:

Is this mod on CKAN? I was trying to find it but seemed to be unable but wasn't sure if I was missing it. Thanks!


Due to a bug in the CKAN client, updated mods compatible with the current version, which have dependencies that have not updated to the current version, are not displayed. KCT is dependent on MagiCore, which has not updated.

KCT is on CKAN, but cannot be installed without installing (through command line) first its (outdated) dependencies (just MagiCore), then itself. If MagiCore gets a new release on GitHub, KCT will show up in CKAN again.

Share this post


Link to post
Share on other sites

Annnnd serves me right for using the quick reply on page 1 for the first time ever! Thank you and apologies for not reading first! 

@blu3wolf - I don't suppose you know the command line to install MagiCore? I tried ckan.exe install magicore=1.1.1 but that didn't seem to work. I've never used CKAN via command line before.

Edited by Bandus

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.