KospY

[1.1.2] Kerbal Attachment System (KAS) 0.5.8

Recommended Posts

So I upgraded KIS and added KAS and now all my rockets are gone at the tracking station. I have no more vessels in orbit and I also now have to re-purchase every part from the R&D building. What's up with this?

Edit: Luckily I had a quicksave I could revert to and everything's there except for vessels that used some of the old KAS parts.

Share this post


Link to post
Share on other sites
Edit: Luckily I had a quicksave I could revert to and everything's there except for vessels that used some of the old KAS parts.

Grab the old KAS parts download from the curse page. That will give you the legacy parts so all of your vessels will load.

Share this post


Link to post
Share on other sites

Am I the only one here absolutely thrilled that the KIS containers work with Tweakscale?

~Steve

Share this post


Link to post
Share on other sites
Am I the only one here absolutely thrilled that the KIS containers work with Tweakscale?

~Steve

I love it. All my rockets now have a tiny package of struts & pipes "just in case" :P

However its kinda annoying that the small box can be tweakscaled but the mounting bracket can't lol. Had to use a tiny resized radial attachment point to mount the thing where i wanted it.

Share this post


Link to post
Share on other sites

Will this be available on ckan soon?

Share this post


Link to post
Share on other sites

Anyone else noticed you can no longer detach grappling hooks via the right-click menu? I don't know if this is a new change or if it's been in KAS for a while, but I certainly remember it used to be possible. The detach action group is still present though.

Share this post


Link to post
Share on other sites
Anyone else noticed you can no longer detach grappling hooks via the right-click menu? I don't know if this is a new change or if it's been in KAS for a while, but I certainly remember it used to be possible. The detach action group is still present though.

I had that same problem with removing a harpoon from a kerbal, apparently you need a screwdriver or maybe a wrench to remove it.

Share this post


Link to post
Share on other sites

SPACE WHALES.

Star Citizen has invaded KSP.

Share this post


Link to post
Share on other sites

Congrats on the release.

Look forward to the new innovations and your support through all these versions is admirable.

Share this post


Link to post
Share on other sites

I'm glad you are keeping up with KAS but it keeps crashing for me while loading. At first I thought it was the cPort1 since that's where module manager was crashing so I deleted it. Then it crashed on the other parts. I can't get it to work. What version of module manager are you using? I'm using 2.6.3

Share this post


Link to post
Share on other sites
I'm glad you are keeping up with KAS but it keeps crashing for me while loading. At first I thought it was the cPort1 since that's where module manager was crashing so I deleted it. Then it crashed on the other parts. I can't get it to work. What version of module manager are you using? I'm using 2.6.3

Hitting the same issue. I'm using 2.6.3, same issue with 2.6.2. Freezing on Cport, but doesn't directly crash.

Share this post


Link to post
Share on other sites

I don't get the crashing - I can't even load the game. The loading screen pauses on the KAS parts, and does not progress. To confirm this, I left the game loading for over an hour - no dice.

Share this post


Link to post
Share on other sites
I'm glad you are keeping up with KAS but it keeps crashing for me while loading. At first I thought it was the cPort1 since that's where module manager was crashing so I deleted it. Then it crashed on the other parts. I can't get it to work. What version of module manager are you using? I'm using 2.6.3

Sorry to double post, waiting on Moderator: updating KIS to the latest version AND using mod manager 2.6.3 seems to resolve it.

Share this post


Link to post
Share on other sites

I can confirm this. I was experimenting with removing and updating random mods, and updating KIS seems to have resolved it.

Share this post


Link to post
Share on other sites
Just checking in to say that Jeb and Bill were testing the harpoons and they seem perfectly safe to me.

http://i.imgur.com/GtDtt2W.jpg

EDIT:

As a suggestion, it would be really cool if "harpooned" parts would start leaking/losing whatever resources they hold over time...

This would not only add a cool thing to deal with/feature (you can't just go around harpooning your stuff as please) but it would also be... quite interesting... for people with Life Support mods... with things like... let's say......... oxygen.

I should have guessed that it would end like this :D

Leaking part is a nice idea, however I'm not sure everyone will like it. How to inform player that the part start leaking/losing resources ?

I can show a message in game everytime a part is "harpooned", but it's maybe too much.

Also, only part with resource will be affected. It will be still possible to harpoon other parts without any constraint.

I rather prefer to wait squad to implement some kind of "health bar" for parts, or maybe create an interface with dang-it

Is there any way at all to have KAS without KIS? I've got two parts in my Infernal Robotics pack that use the Magnet and Grappling hook modules from KAS, and do not need the rest of the functionality. Can't there be a way to have certain functionality just be disabled if KIS is missing rather than have it preventing all parts from loading as it currently does?

Not at the beginning. Currently I use KIS to move old KAS container content to KIS container (KAS container module is rewrited to do that).

Sure I can move this KAS container module to KIS, but I'm some people will lost their old KAS container content if I do this, because they forgot to install KIS.

So I wait 1-2 month before removing KIS reference from KAS, to let the time to people to migrate.

Is there any way to tweak the force that the winches eject with, for longer-range harpooning? I looked in the part.cfg files for them and nothing jumped out at me, so to speak. It seems difficult to get them to retract cleanly with the harpoons or other implements still attached, too, which can make reusing them kind of a hassle.

Ejection force can be tweaked with the "ejectForce" parameter in the winch part.cfg.

Anyone else noticed you can no longer detach grappling hooks via the right-click menu? I don't know if this is a new change or if it's been in KAS for a while, but I certainly remember it used to be possible. The detach action group is still present though.

I will take a look.

I'm glad you are keeping up with KAS but it keeps crashing for me while loading. At first I thought it was the cPort1 since that's where module manager was crashing so I deleted it. Then it crashed on the other parts. I can't get it to work. What version of module manager are you using? I'm using 2.6.3

Did you install the latest version of KIS (1.1.4) ?

Edited by KospY

Share this post


Link to post
Share on other sites

I love the Harpoon part, and also the reworked models and textures, they feel more stockalike.

Also...

ZCwzkh6.jpg

I love the space pirate look of that pic :P

Share this post


Link to post
Share on other sites

Hey, I really like the mod and the possibilities it brings, I just have a problem with the eject-functionality. Every time I right click on a winch and choose "eject", the only thing that happens is that the indicator for the attached part, the harpoon for instance, changes from "Locked" to "Plugged (Docked)" and the cable length jumps to 50m. I apologize if that problem has already been talked about or if I am just too stupid to do it correctly, but I searched the thread and couldn't find anything. Thanks in advance.

Share this post


Link to post
Share on other sites
I'm glad you are keeping up with KAS but it keeps crashing for me while loading. At first I thought it was the cPort1 since that's where module manager was crashing so I deleted it. Then it crashed on the other parts. I can't get it to work. What version of module manager are you using? I'm using 2.6.3

Same here. Has anyone figured out how to fix it? :(

Share this post


Link to post
Share on other sites

"KIS is now required for KAS (at least version 1.1.4). "

Does it solve your problem?

Edited by brienne

Share this post


Link to post
Share on other sites

I have a problem with the round winch (the one radially attachable)...cant preconnect any KAS part (Hook,Harpoon,ConnectorPort) in VAB/SPH.also if i connect another object with that winch that has a connector port and try to disconnect it later (after scene change or quickload) the Object got merged with my Ship which has the winch?

Edited by Zopzodeman

Share this post


Link to post
Share on other sites

There was an attach rules mishap, the fix is a few posts back, or redownload 5.1 he uploaded a fix.

If you don't want to here is the fix.

I made a mistake on the attach rules...

It's not "attachRules = 1,1,0,0,0" but "attachRules = 1,1,1,0,0" in the part.cfg of the winch.

I will upload a fix.

Edited by Woodstar

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.