KospY

[1.1.2] Kerbal Attachment System (KAS) 0.5.8

Recommended Posts

Some fun with Porkjet Jack-O'-Lantern mod and KIS :)

cnScSSk.png

I'm a little bit late, but whatever, it's scary enough for halloween.

Also, it's a helmet, and it show another feature of KIS : support of head and/or helmet removal if needed. Usefull for custom helmet !

Edited by KospY

Share this post


Link to post
Share on other sites
I'm having a small problem with KAS.

I have an SSTO plane on the runway and a refuelling truck.

I grab the KAS pipe from the truck and walk to the plane with it strapped to the kerbal's back as normal, I then right click on the KAS attachment point on the plane and select Plug(Docked) so I can refuel the plane. At this point, both the plane and the truck disappear and I am left with just the kerbal standing there. When I return to the space centre or tracking station, both the plane and the truck are gone.

The plane and truck don't disappear if I use Plug(Undocked) but then obviously I cannot do a fuel transfer.

Any ideas ?

thanks

Can anyone help me with this ?

thanks

Share this post


Link to post
Share on other sites
Can anyone help me with this ?

thanks

Never encountered that issue... Are you on KSP x64 ? Did you try without mods (only KSP and KAS) ? Also, can you send your log file ?

Hi, I think I found an interesting bug with how KAS interacts with Stock Rebalance Project and by extension, zero-mass but physically significant items.

KSP 0.25 (x86), Windows 8.1, KAS 0.4.9. Only other mods installed are Stock Rebalance Project (to make items zero mass) and Module Manager (to actually make items zero mass).

PROBLEM: KAS doesn't grab these items and instead, they explode after a few seconds, but are still available to grab out of containers.. and explode and then grab etc etc.. This is probably because Stock Rebalance Project makes these particular science sensors (thermometer, barometer, gravioli and seismic detector) not weigh anything i.e. their mass is 0. I haven't tested with other items but I think they'll behave the same way.

LOGS: If I grab such an item from a container, the following appears in the output_log:

NullReferenceException: Object reference not set to an instance of an object
at Vessel.findLocalCenterOfMass () [0x00000] in <filename unknown>:0

at ProtoVessel..ctor (.Vessel VesselRef) [0x00000] in <filename unknown>:0

at Vessel.Initialize (Boolean fromShipAssembly) [0x00000] in <filename unknown>:0

at KAS.KAS_Shared.CreatePart (.AvailablePart avPart, Vector3 position, Quaternion rotation, .Part flagFromPart) [0x00000] in <filename unknown>:0

at KAS.KAS_Shared.CreatePart (System.String partname, Vector3 position, Quaternion rotation, .Part flagFromPart) [0x00000] in <filename unknown>:0

at KAS.KASModuleContainer.Take (KAS.PartContent avPart) [0x00000] in <filename unknown>:0

at KAS.KASModuleContainer.GuiContentList (System.Collections.Generic.Dictionary`2 contentsList, ShowButton showButton, KAS.KASModuleContainer actionContainer, Vector2 scrollPos, Boolean showTotal, KAS.KASModuleContainer destContainer, Single scrollHeight) [0x00000] in <filename unknown>:0

at KAS.KASModuleContainer.GuiMainWindow (Int32 windowID) [0x00000] in <filename unknown>:0

at UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID) [0x00000] in <filename unknown>:0

at UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style) [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Vessel.findLocalCenterOfMass () [0x00000] in <filename unknown>:0

at OrbitDriver.TrackRigidbody (.CelestialBody refBody) [0x00000] in <filename unknown>:0

at OrbitDriver.Start () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Vessel.findWorldCenterOfMass () [0x00000] in <filename unknown>:0

at Vessel.FixedUpdate () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Body::setMass: mass is 0.000000, should be positive!

(Filename: ..\..\Physics\src\NpActor.cpp Line: 175)

Full output_log.txt is here. Please ignore the HandleD3DDeviceLost entries at the end, they are just because I Alt+Tabbed away from KSP to write this post.

http://youtu.be/A_X0ds6CJ5A

Look forward to the fix :)

Thanks for this detailed report, I will try to fix this for the next version.

Edited by KospY

Share this post


Link to post
Share on other sites
I mean, one that can take items from containers and attatch things etc in the same way an EVA kerbal can?

Would that be possible or could only kerbals do that?

I study the possibility of an arm to handle content of larger container. However, as KAS is first designed to give some goal to eva, don't expect something small and light, going eva will always be the cheapest and easy way to move (small) parts/items around.

Share this post


Link to post
Share on other sites
I study the possibility of an arm to handle content of larger container. However, as KAS is first designed to give some goal to eva, don't expect something small and light, going eva will always be the cheapest and easy way to move (small) parts/items around.

Like a loader?

Share this post


Link to post
Share on other sites

Please put a link to be ablevto download fro github. I keep getting error trying the curse download. I read tge comments on curse andcsaw I'm not alone in this problem. Ty.

Share this post


Link to post
Share on other sites
Can anyone help me with this ?

thanks

I had something very similar... You're using the pipe endpoint on the fuelling truck right? And the radial attachment port on the plane?

Swap the radial attachment point for another pipe end point, then instead of plug (docked) and plug (undocked) you'll get Link. Then you can transfer fuel etc and they're effectively docked, but it doesn't fritz out.

That's what I found anyway...

Share this post


Link to post
Share on other sites

Question: I have a vertical winch with a magnet attached. I can connect to my payload find by extending and activating the magnet. However, when I retract it all the way, the magnet shuts off and drops the payload without the payload "docking" to the crane. Essentially, the only way I can get the magnet to work is to not retract all the way and have the payload swinging all over the place as I move the crane. Solution?

Share this post


Link to post
Share on other sites
Never encountered that issue... Are you on KSP x64 ? Did you try without mods (only KSP and KAS) ? Also, can you send your log file ?
Found the problem...

DarkMultiPlayer was detecting the docking state as invalid and removing both vessels. Just updated DMP to v1.6.1 (NOV 1st release) and now KAS works perfectly. :)

Share this post


Link to post
Share on other sites

Anyway rotation of grabbed parts can be implemented cause some parts don't make sense when attached the way they were before grabbed?

Share this post


Link to post
Share on other sites
Anyway rotation of grabbed parts can be implemented cause some parts don't make sense when attached the way they were before grabbed?
b and n rotate

Alt B/N will flip it turnways.

Share this post


Link to post
Share on other sites

Good news guys. I'm working on a new concept for the 0.5 radial winch and here a wip i'm sharing with you.

DbhQ8Ii.png

This single new part will replace and merge 3 curent placeholders : the vertical stack winch, vertical radial winch and horizontal radial winch.

You will be able to attach it radially and rotate it the way you want but it also has attachement nodes (on the top and the back) if you want to use it inline or with struts.

I hope you'll enjoy this new (and way more versatile) design :)

Edited by winn75

Share this post


Link to post
Share on other sites

It's great. ;)

And it fits better with the Stock design than the old one :D

Share this post


Link to post
Share on other sites

Wow. That looks fantastic. Way to make the winch way more versatile. What are the dims? does 0.5 refer to the height, or the area of the circular base?

Share this post


Link to post
Share on other sites
What are the dims? does 0.5 refer to the height, or the area of the circular base?

This is a very small model. Here, 0.5 is the height of the cylinder, not the diameter (aproximatly the same size as current radial winches).

If you look at the attachement nodes, there are squares with an X shaped pattern. Thoses square will fit the size of the stock small struts.

Share this post


Link to post
Share on other sites

First, when I downloaded this mod it was one of the first mods I installed and with the 4.9 version only I am getting some missing sound bits, all though they are in the folder: hookBay Store, Container Open, Container Close, bipwrong.

Its not really a functional issue as I don't really need to hear things in space but every time I load onto the launch pad the error text is splattered across my screen.

Does anyone know how to fix this?

I installed 4.7 and it fixed the sound issue but I could not open my containers. I'm not sure where the conflict lies.

Second, and this is just me being overtly needy, I got this mod because I though you could make some high powered cranes with some horizontal traveling winches. My plan was to build an in space Space Hanger to build massive things I could not get off of Kerbal. I though that the Horizontal Radial Mount Winch would travel along a Modular Girder Segment and I would send up parts to assemble in the Container A and B. Then I could send up any amount of resources I needed for a ship. Alas, this is not the case. I am limited to a select few parts to send up and the Horizontal Radial Mount Winch does not travel along the Modular Girder Segment. I am working on stabilizing the "docked" sections of my Research vessel because, Docked bits don't have a whole lot of to structural stability to them.

Well that's my story. Any suggestions on my problem would be great. As for my preconceptions and my wishes, they are just suggestion from a fan.

Share this post


Link to post
Share on other sites

Not sure about the first problem but I think for the second one you would be best using a mod called infernal robotics which adds moving parts which you could use to move the winch.

Share this post


Link to post
Share on other sites

Not sure if anyone thought of this, but besides the fuel pipe with controls furl flow like docks normally do... has anyone though of a fuel duct? Basically, instead of transferring fuel, like the normal fuel duct, it shares the fuel with more than one tank, passively.

The down side being you need to consciously know WHICH WAY the duct is going, when you attach them (the first linked end should signify the direction the duct's fuel flow is going).

Share this post


Link to post
Share on other sites

how can i make a part a container? whats the code? How can I also make a custom part attatchable ?

Share this post


Link to post
Share on other sites

Hi

I tried to add the grab-function to the docking ports from NearFutureConstruction and the stock docking ports.

Works well for normal sized docking port and Jr. docking port.

The senior docking port and those from NFC attache in the wrong way with the docking node pointing to the surface I try to attach them to.

This is not a big deal for the senior docking port because rotating it using Alt+b/n works fine.

The ports from NFC rotate too but they rotate around the docking node causing them to get attached from the inside making them useless (or at least lock very crappy)

I already tried to add

attachNodeName = bottom

(found this anywhere on the internet) but this did not change anything.

Did I missunderstood the use of "attachNodeName"? If so how to use it properly? Do I have to know the exact name of the node? If so how to get them for stock parts or parts from other mods?

Whats the right way to set the attachment direction?

Share this post


Link to post
Share on other sites

Is there some form or angle snap or way to make parts only attach to nodes? I love this mod but I hate how I can never get parts to attach on straight which is a problem when I'm trying to retrofit space debris into usable ships and their center of mass gets put way off.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.