KospY

[1.1.2] Kerbal Attachment System (KAS) 0.5.8

Recommended Posts

With Infernal Robotics and Hullcam VDS, I'm already working on an auto-reloading rotating harpoon minigun with camera aiming :D

Oh, god, I really should go back to... you know... space exploration.

Its a rapid fire lifeline system for when you put a rocket through the hab ring of your space station :P

Saftey First... Destructive auxiliary function included.

Share this post


Link to post
Share on other sites

I'm confused, how does attaching struts on EVA work now? I can only place the beginning end of the strut.

Edited by chrt

Share this post


Link to post
Share on other sites
I'm confused, how does attaching struty on EVA work now? I can only place the beginning end of the strut.

Place two of those, then use their menu option "link"

Share this post


Link to post
Share on other sites
Just checking in to say that Jeb and Bill were testing the harpoons and they seem perfectly safe to me.

http://i.imgur.com/GtDtt2W.jpg

EDIT:

As a suggestion, it would be really cool if "harpooned" parts would start leaking/losing whatever resources they hold over time...

This would not only add a cool thing to deal with/feature (you can't just go around harpooning your stuff as please) but it would also be... quite interesting... for people with Life Support mods... with things like... let's say......... oxygen.

OH EMMM GEEE............ LMAO guess what im going to go do!!!! thats awesome!!!

Share this post


Link to post
Share on other sites

So pumped that this is back! lost a nice element of the game... But oddly enough, the game loading hangs on KAS_Cport1 when loading tyhe MM files. Anyone have this issue? i am not out of ram, so ill see if a mod messed with the works.

Share this post


Link to post
Share on other sites
So pumped that this is back! lost a nice element of the game... But oddly enough, the game loading hangs on KAS_Cport1 when loading tyhe MM files. Anyone have this issue? i am not out of ram, so ill see if a mod messed with the works.

rtfm - you need the latest KIS.

Share this post


Link to post
Share on other sites
Place two of those, then use their menu option "link"

Nothing happens if I right-click them once attached, and they have no menu actions in the inventory.

Share this post


Link to post
Share on other sites

Kospy, I think there are those here who would give you the soul of their first-born in thanks for the update.

Share this post


Link to post
Share on other sites
0.5.0

  • Integrated KIS (KIS is now mandatory)

Is there any way at all to have KAS without KIS? I've got two parts in my Infernal Robotics pack that use the Magnet and Grappling hook modules from KAS, and do not need the rest of the functionality. Can't there be a way to have certain functionality just be disabled if KIS is missing rather than have it preventing all parts from loading as it currently does?

Share this post


Link to post
Share on other sites
Is there any way at all to have KAS without KIS? I've got two parts in my Infernal Robotics pack that use the Magnet and Grappling hook modules from KAS, and do not need the rest of the functionality. Can't there be a way to have certain functionality just be disabled if KIS is missing rather than have it preventing all parts from loading as it currently does?

What does it matter? KIS has almost no parts so it has a negligible memory footprint.

Share this post


Link to post
Share on other sites
So pumped that this is back! lost a nice element of the game... But oddly enough, the game loading hangs on KAS_Cport1 when loading tyhe MM files. Anyone have this issue? i am not out of ram, so ill see if a mod messed with the works.

I am also experiencing this.

Share this post


Link to post
Share on other sites
So pumped that this is back! lost a nice element of the game... But oddly enough, the game loading hangs on KAS_Cport1 when loading tyhe MM files. Anyone have this issue? i am not out of ram, so ill see if a mod messed with the works.

Same problem here. I tried to delete the OLD KAS and use only 1.0.2 version and this did not fix the issue it seems. I updated to KIS 1.1.4. I was using KIS 1.1.2.

Lesson Learned: BOTH KIS and KAS were updated today. Download them boths, install them boths.

Edited by Haze-Zero

Share this post


Link to post
Share on other sites

Quick noobish question maybe: How do i put a part at the end ofa winch so that i can use i as a skycrane ?

I'm trying a winch/conector/part all through the nodes but the part won't attach to the connector. Is the node there some sort of placeholder?

Share this post


Link to post
Share on other sites
Same problem here. The fix is to delete the old KAS and install from the 1.0.2 version only. If you are worried about it messing up your save file or something, you can delete the KAS_Cport1.cfg inside the KAS > Parts > cPort1 folder. The part.cfg is the only .cfg file you need inside the folder.

I am loading from a fresh install.

Share this post


Link to post
Share on other sites

Had the infinite loading issue too until I updated KIS to 1.1.4. Turns out that CKAN is stuck on 1.1.2. And KAS isn't even there yet, I hope it's updated soon.

Share this post


Link to post
Share on other sites
Had the infinite loading issue too until I updated KIS to 1.1.4. Turns out that CKAN is stuck on 1.1.2. And KAS isn't even there yet, I hope it's updated soon.

Lmao refresh your list.

CKAN was updated at least 30min ago before I got home and was able to try updating. Both KAS & KIS are there and current version.

Share this post


Link to post
Share on other sites

Is there any way to tweak the force that the winches eject with, for longer-range harpooning? I looked in the part.cfg files for them and nothing jumped out at me, so to speak. It seems difficult to get them to retract cleanly with the harpoons or other implements still attached, too, which can make reusing them kind of a hassle.

Share this post


Link to post
Share on other sites

Noobee here found a few booboos...

1: in VAB when I choose the explosives from the menu, in the description it says "error corrupted data" right after "timer set to" .. (I would post a picture screen capture, but i can't figure out how to do this here :-()

2: also in VAB, while constructing ships, my mouse wheel stops responding a few time after i play with the containers menus... happened twice so far... only way to fix is to completely shut the game down...

PS, i'm not complaining... just pointing out stuff... I really like this mod... thanks to Devs..

Share this post


Link to post
Share on other sites

Would there be any chance to have a plugin which adds KAS-EVA ability to parts or pods? I wanna roleplaying with some EVA-pod, saying construction vehicle, to build something.

Share this post


Link to post
Share on other sites

So I upgraded KIS and added KAS and now all my rockets are gone at the tracking station. I have no more vessels in orbit and I also now have to re-purchase every part from the R&D building. What's up with this?

Share this post


Link to post
Share on other sites
Just checking in to say that Jeb and Bill were testing the harpoons and they seem perfectly safe to me.

http://i.imgur.com/GtDtt2W.jpg

EDIT:

As a suggestion, it would be really cool if "harpooned" parts would start leaking/losing whatever resources they hold over time...

This would not only add a cool thing to deal with/feature (you can't just go around harpooning your stuff as please) but it would also be... quite interesting... for people with Life Support mods... with things like... let's say......... oxygen.

Wow... this picture! You made me lol.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.