KospY

[1.1.2] Kerbal Attachment System (KAS) 0.5.8

Recommended Posts

Boo on KIS being required. I hate having 30+ extra parts just so i can connect my buildings together

Thumbs down.

KIS doesn't have 30+ parts, it has 6 parts.

Share this post


Link to post
Share on other sites
For what is probably the billionth time in this thread - if no parts are being loaded or KSP freezes upon loading, you must install the latest KIS (1.1.4 or later, as of 16/05/15).

Sorry, I only read the last 3 pages or so. Regardless, thank you for answering my question. I will give this a shot.

- - - Updated - - -

This worked, thank you.

Share this post


Link to post
Share on other sites

Thumbs down for the KIS implementation and making Attach / Detach parts so overcomplicated now.

I really liked the simplicity of KAS in 0.90, especially for Connector Ports. Just EVA, grab a Connector Port and put it where it was needed.

Now I have to bring a Tool and my Kerbal MUST BE Engineer. That increases the mission overhead, because you have to add another Capsule for the extra seat.

But thats still ok ... Immersion / Realism and so. But what really freaks me out right now: Even after reading the manual I still can't figure it out how to ATTACH a previously detached Connector Port to another part.

- I have a Wrench / Screwdriver.

- I EVA.

- I right click on my ENGINEER Kerbal -> Inventory

- Right click the Screwdriver -> EQUIP.

- Go to the Connector Port.

- Hold G, "Detach CC-R2 Connector port", Click.

- Port drops to the ground.

- Hold G, Drag & Drop to my Inventory.

- Walk to the Part where it should be attached to.

- Drag & Drop the Connector Port from my Inventory towards the part.

- Release mouse button.

- A text overlay appears "Drop (srfAttach)"

- Click ...

- ... and instead of being attached, the part drops to the ground over and over and over and over again ... No matter what I try, I can't figure it out how to attach the part either back to my ship or to another part.

Seriously ... ?!?! :huh:

Share this post


Link to post
Share on other sites
Try holding X to attach..

:blush:

Ok, thanks. That works. It is even described in the manual. Just looked it up again. Don't know how I missed that!

... But still, thumbs down for making the whole system so overcomplicated now.

Share this post


Link to post
Share on other sites
Boo on KIS being required. I hate having 30+ extra parts just so i can connect my buildings together

Thumbs down.

Boo on making a negative post without knowing what you are talking about. KIS is basically just the mechanics for attaching etc with like 6 parts (as noted). And KAS is just parts. So KIS + KAS is pretty much the same as just KAS used to be.

Share this post


Link to post
Share on other sites

Having used KAS since pretty much when it came out in 2013, my opinion is that the increased complexity adds, not detracts, from the gameplay. Much as the new aero model doesn't let you get away with the monstrosities of the past, the new KAS+KIS combo doesn't allow you to get away with certain unrealistic behavior.

It's great that the ability is restricted to Engineers. It makes them that much more important. Given that engineers can fly worth a damn, pilots shouldn't be able to assemble stuff worth a damn.

Equipping tools is great and I look forward to KAS+KIS adding a welding tool to (in conjunction with something like the now discontinued UbioZur Welding mod) weld parts together to reduce part count. They could even have a repair tool (in conjunction with DangIt!) to fix failures.

I love how each Kerbal has an inventory and that we can pretty much assemble everything. On my first experiment with KAS+KIS, I was able to put together this perfectly driveable mid-sized rover (http://imgur.com/VFLSuyF) with all parts contained in a single storage unit.

It took a while to get used to pressing X when I wanted to attach something and G when I wanted to grab it, but now it feels quite natural. I like being able to drop something without being forced to attach it. Being able to accurately place objects is great, although it would be nice to have finer XYZ translation control.

So, an enthusiastic thumbs up from me. Meaningful additional complexity is a good thing.

- - - Updated - - -

p.s., Anyone know where I can find a personalized I-beam the same length (or maybe just a little longer) than a 2x2 plate?

Share this post


Link to post
Share on other sites

I've tried out the new "Eject" option, and found it can launch a harpoon about 30 meters. That's pretty reasonable given that we're limited to an 80 meter tether anyway, but I still have a fondness for custom-built harpoons like these ones:

2igj9s0.jpg

Share this post


Link to post
Share on other sites
:blush:

Ok, thanks. That works. It is even described in the manual. Just looked it up again. Don't know how I missed that!

... But still, thumbs down for making the whole system so overcomplicated now.

I kinda agree. I miss the old "grab" system where the kerbal puts it on his back.

Share this post


Link to post
Share on other sites

Loading gets stuck at KAS/Parts/cPort1/part/KAS_CPort1 :/

EDIT: Who put "KIS is now required for KAS (at least version 1.1.4). " there?

Edited by Shurikeeen

Share this post


Link to post
Share on other sites
Loading gets stuck at KAS/Parts/cPort1/part/KAS_CPort1 :/

EDIT: Who put "KIS is now required for KAS (at least version 1.1.4). " there?

i'm getting the same thing stuck on that as well, anyone have any ideas why it would stop loading that part? i can' t see anything obviously out of place in the file. i have KIS been using and have been waiting for KAS to update

EDIT: just saw KIS was updated too >.<

Edited by leoxc

Share this post


Link to post
Share on other sites
i'm getting the same thing stuck on that as well, anyone have any ideas why it would stop loading that part? i can' t see anything obviously out of place in the file. i have KIS been using and have been waiting for KAS to update

Do you have (at least version 1.1.4) ?

Share this post


Link to post
Share on other sites

Hi all, I need help... as soon as I attach 2 ships together in space with pipes... they both go in an controllable wobble / spin..... unsure of where the problem is? I use MJ and have d/l the latest vers of both KIS and KAS... I tried disabling all torques and gimbles.. no changes..

Edited by REGZZZ

Share this post


Link to post
Share on other sites
Hi all, I need help... as soon as I attach 2 ships together in space with pipes... they both go in an controllable wobble / spin..... unsure of where the problem is? I use MJ and have d/l the latest vers of both KIS and KAS... I tried disabling all torques and gimbles.. no changes..

Pipes aren't that stiff. Add some struts to hold them.

That wobbly behavior is something I would expect in real life in that situation.

Share this post


Link to post
Share on other sites
KIS is now required for KAS (at least version 1.1.4)

Any reason they aren't packaged as one mod?

Share this post


Link to post
Share on other sites

Anyone having any luck with the Cport mod problem??? The mod freezing up on loading the game at the cport item?

Share this post


Link to post
Share on other sites
Anyone having any luck with the Cport mod problem??? The mod freezing up on loading the game at the cport item?

Nah, not many people..

Loading gets stuck at KAS/Parts/cPort1/part/KAS_CPort1 :/

EDIT: Who put "KIS is now required for KAS (at least version 1.1.4). " there?

Based on what people have said before, your version of KIS is out of date.
On the main menu, you can go to settings and change the key bindings. But I'm having trouble just STARTING the game because it freezes at KAS/Parts/cPort1/part/KAS_CPort1

- - - Updated - - -

I have Kis aswell, so I dont know what the problem is.

- - - Updated - - -

Never mind, solved it. KIS wasn't updated. :D

Sorry to double post, waiting on Moderator: updating KIS to the latest version AND using mod manager 2.6.3 seems to resolve it.

Share this post


Link to post
Share on other sites

Whoops. I got caught up, I downloaded KIS just the night before so I could have sworn it was 1.1.4, my bad then.

Share this post


Link to post
Share on other sites

Well, I finally got my head wrapped around the voodoo necessary for linking pipes on a Mun base only to have the Kraken attack and wipe it out. I was able to close the window before autosave, so I think it's okay (haven't restarted yet). Before I begin the slow process of elimination, does anyone know off the top of your head, if there is a definite incompatibility between KAS/KIS and any of the more popular mods? I'm running just about all the "must-have's". Just looking for a starting point at the moment.

Thanks! Oh, and yes, I'm using the latest versions.

Share this post


Link to post
Share on other sites

With all of these people ITS TOO DIFFICULT! OH LAWD I HAVE TO USE 2 seperate keys for now i have options!

i can image being a modmaker might not be very rewarding.

so i set out to use your mod and leave something worthwhile,

KospY, you have the thanks of me and bill, and we made you this: we call it kospY relay. its the first part of a lunar base so jeb can stream crashes from mun-side in HD (and for when i want to use surface drones for i dont have satellites orbiting the mun to relay the signal.)

(for the observant, yes it i ankered the craft with lines for i accidentally parked on a steep incline...XD)

v64ZTTc.jpg

the entire thing on the left is built from the ground up from parts taken in containers (and the containers were dropped off the return vessel and slid off beautifully XD)

(everything above the lamps took off, so just the drone, a lot of panels and batteries, and the antenna/dish stayed for now)

EDIT:

ah yes i remember, i do have one question: in the old kas you could grab a line and drag it to a connector port, i tried grabbing the line but no way was found. i tried bringing the port to the line (it made a sort of gui overlay as if this was suposed to be done) but i could only get it to work with the harpoon)

pipes worked perfectly though. am i missing something in how to grab an un-attached-wich line?

Edited by Thahat
pic did not work/spelling..

Share this post


Link to post
Share on other sites
Well, I finally got my head wrapped around the voodoo necessary for linking pipes on a Mun base only to have the Kraken attack and wipe it out. I was able to close the window before autosave, so I think it's okay (haven't restarted yet). Before I begin the slow process of elimination, does anyone know off the top of your head, if there is a definite incompatibility between KAS/KIS and any of the more popular mods? I'm running just about all the "must-have's". Just looking for a starting point at the moment.

Thanks! Oh, and yes, I'm using the latest versions.

Yes It's called KSP. Kraken attacks eating bases, connected via KAS pipes or other things have been a thing since alpha. Once i have surface bases I pretty much quicksave before switching to them as a habit.

Share this post


Link to post
Share on other sites

The game freezes during loading (I have KIS installed)

[LOG 13:52:20.252] PartLoader: Compiling Part 'KAS/Parts/cPort1/part/KAS_CPort1'
[EXC 13:52:20.264] TypeLoadException: Could not load type 'MessageInfo'.
UnityEngine.GameObject:AddComponent(Type)
Part:AddModule(String)
Part:AddModule(ConfigNode)
PartLoader:ParsePart(UrlConfig, ConfigNode)
:MoveNext()
[ERR 13:52:20.267] Error looking up signature for method KASModulePort.OnKISAction

[EXC 13:52:20.268] TypeLoadException: Could not load type 'MessageInfo'.
UnityEngine.GameObject:AddComponent(Type)
Part:AddModule(String)
Part:AddModule(ConfigNode)
PartLoader:ParsePart(UrlConfig, ConfigNode)
:MoveNext()
[EXC 13:52:20.273] TypeLoadException: Could not load type 'MessageInfo'.
System.Reflection.MonoMethodInfo.GetMethodInfo (IntPtr handle)
System.Reflection.MonoMethod.GetPseudoCustomAttributes ()
System.MonoCustomAttrs.GetPseudoCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType)
System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)
System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)
System.Reflection.MonoMethod.GetCustomAttributes (System.Type attributeType, Boolean inherit)
BaseEventList.ReflectActions (System.Object part)
BaseEventList..ctor (.Part part, .PartModule module)
PartModule.ModularSetup ()
PartModule.Awake ()
UnityEngine.GameObject:AddComponent(Type)
Part:AddModule(String)
Part:AddModule(ConfigNode)
PartLoader:ParsePart(UrlConfig, ConfigNode)
:MoveNext()
[EXC 13:52:20.285] NullReferenceException: Object reference not set to an instance of an object
PartModule.Load (.ConfigNode node)
Part.AddModule (.ConfigNode node)
PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node)
PartLoader+.MoveNext ()
[EXC 13:52:20.294] NullReferenceException: Object reference not set to an instance of an object
PartLoader.GetDatabaseConfig (.Part p)
PartLoader.GetDatabaseConfig (.Part p, System.String nodeName)
DragCubeSystem.LoadDragCubes (.Part p)
Part+.MoveNext ()
[LOG 13:52:30.553] IR: [ServoController] destroy

Share this post


Link to post
Share on other sites
Yes It's called KSP. Kraken attacks eating bases, connected via KAS pipes or other things have been a thing since alpha. Once i have surface bases I pretty much quicksave before switching to them as a habit.

Yeah, after further testing, I'm pretty much settled on it being our favorite random "feature". I loaded it up and have since added other components to the base without any trouble.

With all of these people ITS TOO DIFFICULT! OH LAWD I HAVE TO USE 2 seperate keys for now i have options!

i can image being a modmaker might not be very rewarding.

It's called being used to a thing and then adapting to a change. People will comment until they figure it out. No need to be a sanctimonious ass about it.

Edited by jonrd463

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.