KospY

[1.1.2] Kerbal Attachment System (KAS) 0.5.8

Recommended Posts

One of two worst bugs in KSP - other is "Sudden thermal kaboom".

speaking of which...

i cannot use cubic octagonal struts. they explode immediately both on launch or load... anyone else, or just me?

Share this post


Link to post
Share on other sites
speaking of which...

i cannot use cubic octagonal struts. they explode immediately both on launch or load... anyone else, or just me?

everyone dude. everyone.

Share this post


Link to post
Share on other sites

not me though. I still can use cubics.

using stock bug fix modules from claw.

Share this post


Link to post
Share on other sites

I just retrieved a lone 'Thud' engine as part of a contract using KIS to attach the CC-R2 connector port, and then using the KAS winch to reel it into the cargo bay.

If I were you, I'd check to see if it works in 1.0.5 before asking for an update. Which in my case, it does.

Share this post


Link to post
Share on other sites

Anything I need to worry about when it comes to 1.0.5? Besides KSP complaining about version difference?

Share this post


Link to post
Share on other sites
Anything I need to worry about when it comes to 1.0.5? Besides KSP complaining about version difference?

I could be horrendously wrong, but as KAS adds its stuff to parts through module manager, I think it should be ok? :P This is about as weak an 'it should be ok' as possible I don't really know :D

Share this post


Link to post
Share on other sites

If you guys want to ignore the warning till Kospy has a chance to update KAS / KIS. You could just delete the AVC and .version files in the plugins folder. Then it wont bark at you. (But do this under the understanding that KAS and KIS are currently for 1.0.4 (but it seems to work just fine in 1.0.5)

Share this post


Link to post
Share on other sites

Ok, it seams KAS & KIS have not been updated, however, when KSP starts, KSP-AVC says theres a new version on both mods. I check the change log in AVC and it says it was updated to 1.05. Also it says version is 0.5.5 for KAS and 1.2.3 for KIS. The download links give me the previous versions! :S

So, is AVC giving me false info or is there something else?

Share this post


Link to post
Share on other sites
Ok, it seams KAS & KIS have not been updated, however, when KSP starts, KSP-AVC says theres a new version on both mods. I check the change log in AVC and it says it was updated to 1.05. Also it says version is 0.5.5 for KAS and 1.2.3 for KIS. The download links give me the previous versions! :S

So, is AVC giving me false info or is there something else?

I just updated KAS to KSP 1.0.5, so this is normal :)

You can now download KAS 0.5.5 from the main page.

Share this post


Link to post
Share on other sites

lol ok

I guess I spoke too soon! :)

Thx and best of luck.

Share this post


Link to post
Share on other sites

Does anybody know how long it usually takes till an update is shown in CKAN?

So far CKAN still reports 0.5.4 for 1.0.4 to be the latest version for KAS/KIS.

Share this post


Link to post
Share on other sites
Does anybody know how long it usually takes till an update is shown in CKAN?

So far CKAN still reports 0.5.4 for 1.0.4 to be the latest version for KAS/KIS.

Anywhere from a couple hours to a couple days. If you want to speed it along, you should post in the ckan thread.

Share this post


Link to post
Share on other sites

ANyone know if the 1.0.5 version of KAS works with the 64-bit community hack?

Edited by Talavar

Share this post


Link to post
Share on other sites
ANyone know if the 1.0.5 version of KAS works with the 64-bit community hack?
Works great. And you can also grab "KSP Unfixer" removes the x64 block on mods like FAR.

------just remember, no dev will appreciate you going around there block. Don't abuse the devs-------

Share this post


Link to post
Share on other sites

I'm a forum newbie trying to build a station on a class E asteroid. Rather than relying on the Advanced Grabber, I figured I'd try using KAS... winching the first segment into place and then adding the KAS struts. I've encountered a snag after initially creating a docked connection and realizing there's no asteroid-ship collision that way. I switched the mode to undocked and now I can't control the winch as it thinks it's retracted. I've tried removing the winch to inventory and reattaching without success. I've also restarted KSP. Is there a way to reset it in flight? It's a 200 km trip to the parts store! I think I read that a KAS guide was forthcoming, but I haven't found it yet. Any suggestions are appreciated. I'm running 1.0.4 for the time being.

2NfHBYZ.png

Share this post


Link to post
Share on other sites
[quote name='MachTurtle']I'm a forum newbie trying to build a station on a class E asteroid. Rather than relying on the Advanced Grabber, I figured I'd try using KAS... winching the first segment into place and then adding the KAS struts. I've encountered a snag after initially creating a docked connection and realizing there's no asteroid-ship collision that way. I switched the mode to undocked and now I can't control the winch as it thinks it's retracted. I've tried removing the winch to inventory and reattaching without success. I've also restarted KSP. Is there a way to reset it in flight? It's a 200 km trip to the parts store! I think I read that a KAS guide was forthcoming, but I haven't found it yet. Any suggestions are appreciated. I'm running 1.0.4 for the time being.

[URL]http://i.imgur.com/2NfHBYZ.png[/URL][/QUOTE]I don't tend to play career mode much but, I do recall that a kas winch connection usually won't survive a save / load in flight. I know that's not the answer you were looking for, but I hope someone can prove me wrong.

-------

Kospy, I wanted to suggest a part. I've built several scale looking planes to attempt a mid air refuel. I've successfully hit a scoop the size of a Kerbal's head, towed by a KAS winch. With a part the size of a large antenna. The issue I run into is I use mechjeb to pilot the tanker as well as the chase plane. Using heading and altitude hold thus allowing me to make very tiny course and speed adjustments to hit such a small target. But using a "docking port" (It's a scaled down / modified version). It merges the two ships into one, confusing the heck out of mechjeb, and once the smoke clears no more planes.

Now at the end of my very long story. What I'm asking is. Would it be possible to make a part that functions just like a docking port. Magnet / connection, but doesn't actually "dock" the two ships together? Basically like the trailer hitch Lo-fi was working on. Having two ships held together by a solid connection but leave the two vessels separated? And in turn possibly make use of Dmagic1's EVA Transfer to actually refuel the chase plane. Edited by V8jester

Share this post


Link to post
Share on other sites
I'm working on building a small crawler crane, and was wondering if anyone had suggestions for a pulley mechanism? To make a couple of the connections required to hold up the boom, a turn in the cable is required, which is rather difficult as is (and is very annoying to set up, since you have to run a kerbal around quite a lot to connect the various points). Does anyone have any suggestions?

Share this post


Link to post
Share on other sites
I'm wondering: can you plug the plugs without the use of a Kerbal? I'm trying to build an ARM like the ISS and that one can move around on plugs placed around the different modules of ISS.
So i'm wondering if you can connect the plugs when you are only operating the arm?

Or do i have to use the rke kanadarm's docking parts just for this... Edited by MK3424

Share this post


Link to post
Share on other sites

Any reason why this mod shows each part in the VAB 8 times? Also why do the winches no longer have a cable you can pull out and attach stuff? You cant even do the retract,eject,release. The modules were completely left out of the code. They are just static parts that dont have a contex menu. The old KAS worked and not understanding why you went this route.

Share this post


Link to post
Share on other sites
7 hours ago, FlarpingFlipperFlapper said:

Any reason why this mod shows each part in the VAB 8 times? Also why do the winches no longer have a cable you can pull out and attach stuff? You cant even do the retract,eject,release. The modules were completely left out of the code. They are just static parts that dont have a contex menu. The old KAS worked and not understanding why you went this route.

Now that I have picked up my jaw and put my eyeballs back in after reading ... this ... so, you are basically thinking that KospY intentionally removed all functionality from this mod and that everyone posting in this thread after the last release (11th Nov) must be using some older version since noone else is reporting what you are seeing?

With that of my chest: Delete your KSP folder completely (or move it somewhere else), get a new copy from where you bought the game, get a fresh download from KAS and try again after making sure you installed the mod correctly, maybe something went wrong here. If it works again, start adding updated (1.0.5 compatible) versions of other mods (if you used any) and observe if anything breaks to check for incompatibilities between mods and KAS.

Edited by KerbMav

Share this post


Link to post
Share on other sites

Hi KospY,

I have a question about creating KAS pipes. I have some parts in Pathfinder that have multiple KASModuleStrut modules, and I noticed that when they are first connected together, they look fine, but when I re-load the ship, I get duplicate pipe connections. It seems, for example, that port 1 on the Saddle (a part bolted to the ground) connects to port 1 on the Trailer Hitch (a part on the Buffalo) even though I actually had connected port 2 on the Saddle to port 2 on the Trailer Hitch. I don't know if this is a bug or not since I've created multi-port parts and that's not something I've seen done in KAS. Below is an illustration showing what I mean:

mMnavqV.png

I wonder if it could be related to the names of the transforms. In my parts, I standardized the transform names, so that on the Saddle and Trailer Hitch, the names of the ports are defined like so:

	MODULE
	{
		name = KASModuleStrut 
		nodeTransform = plugPort1
		type = PipeSize1
		maxLenght = 50
		maxAngle = 100
		breakForce = 600
		allowDock = true
		allowPumpFuel = true
		hasCollider = false
		tubeScale = 0.15
		jointScale = 0.15
		textureTiling = 1
		tubeSrcType = Joined
		tubeTgtType = Joined
		evaStrutPos = (0.05, 0.059, -0.21)
		evaStrutRot = (0.0, 0.0, 0.0)
		tubeTexPath = KAS/Textures/pipe
	}

	MODULE
	{
		name = KASModuleStrut 
		nodeTransform = plugPort2
		type = PipeSize1
		maxLenght = 50
		maxAngle = 100
		breakForce = 600
		allowDock = true
		allowPumpFuel = true
		hasCollider = false
		tubeScale = 0.15
		jointScale = 0.15
		textureTiling = 1
		tubeSrcType = Joined
		tubeTgtType = Joined
		evaStrutPos = (0.05, 0.059, -0.21)
		evaStrutRot = (0.0, 0.0, 0.0)
		tubeTexPath = KAS/Textures/pipe
	}

Is there a way to set up my configuration so that I won't get the duplicate pipe connections upon load?

Thanks for making such a great mod, and thanks for your help. :)

Edited by Angel-125

Share this post


Link to post
Share on other sites

So, is the only real way to attach heavy things in space multiple kerbals? I wanted to upgrade my space station to use 3.75m crew tubes and docking clamps, but I have a feeling it's going to be impossible to keep 8 kerbals in position because of the stupid ladder sliding bug. 

If it's not... could I present the idea of removing the weight requirement for parts attached to a winch, or an electromagnet mounted on a robotic arm?

Share this post


Link to post
Share on other sites
4 hours ago, CajunInABox said:

So, is the only real way to attach heavy things in space multiple kerbals? I wanted to upgrade my space station to use 3.75m crew tubes and docking clamps, but I have a feeling it's going to be impossible to keep 8 kerbals in position because of the stupid ladder sliding bug. 

If it's not... could I present the idea of removing the weight requirement for parts attached to a winch, or an electromagnet mounted on a robotic arm?

You can edit the settings.cfg in the KIS subdirectory. Look for the following part:

	EvaPickup
	{
		grabKey = g	
		attachKey = h	
		allowPartAttach = false
		allowStaticAttach = false
		allowSnapAttach = false
		maxDistance = 3
		grabMaxMass = 1
		dropSndPath = KIS/Sounds/drop
		attachPartSndPath = KIS/Sounds/attachPart
		detachPartSndPath = KIS/Sounds/detachPart
		attachStaticSndPath= KIS/Sounds/attachStatic
		detachStaticSndPath = KIS/Sounds/detachStatic
		draggedIconResolution = 64
	}

If you change the grabMaxMass you can increase the weight they can "lift". By changing the maxDistance, they have bigger reach. :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.