bac9

[1.2.2] B9 Aerospace | Release 6.2.1 (Old Thread)

Recommended Posts

Many users running KSP 0.90 have reported HX parts falling off/simultaneously exploding.

From how it seems, the node toggle module included in Virgin Kalactic mod is the culprit. The module is used for larger(size 2+) HX modules to allow turning on/off of certain nodes. Parts utilizing that module would simply fall off upon loading and/or start to wobble abruptly, resulting in explosions. It's possible to simply add a lot of struts to forcibly duct tape it to its place, but when you fly it, it explodes after reaching a certain distance(around 6000 meters) from KSC.

I'm not a programmer myself, so I can't tell the reason why this happens, let alone debugging it. Nevertheless, the workaround I found is to remove said module data from the affected part cfg files.

A. Go to {Your KSP Directory}\GameData\B9_Aerospace\Parts\Structure_HX

B. Open the part cfg files. Simple Wordpad will do.

C. Find the following lines and delete them. Size 2 and 3 modules and adapters have these.

MODULE

{

name = NodeToggle

}

D. Rinse and repeat for every part cfg files with above lines. There are about ten of them.

Share this post


Link to post
Share on other sites

Hello.

I've seen several people here saying that the HX parts for the giant ship builds are just falling through each other and exploding on the launchpad. Why have no one even replied to this yet? I'm having the same issue and I've been fiddeling with this for a few days now with no luck at all. Reinstalled, removed all other mods (did not remove the ones that comes with the b9 package), updated firespitter dll manually, etc. Nothing works.

Can someone please look into this?

Share this post


Link to post
Share on other sites

Best off posting a pic and the logs for them to look at they will respond better if you provide all the needed information for them they will then be in a better position to diagnose the problem

Share this post


Link to post
Share on other sites
Only thing that lets it down is the squad cockpit everything else matches nicely, also using the bahmuto adjustable landing gear which has some great features. There isnt a snazzy cockpit to replace this squad one lurking in the B9 crafting room gathering dust that would have a nice teardrop canopy on it is there

Polecatz's D12 expansion for B9 has a re-textured version of the cockpit to match B9 parts.

Share this post


Link to post
Share on other sites
Many users running KSP 0.90 have reported HX parts falling off/simultaneously exploding.

From how it seems, the node toggle module included in Virgin Kalactic mod is the culprit. The module is used for larger(size 2+) HX modules to allow turning on/off of certain nodes. Parts utilizing that module would simply fall off upon loading and/or start to wobble abruptly, resulting in explosions. It's possible to simply add a lot of struts to forcibly duct tape it to its place, but when you fly it, it explodes after reaching a certain distance(around 6000 meters) from KSC.

I'm not a programmer myself, so I can't tell the reason why this happens, let alone debugging it. Nevertheless, the workaround I found is to remove said module data from the affected part cfg files.

A. Go to {Your KSP Directory}\GameData\B9_Aerospace\Parts\Structure_HX

B. Open the part cfg files. Simple Wordpad will do.

C. Find the following lines and delete them. Size 2 and 3 modules and adapters have these.

MODULE

{

name = NodeToggle

}

D. Rinse and repeat for every part cfg files with above lines. There are about ten of them.

This solved the issue for me, using KSP 0.90 and B9 5.2.8. Parts now don't fall through each other. Probably not a good perma-fix but.......I HAVE A SPACE CARRIER NOW! So thanks fucojr!

Share this post


Link to post
Share on other sites

i need to say B9 has "new" Mk3 parts long time a go... but named HL and if i need to decide wich one to use its obvious i will use B9 ones they have cargo ramps and fuel inside and better stile but some stock adapters will be quite usefull within some crasy disines

Great work keep going!

Share this post


Link to post
Share on other sites
Im having a problem with the HX parts staying together, the links give way and the ship crumbles to the ground every launch. Ive tried making a smaller ship with 3-5 parts and same thing happens. Any idears?

You're not the only one, but apparently either nobody has a solution or nobody bothers to answer to this issue.

Share this post


Link to post
Share on other sites
if anyone having issue with no right click of the cockpits in the hangers just delte the mm entries for the cockpits in the mft-rf.cfg and u can right click again. the cockpit entry in it cause a conflict with tac adding ls to cockpits on its own is why

If you decide to delete TACLS MFT/RF support is gone... so just insert "&!TacLifeSupport" to all cockpit-parts in NEEDS[...]

e.g.

// Cockpit Tanks {{{
@PART[HL_Aero_Cockpit]:FOR[B9_Aerospace]:NEEDS[modularFuelTanks|RealFuels&!TacLifeSupport]

Share this post


Link to post
Share on other sites

Just a quick one, for the latest 5.2.8 release, the file 'B9_Aerospace.version' (used for AVC) still says v5.2.6, in the 5.2.8 downloaded zip file.

(cosmetic bug)

Also CKAN is telling me that NEAR/FAR are a requirement for v 5.2.8, is that correct?

Thanks

Share this post


Link to post
Share on other sites
Also CKAN is telling me that NEAR/FAR are a requirement for v 5.2.8, is that correct?

I don't believe anything depends explicitly on FAR or NEAR, however stock aero is officially unsupported by B9 and nothing has been tested with it.

Share this post


Link to post
Share on other sites
Hi guys!

I was super excited about the beta .90 update, downloaded all of my normal mods and installed them and played for a bit before I realized that the b9 parts weren't showing up in my tech tree at all in career mode. I checked the sandbox and all the parts were there. Do ya'll have any recommended things to go to get the parts to appear in the career mode? I've been searching on the forums and google for a good day and half now and haven't had any luck.

Thanks!

What other mods are you using? Is this a new save? How far along are you in the tech tree?

I've re-installed and tried with no extra mods, but normally I'll use MJ, Kerbal Joint Reinforcement, Procedural Fairings and Procedural Wings. The parts from the other mods appear on the tech tree . Brand new save with .90. I got to 4th node completely unlocked on the tech tree. Before on .25 the parts started on the 1st node so has that been reworked so they appear much later than the 4th node?

edit...

Well I feel a bit slow.... all the parts have been moved to later places in the tech tree. Thanks for the help!

Edited by Nocturin

Share this post


Link to post
Share on other sites

Im missing the HL, HX, and wings, I dont even think they are in the .zip for me.

Share this post


Link to post
Share on other sites
I've re-installed and tried with no extra mods, but normally I'll use MJ, Kerbal Joint Reinforcement, Procedural Fairings and Procedural Wings. The parts from the other mods appear on the tech tree . Brand new save with .90. I got to 4th node completely unlocked on the tech tree. Before on .25 the parts started on the 1st node so has that been reworked so they appear much later than the 4th node?

Yeah, they are spreaded out now, scattered along the space plane path.

Im missing the HL, HX, and wings, I dont even think they are in the .zip for me.

Check the B9_Aerospace/Parts folder and see if you find any folder with "HL" or "HX" in its name.

Share this post


Link to post
Share on other sites
I've re-installed and tried with no extra mods, but normally I'll use MJ, Kerbal Joint Reinforcement, Procedural Fairings and Procedural Wings. The parts from the other mods appear on the tech tree . Brand new save with .90. I got to 4th node completely unlocked on the tech tree. Before on .25 the parts started on the 1st node so has that been reworked so they appear much later than the 4th node?

edit...

Well I feel a bit slow.... all the parts have been moved to later places in the tech tree. Thanks for the help!

Hey it happens! Glad to see everything is working ok :)

Share this post


Link to post
Share on other sites

Hey guys, this mod looks great and I would love to try it out, but every time I install it, my staging on the right of the launch screen disappears (though its there in construction) and space will not work for staging. Also, not sure if its important but my stage light on the left bottom hud is blinking purple.

Sorry if any of this is unimportant or if this is a problem thats already been solved, I am a noob to the game and couldn't find anything about this issue.

Share this post


Link to post
Share on other sites
Yeah, they are spreaded out now, scattered along the space plane path.

Check the B9_Aerospace/Parts folder and see if you find any folder with "HL" or "HX" in its name.

STRUCTURE_HX

that is the only HX part, it doesnt come up in game, the HL Parts are apparent, the adapters are the only HL part in the game although, some wings are apparent, but only the heavy wing is in the game.

Share this post


Link to post
Share on other sites

hi!.

I've found that all Landing Gears doesn't work with 0.90 - they are not wheeling and i cannot interact with them at all.

Edited by Computer.Pers

Share this post


Link to post
Share on other sites
hi!.

I've found that all Landing Gears doesn't work with 0.90 - they are not wheeling and i cannot interact with them at all.

Are the mesh/fuel switchers working? If not, then the firespitter plugin isn't activating. Reinstall the latest version of B9 - the plugin has been updated to work in 0.90.

Share this post


Link to post
Share on other sites
Are the mesh/fuel switchers working? If not, then the firespitter plugin isn't activating. Reinstall the latest version of B9 - the plugin has been updated to work in 0.90.

Thank you for tip about Firespitter, i've removed only it and unzipped only plugin from b9 archive (i've done that before, but with full firespitter installed). now everything working fine.

Share this post


Link to post
Share on other sites
Many users running KSP 0.90 have reported HX parts falling off/simultaneously exploding.

From how it seems, the node toggle module included in Virgin Kalactic mod is the culprit. The module is used for larger(size 2+) HX modules to allow turning on/off of certain nodes. Parts utilizing that module would simply fall off upon loading and/or start to wobble abruptly, resulting in explosions. It's possible to simply add a lot of struts to forcibly duct tape it to its place, but when you fly it, it explodes after reaching a certain distance(around 6000 meters) from KSC.

I'm not a programmer myself, so I can't tell the reason why this happens, let alone debugging it. Nevertheless, the workaround I found is to remove said module data from the affected part cfg files.

A. Go to {Your KSP Directory}\GameData\B9_Aerospace\Parts\Structure_HX

B. Open the part cfg files. Simple Wordpad will do.

C. Find the following lines and delete them. Size 2 and 3 modules and adapters have these.

MODULE

{

name = NodeToggle

}

D. Rinse and repeat for every part cfg files with above lines. There are about ten of them.

Thank you so much for this! We're trying B9 now at a LAN party (DMP) and this was driving one of my friends absolutely crazy - we couldn't figure out why his whole ship kept falling apart. Making this change fixed the issue, so you saved our multiplayer session.

Share this post


Link to post
Share on other sites

I do not recommend using that fix unless you absolutely need HX parts today or tomorrow. The plugin causing the issue is essential for setting up proper centered connections between numerous HX attachment points. MrBlaQ might investigate the issue with it tomorrow if he'll have some free time.

Share this post


Link to post
Share on other sites
does nobody have a fix for the really big parts falling through each other?

Read the two posts above yours...

Share this post


Link to post
Share on other sites

I'm getting a problem about where only the cockpits and random parts and none of the hx parts that i want show up.:mad: any help?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.