Jump to content

[1.2.2] B9 Aerospace | Release 6.2.1 (Old Thread)


bac9
 Share

Recommended Posts

When I try to weld the HX parts together using Ubiozur's welding tool, it appears to break the Firespitter texture/part switcher. Any HX parts with switching capability show that strange white shimmering texture you get from clipping parts inside each other. Also, the welded part contains only one part's worth of fuel. I'm not expecting a fix for this mod, but would appreciate if someone could tell me how to edit the welded part config to remove the texture switch (I can already change the fuel amount easily enough). Simply deleting the MODULE lines doesn't fix the issue.

Crook

Link to comment
Share on other sites

When I try to weld the HX parts together using Ubiozur's welding tool, it appears to break the Firespitter texture/part switcher. Any HX parts with switching capability show that strange white shimmering texture you get from clipping parts inside each other. Also, the welded part contains only one part's worth of fuel. I'm not expecting a fix for this mod, but would appreciate if someone could tell me how to edit the welded part config to remove the texture switch (I can already change the fuel amount easily enough). Simply deleting the MODULE lines doesn't fix the issue.

Crook

It's actually not easy. The firespitter mesh switching relies on all of the variants being present, then disables the ones that aren't active. I don't know of any other way to disable meshes like that. If the welding tool isn't compatible with the firespitter mesh switch you may want to ask the mod author if anything can be done to add in compatibility.

Link to comment
Share on other sites

I'm having a issue with B9 tank parts.

Whenever I try to place any part that has a variant, the textures flicker/flashing all at the same time (for each variant) and the right-click menu doesn't shows up when I try to use it.

At the same time the Info window (that blue part that shows up a list, I forgot the name) doesnot work either, either the right-click menu or the list window.

I've tried to look everywhere and checked my mods for incompatibility problems but no avail. Firespitter is up to date, I tried unninstalling TweakScale and Tweakable Everything but the problem persisted.

Sorry if this turns out to be something simple or was answered before.

Link to comment
Share on other sites

No it isn't.

Sigh. I knew it was going to be something stupid, aparently I can't even notice that the Firespitter has not been updated since .24. I found the updated one, thanks >.<

Link to comment
Share on other sites

It's actually not easy. The firespitter mesh switching relies on all of the variants being present, then disables the ones that aren't active. I don't know of any other way to disable meshes like that. If the welding tool isn't compatible with the firespitter mesh switch you may want to ask the mod author if anything can be done to add in compatibility.

It doesn't seem to be a problem with the firespitter switching as such - welding parts from the firespitter parts pack seems to work fine, although that might be because that's just a texture switch rather than a mesh one, so the game doesn't try to fit several part models into the same space.

I suppose it would be theoretically possible to create a second identical part that only had one model, but I lack the skill to change the .mu files.

Looks like that space carrier will have to wait, unless anyone has any way of only calling one model variant from a .mu file in the config.

Crook

Link to comment
Share on other sites

Hello guys,

Ok, so I've installed KSP .90 on my MAC and it works flawlessly. I then installed FAR, and again no issues. Then when I installed [0.90] B9 Aerospace | Release 5.2.8 (updated 30.12.14) it freezes on loading here:

Screen%20Shot%202015-03-22%20at%201.58.00%20PM_zpszf62bx6y.png

So I decided to uninstall everything and start from scratch. I reinstalled KSP 0.90 and loaded it, it worked fine. Once again I installed the B9 Aerospace Mod and it got stuck in the loading screen, same place. So I thought maybe I had a corrupted B9 Aerospace ZIP file so I downloaded it from a different source, reinstalled both KSP and B9. No luck it always gets stuck right there and it's not like the game screen freezes as those whitty comments still change at their regular frequency.

Here are my system specs and current usage

Screen%20Shot%202015-03-22%20at%202.01.40%20PM_zpsjeztlll8.png

Screen%20Shot%202015-03-22%20at%202.02.13%20PM_zpsbzwhx7yf.png

Any help you guys could give would be fantastic

How can upload the log guys?

Link to comment
Share on other sites

It hangs on loading because it can't find the Monopropellant resource used in that cockpits RCS. Do you know why KSP isn't loading the stock MP resource? Do you have any mods that change it or something? You can upload your output log to Mediafire, Dropbox, Google Drive etc - throw us a link to download it and we can try and help more.

Link to comment
Share on other sites

I would love to upload the log, how? I can upload pictures just fine but Ive never uploaded a .txt file .

output_log.txt is found in the KSP_Data folder, but it's a pretty big file so you should probably use something like Dropbox to upload and share it. If it isn't recognizing the monopropellant resource though, it probably means that your GameData/Squad folder is corrupted and needs to be reinstalled.

Link to comment
Share on other sites

https://pastebin.com/embed_js.php?i=LiHrk2AW

Ok the link works now

Holy cow, I messed that up...

ETR:My sad attempt at linking..lol

- - - Updated - - -

output_log.txt is found in the KSP_Data folder, but it's a pretty big file so you should probably use something like Dropbox to upload and share it. If it isn't recognizing the monopropellant resource though, it probably means that your GameData/Squad folder is corrupted and needs to be reinstalled.

Ok but how do I do that specifically? I've uninstalled and reinstalled both the game and mod three times now.

Edited by AEROMechanic
Link to comment
Share on other sites

Ok but how do I do that specifically? I've uninstalled and reinstalled both the game and mod three times now.

NullReferenceException: Object reference not set to an instance of an object
at ModuleRCS.SetResource (System.String resource) [0x00000] in <filename unknown>:0
at ModuleRCS.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0
at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

Yeah, Monopropellant, for some reason, isn't loading. I guess the ultimate option would be to comment out or remove the ModuleRCS section from the HL cockpit cfg - that would prevent it ever needing to load and so stop the error but then, I guess you're just treating the symptom rather than the cause.. Your call, though.

Link to comment
Share on other sites

NullReferenceException: Object reference not set to an instance of an object
at ModuleRCS.SetResource (System.String resource) [0x00000] in <filename unknown>:0
at ModuleRCS.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0
at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

Yeah, Monopropellant, for some reason, isn't loading. I guess the ultimate option would be to comment out or remove the ModuleRCS section from the HL cockpit cfg - that would prevent it ever needing to load and so stop the error but then, I guess you're just treating the symptom rather than the cause.. Your call, though.

No, I'd prefer to fix the issue if possible. Is it just that the B9 mod Ive got is corrupted and if so is there another source for it?

Link to comment
Share on other sites

Ok guys I got it figured out. When you said the Squad folder is corrupted and needs to be reinstalled I went to the GameData folder to delete the squad folder. Low and behold there wasn't a squad folder! Apparently when I extracted the B9 mod into the KSP folder it wiped it out/over wrote it, whatever you wanna call it.

Anyway I uninstalled everything again, reinstalled KSP and then removed the squad folder before installing the B9 mod. Once I installed the B9 mod I placed the squad folder into the GameData root folder and viola!

I thank you two for your help because without the info you provided me I'd have never got it to work. :-)

Link to comment
Share on other sites

Right, because in OSX folders don't merge, they overwrite. So rather than copying over the GameData folder which comes with a mod you need to copy the contents into the existing GameData folder.

Link to comment
Share on other sites

I know this will sound weird but is there any chance of seeing stock-alike textures instead of/in addition to B9 textures ?

The B9 style is great but now that many new mods are out and stock improved, I find myself mix-and-matching B9 and stock-alike parts far more often and let's say the result is not always that aesthetically pleasing.

From that perspective I think the B9 style no longer makes sense except for the HX, S2 and S2 Wide parts as they have the least probability of being mixed with stock-alike parts.

Of course you could view that from the reverse position and think that all things should be B9-ified and it would suit me fine too, however I think the easiest path would be transitionning B9 to a stock-alike aesthetic.

Am I the only one out there thinking so ?

Link to comment
Share on other sites

I would discard any stock-alike textures, not a fan at all, especially the Mk3 which seems to have been bashed together with random bits of panelling :S. It's nicely done and I admire Porkjet's skills, but that doesn't mean I have to like the end result. You could always do a set of stockalike textures yourself and just swap them in :P

I admit some more detailing wouldn't go amiss with the B9 textures but only in keeping with the overall clean aesthetic.

Link to comment
Share on other sites

I have been having a problem with the B9 pack. I seem to be unable to change the variants of the structural parts, in the right click menu it says that it changes and the visual changes but the CoM doesnt change and the cargo doesnt change.

feGBgtl.jpg

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...