Jump to content

[1.2.2] B9 Aerospace | Release 6.2.1 (Old Thread)


bac9
 Share

Recommended Posts

This mod rocks. I am a "Steam" user. "They" auto updated my game and now this mod is outdated. I don't like to grovel. But, PPPPLLLLLEEEEEEAAAAAASSSSSSSEEEEEE!!!!!!!! get this up to speed. Thank You!:)

[MOD - Removed overly long quote - sumghai]

Got to your Steam library.

Right click Kerbal Space Program, then select properties.

Select the Betas tab

In the "Select the beta you would like to opt into", select "Previous stable release"

Your game will update the the last beta (0.90 as of this time)

You can then copy the KSP sub-directory in your Steam directory to somewhere else to keep as a back up.

After that, you can undo the change in Steam and return to 1.0.2. As a side note, I would also make a copy of that version as a back up.

don't download b9 is outdated mod

Does it come with the Firespitter plugin? That will need to be updated to the current version.

Link to comment
Share on other sites

100% truth. People have an irrational sense of entitlement to free stuff even more than paid stuff for some reason. Try posting a webgame to a site like kongregate, and see what i mean. LOL "hey guys, check out this free thing i made for you." "what the hell is wrong with the characters face?" "this doesn't work on my 15 year old potato computer with onboard video card and 512 mb of ram! FIX IT NOW OR I'LL SPREAD BAD THINGS ABOUT YOU ALL OVER THE INTERNET!" "the color of the button on the quit game menu is a single RGB value off, this triggers my OCD, pls fix!" etc etc. list goes on. After a while you just tune it out and completely ignore the idiots and focus on the meaningful comments/suggestions/bug reports. becomes funny after a while.

100% agree with you. It pushes my buttons too but imagine doing low paid stuff with people pestering the same. It's like the world wants everything given on a silver platter. :/

Link to comment
Share on other sites

This mod rocks. I am a "Steam" user. "They" auto updated my game and now this mod is outdated. I don't like to grovel. But, PPPPLLLLLEEEEEEAAAAAASSSSSSSEEEEEE!!!!!!!! get this up to speed. Thank You!:)

[MOD - Removed overly long quote - sumghai]

Copy your Kerbal Space Program into another folder on the same (or different) drive and mod that one instead. That's what I do.

I already have modded versions of KSP 0.24.2 , KSP 0.25 , KSP 0.90 , and now KSP 1.0.2 in different folders. :wink:

Aswell as an unmoded version of all as backup.

Another option is to rightclick the game launcher in the Steam program -> Properties ->Updates tab, and choose not to auto-update it.

Edited by Jan Gaarni
Link to comment
Share on other sites

Hey

Great mod, again ! Thank you for the awesome work !

It's funny to see all these trolls making it a pain in the ass to update our mods everytime squad is updating their game! Over 6 pages of trolling and there is like 5 relevant comments! All the other are just these silly imperative and irrelevant request and complaint about the update of the mod. I am choosing the funny side, cause on another hand it is the biggest pain in the ass in the world to read throught that garbage to get actual information about the ETA of the mod and the specific incompatibilities. Internet is somehow proving that mankind is hopeless, or at least that freedom of speech should be limited...

Anyways, thank you for not giving up on us and to keep working on this mod!

Link to comment
Share on other sites

Hey

Great mod, again ! Thank you for the awesome work !

It's funny to see all these trolls making it a pain in the ass to update our mods everytime squad is updating their game! Over 6 pages of trolling and there is like 5 relevant comments! All the other are just these silly imperative and irrelevant request and complaint about the update of the mod. I am choosing the funny side, cause on another hand it is the biggest pain in the ass in the world to read throught that garbage to get actual information about the ETA of the mod and the specific incompatibilities. Internet is somehow proving that mankind is hopeless, or at least that freedom of speech should be limited...

Anyways, thank you for not giving up on us and to keep working on this mod!

Don't think freedom of speech should be limited. But perhaps an IQ test before being allowed to write anything on the internet? That would work. =)

Link to comment
Share on other sites

Don't think freedom of speech should be limited. But perhaps an IQ test before being allowed to write anything on the internet? That would work. =)

We used to be able to train them to behave before AOL and before the Internet was commercialized. Back then if you crossed the line or got too stupid your system admin would ban you rather than having to deal with losing their upstream connections so there was some enforced civility. Then came the September That Never Ended and Al Gore handed the Internet over from NSFNet to the private sector. With nothing to stop them, all the trolls have now gotten organized and metastasized.

Now we see that play out over the course of a few months on forums. This forum did used to be better and now you've got all the clever assholes that the moment someone posts a new mod there's an immediate "no pics no downloads!" post tacked onto it. <stuff> like that is corrosive. Like the author didn't spend enough time doing the coding in their free time...

But, yeah, its gotta be a lot of work to fix this mod up for 1.0.x, appreciate all the work...

Link to comment
Share on other sites

or at least that freedom of speech should be limited...

...?!?!? You want to censor freedom of speech because morons annoy you on the internet??

.......Do you perhaps work for Google?

Link to comment
Share on other sites

Would love a couple of simple utility parts (RCS blocks, spotlights) from the B9 pack, but haven't been able to get them working. So far I've converted the textures to dds and tweaked the cfg in a number of ways without much success. ;.;

Link to comment
Share on other sites

yeah dude, it's one of those mods packs which needs an experienced touch. LLL was easy to convert but B9 is another beast entirely. Think we'll have to wait a bit longer for this one.

It always takes about a month or two after a new update to have mods ironed out and stable... but then another update comes soon after and it's time to wait again... like now! :)

EDIT : LLL was certainly NOT easy as I just found out. Switching bottom nodes to -1.0 only scratched the surface. I guess both mods are back in the "wait for it" basket

Edited by Maars
Link to comment
Share on other sites

yeah dude, it's one of those mods packs which needs an experienced touch. LLL was easy to convert but B9 is another beast entirely. Think we'll have to wait a bit longer for this one.

It always takes about a month or two after a new update to have mods ironed out and stable... but then another update comes soon after and it's time to wait again... like now! :)

EDIT : LLL was certainly NOT easy as I just found out. Switching bottom nodes to -1.0 only scratched the surface. I guess both mods are back in the "wait for it" basket

True this needs to be done professionally, personal attempts failed to generate anything else then stress :D for me AND I understand that this takes time also that I should not say this but dammmmmmmmm I can't wait for this to become compatible with new KSP vs

Link to comment
Share on other sites

yeah dude, it's one of those mods packs which needs an experienced touch. LLL was easy to convert but B9 is another beast entirely. Think we'll have to wait a bit longer for this one.

It always takes about a month or two after a new update to have mods ironed out and stable... but then another update comes soon after and it's time to wait again... like now! :)

EDIT : LLL was certainly NOT easy as I just found out. Switching bottom nodes to -1.0 only scratched the surface. I guess both mods are back in the "wait for it" basket

True this needs to be done professionally, personal attempts failed to generate anything else then stress :D for me AND I understand that this takes time also that I should not say this but dammmmmmmmm I can't wait for this to become compatible with new KSP vs

or you do what happend with HGR first you just fix your favorite parts which then inspires someone else to fix just their favorite parts so on and so forth. patching and rebalancing for 1.0.2 isn't difficult it doesn't need modeling, texturing, unity, or coding it is simply tedious config editing.

Link to comment
Share on other sites

Well, I managed to get it to the point where the game doesn't lock up on the loading screen when including the B9 parts, so that's something. Still not showing up on the VAB parts list, unfortunately, so something's being f**ky in spite of my efforts. I suspect it's something very subtle in the png-to-dds conversion.

Link to comment
Share on other sites

or you do what happend with HGR first you just fix your favorite parts which then inspires someone else to fix just their favorite parts so on and so forth. patching and rebalancing for 1.0.2 isn't difficult it doesn't need modeling, texturing, unity, or coding it is simply tedious config editing.

hmmm... good point.

sooo, instead of lurking around, waiting anxiously for my freebie and annoying the mod creator with "hey, is it updated yet?" "hey, when is going to be updated?" "WHY THE F*%! HAVE'NT YOU UPDATED IT YET?!?!? I'LL KILL U, I'LL KILL ALL OF YOU!!!!", me thinks I'll simply take your advice. pick some parts and start fiddling with the configs. If anything works out for me, naturally I'll share asap.

ps- what if they're all my favourite parts? :)

Link to comment
Share on other sites

hmmm... good point.

sooo, instead of lurking around, waiting anxiously for my freebie and annoying the mod creator with "hey, is it updated yet?" "hey, when is going to be updated?" "WHY THE F*%! HAVE'NT YOU UPDATED IT YET?!?!? I'LL KILL U, I'LL KILL ALL OF YOU!!!!", me thinks I'll simply take your advice. pick some parts and start fiddling with the configs. If anything works out for me, naturally I'll share asap.

ps- what if they're all my favourite parts? :)

A few things I discovered that you may find useful. First, obviously, you'll need to convert the png textures to dds, which can be done in paint.net or in KSP4DDS or whatever that utility is called. Second, the way the 0.9 configs reference the relevant .mu files needs to be updated. Previously to this version, from what I've seen, the B9 configs did not include the .mu file extension in the file path; this is something you'll need to add for KSP not to lock up on the loading screen.

Good luck!

Link to comment
Share on other sites

Cheers for that. Im thinking which parts to start with. Since you're after the lights and such, ill pick something else to fiddle with. And yeah, ill need some luck and some tenacity with this :)

Link to comment
Share on other sites

Cheers for that. Im thinking which parts to start with. Since you're after the lights and such, ill pick something else to fiddle with. And yeah, ill need some luck and some tenacity with this :)

I've given up due to hitting the limits of my improvisational ability, so have at whatever you like.

Link to comment
Share on other sites

I haven't even attempted to modify a config since .23ish. But i am a somewhat skilled/knowledgeable 3d modeler and know my way around unity and C# well enough to make my own cheesy armature version of KSP (if i had the time to do all that. LOL), so perhaps its time i learned configs again and started fixing some of my beloved B9 spaceplane parts. Anyone know a good current config guide? or should i just compare old configs to stock and see whats different and go the trial and error approach?

Link to comment
Share on other sites

I haven't even attempted to modify a config since .23ish. But i am a somewhat skilled/knowledgeable 3d modeler and know my way around unity and C# well enough to make my own cheesy armature version of KSP (if i had the time to do all that. LOL), so perhaps its time i learned configs again and started fixing some of my beloved B9 spaceplane parts. Anyone know a good current config guide? or should i just compare old configs to stock and see whats different and go the trial and error approach?

Old configs appear to still work, but in many cases require a slight tweak here and there.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...