Jump to content

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!


Ven
 Share

Recommended Posts

1 hour ago, Timmy1404 said:

Hey,

I'm sorry but I am new in this Forum. Also, english isn't my mothertounge.

 

I read the last few pages but I couldn't find a download link to a "working" version of the mod. Is there even a working one right now (V 1.2)?

I understood it like this: The community is working on the mod together as Ven is inactive right now (?) I found a link to a "VensShared" Dropbox. How do I have to install it? If I put in in the GameData folder it just crashes at the loading screen.

I really like this mod and would love to use it for my next carreer game.

https://github.com/Kerbas-ad-astra/Stock-Revamp/tree/KSP_1.2

This version is mostly working as far as I know. 

Link to comment
Share on other sites

18 minutes ago, Kerbas_ad_astra said:

Since I've updated the legs on both of my installs with no issues, I've pushed the re-revamped legs to my KSP_1.2 branch.

Yay! I'm starting to think that a new thread is in order as it seems that Ven will never come back. 

Link to comment
Share on other sites

He logs in regularly, and he accepted my last batch of changes a few weeks ago.  Since that one had a problem with drag cubes, I don't blame him for waiting until I'm well and truly finished with this set before accepting and releasing it.  (Which I do think it's ready for.)  If he doesn't feel he has the time to keep managing VSR, we'll cross that bridge, but he surely aten't dead.

Link to comment
Share on other sites

On 1/31/2017 at 4:56 PM, Kerbas_ad_astra said:

He logs in regularly, and he accepted my last batch of changes a few weeks ago.  Since that one had a problem with drag cubes, I don't blame him for waiting until I'm well and truly finished with this set before accepting and releasing it.  (Which I do think it's ready for.)  If he doesn't feel he has the time to keep managing VSR, we'll cross that bridge, but he surely aten't dead.

Well, that's good news, at least it seems he may be keeping his eye on it.

Link to comment
Share on other sites

On 1/31/2017 at 1:56 PM, Kerbas_ad_astra said:

He logs in regularly, and he accepted my last batch of changes a few weeks ago.  Since that one had a problem with drag cubes, I don't blame him for waiting until I'm well and truly finished with this set before accepting and releasing it.  (Which I do think it's ready for.)  If he doesn't feel he has the time to keep managing VSR, we'll cross that bridge, but he surely aten't dead.

I think you're giving me too much credit... But whatever, I'll just say that it's the case.

I've accepted your pull requests and made a proper release and shiz.

Link to comment
Share on other sites

Docking port lights shine all the way to an orbited planet for some reason. I tried disabling the lights by commenting out ModuleLight, but for some reason that removes the texture and model - reverting it back to the original model. I copied the code below with my comment slashes in Red. Any idea why this wouldn't work as in most .cfg files? Any advice on how to turn those lights off? 

Thanks

 

@PART[dockingPort3] {
    !mesh = DELETE
    !MODEL {}
    MODEL {
        model = TykoMods/VenUtility/DockingPorts/JrDockingPort
    }
    %rescaleFactor = 1
    //MODULE {
        name = ModuleLight
        lightName = Spotlight
        useAnimationDim = true
        lightBrightenSpeed = .3
        lightDimSpeed = .4
        resourceAmount = 0.04
        animationName = jrdockingport
        useResources = true
    }
    MODULE
    {
       name = ModuleAnimateGeneric
       animationName = jrdockingport_bumper
       isOneShot = false
       startEventGUIName = Deploy bumper
       endEventGUIName = Retract bumper
    }
}

Link to comment
Share on other sites

You commented out just one line, leaving rest of the module config just hanging - the properties themselves probably wouldn't be a problem (as they would be attached to the part itself, though name might cause a conflict), but that closing brace is definitely throwing off the parser. To properly disable light comment out ALL the lines starting from MODULE { and ending with the line with corresponding closing }.

 

  //MODULE {
  //      name = ModuleLight
//        lightName = Spotlight
//        useAnimationDim = true
//        lightBrightenSpeed = .3
//        lightDimSpeed = .4
//        resourceAmount = 0.04
//        animationName = jrdockingport
//        useResources = true
//    }

 

Or just delete the whole thing.

Link to comment
Share on other sites

First off, THANK YOU!!!  Since I came back to 1.2.2 KSP I've been dying for this mod to be updated and to see it pop up on CKAN made my entire day.  I've been playing around with the various parts and ogling how much prettier they are.  The only thing I've found is that the Survey Scanner looks very strange.  The attachment node is sort of floating below the actual scanner and the scanner itself seems kind of stretched perhaps?  I have some images and if I am able to figure out how I will attach them to this post.

Link to comment
Share on other sites

On 2/8/2017 at 1:30 AM, Yaar Podshipnik said:

You commented out just one line, leaving rest of the module config just hanging - the properties themselves probably wouldn't be a problem (as they would be attached to the part itself, though name might cause a conflict), but that closing brace is definitely throwing off the parser. To properly disable light comment out ALL the lines starting from MODULE { and ending with the line with corresponding closing }.

 

  //MODULE {
  //      name = ModuleLight
//        lightName = Spotlight
//        useAnimationDim = true
//        lightBrightenSpeed = .3
//        lightDimSpeed = .4
//        resourceAmount = 0.04
//        animationName = jrdockingport
//        useResources = true
//    }

 

Or just delete the whole thing.

When I commented out as shown above, the default value seems to be that all the lights are on and I can't turn them off. Does that make any sense?

Edited by Tyko
Link to comment
Share on other sites

On 2/9/2017 at 11:27 PM, Tyko said:

When I commented out as shown above, the default value seems to be that all the lights are on and I can't turn them off. Does that make any sense?

 

On 2/10/2017 at 2:22 AM, Yaar Podshipnik said:

Could be something related to how the model is set up, though I can't really help you with that. Parts, animations, and textures are a bit of a black magic to me.

To elaborate on @Yaar Podshipnik 's comment, yes this makes sense. You removed the ModuleLight from the part, which takes away the functionality of the right click options in game. The part model (xxx.mu file) still has a light, so without the corresponding part cfg, it's always on. The only way to fix this issue would be to update the 3D model, it can't be done via a cfg change.

Edited by MalevolentNinja
Link to comment
Share on other sites

Has anyone been able to get the alternative Mk1 Cockpit and the aerobee engines to work? I've tried to give them configs but I've had no luck, and can't see where I'm going wrong.

This is the config I've been trying to use to get the alternative Mk1 cockpit to work

PART
{
	name = Mark1Cockpit-Alt
	module = Part
	author = Ven
	MODEL {
        model = VenStockRevamp/Part Bin/NewParts/Mk1Cockpit-Alt/MK1Cockpit
		scale = 0.98,0.98,0.98
	}
	rescaleFactor = 1.0
	node_stack_bottom = 0.0, -0.3, 0.0, 0.0, -1.0, 0.0, 2
	node_stack_top = 0.0, 1.17, 0.0, 0.0, 1.0, 0.0, 1
	TechRequired = start
	entryCost = 6575
	cost = 2400
	category = Pods
	subcategory = 0
	title = MK1 Cockpit Alt
	manufacturer = Jebediah Kerman's Junkyard and Spacecraft Parts Co
	description = WIP
	attachRules = 1,0,1,1,0
	mass = 1.8
	dragModelType = default
	maximum_drag = 0.20
	minimum_drag = 0.20
	angularDrag = 4
	crashTolerance = 18
	maxTemp = 2000 // = 3400
	vesselType = Ship
	CrewCapacity = 1
	bulkheadProfiles = size1
	tags = capsule cmg control ?eva fly gyro ?iva moment pilot react rocket space stab steer torque (ven (vsr
	MODULE
	{
		name = ModuleCommand
		minimumCrew = 1
	}
	RESOURCE
	{
		name = ElectricCharge
		amount = 100
		maxAmount = 100
	}
	MODULE
	{
		name = ModuleReactionWheel
		PitchTorque = 7
		YawTorque = 7
		RollTorque = 7
		RESOURCE
		{
			name = ElectricCharge
			rate = 0.9
		}
	}
	MODULE
	{
		name = ModuleScienceExperiment
		experimentID = crewReport
		experimentActionName = Crew Report
		resetActionName = Discard Crew Report
		reviewActionName = Review Report
		useStaging = False
		useActionGroups = True
		hideUIwhenUnavailable = True
		rerunnable = True
		xmitDataScalar = 1.0
		usageReqMaskInternal = 5
		usageReqMaskExternal = -1
	}
	MODULE
	{
		name = ModuleScienceContainer
		reviewActionName = Review Stored Data
		storeActionName = Store Experiments
		evaOnlyStorage = True
		storageRange = 1.3
	}
	INTERNAL
	{
		name = mk1CockpitInternal
	}
	RESOURCE
	{
		name = MonoPropellant
		amount = 15
		maxAmount = 15
	}
	MODULE
	{
		name = FlagDecal
		textureQuadName = flagTransform
	}
	MODULE {
		name = ModuleAnimateGeneric
        animationName = MK1Light
        defaultActionGroup = Light
        startEventGUIName = Lights On
        endEventGUIName = Lights Off
    }
	
	MODULE
	{
		name = ModuleDataTransmitter
		antennaType = INTERNAL
		packetInterval = 1.0
		packetSize = 2
		packetResourceCost = 12.0
		requiredResource = ElectricCharge
		antennaPower = 5000
		optimumRange = 2500
		packetFloor = .1
		packetCeiling = 5
	}
}

 

Link to comment
Share on other sites

On 2/12/2017 at 0:51 PM, Chimer4 said:

Has anyone been able to get the alternative Mk1 Cockpit and the aerobee engines to work? I've tried to give them configs but I've had no luck, and can't see where I'm going wrong.

This config works for the cockpit:

But the cockpit is too small in diameter. As if it were a 1.20m part or something. Also the lights don't work.

Cheers,

Link to comment
Share on other sites

Is there a list of the parts that comes with this mod?  I'm really enjoying this mod, but would like an easy reference to view tank size, etc.  

I've been playing kerbal for 2 years and never heard of this mod until this weekend!  I LOVE IT!

Link to comment
Share on other sites

Nice to see this mod up and running, now on to bug hunting.

Is it me or are the engine bottom nodes a bit off? (they could be a bit lower, they clip into other things causing a bit of wobbling when decoupling is engaged)

Link to comment
Share on other sites

I'm experiencing a minor visual bug which seems to be directly caused by this mod (I've tested it with just Ven Stock Part Revamp + MM installed, and compared to completely stock).

When Ven's is installed, I'm getting strange aero visual effects; here are some pictures testing it with the Aeris 4A.

This is the craft in flight with no mods installed:

https://www.dropbox.com/s/zjieebhazci3a4i/20170224180908_1.jpg?dl=0

And this is the craft in flight with just Ven's + MM installed:

https://www.dropbox.com/s/zfqtawb6vll3i4m/20170224180657_1.jpg?dl=0

Ignore velocity and altitude; the odd visual effects start showing up at the same time as the normal visual effects. I'm not sure if this is causing any actual issues beyond the visual effects, but I don't believe it is.

P.S. This is the first time I've tried to include photos in a post, and couldn't figure out how to just add them straight into the post.

 

Edit: Just starting thinking about it, and maybe the issue is being caused by some specific part(s), and I was only testing with the Aeris 4A; I'll go fly a few more craft with Ven's installed and see if I can find anything out.

Edit 2: So after some cursory testing, I'm fairly certain that the external fuel lines are causing the exaggerated effects. I tested the stock Osprey, switched it's Panther out for a Whiplash, traded vertical control surfaces between the Osprey and the Aeris 4A, and a few other similar re-combinations, and the only time the exaggerated effects show up is when the external fuel lines are present (most noticeably on the Aeris 4A).

Switched back to fully stock to make sure, and the exaggerated effects do not appear at all, fuel lines or otherwise.

Edited by RocketRyleigh
Link to comment
Share on other sites

Would someone, who is able, load the HighBypassJet model into Blender or where ever to see if there actually is an emissive called HeatAnimationEmmissiveTurbofan, or even an emissive at all. It doesn't show up in game. Thanks!

Link to comment
Share on other sites

On 25.02.2017 at 2:55 AM, RocketRyleigh said:

'm experiencing a minor visual bug which seems to be directly caused by this mod (I've tested it with just Ven Stock Part Revamp + MM installed, and compared to completely stock).

When Ven's is installed, I'm getting strange aero visual effects; here are some pictures testing it with the Aeris 4A.

Very nice find! Noticed the issue too, but never would thought of VSR causing this...

Hello everyone, may be somebody found the way to fix small cone drogue chute? (mk26 I beleive)

I tried to change config, but had no luck in this. Can be chute drag chnged with config or it's a characteristic of model itself?

Link to comment
Share on other sites

I've hit a snag with the Clamp-o-tron docking port, for some reason it won't dock no matter what I do, also I found out about it after assembling the bulk of my station since I was using only Clamp-o-tron Senior up until then :D yay.

If someone knows of a fix I would greatly appreciate it. I can replace the docks with some from another mod but I am yet to find one where the docking ports look as good as in this mod :) .

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...