Jump to content

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!


Ven
 Share

Recommended Posts

If they're retractable, try retracting and redeploying them. Otherwise you might need to save-file-edit the panels back to a retracted state, then deploy them again. At least I think that'll do it...

Link to comment
Share on other sites

Weird problem with the Mk2 (4m) pod in Realism overhaul...

rYrAnpm.jpg

The integral RCS appear to always be on and cannot be changed.  There is no propellent consumption, vessel translation or rotation.  I cannot seem to find the config file for this particular part and am wondering if it was inadvertently missed out in the command.cfg (and if that is the problem?)

Any thoughts are welcome.

(Was not sure if this question should be posted here of in the RO thread - oh well, here it is...)

Edited by Wallygator
Link to comment
Share on other sites

30 minutes ago, Wallygator said:

Realism overhaul...

Well, that's your problem! This is not a problem with VSR but with the RO part config of the Mk2. The RO repository (and probably the pre-release) already includes a fix for that so make sure that you have the latest RO beta testing distribution.

Link to comment
Share on other sites

1 hour ago, Phineas Freak said:

Well, that's your problem! This is not a problem with VSR but with the RO part config of the Mk2. The RO repository (and probably the pre-release) already includes a fix for that so make sure that you have the latest RO beta testing distribution.

OK. Thanks for that. :)

 

Link to comment
Share on other sites

Does anyone else think the exhaust plume for the Bollard is too high? 

I have tried to lower it, unsuccessfully. So far this is what I have tried:

Spoiler

I added

    @MODULE[ModuleEnginesFX]
    {
        fxOffset = 0, 0, 1
    }

and separately I added

localOffset = 0, 0, 1

to MODEL_MULTI_PARTICLE

 

 

 

Any thoughts?

Cheers,

Link to comment
Share on other sites

Dumping the source files, if any of you can re-host the files, and post a new link here that would be fantastic. Same licensing rules as the base mod (https://creativecommons.org/licenses/by/4.0/) :

https://www.dropbox.com/s/2hst7myddq34kuk/VSR_Models.zip?dl=0

https://www.dropbox.com/s/t9lw5dm33x7i6g5/VSR_Textures.zip?dl=0

What remains of the unity files will be uploaded when I have more space to upload them.

It took two days to upload that second file.

Link to comment
Share on other sites

On 3/23/2017 at 8:50 PM, Stratickus said:

Does anyone else think the exhaust plume for the Bollard is too high? 

I have tried to lower it, unsuccessfully. So far this is what I have tried:

  Hide contents

I added

    @MODULE[ModuleEnginesFX]
    {
        fxOffset = 0, 0, 1
    }

and separately I added

localOffset = 0, 0, 1

to MODEL_MULTI_PARTICLE

 

 

 

Any thoughts?

Cheers,

assuming you are using RealPlume, just use the smokescreen interface in game to tweak the plume, then make a config with those settings.  There is probably already a config in the RealPlume-Stock folder, just match up the name of the part.   I've noticed a couple that do not look good.  

Link to comment
Share on other sites

3 hours ago, Ven said:

Dumping the source files, if any of you can re-host the files, and post a new link here that would be fantastic. Same licensing rules as the base mod (https://creativecommons.org/licenses/by/4.0/) :

1

I'd love to, what sorts of hosting would you like? 

I will host it on my own NAS and share the download link as soon as I finish downloading them.

Link to comment
Share on other sites

5 minutes ago, MaxZhao said:

I'd love to, what sorts of hosting would you like? 

I will host it on my own NAS and share the download link as soon as I finish downloading them.

Anything works, I just need a link to them XD

Link to comment
Share on other sites

On 3/28/2017 at 3:09 PM, eberkain said:

assuming you are using RealPlume, just use the smokescreen interface in game to tweak the plume, then make a config with those settings.  There is probably already a config in the RealPlume-Stock folder, just match up the name of the part.   I've noticed a couple that do not look good.  

I wasn't using Real Plume, but that is a good idea. I installed it and unfortunately, RP adds a new module that it uses to adjust the plume. Looking at the RP config didn't really give me too much insight either. To clarify, I was trying get MM to edit this:

Spoiler

EFFECTS
    {
        running_closed
        {
---
            PREFAB_PARTICLE
            {
                prefabName = fx_smokeTrail_veryLarge
                transformName = smokePoint
                emission = 0.0 0.0
                emission = 0.05 0.0
                emission = 0.075 0.25
                emission = 1.0 1.25
                speed = 0.0 0.25
                speed = 1.0 1.0
                localOffset = 0, 0, 1
            }
            MODEL_MULTI_PARTICLE
            {
                modelName = Squad/FX/ks25_Exhaust
                transformName = thrustTransform
                emission = 0.0 0.0
                emission = 0.05 0.0
                emission = 0.075 0.25
                emission = 1.0 1.25
                speed = 0.0 0.5
                speed = 1.0 1.2
            }

---

 By adding localOffset = 0, 0, 1 to MODEL_MULTI_PARTICLE. You can see that it is a part of PREFAB_PARTICLE as well as being in other engines configs. I am assuming its lack of inclusion was simple oversight, but I could be wrong.

Again, separately I tried adding:

Spoiler

    @MODULE[ModuleEnginesFX]
    {
        fxOffset = 0, 0, 1
    }

This too is a part of several other engines with ModuleEnginesFX. For whatever reason, either poor MM integration, or something else I am missing entirely, it is not getting the desired effect. I have managed to lower the plume for another engine, which is why its frustrating I cant figure this one out.

Cheers,

Edited by Stratickus
Link to comment
Share on other sites

Hi! Does anyone know why the Comms DTS-M5 keeps falling off my satellite during launch? I am running Realism Overhaul with FAR 1.1.3 and the satellite is inside a fairing. This seems to only happen to parts that 'snap under high dynamic pressure'. I don't place these parts outside of my rocket so does anyone know how to remove this trait?

Link to comment
Share on other sites

I think the Survey Scanner being squished was related to having an old version of IndicatorLights Community Extensions, maybe try updating that if you have it:

Pretty sure that's how I fixed it while keeping Ven's model... but it was a while ago lol

Link to comment
Share on other sites

Hi I'm A long time fan and I've been having shroud issues. that is the reliant however I'm having that issue with the nerv swivel poodle and a couple of others. i was running kerbal engineer, and docking alignment indicator however I've had this problem on a clean slate too.

 

Link to comment
Share on other sites

45 minutes ago, Senex said:

Hi I'm A long time fan and I've been having shroud issues. that is the reliant however I'm having that issue with the nerv swivel poodle and a couple of others. i was running kerbal engineer, and docking alignment indicator however I've had this problem on a clean slate too.

Welcome to the forums!  There are two nodes on most of those engines.  One of them has the mounting structure, the other does not.  It can be a little fiddly to get the correct one in the editor, but not to difficult with some practice.

Link to comment
Share on other sites

@Ven, you are incredibly generous to upload all you source files and Unity scenes, I presume with the idea that others can carry the flame and make the changes/fixes that you may not have time to do?

I also feel for you with you internet speed, let me comfort you in the fact you're upload rate is 50% faster than mine. :(

Link to comment
Share on other sites

1 hour ago, Poodmund said:

@Ven, you are incredibly generous to upload all you source files and Unity scenes, I presume with the idea that others can carry the flame and make the changes/fixes that you may not have time to do?

I also feel for you with you internet speed, let me comfort you in the fact you're upload rate is 50% faster than mine. :(

Pretty much. Though, there's quite a bit more stuff in there than just the models and textures currently seen (like the wheels/ landing legs, their finished. An unfinished LVN Turboprop and V2 engine) Plus it could be a learning tool for new modders I suppose, even with the broken Unity files. Sadly, during the unity 5 editor conversion, half of the mod vanished, kinda ending development. 

It's hard to believe that anyone could be slower... *shivers*

On 3/28/2017 at 4:16 PM, MaxZhao said:

Here's the link to the models, the textures will be much more painful I'm sure. I'll send you all the links in this post.

Models

textures

I have separated the texture files to upload but you can download them in one zip file

@Ven

Thanks for taking the time to do that! I've added the links to the OP.

Link to comment
Share on other sites

On 3/28/2017 at 3:26 PM, Ven said:

Dumping the source files, if any of you can re-host the files, and post a new link here that would be fantastic. Same licensing rules as the base mod (https://creativecommons.org/licenses/by/4.0/) :

https://www.dropbox.com/s/2hst7myddq34kuk/VSR_Models.zip?dl=0

https://www.dropbox.com/s/t9lw5dm33x7i6g5/VSR_Textures.zip?dl=0

What remains of the unity files will be uploaded when I have more space to upload them.

It took two days to upload that second file.

Why not use Github to host it?

Link to comment
Share on other sites

10 hours ago, blowfish said:

Welcome to the forums!  There are two nodes on most of those engines.  One of them has the mounting structure, the other does not.  It can be a little fiddly to get the correct one in the editor, but not to difficult with some practice.

yeah its not a lining up issues when you put them in even in isolation they always have the joining shroud and the one surrounding the engine

 

Link to comment
Share on other sites

On 4/2/2017 at 10:52 AM, Ven said:

Though, there's quite a bit more stuff in there than just the models and textures currently seen (like the wheels/ landing legs, their finished.

Are the wheels in Unity set up for the post-1.1 system? If not I can go ahead and fix those as well. 

22 hours ago, linuxgurugamer said:

Why not use Github to host it?

Would be great to have the ability to add the Blender/Unity files for the legs and wheels.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...