Ven

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!

Recommended Posts

safe to use in 1.5.1?

guess not, just encountered  a windows error and the game had to be closed.

 

Edited by putnamto

Share this post


Link to post
Share on other sites
17 hours ago, putnamto said:

safe to use in 1.5.1?

guess not, just encountered  a windows error and the game had to be closed.

 

I've been using it in 1.5.1 for a while now.  Be sure you're grabbing the most up-to-date version from my repository (use the green "Clone or download" button): https://github.com/Kerbas-ad-astra/Stock-Revamp/tree/KSP_1.5

Share this post


Link to post
Share on other sites

@Kerbas_ad_astra are the docking port lights fixed in the latest build? The build I'm using I can still light up the planet below with the docking light.

Share this post


Link to post
Share on other sites
2 hours ago, Kerbas_ad_astra said:

I've been using it in 1.5.1 for a while now.  Be sure you're grabbing the most up-to-date version from my repository (use the green "Clone or download" button): https://github.com/Kerbas-ad-astra/Stock-Revamp/tree/KSP_1.5

weird, when i got it to play withought force closing my ships became unstable and uncontrolable in my quicksave, in this video im hammering all the directions and nothing happens, then the landing leg just kind of pops off. and the shroud on the terrier wasnt their before i tried using the mod, but it just kinda showed up.

weird. any incite as to why this happened? could it have been that the ship was built before the mod was installed and included parts that the mod changes?

going to make a backup of the backup of the backup, then try loading the mod again and playing around abit.

 

Edited by putnamto

Share this post


Link to post
Share on other sites
46 minutes ago, Tyko said:

@Kerbas_ad_astra are the docking port lights fixed in the latest build? The build I'm using I can still light up the planet below with the docking light.

Should be.  I made a change to that effect some time ago.

26 minutes ago, putnamto said:

weird, when i got it to play withought force closing my ships became unstable and uncontrolable in my quicksave, in this video im hammering all the directions and nothing happens, then the landing leg just kind of pops off. and the shroud on the terrier wasnt their before i tried using the mod, but it just kinda showed up.

weird. any incite as to why this happened? could it have been that the ship was built before the mod was installed and included parts that the mod changes?

going to make a backup of the backup of the backup, then try loading the mod again and playing around abit.

 

What is this, a video for ants?  ;)

It's hard for me to be sure with the low resolution, but those fuel tanks don't look like they come from this mod, and I've never had issues like that.  I could believe that both of those issues are caused by upgrading a ship that was made already, if there are suddenly extra colliders and models which normally get disabled in the editor pre-launch.  Could you get me a full-res screenshot?

Share this post


Link to post
Share on other sites
5 minutes ago, Kerbas_ad_astra said:

Should be.  I made a change to that effect some time ago.

What is this, a video for ants?  ;)

It's hard for me to be sure with the low resolution, but those fuel tanks don't look like they come from this mod, and I've never had issues like that.  I could believe that both of those issues are caused by upgrading a ship that was made already, if there are suddenly extra colliders and models which normally get disabled in the editor pre-launch.  Could you get me a full-res screenshot?

the fuel tanks are stock, and sadly no i cant get you a full res screenshot, i finnally got the ship back home after removing the mod and reloading the save.

the video would be full res, but for some reason shadowplay decides that its going to record 4k even if my game is only 1080, suggestions for better capture software?

to be more clear on exactly what happened, ship landed on mun, quicksaved, closed game, load stock part revamp, open game, load quicksave, ship is uncontrollable and made out of jello.

Edited by putnamto

Share this post


Link to post
Share on other sites

I use Open Broadcaster Software, but surely there's a setting in Shadowplay to set the recording resolution.  For this video in particular, it should be possible to crop it with Avidemux or the like.

Share this post


Link to post
Share on other sites
Just now, Kerbas_ad_astra said:

I use Open Broadcaster Software, but surely there's a setting in Shadowplay to set the recording resolution.  For this video in particular, it should be possible to crop it with Avidemux or the like.

ill check into that, i just found the resolution setting in shadowplay, weird thing is though, its set to use games resolution but it still has that black space around the vid, going to try to record later tonight with it set to 1080 and see what happens.

ill try cropping it later after i eat something.

Share this post


Link to post
Share on other sites

Everything's looking pretty good on 1.5. Surprised stuff hasn't completely broken beyond any reasonable sense of repair lmao.

With 1.6 Part Revamp Update coming along will VSPR still be updated? I This mod is way more aesthetically pleasant to focus my ocular facial orbs on compared to current vanilla's parts and 1.6's updated parts.

Share this post


Link to post
Share on other sites

I am using the mod for a 1.4.5 play through but I was trying to figure out how to eliminate one of the Ven Revamp textures for the service bays and go back to the stock service bays and leave the reset of them.  How does one go about doing that?

Share this post


Link to post
Share on other sites
10 hours ago, Vahnskir said:

Everything's looking pretty good on 1.5. Surprised stuff hasn't completely broken beyond any reasonable sense of repair lmao.

With 1.6 Part Revamp Update coming along will VSPR still be updated? I This mod is way more aesthetically pleasant to focus my ocular facial orbs on compared to current vanilla's parts and 1.6's updated parts.

Ven's structural parts and fuel tanks will be added as default variants, but functional parts (thrusters, engines, and presumably anything with animations like wheels or antennas) don't play very well with the part variant system.  (I've figured out a way around the 'burning in the editor' bug from last page, but that required abusing the multi-mode engine module, and now the effects in-flight are missing...there may be a way to get them back, but it will take time to permute the effects config to find it.  My efforts are cataloged in a new "KSP_1.5_experimental" branch -- not safe for careers!)

Currently, that only applies to the Mk1 and Mk1-3 pods and RT-5 and RT-10 boosters, but from the KSP blog we know that the Spark is coming in 1.6, and probably others as well.  In general, I agree with you that I like Ven's parts better than the new Squad variants, so most of the time I will overwrite Squad's models if they can't coexist.  (Pretty much how VSR has always worked, but now I'll feel just a little bit guilty.)  That said, I'll evaluate everything on a case-by-case basis.

  • I'm planning to add Ven's Mk1 pod as a variant to Squad's revamped pod, because the only friction between them is that the part action window has two Flag Toggle buttons (one that works for Squad's variants, one for Ven's).
  • I'm planning to not overwrite Squad's Mk1-3 model, because both sets of RCS thrusters remain active even when one model or the other is disabled, and while I like Ven's thruster layout better, the model is too different for the IVA to look good (unlike the Mk1, which is basically unchanged).
  • Last page I said I'd make Ven's RT-10 model into its own part, because it has gimbals and the stock thruster does not.  I had thought to re-purpose Ven's RT-5 model as a tiny Size 00 (0.35m) motor, good for very small probes and so on, essentially a stack-mountable Sepratron.  But...since I do like Ven's models better, I'm feeling more inclined to overwrite Squad's models.

Before I completely commit to overwriting one model or the other, I'll play around with B9 Part Switch to see if it disables variant models more firmly.

2 hours ago, Galland1998 said:

I am using the mod for a 1.4.5 play through but I was trying to figure out how to eliminate one of the Ven Revamp textures for the service bays and go back to the stock service bays and leave the reset of them.  How does one go about doing that?

You'll want to crawl through VenStockRevamp/PathPatches/All-PathPatches.cfg and remove the ServiceBay lines, and likewise VSR/Patches/Kerballoons.cfg and VSR/Squad/Data/Structural.cfg.  The model and texture files themselves are in VSR/Squad/Parts/Structural.

Share this post


Link to post
Share on other sites
24 minutes ago, Kerbas_ad_astra said:

Ven's structural parts and fuel tanks will be added as default variants, but functional parts (thrusters, engines, and presumably anything with animations like wheels or antennas) don't play very well with the part variant system.  (I've figured out a way around the 'burning in the editor' bug from last page, but that required abusing the multi-mode engine module, and now the effects in-flight are missing...there may be a way to get them back, but it will take time to permute the effects config to find it.  My efforts are cataloged in a new "KSP_1.5_experimental" branch -- not safe for careers!)

Currently, that only applies to the Mk1 and Mk1-3 pods and RT-5 and RT-10 boosters, but from the KSP blog we know that the Spark is coming in 1.6, and probably others as well.  In general, I agree with you that I like Ven's parts better than the new Squad variants, so most of the time I will overwrite Squad's models if they can't coexist.  (Pretty much how VSR has always worked, but now I'll feel just a little bit guilty.)  That said, I'll evaluate everything on a case-by-case basis.

  • I'm planning to add Ven's Mk1 pod as a variant to Squad's revamped pod, because the only friction between them is that the part action window has two Flag Toggle buttons (one that works for Squad's variants, one for Ven's).
  • I'm planning to not overwrite Squad's Mk1-3 model, because both sets of RCS thrusters remain active even when one model or the other is disabled, and while I like Ven's thruster layout better, the model is too different for the IVA to look good (unlike the Mk1, which is basically unchanged).
  • Last page I said I'd make Ven's RT-10 model into its own part, because it has gimbals and the stock thruster does not.  I had thought to re-purpose Ven's RT-5 model as a tiny Size 00 (0.35m) motor, good for very small probes and so on, essentially a stack-mountable Sepratron.  But...since I do like Ven's models better, I'm feeling more inclined to overwrite Squad's models.

Before I completely commit to overwriting one model or the other, I'll play around with B9 Part Switch to see if it disables variant models more firmly.

You'll want to crawl through VenStockRevamp/PathPatches/All-PathPatches.cfg and remove the ServiceBay lines, and likewise VSR/Patches/Kerballoons.cfg and VSR/Squad/Data/Structural.cfg.  The model and texture files themselves are in VSR/Squad/Parts/Structural.

You might find my ModulePartVariantsEx helpful: it lets you change any PartModule values depending on the selected variant.

Edited by Electrocutor

Share this post


Link to post
Share on other sites

I have a small problem that I think is largely Module Manager based, but I figured I'd ask here any way.

I am trying to revert the HG-5 antenna model from VSR back to Squad as it is one of the few Squad models I actually like. I am re-purposing the VSR HG-5 as an additional, slightly more powerful antenna. 

I have tried replacing everythign that VSR does back to stock, but for some reason the models get stacked/merged

This is the MM patch I have attempted to use:

Spoiler

@PART[HighGainAntenna5]:AFTER[VenStockRevamp]
{
    !mesh = DELETE
    !MODEL {}    // Reverts HG-5 back to not bad looking Squad model and allows for new HG-50
    !MODULE[ModuleAnimateGeneric]{}
    MODEL
    {
        model = Squad/Parts/Utility/DirectAntennas/HGAntenna
    }
    !MODULE[ModuleDeployableAntenna]{}    // Reverts back to stock MODULE
    MODULE
    {
        name = ModuleDeployableAntenna
        showStatus = false
        isTracking = false
        pivotName = Rod
        windResistance = 1
        animationName = Extend
        extendActionName = #autoLOC_6002398 //#autoLOC_6002398 = Extend <<1>>
        retractActionName = #autoLOC_6002399 //#autoLOC_6002399 = Retract <<1>>
        extendpanelsActionName = #autoLOC_6002400 //#autoLOC_6002400 = Toggle <<1>>
    }
    !MODULE[ModuleDataTransmitter]{}    // Reverts back to stock MODULE
    MODULE
    {
        name = ModuleDataTransmitter
        antennaType = RELAY
        packetInterval = 0.35
        packetSize = 2
        packetResourceCost = 18.0
        requiredResource = ElectricCharge
        DeployFxModules = 0
        antennaPower = 5000000
        antennaCombinable = True
    }
}

I have done this with the 'new' VSR Poodle and successfully reverted the model back to the 'old' VSR model, not to mention other parts, so I'm not entirely sure what I'm missing.

Cheers,

 

EDIT: Never mind, I sorted it out. I had an another mod that was adding an additional model, so my MM patch only deleted the first model, which is why the second remained and then became stacked.

Edited by Stratickus

Share this post


Link to post
Share on other sites

@Kerbas_ad_astra Are you aware of the fact that your new Poodle is slightly taller than both the original and Ven's revamped Poodle? I installed your updated version and found out that due to its new height it may or may not cause explosions while decoupling.

Additionally, is it possible that you accidentally made some Making History parts available without needing MH at all? I don't have the expansion (yet), but I still have access to structural parts that were introduced in MH, or at least they look like these parts.

Edited by Delay

Share this post


Link to post
Share on other sites
12 hours ago, Delay said:

@Kerbas_ad_astra Are you aware of the fact that your new Poodle is slightly taller than both the original and Ven's revamped Poodle? I installed your updated version and found out that due to its new height it may or may not cause explosions while decoupling.

Additionally, is it possible that you accidentally made some Making History parts available without needing MH at all? I don't have the expansion (yet), but I still have access to structural parts that were introduced in MH, or at least they look like these parts.

Well, it's not 'my' new Poodle; Ven changed which model he used to replace the stock model over a year ago.  I will accept blame for changing the node positions so that the top node stays in place while the bottom node moves down; I did that because Poodles are generally used on upper stages and are only attached to things from below for the first few minutes of flight, but I could switch it to the other way to 'tuck in' the engine when VSR is installed.

It is not possible to make Making History parts available without getting Making History.  Ven was just making triangular panels before it was cool.  :)

Share this post


Link to post
Share on other sites
20 minutes ago, Kerbas_ad_astra said:

Well, it's not 'my' new Poodle; Ven changed which model he used to replace the stock model over a year ago.

Obviously I was playing with an ancient version of VSR, then.

Sorry for accusing you of messing with my spacecrafts.

 

Edit: Wait, do the node positions determine whether something clips to cause an explosion or not?
The "problem" I have is that I switched from the ancient version to your newest one, which had the newer Poodle instead of the older one. The result was an explosion as soon as I staged.

Edited by Delay

Share this post


Link to post
Share on other sites
On 11/29/2018 at 1:41 PM, Delay said:

Edit: Wait, do the node positions determine whether something clips to cause an explosion or not?

The "problem" I have is that I switched from the ancient version to your newest one, which had the newer Poodle instead of the older one. The result was an explosion as soon as I staged.

Yeah, the positions of the part centers are 'fixed' at construction time, and then the models get draped around those points.  Ven's Poodle model is longer than the stock model, and so for e.g. the Kerbal X, that length has to go somewhere.  I chose to put it out the bottom, but that means that there is a risk of intersection between two parts in the moment the lower stage is ejected.  I've never had them explode before, but I could believe that depends on the exact decoupler used below the Poodle and how its colliders are arranged.  I'll try moving the model up (and testing what it does to vehicles in-flight) before too long.

Share this post


Link to post
Share on other sites

@Kerbas_ad_astra Pre-revamp spacecraft engines seem to get covered by their shroud again. Is it possible to edit them out? I'm looking at the save file right now and it doesn't look like you can.
cp104Ez.png

Share this post


Link to post
Share on other sites
1 hour ago, Delay said:

@Kerbas_ad_astra Pre-revamp spacecraft engines seem to get covered by their shroud again. Is it possible to edit them out? I'm looking at the save file right now and it doesn't look like you can.

Looking through my saves, maybe if you add "isJettisoned = True" to that part's ModuleJettison block the shroud will go away?

Share this post


Link to post
Share on other sites

@Delay Try setting it to False for everything you want it set for, load the save, quit, then set it to True.

Share this post


Link to post
Share on other sites
On 11/16/2018 at 7:38 PM, Kerbas_ad_astra said:

I've been using it in 1.5.1 for a while now.  Be sure you're grabbing the most up-to-date version from my repository (use the green "Clone or download" button): https://github.com/Kerbas-ad-astra/Stock-Revamp/tree/KSP_1.5

I'm playing in 1.3.1, and decided to take a look at this version (I may have to update at some point, to keep up with mods updates), and I'm impressed how the files are organized now, making extremely easy to choose what parts we want or not. When I decide to update, this will make my life way easier. Good job! :)

Share this post


Link to post
Share on other sites

Before people come to ask I will say that Ven, while functioning in 1.6 is somewhat broken. Engines stay on which is common, and right clicking the new mk2 lander can prevents right clicks until exit and re-entering the SPH/VAB. MK1 inline docking port also does not animate. Nothing major.

Edit:Should note that the engines don't seem to be a ven thing.

Edited by Spartwo

Share this post


Link to post
Share on other sites

Huh, I thought 1.6 was coming in January.  (It might take until then for me to get some dev time, but I'll be happy to review pull requests that come before then.)

Looking at the new parts, they're alright, but I will stick with the plan from before.  Parts with static models (tanks and structural adapters) will have Ven's models added as default variants, engines will get overwritten, and the Mk1-3 pod and Mk2 lander can will be left alone.  I'll have to do some more testing of the Mk1 pod -- Squad's new model is close to Ven's in size but not quite the same, so I need to see how it affects e.g. the IVA alignment and so on.

Share this post


Link to post
Share on other sites
On 12/20/2018 at 10:26 PM, Spartwo said:

Before people come to ask I will say that Ven, while functioning in 1.6 is somewhat broken. Engines stay on which is common, and right clicking the new mk2 lander can prevents right clicks until exit and re-entering the SPH/VAB. MK1 inline docking port also does not animate. Nothing major

It's not Ven, it's Module Manager; whatever version I tried, even alone, it broke the right clic...

Edit: I'm back from the MM thread, and it's not even that, they were able to reproduce the problem without MM or anything else but the squad files. Seems to be a problem with how PartDatabase.cfg is handled by the game, and it needs to be started twice to properly work. I'll check that with Ven...

Final edit: Ok so, it works, at least for me. So you have to start the game twice - after a proper exit - in order to avoid the right-clic vanishing after having right-clicked the Mk2 Can. And you have to do it after adding anything else into the game data folder... 
Sorry for the multiple editing, I'm tired and have a bit of a hard time to focus on doing things in the right order :blush: Hope that'll help somehow...

Edited by Rawenwarcrow
New informations

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.