Jump to content

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!


Ven
 Share

Recommended Posts

Problem with the capsule and it's RCS thingy.

8r1eV6E.png

Buggy placement near the hatch.

i9hOxCJ.png

More importantly, the RCS thingy has too low drag so it automatically orients itself Prograde by aerodynamics. The RCS thingy definitely needs to have the same drag as the parachute part. (when not deployed, of course)

Link to comment
Share on other sites

Problem with the capsule and it's RCS thingy.

Buggy placement near the hatch.

More importantly, the RCS thingy has too low drag so it automatically orients itself Prograde by aerodynamics. The RCS thingy definitely needs to have the same drag as the parachute part. (when not deployed, of course)

On the drag isuue, that's due on how stock aerodynamics work, the whole using mass to calculate etc...Considering that in the next version aero will get a revamp, I suggest to wait before try to make alterations to it.

Link to comment
Share on other sites

On the drag isuue, that's due on how stock aerodynamics work, the whole using mass to calculate etc...Considering that in the next version aero will get a revamp, I suggest to wait before try to make alterations to it.

It's going to be quite a while before the next update, it being 1.0 and all.

Link to comment
Share on other sites

So I am having a problem with the Mk1-2 pod just looking like it is spraying RCS at max thrust from every port. It doesn't generate thrust or anything once deployed it just looks really crazy o.o

If you have activated RCS and SAS in prograde or other direction mode, it could just constantly trying to correct the pod's direction. So it constantly rotates up, down, left and right on tiny angle.

Link to comment
Share on other sites

Hello! I have a small issue with the 1.7 update.

None of the mod-added parachutes are working (that is, the small drogue, the radial drogue, and the docking port/parachute combo.) They don't even appear to have the parachute module installed - they are completely inert (aside from the docking mechanism on the docking port.) I have reinstalled the mod on an otherwise stock .90 install (and no, this time I did not forget to put ModuleManager in the Gamedata folder :P) It's a small issue, seeing as how I don't usually use the drogues, but they would be handy to have nonetheless.

Link to comment
Share on other sites

I've also found that the science lab has no usable EVA hatch. I can't click on the hatch to EVA or Transfer a kerbal inside. They're basically trapped once they're in there.

- - - Updated - - -

Hello! I have a small issue with the 1.7 update.

None of the mod-added parachutes are working (that is, the small drogue, the radial drogue, and the docking port/parachute combo.) They don't even appear to have the parachute module installed - they are completely inert (aside from the docking mechanism on the docking port.) I have reinstalled the mod on an otherwise stock .90 install (and no, this time I did not forget to put ModuleManager in the Gamedata folder :P) It's a small issue, seeing as how I don't usually use the drogues, but they would be handy to have nonetheless.

Can reproduce, is problem.

Link to comment
Share on other sites

Is there real life prototype for small SRB module? For me it's unusual to see solid rocket with four nozzels.

the RL minuteman ICBM had 4 nozzles and as your starter srb naturally some parts would come from military surplus also the revamped rt-10 has a fairing so its not like you gotta stare at those nozzles on the way up like you do the stock ones

Link to comment
Share on other sites

Just installed 1.7 yesterday and found 4 problems.

1. It seemed there some problems of attaching things like light onto the science lab and the Hitchhiker container. Sometimes I couldn't attach anything onto these two parts.

2. Kerbal went EVA from the science lab and the Hitchhiker container were very likely to be throw away once they leave door.

3. Kerbal could not catch the ladder on the lab and the container. When closely approaching, there was no sign of 'catch' at all.

4. Could not click the door of the lab and the container to EVA or transfer kerbal.

The new parts looks definitely awesome.

Link to comment
Share on other sites

the RL minuteman ICBM had 4 nozzles and as your starter srb naturally some parts would come from military surplus also the revamped rt-10 has a fairing so its not like you gotta stare at those nozzles on the way up like you do the stock ones

Another example is Topaze (the second stage of the Diamant rocket):

diamantA%20etage2.jpg

Link to comment
Share on other sites

Is there any way to disable the RCS ports on the 1-2 pod? While I appreciate the idea; I'm afraid they make it far harder to balance the RCS thrust on some of my craft, particularly some of my specialized designs, and I'd rather save myself some hassle while building.

Link to comment
Share on other sites

the RL minuteman ICBM had 4 nozzles and as your starter srb naturally some parts would come from military surplus also the revamped rt-10 has a fairing so its not like you gotta stare at those nozzles on the way up like you do the stock ones

Minuteman missiles were made after Gemini-era irl, so that's not available at the time KSP would start at. Rockets are still a basic technology, and there's no reason to have four nozzles on a trash bin of boom. At the very least, give it back some yellow!

- - - Updated - - -

Is there any way to disable the RCS ports on the 1-2 pod? While I appreciate the idea; I'm afraid they make it far harder to balance the RCS thrust on some of my craft, particularly some of my specialized designs, and I'd rather save myself some hassle while building.

Yes, but not in the editor. Right click in flight. I suppose TweakableEverything might have that functionality, though.

Link to comment
Share on other sites

Edit: I stand corrected on the whole 1.0 thing, apparently I am totally out of the loop

May I make a suggestion? I find that the updated engine parts are lacking an engine that seems like it's dedicated for first stage engines. There's no covers on the 2.5m engines, so they look like they should go on an upper stage. I just think it'd look nicer, is all.

As such things are purely cosmetic in nature and adding additional parts/textures is not something most would want, the best way to achieve this is to simply put a structural adapter on the end of your tank and then use the awesome new editor tools to clip the engine up into it so that just the nozzle is showing out the bottom.

Is there any way to disable the RCS ports on the 1-2 pod? While I appreciate the idea; I'm afraid they make it far harder to balance the RCS thrust on some of my craft, particularly some of my specialized designs, and I'd rather save myself some hassle while building.

Open the PartRevamp-MM.cfg in the part revamp folder in gamedata, under the Mark1-2Pod section (should be at the very top) delete the following:


MODULE
{
name = ModuleRCS
thrusterTransformName = RCSthruster
thrusterPower = 1
resourceName = MonoPropellant
resourceFlowMode = STAGE_PRIORITY_FLOW
atmosphereCurve
{
key = 0 260
key = 1 100
}
}

That will remove the RCS from the pod.

Edited by Akira_R
Link to comment
Share on other sites

Unless squad has changed something next update is not 1.0, they said numerous times before and after the .90 release that they were doing a large number jump just to illustrate the transition into a more "beta" phase, there are still going to be many many updates before we reach 1.0 release status.

You missed a big announcement:

http://forum.kerbalspaceprogram.com/content/326-Beyond-Beta

Link to comment
Share on other sites

Minuteman missiles were made after Gemini-era irl, so that's not available at the time KSP would start at. Rockets are still a basic technology, and there's no reason to have four nozzles on a trash bin of boom. At the very least, give it back some yellow!

Its a game chill out if you don't want nozzles and want your yellow back so bad then just use the old stock model. I like Ven's change it matches the asthetic of the other SRB's, and with a fairing I don't care how many nozzles it has. What I do care about is you making him waste the free time he volunteers to make this mod changing it back to a single nozzle, but thankfully you are the only one who's really making a fuss about the SRB so hopefully he'll take most everyone else's silence on the subject as a sign of acceptance and gratitude for the work he puts in.

Edited by passinglurker
Link to comment
Share on other sites

Problem with the capsule and it's RCS thingy...

More importantly, the RCS thingy has too low drag so it automatically orients itself Prograde by aerodynamics. The RCS thingy definitely needs to have the same drag as the parachute part. (when not deployed, of course)

On the drag isuue, that's due on how stock aerodynamics work, the whole using mass to calculate etc...Considering that in the next version aero will get a revamp, I suggest to wait before try to make alterations to it.

I made a small change (in red) to the "Part Revamp-MM.cfg" that cleared this up nicely:

+PART[RCSBlock] {
@author = Ven
@name = InlineRCS
@title = Inline RCS Block
@description = This inline RCS block was originally part of the ageing MK1 pod, but was removed when management decided that it was too expensive. This block provides four way altitude control for your command pods and rockets, even includes a small mono-propellant supply to boot.
@attachRules = 1,0,1,1,0
@scale = 1
node_stack_top = 0.0, 0.14, 0.0, 0.0, 1.0, 0.0, 0
node_stack_bottom = 0.0, -0.14, 0.0, 0.0, 1.0, 0.0, 0
@entryCost = 0
@cost = 400
@TechRequired = start
[COLOR="#FF0000"]@mass = 0.025
@maximum_drag = 0.005
@minimum_drag = 0.001
@angularDrag = 0.005[/COLOR]
!PhysicsSignificance = 1
!mesh = DELETE
!MODEL {}
MODEL... (etc)

The capsule remained heatshield down the entire re-entry.

Now, is anyone having problems with the Mark 1-2 pod's heatshield fairing already in place when nothing else is attached to the capsule?

Edited by Jack Wolfe
Link to comment
Share on other sites

Okay, I've been having more problems, which are probably because I've done something stupid, or they're really common issues, but I can't figure them out. With the latest texture replacer, Ven's solar panels are no longer shiny and the lights aren't pretty anymore.

In an unrelated (probably) issue, engine fairings are permanently on when I've got the stock revamp installed, and lights seem to be always switched on. Uninstalling stock revamp fixes this, reinstalling it breaks it again. Here's a screenshot of my mods folder: http://a.pomf.se/jojlsp.PNG

So I fixed this issue with a full reinstall a couple of pages back, but I realise what might have caused it -- I was launching KSP with -opengl tags to save memory. On my reinstall I forgot to do this, but installed the same mods, so perhaps it's something to do with that. If someone comes up with the same issue, it might be worth mentioning!

Link to comment
Share on other sites

Anyone else noticed any funky behaviour with the docking ports? Both NavyFish's indicator and MechJeb got really confused when I was docking after updating - both were indicating the port being 90 degrees rotated (on the yaw axis, from memory). Was able to dock manually, though on closing with the port, my whole ship got spun round to match the roll of the vessel it was docking to.

Can you post (or send me) pictures of this? The docking ports seem to function normally, and seem to control from the right direction.

More importantly, the RCS thingy has too low drag so it automatically orients itself Prograde by aerodynamics. The RCS thingy definitely needs to have the same drag as the parachute part. (when not deployed, of course)

Increased the drag of the part (it originally had the same amount of drag as an RCS port) so now it should fall in the right direction now.

Hello! I have a small issue with the 1.7 update.

None of the mod-added parachutes are working (that is, the small drogue, the radial drogue, and the docking port/parachute combo.) They don't even appear to have the parachute module installed - they are completely inert (aside from the docking mechanism on the docking port.) I have reinstalled the mod on an otherwise stock .90 install (and no, this time I did not forget to put ModuleManager in the Gamedata folder :P) It's a small issue, seeing as how I don't usually use the drogues, but they would be handy to have nonetheless.

The problem was caused by the Realchutes patch, it was overwriting the new parachutes even if you didn't have that mod installed. This resulted in the parachutes having their parachute modules removed and becoming orange colored paper-weights. This is fixed in 1.7.1.

May I make a suggestion? I find that the updated engine parts are lacking an engine that seems like it's dedicated for first stage engines. There's no covers on the 2.5m engines, so they look like they should go on an upper stage. I just think it'd look nicer, is all.

The mainsail engine is going to have some sort of cover when I finish the NASA parts, the current model for the mainsail won't be wasted however, it'll go on the LFB.

Just installed 1.7 yesterday and found 4 problems.

1. It seemed there some problems of attaching things like light onto the science lab and the Hitchhiker container. Sometimes I couldn't attach anything onto these two parts.

2. Kerbal went EVA from the science lab and the Hitchhiker container were very likely to be throw away once they leave door.

3. Kerbal could not catch the ladder on the lab and the container. When closely approaching, there was no sign of 'catch' at all.

4. Could not click the door of the lab and the container to EVA or transfer kerbal.

The new parts looks definitely awesome.

  1. Texture Replacer seems to be causing this problem, I don't know exactly why, but it did leave a massive debug log while the parts refused to attach.
  2. I've moved the hatches further away from the pod, so this shouldn't happen as often now.
  3. I forgot to tag the ladders as ladders in Unity for those parts, I've fixed that. Sorry about that.
  4. Texture Replacer also was causing the ladder and hatch colliders to behave oddly, so I've disabled the TR config for now.

Now, is anyone having problems with the Mark 1-2 pod's heatshield fairing already in place when nothing else is attached to the capsule?

This happens when you first load up the game, just grab a new pod and it should work properly.

If not, then delete your Ven stock revamp folder and re-install the mod.

I've just updated both links to 1.7.1, featuring bug fixes and a re-added KerbCan. TR is surrently disabled due to the several bugs it seems to be causing, but you can reactivate it by saving the .txt file to a .cfg.

Link to comment
Share on other sites

The mainsail engine is going to have some sort of cover when I finish the NASA parts, the current model for the mainsail won't be wasted however, it'll go on the LFB..

Is it weird that I'm hyped for that? The NASA revamp, I mean.. I honestly didn't think you'd tackle them, but now you are, I'm more stoked than a fireplace in winter :D

Link to comment
Share on other sites

Is it all ok with docking port (Sr, to be specific)? I was docking 2 vessels with Sr after 1.7.1 update and MJ has gone crazy, like if target's port was inverted or rotated - it couldn't position my vessel's port parallel to target, instead it was turning some other direction. I docked them manually, so technically ports seem to work fine. Also there was no such problem with regular clampotron, only Sr one, so I guess MJ itself is not related to this issue. And also in Sr situation docking port alignment indicator gone crazy - it was showing that I was moving like inverted related to target. So I guess it has something to do with Sr port's settings, which cause MJ and alignment indicator to work incorrect.

Visually both ports are positioned ok, I was targeting correct port and controlling vessel from its port. And they finally connected (darn, connecting 300 ton vessel to 150 ton vessel like this is a bit nervous), so ports are definitely attached by correct sides.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...