Ven

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!

Recommended Posts

On 18.12.2015 at 6:14 AM, legoclone09 said:

@Ven Just a quick bug report:

The 1.25m decouplers are a bit too big for the fuselage, they stick out a bit. Also the node is too far down leading to problems with the heatshield fairings and clipping into the Mk1 pod.

Not only 1.25 - 2.5 and separators also...

I did this:

EDIT \Part Bin\ExtraDecouplers.cfg:
		+PART[decoupler1-2]:FIRST {...MODEL {scale = 0.97,1.0,0.97 }}
EDIT \Squad\Parts\Utility.cfg:
		@PART[decoupler1-2] {...MODEL {scale = 0.97,1.0,0.97 }}
		@PART[stackDecoupler] {...MODEL {scale = 0.94,1.0,0.94 }}
		@PART[stackSeparator] {...MODEL {scale = 0.945,1.2,0.945 }}
		@PART[stackSeparatorBig] {...MODEL {scale = 0.97,1.0,0.97 }}

 

Share this post


Link to post
Share on other sites

Is the Mk1-2 Command Pod supposed to have a balance offset to the hatch? This kinda ruins all my excisting designs. 

If you don't know what i mean just slab a rocket engine under a Mk1-2 Command Pod and cheat fuel in. Fire up the engine and look at the massive offset. 

Share this post


Link to post
Share on other sites
13 minutes ago, DryTaste said:

Is the Mk1-2 Command Pod supposed to have a balance offset to the hatch? This kinda ruins all my excisting designs. 

If you don't know what i mean just slab a rocket engine under a Mk1-2 Command Pod and cheat fuel in. Fire up the engine and look at the massive offset. 

In real life returning pods will have an offset center of mass so that they can control their reentry by turning. At least, I think.

Share this post


Link to post
Share on other sites
2 minutes ago, Sgt.Shutesie said:

In real life returning pods will have an offset center of mass so that they can control their reentry by turning. At least, I think.

Yeah, in real life a pod can't be perfectly balanced anyway. But it is in ksp stock, the current offset ruins most radial engine configurations. 

Share this post


Link to post
Share on other sites
On 20.12.2015 at 8:18 PM, DryTaste said:

Yeah, in real life a pod can't be perfectly balanced anyway. But it is in ksp stock, the current offset ruins most radial engine configurations. 

EDIT \Squad\Parts\Command.cfg:
        @PART[Mark1-2Pod] {
            %rescaleFactor = 1.025 //1
            // %CoMOffset = 0, 0.0, 0.07
        @PART[mk1pod] {
            // %CoMOffset = 0, 0.0, 0.006

Share this post


Link to post
Share on other sites
10 hours ago, ZobrAA said:

EDIT \Squad\Parts\Command.cfg:
        @PART[Mark1-2Pod] {
            %rescaleFactor = 1.025 //1
            // %CoMOffset = 0, 0.0, 0.07
        @PART[mk1pod] {
            // %CoMOffset = 0, 0.0, 0.006

Thank you so much!

Share this post


Link to post
Share on other sites

@Ven Im in love with this mod. am super thankful you have created this mod. But if you kindly kept these five suggestions in mind, I'd be glad if these appeared in a future release:

3.75m  heavy orbital habitat (carries 10 kerbals)

IVA for the Kerbal Safety Bubble (and renaming of it to Inflatable Habitat Module)

2.5m inflatable centrifuge (like that of the Nautilus-X)

Inline monopropellant engine (1.25m in diameter and has its own storage of monopropellant)

2.5m ion engine (has BEAUTIFUL custom exhaust)

BONUS SUGGESTION: Fixing of the VSR Vector's oddly aligned exhaust

Edited by AJTheMighty

Share this post


Link to post
Share on other sites

I am having a problem.

[Log]: [TR.TRReflection] Failed to replace any shader on "aje.solarPanels" with its reflective counterpart.

After this log I can't grab the part again.

Share this post


Link to post
Share on other sites

i've loved this mod in the past, makes KSP look brand spankin new! but i went to download and install it just now, and i can't for the life of me find the pruners :(
without them, ksp runs out of memory trying to load too much. i checked out the readme but i must be going insane because it says to "drag and drop the 'Pruners' folder into your KSP directory"

can anyone point me in the right direction?

Share this post


Link to post
Share on other sites
1 hour ago, dresoccer4 said:

i've loved this mod in the past, makes KSP look brand spankin new! but i went to download and install it just now, and i can't for the life of me find the pruners :(
without them, ksp runs out of memory trying to load too much. i checked out the readme but i must be going insane because it says to "drag and drop the 'Pruners' folder into your KSP directory"

can anyone point me in the right direction?

There aren't any pruners for 1.9, yet. In the meantime, if you haven't tried this already, force ksp to use OpenGL. Create a shortcut of ksp.exe, go to its poperties, go to the Target box. Click directly after the last quotation mark, space, and paste in      -force-Opengl

Start up using that shortcut. I'm running high resolution Stock Visual Enhancments, Stock revamp, Scatter, KW, AIES, MKS, and assorted small part mods. OpenGL works miracles.

 

 

Also, Ven, could you make a procedural parts tank texture or two? Pure white is the closest that fits your style, but... well, you can see it's kind of ugly side by side.

bW89I8h.png?1

 

 

 

 

 

Share this post


Link to post
Share on other sites
25 minutes ago, lagcity613 said:

There aren't any pruners for 1.9, yet. In the meantime, if you haven't tried this already, force ksp to use OpenGL. Create a shortcut of ksp.exe, go to its poperties, go to the Target box. Click directly after the last quotation mark, space, and paste in      -force-Opengl

Start up using that shortcut. I'm running high resolution Stock Visual Enhancments, Stock revamp, Scatter, KW, AIES, MKS, and assorted small part mods. OpenGL works miracles.

 

 

 

 

 

thanks for advice. i've used opengl in the past, but it did some wonky things like strange textures and framerate drops so i try to avoid it. i went ahead and downloaded the source for 1.9 from github, and there were pruners in there. i ran them, but haven't checked if my memory usage has decreased. 

Share this post


Link to post
Share on other sites
1 hour ago, dresoccer4 said:

thanks for advice. i've used opengl in the past, but it did some wonky things like strange textures and framerate drops so i try to avoid it. i went ahead and downloaded the source for 1.9 from github, and there were pruners in there. i ran them, but haven't checked if my memory usage has decreased. 

Unfortunately, those pruners are outdated to a large degree (they weren't updated for new parts and/ or they prune stock models that are currently kept ingame (Porkjets parts mostly)).

Share this post


Link to post
Share on other sites
5 minutes ago, Ven said:

Unfortunately, those pruners are outdated to a large degree (they weren't updated for new parts and/ or they prune stock models that are currently kept ingame (Porkjets parts mostly)).

eek, thanks for the heads up. i shall un-prune momentarily. are new and improved pruners planned for a future release?

Share this post


Link to post
Share on other sites
4 minutes ago, dresoccer4 said:

eek, thanks for the heads up. i shall un-prune momentarily. are new and improved pruners planned for a future release?

I don't know currently, I'd have to manually update each pruner by hand, and I really don't want to do that right now. :/

Share this post


Link to post
Share on other sites
20 minutes ago, Ven said:

I don't know currently, I'd have to manually update each pruner by hand, and I really don't want to do that right now. :/

totally understandable. i think everyone can agree you've done enough awesome work for now. thanks again! :cool:

Share this post


Link to post
Share on other sites
1 hour ago, Ven said:

Unfortunately, those pruners are outdated to a large degree (they weren't updated for new parts and/ or they prune stock models that are currently kept ingame (Porkjets parts mostly)).

I did a manual prune on my install by renaming all stock assets and seeing what errored when the game was trying to compile the models. I'll log an issue over on GitHub with the paths of prunable assets. (*IF* I have time over the holidays I can try to update the pruners and send a proper pull request.)

Edit:

If anyone wants to prune their own copy or update the pruners, here's the list of assets https://github.com/VenVen/Stock-Revamp/issues/70

Edited by somnambulist
Updated with link

Share this post


Link to post
Share on other sites

For anyone that uses Connected Living Spaces you may have noticed that some parts that should be passable, simply aren't. Well, this is because of a simple mistake in the patch currently included with the 1.9.1 release. As it stands now, I currently have a pull request waiting to be merged with the main branch, which, once merged, any further releases with the CLS-Patch will work correctly out of the box. 

As a temporary fix, I've gone ahead and put together this small patch so you can already use it during the waiting process. Simply install it like any mod. If installed correctly, you should get a notification asking if you want to overwrite one file. Once you click yes, you'll be good to go!

Here's the download link!

This little fix is being hosted Google Drive. Since it isn't used as much, as say, Dropbox, people aren't as familiar with it. So, if you can't find the download button, it's at the top of the page - dead center. 

I hope this small fix will help someone, and happy holidays!

Share this post


Link to post
Share on other sites

This is probably a problem on my end, cause I don't see anyone else talking about it.

Here's my problem, the RE-D7 "Bollard" doesn't seems to have plume/flame/smoke trail, this is a problem only persist on the Bollard, regardless of whether RealPlume is installed or not.

Any idea what causes this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.