Ven

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!

Recommended Posts

Alright, loved 1.8 to death, loving this too, even as I'm pruning unneeded parts and adding probe functionality to the radial SAS.

However, am I right to suspect that pitch-black stock solar panels were not part of the plan?

Also, are the blue internals of 3.75 m tanks intentional?

Share this post


Link to post
Share on other sites

Hey Ven, do you have any configs or plans to make this compatible with CTT (Community Tech Tree)? I ask this because the parts are are unlocked in really weird orders. The Reliant is unlocked before the Dachshund, even though the Dachshund is suppose to be unlocked before everything else (at least that's what the description says). 

Also, like I said a week ago, the auto tank butts don't work.

Edited by Mr Betelgeuse

Share this post


Link to post
Share on other sites
15 hours ago, Blastard said:

This is probably a problem on my end, cause I don't see anyone else talking about it.

Here's my problem, the RE-D7 "Bollard" doesn't seems to have plume/flame/smoke trail, this is a problem only persist on the Bollard, regardless of whether RealPlume is installed or not.

Any idea what causes this?

Seems ok for me:

 

Share this post


Link to post
Share on other sites
16 hours ago, Blastard said:

This is probably a problem on my end, cause I don't see anyone else talking about it.

Here's my problem, the RE-D7 "Bollard" doesn't seems to have plume/flame/smoke trail, this is a problem only persist on the Bollard, regardless of whether RealPlume is installed or not.

Any idea what causes this?

Are you using the 64 bit?

Share this post


Link to post
Share on other sites

I somehow seem to have two sets of three seemingly-identical ladders, one in the shape of Pegasus Mobility Enhancers and one with its own style (with vertical bars as well as rungs). They have different names but identical flavor text, and one set costs all the same while the other's pricing makes no sense, with the medium one costing less than the short (regular Pegasus) one. This is the only pack I've installed that affects ladders, so can somebody tell me what's going on?

Share this post


Link to post
Share on other sites
14 hours ago, Hlothwig said:

I somehow seem to have two sets of three seemingly-identical ladders, one in the shape of Pegasus Mobility Enhancers and one with its own style (with vertical bars as well as rungs). They have different names but identical flavor text, and one set costs all the same while the other's pricing makes no sense, with the medium one costing less than the short (regular Pegasus) one. This is the only pack I've installed that affects ladders, so can somebody tell me what's going on?

Duplicate ladders happened to me too, before I began to axe mods, so I can't point to the culprit. So I imagine that you should list all your mods anyway.

Share this post


Link to post
Share on other sites
On ‎28‎.‎12‎.‎2015 at 10:01 PM, DDE said:

Alright, loved 1.8 to death, loving this too, even as I'm pruning unneeded parts and adding probe functionality to the radial SAS.

However, am I right to suspect that pitch-black stock solar panels were not part of the plan?

Also, are the blue internals of 3.75 m tanks intentional?

Adding image of both glitches at once.

http://1drv.ms/1RQ1ysL

1RQ1ysL

All "stock" solars are affected. I've dropped in an NF Solar Blanket, a non-stock stockalike (RCS Capsuledyne) 3.75 m tank, and 2.5 and 1.25 m parts for comparison).

Partial modlist via AVC:

KSP: 1.0.5 (Win32) - Unity: 4.6.4
f1 - OS: Windows 8.1  (6.3.10240) 64bit
USI Tools - 0.5.4
Chatterer - 0.9.7.86
Community Resource Pack - 0.4.8
DMagic Orbital Science - 1.1
Docking Sounds - 1.2
Firespitter - 7.1.5
HeatControl - 0.2.1
Kerbal Attachment System - 0.5.5
Kerbal Joint Reinforcement - 3.1.4
InlineBallutes - 1.2.3
Kerbal Inventory System - 1.2.3
KSP-AVC Plugin - 1.1.5
Infernal Robots - 0.21.4
Docking Port Alignment Indicator - 6.2
NearFutureConstruction - 0.5.5
NearFutureElectrical - 0.6
NearFuturePropulsion - 0.5.4
NearFutureSolar - 0.5.5
NearFutureSolar - 0.4.4
Final Frontier - 0.8.10.1609
Outer Planets Mod - 1.9
RealChute - 1.3.2.6
RemoteTech - 1.6.9
SCANsat - 1.1.4.5
Sigma: PluronKhato - 1.2
SmartParts - 1.6.6
StageRecovery - 1.6
ThrottleControlledAvionics - 2.3.0.2
TAC Life Support - 0.11.2.1
Trajectories - 1.4.5
Kerbal Alarm Clock - 3.5
TweakScale - 2.2.5
USI Core - 0.1.2
USI Exploration Pack - 0.4.3
USI Survivability Pack - 0.3.3
Universal Storage - 1.1.0.8
VenStockRevamp - 1.9

Uhm... yeah.

Edited by DDE

Share this post


Link to post
Share on other sites
6 hours ago, DDE said:

Duplicate ladders happened to me too, before I began to axe mods, so I can't point to the culprit. So I imagine that you should list all your mods anyway.

Well, here goes (spoilered to save space):

Spoiler

Alcubierre Drive

BetterTimeWarp

Command Inventory

Engineer Level Fixer

Jump Beacons (parameciumkid)

Kerbal Attachment System

Kerbal Inventory System

Kerbal Joint Reinforcement

Kopernicus Planetary System Modifier

Kopernicus Expansion

KSI - Placement Services

Mk2 Essentials

Module Manager

New Horizons

No More Science Grinding

Other_Worlds Star Pack

Portrait Stats

RasterPropMonitor

RasterPropMonitor Core

RLA Stockalike

Rover Wheel Sounds

Science Revisited Revisited

SpaceY Heavy Lifters Parts Pack

Transfer Window Planner

and of course Ven's Stock Part Revamp.

Aside from Ven's Stock Revamp, only SpaceY, RLA, KIS, KAS, Jump Beacons, and the Alcubierre Drive add any parts, and none of them add ladders.

 

Edit: And upon updating from 1.9.0 to 1.9.1, all of the ladders are gone except the original Pegasus. That's a shame, I liked the square ones.

Edited by Hlothwig
Additional Info

Share this post


Link to post
Share on other sites
11 minutes ago, Blastard said:

Yes I'm using 64bit, is that the cause?

Yes, it usually is the problem. 64 bit doesn't let you use special flame effects that aren't stock. 

Share this post


Link to post
Share on other sites
31 minutes ago, Mr Betelgeuse said:

Yes, it usually is the problem. 64 bit doesn't let you use special flame effects that aren't stock. 

That's not so, RealPlume works fine for me on Windows 64-bit KSP, for example.

Share this post


Link to post
Share on other sites

AFAIC, this mod is mandatory if you like realism. Thank you so much! Squad should be paying you big bucks and folding this into stock. 

small thought on the RE L10: I like where you are going with this one, making it an RL-10 analog. I'd like to see a sloped 2.5m thrust structure akin to Centaur. And maybe a quad thrust structure akin to the SLS Exploration Upper Stage. On the flip side, I do like how you made this and the Skipper able to fit 1.5m tanks. 

Share this post


Link to post
Share on other sites
8 hours ago, DDE said:

Adding image of both glitches at once.

http://1drv.ms/1RQ1ysL

1RQ1ysL

All "stock" solars are affected. I've dropped in an NF Solar Blanket, a non-stock stockalike (RCS Capsuledyne) 3.75 m tank, and 2.5 and 1.25 m parts for comparison).

Partial modlist via AVC:


KSP: 1.0.5 (Win32) - Unity: 4.6.4
f1 - OS: Windows 8.1  (6.3.10240) 64bit
USI Tools - 0.5.4
Chatterer - 0.9.7.86
Community Resource Pack - 0.4.8
DMagic Orbital Science - 1.1
Docking Sounds - 1.2
Firespitter - 7.1.5
HeatControl - 0.2.1
Kerbal Attachment System - 0.5.5
Kerbal Joint Reinforcement - 3.1.4
InlineBallutes - 1.2.3
Kerbal Inventory System - 1.2.3
KSP-AVC Plugin - 1.1.5
Infernal Robots - 0.21.4
Docking Port Alignment Indicator - 6.2
NearFutureConstruction - 0.5.5
NearFutureElectrical - 0.6
NearFuturePropulsion - 0.5.4
NearFutureSolar - 0.5.5
NearFutureSolar - 0.4.4
Final Frontier - 0.8.10.1609
Outer Planets Mod - 1.9
RealChute - 1.3.2.6
RemoteTech - 1.6.9
SCANsat - 1.1.4.5
Sigma: PluronKhato - 1.2
SmartParts - 1.6.6
StageRecovery - 1.6
ThrottleControlledAvionics - 2.3.0.2
TAC Life Support - 0.11.2.1
Trajectories - 1.4.5
Kerbal Alarm Clock - 3.5
TweakScale - 2.2.5
USI Core - 0.1.2
USI Exploration Pack - 0.4.3
USI Survivability Pack - 0.3.3
Universal Storage - 1.1.0.8
VenStockRevamp - 1.9

Uhm... yeah.

Those are such hot bugs though... Actually, I'm now claiming that their intentional.:sticktongue:

(all kidding aside, they are indeed intentional).

6 hours ago, Hlothwig said:

Well, here goes (spoilered to save space):

  Reveal hidden contents

Alcubierre Drive

BetterTimeWarp

Command Inventory

Engineer Level Fixer

Jump Beacons (parameciumkid)

Kerbal Attachment System

Kerbal Inventory System

Kerbal Joint Reinforcement

Kopernicus Planetary System Modifier

Kopernicus Expansion

KSI - Placement Services

Mk2 Essentials

Module Manager

New Horizons

No More Science Grinding

Other_Worlds Star Pack

Portrait Stats

RasterPropMonitor

RasterPropMonitor Core

RLA Stockalike

Rover Wheel Sounds

Science Revisited Revisited

SpaceY Heavy Lifters Parts Pack

Transfer Window Planner

and of course Ven's Stock Part Revamp.

Aside from Ven's Stock Revamp, only SpaceY, RLA, KIS, KAS, Jump Beacons, and the Alcubierre Drive add any parts, and none of them add ladders.

 

Edit: And upon updating from 1.9.0 to 1.9.1, all of the ladders are gone except the original Pegasus. That's a shame, I liked the square ones.

Its supposed to be two different styles with three lengths each. The Utility ladders prices seem to have gotten swapped at some point (or more likely, the +PART{} entries got switched around and I entered the values in the wrong order).

Make sure that you delete the entire VSR folder when you install a new version. Things change, so configuration files may not be deleted and may be causing the issue you're having.

On 12/28/2015 at 0:35 PM, Mr Betelgeuse said:

Hey Ven, do you have any configs or plans to make this compatible with CTT (Community Tech Tree)? I ask this because the parts are are unlocked in really weird orders. The Reliant is unlocked before the Dachshund, even though the Dachshund is suppose to be unlocked before everything else (at least that's what the description says). 

Also, like I said a week ago, the auto tank butts don't work.

I don't have any plans of adding support for CTT, But If someone submits a config for it on github, then it'll be included.

Auto-tank butts were nuked from orbit because of how annoying they behaved and looked. They may (or may not) return in the future.

Share this post


Link to post
Share on other sites
39 minutes ago, Ven said:

Its supposed to be two different styles with three lengths each. The Utility ladders prices seem to have gotten swapped at some point (or more likely, the +PART{} entries got switched around and I entered the values in the wrong order).

Make sure that you delete the entire VSR folder when you install a new version. Things change, so configuration files may not be deleted and may be causing the issue you're having.

Well, I tried that and it worked... kind of. The Mk II and Mk I still have their prices swapped, but whatever. For 175 spesos I'll make my own ladder.

 

Two new questions:

1. Why is the Dachsund still in general rocketry, and not basic rocketry like its flavor text would imply it should be?

2. Since the pruner still doesn't work, is it possible to get a version of this pack with just the new parts that doesn't overwrite Squad textures? Much as I love the Ven ones, having both is killing my memory usage and causing overflow errors every time I return to the space center.

3 (bonus question). Is there any way to change these things myself? I tried deleting everything but the parts bin, and it destroyed the LVT-15 Dachsund, the LV-900 Beagle and the NT-5R Shiba.

Edited by Hlothwig
for clarity

Share this post


Link to post
Share on other sites
41 minutes ago, Ven said:

Those are such hot bugs though... Actually, I'm now claiming that their intentional.:sticktongue:

(all kidding aside, they are indeed intentional).

Its supposed to be two different styles with three lengths each. The Utility ladders prices seem to have gotten swapped at some point (or more likely, the +PART{} entries got switched around and I entered the values in the wrong order).

Make sure that you delete the entire VSR folder when you install a new version. Things change, so configuration files may not be deleted and may be causing the issue you're having.

I don't have any plans of adding support for CTT, But If someone submits a config for it on github, then it'll be included.

Auto-tank butts were nuked from orbit because of how annoying they behaved and looked. They may (or may not) return in the future.

With your permission, can I create the CTT configs for you? 

Share this post


Link to post
Share on other sites
9 hours ago, Ven said:

Those are such hot bugs though... Actually, I'm now claiming that their intentional.:sticktongue:

(all kidding aside, they are indeed intentional).

:mad:

At the very least, I am stubborn enough to dig into the old version to retrieve and plug in the blueish textures. Your new sharper maps will not draw me to the Dark Side!

Seriously, though. The all-black panels don't exactly fit with the NF Solar pack's progression. Nor do they make for as cool a picture.

Share this post


Link to post
Share on other sites

Having issues with the LV-909, no sound and no plume, but engine works. This is annoying as its the best engine I can use ATM for my manned orbital missions.

Share this post


Link to post
Share on other sites

Hey guys I made some really quick CTT (Comunity Tech Tree) Patch for this pack!

Only a few things have changed, and I moved only a couple stock things around so that some of Ven's parts work.

Things like the Dachhound engine are unlocked before the relient, and a couple changes with the SRBs. Most of the changes are in the early game, but the rest is fine. The Mk2VA cockpit is also unlocked before the MK2 (stock) cockpit, and the 2.5m Nova Nuclear engine is unlocked after the current 1.25m nuclear engine. 

To install, make sure you have CTT already installed, then just move the "CTTPatch.cfg" into 'Gamedata/CommunityTechTree/Tree'

Hopefully Ven might include it, maybe not. 

If there's any problems or suggestions, just tell me and I'll try my best to work and fix them. 

Download

Edited by Mr Betelgeuse

Share this post


Link to post
Share on other sites

seems as though the LV-900 is also bugged, it has sounds, but the plume is misplaced

 

277D63827E19813BB5ED32230D349F2F55597EC5

Share this post


Link to post
Share on other sites

Having some troubles with the Materials Bay. It will attach radially, but float several meters away from the central part I'm trying to attach it to. I'm seeing this on a fresh install, Ven's is the only installed mod. I searched through the thread and wasn't able to find others experiencing this. Lemme know if there's a fix in the .cfgs (where I suspect it would be, but can't figure it out), or elsewhere. Thanks, all.

zlNuUSW.png?1

Share this post


Link to post
Share on other sites
5 hours ago, vctr said:

Having some troubles with the Materials Bay. It will attach radially, but float several meters away from the central part I'm trying to attach it to. I'm seeing this on a fresh install, Ven's is the only installed mod. I searched through the thread and wasn't able to find others experiencing this. Lemme know if there's a fix in the .cfgs (where I suspect it would be, but can't figure it out), or elsewhere. Thanks, all.

zlNuUSW.png?1

Perhaps dividing the radial attach node by 10? I think I reset the scale value some time ago...

Share this post


Link to post
Share on other sites
On 12/31/2015 at 2:13 AM, Sovek said:

seems as though the LV-900 is also bugged, it has sounds, but the plume is misplaced

 

277D63827E19813BB5ED32230D349F2F55597EC5

I'm not seeing any of the issues mentioned with either engine under a very, very heavily modded install... Do you have HotRockets or RealPlume installed? I've seen others have issues in the past with something missing whether it be SmokeScreen, specific HotRocket configs, or the stock RealPlume addition.

Almost everything installed has been touched in some way though, whether it be texture conversion, reduction, Custom MM configs to fix personal gripes, etc. So, it may have been accidentally fixed in my install but I highly doubt it..

Share this post


Link to post
Share on other sites

I've been using this mod for a long time, and each update is better than the previous one. This one has some bugs, but the quality of the textures is just amazing. I love the black solar pannels, and also look more realistic. Keep doing what you are doing, Ven! :D

Share this post


Link to post
Share on other sites
18 hours ago, Mods_o_joy said:

also why are all of the solar panels non retractable

Because SQUAD decided so :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.