TriggerAu

[1.7.x] Transfer Window Planner v1.7.1.0 (August 19)

Recommended Posts

On 25/02/2017 at 2:07 AM, Jebs_SY said:

You can click COPY DETAILS and then in the mod "Precise Maneuver" paste the values and then you have the node created. But is your orbit is not perfectly 100x100km with 0.00° inclination, some small fine tuning needs to be done.

huh... it might be more useful the other way around then. By that I mean, the ability to plan the manoeuvre and have this mod, in real time, displaying efficiency, time etc, on the visualisation thingy :)

or can this mod plan transfers based on the current vessels exact position/orbit?

Edited by MR L A

Share this post


Link to post
Share on other sites

Are there plans to make TWP compatible with Kronometer to support scaled systems?

Or, is there a way I can change to day length myself? I'm running 2.5x with a 10 hour day.

Thanks!

Share this post


Link to post
Share on other sites

Having the same problem - TWP and KAC seems to incompatible with Kronometer.

@Sigma88 says he'd be happy to help making those three work together.

Share this post


Link to post
Share on other sites
2 hours ago, Barcel said:

says he'd be happy to help making those three work together.

this is wildly paraphrased :0.0:

Share this post


Link to post
Share on other sites
5 hours ago, Likasombodee said:

Does this work with RSS? I've been trying to figure out the web app and how to calculate Delta-V from Earth to Mars.

Yes. The plugin works with any planet pack or rescale. It reads all the orbit information from the in-game database.

The web app is completely separate. For a rough guide to delta-V try a delta-V map instead - e.g. this one

Edited by Aelfhe1m
Extra info

Share this post


Link to post
Share on other sites

Hey there,

Is there anyway to manually reset what date the transfer window planner thinks it is?

It started off fine, and now it is off by about a couple years making it fairly annoying to use. 

For example, the current actual game date is year 40 day 92, and the planner by default looks for a window starting from year 38 day 156. 

 

It was working perfectly fine originally.

I am using Galileo’s planet pack, but no rescale mods. It seems like this mod is internally tracking the time separately from the actual game time and when warping there is some very small error being introduced over time that causes the two to diverge. 

Share this post


Link to post
Share on other sites
On 2/7/2018 at 9:27 AM, MechBFP said:

Hey there,

Is there anyway to manually reset what date the transfer window planner thinks it is?

It started off fine, and now it is off by about a couple years making it fairly annoying to use. 

For example, the current actual game date is year 40 day 92, and the planner by default looks for a window starting from year 38 day 156. 

 

It was working perfectly fine originally.

I am using Galileo’s planet pack, but no rescale mods. It seems like this mod is internally tracking the time separately from the actual game time and when warping there is some very small error being introduced over time that causes the two to diverge. 

Have you solved this? You might want to ask in the GPP forum.

Share this post


Link to post
Share on other sites
On 2018-02-15 at 8:49 AM, Tyko said:

Have you solved this? You might want to ask in the GPP forum.

Actually it resolved itself. Simply restarting the game (or computer) fixed it. Don’t know why it got screwed up during that session, but haven’t ran into the issue again. 

The only issue I have now is that the Transfer Window Planner and KAC times don’t match up. I posted this in the KAC thread as well, but haven’t heard back from anyone. The problem is that whenever I set an alarm through the planner, it always alarms in KAC 4 days too early. The transfer window shows the correct departure date but for some reason makes the KAC alarm 4 days earlier. 

Edited by MechBFP
A stupid amount of autocorrect typos.

Share this post


Link to post
Share on other sites
39 minutes ago, MechBFP said:

Actually it resolved itself. Simply restarting the game (or computer) fixed it. Don’t know why it got screwed up during that session, but haven’t ran into the issue again. 

The only issue I have now is that the Transfer Window Planner and KAC times don’t match up. I posted this in the KAC thread as well, but haven’t heard back from anyone. The problem is that whenever I set an alarm through the planner, it always alarms in KAC 4 days too early. The transfer window shows the correct departure date but for some reason makes the KAC alarm 4 days earlier. 

The alarm defaults to 24 hours early, which in KSP is 4 days. It's in the TWP settings window, somewhere in the dropdowns. Click everything and you'll find it, sometimes the dropdown lists look like title bars of sections.

I personally set it to 0 time before, because I care more about when it actually is, than getting an alarm for it.

Share this post


Link to post
Share on other sites
On 2018-02-27 at 8:39 PM, 5thHorseman said:

The alarm defaults to 24 hours early, which in KSP is 4 days. It's in the TWP settings window, somewhere in the dropdowns. Click everything and you'll find it, sometimes the dropdown lists look like title bars of sections.

I personally set it to 0 time before, because I care more about when it actually is, than getting an alarm for it.

Thanks mate! Don’t know how I missed that before!

Share this post


Link to post
Share on other sites
Album PVbX75Q.png will appear when post is submitted

First time using this. Everything looks right, except I think my orbit is opposite of what Transfer Window wants. How can I know what side to orbit for moons/planets to make Transfer window right? In this case it's obvious I need quickload and reverse orbit, but I don't wanna do that 50/50 game every time I'm gonna use this. Please let me know if I've made other mistakes.

 

BTW, is there a manual? Greyed out on website.

Edited by kerbini

Share this post


Link to post
Share on other sites

You don’t have to use the guide, but if want to then you can always launch to the east to get the correct orbit. Otherwise just put your manevour node on the exact opposite side of where the guide says (which is a bit difficult mind you to eyeball). 

Edited by MechBFP

Share this post


Link to post
Share on other sites
19 hours ago, MechBFP said:

You don’t have to use the guide, but if want to then you can always launch to the east to get the correct orbit. Otherwise just put your manevour node on the exact opposite side of where the guide says (which is a bit difficult mind you to eyeball). 

@MechBFP So, in my case (61.9 + 180) mod 360 = 241,9°. I really don't see how my prograde and normal ejection would turn out correctly though, are you sure? And wouldn't this mess with ejection time?

Anyway, when you say always launch to east, does that mean always insert/intercept a planet from behind instead of ahead of it's orbit?

Edited by kerbini

Share this post


Link to post
Share on other sites
22 minutes ago, kerbini said:

@MechBFP So, in my case (61.9 + 180) mod 360 = 241,9°. I really don't see how my prograde and normal ejection would turn out correctly though, are you sure?

Anyway, when you say always launch to east, does that mean always insert/intercept a planet from behind instead of ahead of it's orbit?

For the first part, I just mean put your manevour node on that opposite spot and then manually play around with the handles manually. You will have to use the anti-normal handle instead (or vice-versa) though in that case for inclination change because those end of being the opposite value.  

To make sure you are going the “right” way (a prograde orbit), your orbital inclination should be 0 degreees. If you are going the “wrong” way, then it will be -180 degrees (a retrograde orbit). 

The easiest way to think about this is that from the map view the “top” of the planet is north, so your ship should always be travelling from the west *towards the east*. Does that make sense?

Edit: Unless you are off by days, the ejection time isn’t that crucial. If you are off by 2 or 3 hours, for example, the difference is completely negligible. 

Edited by MechBFP

Share this post


Link to post
Share on other sites

Yeah I have a KER tab for inclination stuff, and I get what ur saying is orbit towards east, but I don't know what east and west is when I'm arriving into orbit of another planet. That's why I'm asking if the rule of thumb is always to insert behind it's orbit (or does that not work for all planets)?

Since I usually always get into Mun orbit from it's front.

Edited by kerbini

Share this post


Link to post
Share on other sites
11 minutes ago, kerbini said:

Yeah I have a KER tab for inclination stuff, and I get what ur saying is orbit towards east, but I don't know what east and west is when I'm arriving into orbit of another planet. That's why I'm asking if the rule of thumb is always to insert behind it's orbit (or does that not work for all planets)?

Since I usually always get into Mun orbit from it's front.

You get what I mean if I say the top of the planet is north right? (When viewed from the map view). 

I am aware directions like this are a bit silly as they don’t apply properly to space, but it should give you a bit of a bearing at first, especially because the map view doesn’t rotate 360 degrees and forces the top of the planet to always be the north  

In any case, you want to insert behind the planets orbit to be going the right way. 

Share this post


Link to post
Share on other sites

I also forgot to mention that launching eastwards from Kerbin is more efficient because you are going in the same direction as the rotation of the planet. You end up saving a few hundred delta V. 

So it is perfectly possible to do an interplanetary transfer from a retrograde orbit, there is no point because it is inefficient with no benefits. 

Edited by MechBFP

Share this post


Link to post
Share on other sites

I can never get transfer window from Mun to Minmus right. Is it broken?

Share this post


Link to post
Share on other sites

@cpx Look very closely at the direction it is giving u, which is also why I'm having trouble with it. I really wish there was a setting @TriggerAu that would deny plots requiring reversal of orbit. "x° to/from prograde/retrograde", you never know if your orbit is going in the right direction beforehand.

I was told to always insert behind planets orbit for alignment with this mod, but that doesn't seem to be the case.

Edited by kerbini

Share this post


Link to post
Share on other sites

I broke it.

 

0XXJe7p.jpg

Anyone know off the top of their heads if this is a 1.4+ issue, or did I do something?  The fact this is also affecting Kerbal Alarm Clock (but KAC is actually working, aside from the icons being whited out) suggests to me it's missing a folder, but I went digging and the icons are there in the files soo...  I'm stumped.

Originally installed via CKAN, I have uninstalled both, reinstalled both with CKAN, and re-reinstalled them manually with no change.  I've tried removing other mods one at a time as well, no luck so far.

Edited by Kyrt Malthorn
clarification

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.