flywlyx

[1.8.x]GN Drive from Mobile Suit Gundam 00

Recommended Posts

Of note for those of you trying out the latest KSP version using the 1.3.0 version of this mod:

When using the GN Drive, GN Drive Tau, and Condenser Frame a very bright and flashing light object will pop into existence in the builder and then proceed to flicker like a mofo. I don't know if/when the creator will be back, nor how to fix this problem, but we can hold out hope. He's come back miraculously when I've posted before, so I'm certain he'll come back and deliver us from this possible seizure inducing problem.

Edited by DonKalypso

Share this post


Link to post
Share on other sites

This sooooooo needs to be fixed the flashing strobe lights are so annoying and its a bummer since this basically is my favorite mod. plz, Original Owner of this mod fixes it. or give it to someone else so they can fix it or Someone make a new GN Drive mod and add the Non-energy version the Ptolemaios has. if anyone is interested in a new GN-Drive mod and has the technical know-how id be happy to help, a mod adding the Ahab Reactor could also be cool. wolf out.

 

Edited by TheRedWolf2099

Share this post


Link to post
Share on other sites

A friend and I were lamenting how the inability to time accelerate during an engine burn nerfs ion engines.  He started talking about hand modding my install to boost their TWR,  and asking if anyone had done similar mods. 

I couldn't help but smile when I told him of this mod.  He laughed when I explained when you slap a Mk1 Cockpit on a GN Drive,  push the throttle to the firewall, activate Trans Am and hit that staging button...  It was a brief, pointed lesson in the dangers of atmospheric heating. :-)

I do miss this mod.

Share this post


Link to post
Share on other sites

I don't think there is another mod out there anything like this, and this is perfect for SciFi vessels and Star Trek like vessels. I was going to have a look inside the latest source files,  but I cannot find them anywhere.

Share this post


Link to post
Share on other sites
18 hours ago, DonKalypso said:

@TheKurgan When you say "Source files" are you referring to simply the mod folders and data therewithin? If so I might be able to send you a copy.

The source files would be the 3D object files in Blender, Autodesk Maya, etc format...the Unity projects...and the C# files for the plugin.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

Hey, just out of curiosity, is it possible to disable the particle effects that prevent this from being used in versions of KSP beyond 1.3.1? If so, how would one go about doing that?

Thanks in advance!

Share this post


Link to post
Share on other sites

@Vectorv12 unfortunately not, BUT there is another solution.

I still use this, and here is how. 

Delete the parts and ships folders, basically keeping only the Plugins and Resource folders.

Make a new engine, using a Squad model. As long as you are NOT copying the model, and only using it... basically linking to it, you're fine.

For example, in the spoiler below, I the Squad Ion Engine as the model, but rescaled it 2x .

Spoiler

PART
{
    name = AntiGravityEngine
    module = Part
    author = NovaSilisko

MODEL
    {
        model = Squad/Parts/Engine/ionEngine/model
    }    
    
    rescaleFactor = 2
    
    node_stack_top = 0.0, 0.2135562, 0.0, 0.0, 1.0, 0.0, 0
    node_stack_bottom = 0.0, -0.1872844, 0.0, 0.0, -1.0, 0.0, 0
    TechRequired = Experimental Motors
    entryCost = 16800
    cost = 8000
    category = Engine
    subcategory = 0
    title = Anti Gravity Engine
    manufacturer = KTech
    description = Standard issue anti gravity device. Can also propel you forward!!
    attachRules = 1,1,0,0,0
    mass = 0.25
    dragModelType = default
    maximum_drag = 0.2
    minimum_drag = 0.2
    angularDrag = 2
    crashTolerance = 7
    maxTemp = 2000 // = 3600
    bulkheadProfiles = size0
    tags = engine
    
    RESOURCE
    {
        name = GNparticle
        amount = 6000
        maxAmount = 6000
    }
MODULE
{
    name = ModuleGenerator
    isAlwaysActive = true

    OUTPUT_RESOURCE
    {
        name = ElectricCharge
        rate = 5
    }
}

MODULE
    {
        name = GNdrive
        fuelefficiency = 1
        particlegrate = 8000
    }
MODULE
    {
        name = FXModuleAnimateThrottle
        animationName = colorAnimation
        dependOnEngineState = false
        responseSpeed = 0.5
        dependOnThrottle = True
    }
    EFFECTS
    {        
        IonPlume
        {
            AUDIO
            {
                channel = Ship
                clip = sound_IonEngine
                volume = 0.0 0.0
                volume = 0.05 0.20
                volume = 1.0 0.25
                pitch = 0.0 0.2
                pitch = 1.0 0.8
                loop = true
            }
            //MODEL_MULTI_PARTICLE
            //{
            //    modelName = Squad/FX/IonPlume
            //    transformName = thrustTransform
            //    emission = 0.0 0.0
            //    emission = 0.25 0.5            
            //    emission = 1.0 1.0
            //    speed = 0.0 0.0
            //    speed = 1.0 1.0
            //    localPosition = 0, 0, 0.12
            //}
        }
    }
}
 

 

Edited by TheKurgan

Share this post


Link to post
Share on other sites

@TheKurgan Ooooh, that's clever!

So just to make sure I understand correctly, what exactly did you do? Did you edit the .cfg files of one of the GN drives?

Also, does the GN Drive still function as intended?

Share this post


Link to post
Share on other sites

@Vectorv12

Basically I deleted all of the engine parts out of the Squad ion drive config, then added this:

    RESOURCE
    {
        name = GNparticle
        amount = 6000
        maxAmount = 6000
    }
    MODULE
    {
        name = ModuleGenerator
        isAlwaysActive = true

        OUTPUT_RESOURCE
        {
            name = ElectricCharge
            rate = 5
        }
    }

    MODULE
    {
        name = GNdrive
        fuelefficiency = 1
        particlegrate = 8000
    }
 

 

And yes, it still functions exactly like the GNdrive in the mod.

Oh, and particlegrate is the regeneration rate of the GNparticle... default is 1000, I made it 8000, so you never run out of GNparticle.

Make it 1000 if you want to keep it exactly the same... I did this because I do not use the GNcap (the GNparticle generator in the mod)

Edited by TheKurgan

Share this post


Link to post
Share on other sites

@TheKurganAhh, I see. Thank you.

I noticed that you commented out the effect line in the Squad file - would it be possible for me to just comment out the effects and leave everything else intact?

Share this post


Link to post
Share on other sites
19 minutes ago, Vectorv12 said:

would it be possible for me to just comment out the effects and leave everything else intact?

If you are talking about the .cfg files in this mod, then no, the effects from the drives in this mod are coming from the model itself.

I commented the particle effects out of the edited Squad ion drive file just as a personal preference for this specific application.

What I posted above in the spoiler is the complete .cfg file for a working GN Drive... or as I called it an Anti Gravity drive.

Copy ALL of that into a txt file, and save it as something like what I called it AGdrive.cfg and dump it in your gamedata folder somewhere. 

Edited by TheKurgan

Share this post


Link to post
Share on other sites
On 8/30/2018 at 6:06 PM, JadeOfMaar said:

The source files would be the 3D object files in Blender, Autodesk Maya, etc format...the Unity projects...and the C# files for the plugin.

I missed that reply... :)

Yes, what I am mostly interested in, is the source files for the plugin.

@flywlyx any chance on making the latest source files for the plugin available?

Edited by TheKurgan

Share this post


Link to post
Share on other sites

@flywlyx Thanks!!

I have not loaded it up yet, but looking at the code, it looks as if the Hover function has been fixed :)

Edited by TheKurgan

Share this post


Link to post
Share on other sites
1 hour ago, TheKurgan said:

@flywlyx Thanks!!

I have not loaded it up yet, but looking at the code, it looks as if the Hover function has been fixed :)

It is still not working perfectly, please feel free to suggest anything.

Share this post


Link to post
Share on other sites

Running into a bit of an issue with the latest release and using the KSP version 1.5.1, it seems as soon as any of the modules are activated the GN particles immediately deplete and kill the engine. Any idea on whats causing it?

Share this post


Link to post
Share on other sites
On 9/7/2014 at 3:09 PM, Mekan1k said:

... What happens if you put two on a vessel?

it will become 00 QAN(T) GUNDAM

Share this post


Link to post
Share on other sites
On 9/7/2014 at 3:09 PM, Mekan1k said:

... What happens if you put two on a vessel?

it will become 00 QAN(T) GUNDAM

1.6 compatibe??

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.