katateochi

KerbalX.com - Craft & Mission Sharing

Recommended Posts

On August 6, 2016 at 5:05 AM, katateochi said:

By the way @Mycroft, your Leviathan is now the heaviest craft on the site and is in the top 3 for most expensive!
top 3 most expensive craft | top 3 most massive craft 

Well, I can't say I'm extremely surprised by the expensive part, as a few quick calculations (Siri) revealed that the Leviathan costs over 17 times my entire career mode budget. I was kinda miffed to discover how common the name Leviathan is on the site, as I built mine as a microscopic scale rough model of a ridiculously huge space battleship I dreamed up 5 years ago. As for the mass, I'm not sure, but I may end up beating my own record soon here. I have so much trouble building small, and so much fun building huge that I really get carried away, I guess. I really should get a computer that's better than my 06 MacBook Pro. 

Anyway, I really appreciate everything you've done on that site and I just cannot thank you for your dedication and sacrifice enough.

Saaayyy..... I was just looking at the 'Tower of defense' (I think that's the  name) and WOOOOOOOOO NELLY!!! That's four times as expensive as my Leviathan!! I am floored! And I thought I was bad with glamorous, overly expensive and massive craft!!

Share this post


Link to post
Share on other sites
1 hour ago, Mycroft said:

I used the profile picture feature to upload a logo for CMAU Incorporated, and I find that it seemingly randomly deletes my profile picture.

It looks like you've got a profile pic in place, or did you mean the signature pic? The profile pic just takes an image url whereas the signature takes markdown so change your sig to:

[img:http://i.imgur.com/hocgYtQ.jpg]
or if you want it centered
[center][img:http://i.imgur.com/hocgYtQ.jpg][/center]

If it's the profile pic that's not working, post the image url you're having issues with here (and any steps that you take that lead up to it being deleted) and I'll have a look. Setting the profile pic seems to be working from here, so maybe it's an issue with that specific image. 

Share this post


Link to post
Share on other sites
5 hours ago, katateochi said:

It looks like you've got a profile pic in place, or did you mean the signature pic? The profile pic just takes an image url whereas the signature takes markdown so change your sig to:


[img:http://i.imgur.com/hocgYtQ.jpg]
or if you want it centered
[center][img:http://i.imgur.com/hocgYtQ.jpg][/center]

If it's the profile pic that's not working, post the image url you're having issues with here (and any steps that you take that lead up to it being deleted) and I'll have a look. Setting the profile pic seems to be working from here, so maybe it's an issue with that specific image. 

I was talking about my profile picture. Yes, my profile picture is currently up. I am aware of that. So last night, I was visiting my profile, checking for typos, when I saw that my profile picture was gone AGAIN. So I re-uploaded it, and came straight to this thread to tell you. I don't know why this is happening, and I don't know if it's happened to anyone else, or if I'm just cursed, but figured that you'd want to know. How about this? The next time this happens, I won't re-upload my profile picture, instead I'll tell you on the forums, and you can maybe check it out? (Of course, this means that now the site will not delete my profile picture) 

Thanks for your tip about the signature pic! I wil definitely try it.

Share this post


Link to post
Share on other sites
3 minutes ago, Mycroft said:

I don't know why this is happening, and I don't know if it's happened to anyone else, or if I'm just cursed

It might be down to caching on the CDN resulting in a delay before you see changes. Also if it happens again, try clearing your browser's cache. And yeah, if it appears to have been deleted just leave it and let me know and then I can see if it's actually reset the url on your account and if the picture is present or not. 

Share this post


Link to post
Share on other sites

Funny, it just happened. I juuust got the craft signature working, and I hit save on my profile, and boom! My profile picture is gone again! I think that entering the editor for anything on the profile page (like the links at the top to edit various things) a certain number of times, like two or three within a certain time frame might be what's triggering it? Maybe? I really don't know, but that's when it seems to happen. Do you still see the profile picture? Or is it just me?

Share this post


Link to post
Share on other sites
18 hours ago, Mycroft said:

Or is it just me?

No! It was a bug (actually a really stupid derp on my part. the picture url was being reset if you changed anything other than the profile picture. So it was fine if you set the picture last and then didn't change anything else, but if you edited any other part of your profile after then the pic got reset. doh!) Anyway, should be fixed now. 

Share this post


Link to post
Share on other sites
5 hours ago, katateochi said:

No! It was a bug (actually a really stupid derp on my part. the picture url was being reset if you changed anything other than the profile picture. So it was fine if you set the picture last and then didn't change anything else, but if you edited any other part of your profile after then the pic got reset. doh!) Anyway, should be fixed now. 

Yes! Thank you so much!

Share this post


Link to post
Share on other sites

@siliconworm that mod kinda breaks convention by being installed into the Squad folder which makes it hard to determine that it's a separate mod (unless it was on CKAN). If it was available via CKAN then the KerbalX CKAN parser would pick it up as a separate mod.  
I could force a change in the knowledge base, but the knowledge base would gradually unlearn that change and it would go back to seeing them as part of Squad(stock). I really don't want to get into having to have a manual list of parts-to-mods because that becomes a maintaining hell for me to make sure it stays up to date as mods change.  One of the things about KerbalX is it figures all that out for itself (and while that's not 100% it's not far off the mark, and better than having to maintain that data).

The best thing to do would be to request the mod developer makes their mod available on CKAN. Or at least to package it so that it lived in it's own folder (in which case the KX PartMapper would pick up on that after a few (5) people had run it).  

Share this post


Link to post
Share on other sites
4 hours ago, katateochi said:

@siliconworm that mod kinda breaks convention by being installed into the Squad folder which makes it hard to determine that it's a separate mod (unless it was on CKAN). If it was available via CKAN then the KerbalX CKAN parser would pick it up as a separate mod.  
I could force a change in the knowledge base, but the knowledge base would gradually unlearn that change and it would go back to seeing them as part of Squad(stock). I really don't want to get into having to have a manual list of parts-to-mods because that becomes a maintaining hell for me to make sure it stays up to date as mods change.  One of the things about KerbalX is it figures all that out for itself (and while that's not 100% it's not far off the mark, and better than having to maintain that data).

The best thing to do would be to request the mod developer makes their mod available on CKAN. Or at least to package it so that it lived in it's own folder (in which case the KX PartMapper would pick up on that after a few (5) people had run it).  

For what my vote is worth: I agree with not going out of your way to support a mod that is clearly doing things wrong. Mod parts do not belong in the Squad folder, period. So even that first option is not really a solution, they need to repackage the mod correctly in their own folder and keep it out of the stock Squad one.

Share this post


Link to post
Share on other sites

So....We just hit

10,000
Craft Hosted!!

Wooooo! 
(well, it's 10,000 if you include the ones without pictures, 8859 excluding ones without pics, but yeah, 10,000!).
That's awesome guys! The site has been live for 710 days, so that's an ave of 14 craft a day posted. And so many of them are just epic!  I can honestly say I've not enjoyed building/running a site as much as I've enjoyed this. I love seeing what everyone posts and you guys are the best community to work with. 
Does anyone else flip back through some of the older KSP versions (or just invert the sort filter) and look at how designs have changed? I like doing that sometimes, and as this collection grows it's going to become an interesting archive of how both the game and our designs have changed.  

So....I'm wondering about taking the "beta" badge off the site.  I've got a pretty big performance optimization coming soon (next week or so) to speed up page loads and craft upload times and try and push the memory usage down.  Assuming I don't break anything with that (I have re-written about 70% of the logic for processing craft files, so....?) maybe it will be time to take it out of beta?  tbh it won't mean anything will change, I'll still be considering ways to improve it and add to it. oh...and I may have to log you all out again at some point in the next month cos I'm not totally happy with the recent change I made to managing sessions but I need to do more tests on that. 

Share this post


Link to post
Share on other sites
13 hours ago, katateochi said:

So....I'm wondering about taking the "beta" badge off the site.

I was wondering this same thing just a few days ago. I honestly think 'beta' does not fit the site properly anymore: it has been doing its job for a good while now, all the main functionality has been working, it deserves to be 'release'.

Congrats on the milestone!

Share this post


Link to post
Share on other sites

Wow! That's impressive! Congrats on the milestone! 

As I'm sure you can guess, I actually have another bug report. The site is incorrectly listing my 'most downloaded' crafts. It has decided that the first craft I uploaded is one of them, even though it's not, and one other seemingly random craft, when if you look at the actual number of downloads for each of my 10 crafts, only two of the 'most downloaded' actually fit that description. 

I feel bad that pretty much every time @katateochi has a big, cool announcement, I come in and rain on the parade with a bug report. Really sorry.

Meanwhile, the milestone is really cool, and I would agree that the beta tag is not necessary. Thanks for your hard work and positive attitude, @katateochi!

Share this post


Link to post
Share on other sites
2 hours ago, Mycroft said:

I come in and rain on the parade with a bug report. Really sorry.

No sorry needed! honestly, I like bug reports! They help make things better. 

Though this isn't so much a bug, but maybe something that's not clearly stated. (I presume we're talking about the "most downloaded craft" section on your profile page).  It's technically correct title could be "Most downloaded craft which aren't also shown in the most recently uploaded craft", but that's rather clunky! 
So even though your Aurora is your second most downloaded it's not shown in that list because it's also shown in the recently uploaded list. My thinking here being it's better to have more of your craft shown on that page than to have one (or more) craft appearing twice. So your top 4 are; Leviathan (23), Aurora (10), Bomber B-3 (10), Twin Engine Delta Wing Fighter (7), but Aurora is in the other list so the AA Battery 1 (4) get's a look in. 
It will also sort itself out as time goes on and you upload more craft. I guess I could flip the selection around so it gets the 4 most downloaded first, then the 4 most recently uploaded which aren't also in the 4 most downloaded. But I think this way puts more of your "top" craft on that page ("top" being simply a measure of download count).  

Share this post


Link to post
Share on other sites
1 minute ago, katateochi said:

No sorry needed! honestly, I like bug reports! They help make things better. 

Though this isn't so much a bug, but maybe something that's not clearly stated. (I presume we're talking about the "most downloaded craft" section on your profile page).  It's technically correct title could be "Most downloaded craft which aren't also shown in the most recently uploaded craft", but that's rather clunky! 
So even though your Aurora is your second most downloaded it's not shown in that list because it's also shown in the recently uploaded list. My thinking here being it's better to have more of your craft shown on that page than to have one (or more) craft appearing twice. So your top 4 are; Leviathan (23), Aurora (10), Bomber B-3 (10), Twin Engine Delta Wing Fighter (7), but Aurora is in the other list so the AA Battery 1 (4) get's a look in. 
It will also sort itself out as time goes on and you upload more craft. I guess I could flip the selection around so it gets the 4 most downloaded first, then the 4 most recently uploaded which aren't also in the 4 most downloaded. But I think this way puts more of your "top" craft on that page ("top" being simply a measure of download count).  

That makes sense! Thanks!

Share this post


Link to post
Share on other sites

Got a quick typo report: If you have parts that are unrecognized like OPT, then it says: "Note - Not all the parts of this craft where detected”. Should be were.

Share this post


Link to post
Share on other sites

Just deployed a minor(ish) update.  No new features, just a whole bunch of optimisations.  Rewrote a large chunk of the logic for processing craft files so uploading craft should be faster. Various other tweaks all over the place to improve page loading times and reduce memory usage.  There is still something else to do on that front but that's not ready yet. 

Minor change to the stats graphs on the dashboard and craft stats pages. Mostly they just load faster, but also on the dashboard it defaults to the last month of activity rather than all activity, but you can still view that and the control for selecting the range is simpler/nicer. 

I've totally broken the list of all your comments page (ie /katateochi/comments), but it was kinda borked anyway as it was trying to load all comments and their replies in one go.  I'll fix that soon (I don't think anyone even looked at that page anyway). Otherwise comments/replies are working as usual. oh and the comments text field should now auto-resize as you type (as well as not overflowing off the bottom of the page as it was before). 

Lots of changes in lots of places so I'm sure I've broken something! So let me know if you spot anything weird! :wink:

Share this post


Link to post
Share on other sites
3 hours ago, katateochi said:

So let me know if you spot anything weird!

Other than craft, you mean? KerbalX is like the home of weird... that's what we use it for. :D

Share this post


Link to post
Share on other sites

I would be interested to hear some stuff on this: 

What is your favorite thing about KerbalX (aside from the obvious fact that it allows you to share crafts free)?

I'll start: My favorite is how open and personable @katateochi is.

Share this post


Link to post
Share on other sites

It makes the whole process of uploading, showcasing and sharing a craft simple and easy. And it does this for the other side too: searching/browsing and downloading, which don't even need registering.

Very rare thing these days for a website to just be simple and effective at their intended task.

(* from the viewpoint of the user; I recognize that sometimes, making it look simple requires a lot of complex code).

Share this post


Link to post
Share on other sites

@siliconworm hmmm, interesting! I shall look into that negative mass/cost issue (That is a very tiny craft!!) and the vid url problem. (I'm away today though, so prob won't have a chance until tomorrow or the weekend).


 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.