Jump to content

KerbalX.com - Craft & Mission Sharing


katateochi
 Share

Recommended Posts

On 5/22/2021 at 2:57 PM, Lady Vikki said:

Question: if I create a new part mod, how do I get KerbalX to recognise when I upload (or someone else uploads) a craft containing parts from that mod?

On 5/22/2021 at 3:17 PM, swjr-swis said:

Use the KerbalX CraftManager mod to upload your craft. It will automatically update the KerbalX database with any new parts it sees.

https://kerbalx.com/CraftManager

As far as I know, KerbalX's part↔mod mapping is generated from CKAN metadata by this script, not from user uploads of crafts:

(I had to look into it to submit a fix for it at https://github.com/Sujimichi/KerbalX/pull/37, which hopefully will get reviewed and merged someday.)

There's a script to submit info at  https://kerbalx.com/partmapper, but the site implies that it takes a back seat to the CKAN-sourced data:

https://kerbalx.com/about

Quote

These days KerbalX also uses CKAN to get info about mods, but not all mods are listed by CKAN, so KerbalX still needs it's users to run the part mapper tool and provide info.

So I think the answer to the original question is: Get your mod listed on CKANor (ask your users to) run the KerbalX partmapper script and submit the data.

Edited by HebaruSan
Link to comment
Share on other sites

19 minutes ago, HebaruSan said:

So I think the answer to the original question is:

.. some of the pages haven't been updated in a while, and still refer to now-superseded things.

Link to comment
Share on other sites

33 minutes ago, swjr-swis said:

.. some of the pages haven't been updated in a while, and still refer to now-superseded things.

If anything I said above has been superseded, that could potentially be great, but unfortunately this craft still has "Airship Pirates KSP Modpack" instead of BDArmory, which indicates that the bug that I was fixing in the pull request I linked is still there:

OK, I clicked around a bit more, and while the main page of the craft shows the old, wrong mod list, clicking "Mods" brings up what looks like a more accurate list (or at least, it has BD Armory Continued instead of Airship Pirates KSP Modpack):

YJWYkNa.png

So may have been fixed after all, hooray! Now if only that "download ckan meta-file" link would work...

Edited by HebaruSan
Link to comment
Share on other sites

  • 2 weeks later...

I'm receiving an error trying to load my latest craft file. First it will let me attempt to upload and it takes around 15 minutes for it to finally load after uploading but will not show the picture of the file. Tried this around 2 am CST. Finally went though around 2:30ish. Pictures would not load on the page. I tried to update the file but received application error message  refreshed page this morning still missing thumbnail and then somehow my craft got deleted?

 

Trying to reupload now but still is hanging when trying to upload craft. Getting a application error message again.  The craft file size is bigger than most of my normal craft so i'm not sure if that's the problem? at 2,887 KB File goes though fine on steam

Still getting 500 error message and it fails every time now. 

 

Also to edit the post. I have cleared all cache and cookies and other site data just to be sure and even tried to download the kraft uploader and get the exact same message on chrome browser. Not sure what's going on. Tired to upload another craft file that was smaller just to see and getting the same error message. 

9CPlMRU.jpg

0j4kTb1.jpg

This was the title image that refused to load 

wfVD6gs.jpg

but yeah kind of sad i can't get this craft to the masses.

When I try and re upload i get this message 

DOtPuCr.jpg

when I click continue with your previous craft I end up with this page next.

JrGRZOH.jpg

I try and start the process over again I'm back again at it hanging trying to scan file.

 

Update: Was able to download Kerbal X uploader and the other required file in CKAN, Website still not working for me

 

Uploaded the craft file but images still not loading up. (at least on my end) Not sure if file is corrupted like the last time.. My steam workshop file is working just fine.  

Edited by InterstellarKev
Link to comment
Share on other sites

6 hours ago, InterstellarKev said:

The craft file size is bigger than most of my normal craft so i'm not sure if that's the problem? at 2,887 KB File goes though fine on steam

Still getting 500 error message and it fails every time now. 

Hi there. Thank you for reporting this. I'm glad to see you already succeeded in uploading this craft in the mean time.

There's a complicated update ongoing at the moment, and very limited RL opportunity to tend to it. There's a slightly higher chance than usual of site errors or services needing to be restarted. In almost all cases though, it's a temporary error and you just need to retry a bit later for it to work.

Link to comment
Share on other sites

7 hours ago, swjr-swis said:

Hi there. Thank you for reporting this. I'm glad to see you already succeeded in uploading this craft in the mean time.

There's a complicated update ongoing at the moment, and very limited RL opportunity to tend to it. There's a slightly higher chance than usual of site errors or services needing to be restarted. In almost all cases though, it's a temporary error and you just need to retry a bit later for it to work.

Yep Its all  good for now! Thank you. Will be releasing more craft later on this week! thanks again.

Link to comment
Share on other sites

  • 1 month later...
4 hours ago, Admiral Fluffy said:

Bug Report: This craft is stock, but it reports it as modded. For some reason it says the stock stuff is modded.  Anything you can do?

https://kerbalx.com/Admiral_Fluffy/Xenon-Spacecraft

Apparently, the engine plate is not being recognized as part of the DLC, and considered part of a mod called 'squadexpansion'. I notice there are another 5 parts where it does the same thing. Not sure how or why this happened, but this might need to be manually adapted in the KX part database. Thank you for pointing this out.

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Running into an issue here: When installing the Craft Manager mod from KerbalX over Ckan it also needs the KXAPI mod, which is subsequently also installed. However, this leads to some issues as KatLib.dll is included in both Craft Manager and KXAPI, which means the same DLL is being loaded twice, which is marked as a potentially gamebreaking problem by KspAVC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...