• 0
Sign in to follow this  
Dieter_G

Strut-Connectors to Boosters take Rocket off-balance, why ?

Question

Hi there,

I found something strange to which I have no explanation :

I build a (Test-)Rocket using two SRBs mounted on radial decouplers. To prevent the Boosters from skewing I added one strut-connector for each booster (see images). The problem now is, that the version WITH strut-connectors will lean to one side during flight and wants to tilt while the version WITHOUT strut-conns won't.

I now try to figure out and understand why this is the case. Please note that my primary interest ist NOT to find a solution (like using two struts on each booster), but to understand why it is the case.

Before answering, please consider the following :

-The struts I use are perfectly aligned. They are exactly perpendicular to the fuel-Tank and do point exactly to the center of the each booster. I did this by adjusting the .craft file.

Thought I could have made a mistake symetrising the struts, the behaivior was the same with normally placed struts (as good as can be done by eye).

-The two Rockets are identical (apart from the struts) . I "generated" the Rocket without struts by removing them from the one with struts, so everything else should be unchanged.

-The struts work by tension, not by pressure, so they should self-align.

Previously I had the struts at the top, where they work by pressure. The effect was the same but there was an explanation for that : Because they are just a point-to-point connection they cannot

absorb torque. By "pressing" at the fuel-tank from both sides, they made the tank to elude to one side (you know what I mean?)

Here are the images (3 per Rocket) : The upper ones is with struts, tilting to the left during flight; The lower ones is without struts, going straight up

wWKNS13.jpg6OSLjmw.jpg

Edited by Dieter_G

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

For boosters, I'll strut a ring at top and bottom, plus a diag strut upwards diagonally to the next stage above.

Basically the booster "ring" then falls off cleanly when staging, no tendancy for them to then rotate and hit the stage continuing onwards, or its engines...

Share this post


Link to post
Share on other sites
  • 0

Struts don't actually get their physics loaded. Similar to the radial batteries, RCS ports and RCS engines, their mass, drag etc has no effect on the ship. So, in theory, the struts should not be doing anything to make the ship lean. Unless if they patched the physics calculation in the .24.2 bug squash... But the struts should not actually be having any effect. Although it shows up as moving the CoM (if you place a lot) it shouldn't have any actual effect on the craft. Shouldn't. I'm not saying I'm right here, I'm just saying what I know.

Share this post


Link to post
Share on other sites
  • 0

Okay, I didn't say much earlier because I didn't have the time to take proper pictures.

Personally, I think you guys are applying a little too much real world physics to KSP. Remember, it's still a simulation. It's subject to finite slices of time and developer coded orders of preference when it comes to physics. (Unlike the real world, where everything happens at the same time on an infinitesimal timeline).

So (based on what I know about decouplers) I think what's happening is that the physics for the struts and the decouplers are not being applied at the same time. So the end result is some asymmetric push/pull on the connections. Yes, some level of angles and torque applies, but I think this particular oddity is due to the physics application when the parts are in line.

For example, as you'll see in the slides below, I can direct connect the SRBs (surface mount) them to the core fuel tank, then apply a strut at the bottom. This is basically the same design, just less bendy without the decoupler in the way. The rocket flies straight as an arrow. You can substitute other less bendy parts in here and the "turning" effect is less than with a regular decoupler.

For the second two pictures, I put the decoupler back but included two struts between each booster and the core fuel tanks. One strut at the top and one at the bottom. If there were true torque, the parts would still twist around the horizontal axis that runs along the SRB/core fuel tank plane. I know that in the pictures the struts are angled, but I tested them flat and angled both directions. I think having two connection points between the SRB and core fuel tank prevents some of the oddities of when physics is applied on each frame.

Javascript is disabled. View full album

And just to really bake your noodle, give this method a try. This is why I say perhaps too much real physics thought is being applied to this simulation oddity. (Yes, that is just one strut on each SRB.)

qw7OeGR.jpg

Just my √0.02

Cheers,

~Claw

Share this post


Link to post
Share on other sites
  • 0

Seriously, these "issues" or "bugs" are absolutely negligible in 99% of cases. The remaining 1% are cases when your space station starts resonating and either self-destructs or at least destroys its solar arrays. I don't see them fixed in the game anytime soon, there are other, much more important things to do and fix.

Ok, this may be your opinion, but for sure isn't mine. From my experience, when designing a rocket I get most of the simple designs done without any problems of strange behavior. Lastly however, all new designs suffered strange penomenons (because they were bigger, had more parts). So what you claim to be just 1% looks more like 80% to me.

Also, it seems like a lot of other people are experiencing problems with larger designs. Most often they then put on loads of struts (some of which likely make things even worse, see later post) and RCS-Trusters in order to get the beast back under control. I think if these issues were fixed, people would 1.) experience a much more steady and comprehensible behaiviour of their rockets 2.) be able to realise a lot more designs wich are made impossible/hindered by strange bugs now.

Just one more example. This one needs the lower boosters to be connected with struts (as is in left image) because otherwise the boosters are spread apart by the weigth (right image)

sobTDBR.jpgdslro4d.jpg

The problem now is that having the struts attached results in perpetual wobbling/resonance of the boosters making the rocket uncontrollable.

Funnily, the central three tanks are also connected by struts but don't expose that behavior. Instead they start perpetual wobbling (till destruction) when the struts are removed (I used the central part of this rocket as a previous example). Now, where is the logic ? How should I plan for a next design ?

Resembling real physics (at least its fundamentals, NOT down to 1% accuracy of course) is at the heart of this game. I'll let em get away with second-class graphics, I'll let them get away with second-class sound but not with second-class physics.

Edited by Dieter_G

Share this post


Link to post
Share on other sites
  • 0

@ToTheMun

I don't understand completely. What does "not getting theirs physics loaded" mean ? You mean the thing with setting their 'PhysicsSignificance = 0', so then they don't have mass, drag ect. anymore ?

So basically what you are saying is that they don't account to the weight of the rocket ?

@RW-1, Claw

Yes struts at the top and the bottom seem to be the solution for this problem. See next post.

Ok, on my next two posts, I'll expose some astonishing properties of the struts. Be curious !

Share this post


Link to post
Share on other sites
  • 0

OK, after finding that this rocket (only one asymetrically placed strut at the top of each booster)

OX3jTg9.jpg

doesn't spiral, thought it should (similiar to your findings, Claw) and that ...

7GvGdK8.jpg

this piece of crap (one strut at bottom, two totally asymetrical at top for each booster) goes straight "as an arrow", even with SAS disabled (!!!)...

I decided to give up using rockets to get an understanding of the behavior of the struts. Instead, I did set up some synthetical tests... [next post, may take an hour to complete]

Edited by Dieter_G

Share this post


Link to post
Share on other sites
  • 0

When I talk about these issues being negligible in 99% cases, I mean cases where the player takes care that the rocket will not spontaneously disassemble during use, particularly when deployed on launchpad or when launched. Struts are here exactly for that purpose. The rocket is like a tree, it branches out but never in, struts are here to keep these branches together. You don't need to use too many of them but you need to find places where to put them to do their job. If you do it right, all that's left will be some amount of wobble or roll that is no problem to compensate.

Things used to be way worse. Part connections we have today are rock solid compared to what used to be in game not even a year ago.

Share this post


Link to post
Share on other sites
  • 0

ok, I wanted to show my results but for some reason am to dumb to get the imgur-album embedded.

I got

<iframe class="imgur-album" width="100%" height="550" frameborder="0" src="//imgur.com/a/IT0T5/embed"></iframe>

Can someone tell me how to use that in order to have the album embedded in my post like with claws post ?

Edited by Dieter_G

Share this post


Link to post
Share on other sites
  • 0
Can someone tell me how to use that in order to have the album embedded in my post like with claws post ?

There's a link under the "BB code is on" message at the bottom of this page. Search for "imgur".

Share this post


Link to post
Share on other sites
  • 0

Ok, here are the results :

Javascript is disabled. View full album

First up, thats the Test setup. A tank attached to four launch stabiliser. Another tank (9t) is suspended to it with a number of small stack decouplers. As you may know these are very labile, highly compressible and highly strechable; to make it short they behave like a long and weak spring. They idea behind using them is to minimise their mechanical impact because lastly what I want to test, is a strut (but the game doesn't allow to mount the tank on a strut only - you know).

The test is based on the fact that initially (after going to the launch pad) the rocket is in kind of "stasis" where no gravity ect. is applied. After a few seconds, the "stasis" is voided and gravity applies. It is then, when the rockets "settles". With my slow computer I got about 5 seconds to quickly adjust the cam and take a first screenshot (entitled "before" in the images). I take a second one after gravity is applied (entitled "after" in the images).

So by comparing the two shots per setup you can see how the (single) strut is deformed by the weight of the tank.

Test 1 : no strut.

Here you can see how the decouplers alone are doing. The tank falls down, more or less, thought it is still barely hovering over ground in the end.

Test 2 : strut up.

Here the strut is mounted upwards to the tank. As you can see it is very strong, not bending visibly, just getting a bit compressed (shortened). The tank moves a bit to the left and maybe/most likely also a bit down. Unfortunately, the cam also moves a bit after "stasis" is voided, thus making it hard to judge about vertikal movement of the tank.

Test 3 : strut horizontally.

Ok, the strut can take an awful lot of torque, obviously. Its really awful, as the last two images will show...

But what is that ? It is still moving to the left, as if the strut was still beeing compressed and thus squeezed. That makes me really skeptikal. It shouldn't move to the left in this case, so here must be something wrong already. I think by analysing the cause of the tank moving to the left, one will find the bug.

Test 4 : strut down.

basically same as before. Tank moves to the left. With this setup, the movement to the left would be explainable by the strut beeing bend a little downwards, therby moving a bit on an arc (hope you know what I...), however, as the strut barely does bend, it looks to much.

Test 5 : strut even more downwards

at this point we get perpetual motion again.

Test 6 : see what a strut can take

Here you can see what a strut can take. Yes, gravity already applies ! The second image shows the poor stack decouplers alone. They seem to be overloaded :D

However, even thought the strut might look almighty here, it isn't. Put on more tanks and it does clearly bend.

last two images (Updated)

Here another issue/maybeBug : connecting a strut [to a decoupler] instead of [to the tank] weakens it significantly. Don't know if this is by intension. Could be related with above behavior thought, thats why I put it in.

Of course, again first of the two images is before gravity apllies, second one is after.

Now the conclusions (which aren't that conclusive at all) :

--------------------------------------------------------

1.)

At some point I thought the error was, that all forces (tensile or thrust) are handled as beeing thrust (even if they should be tensile) and thus the strut always was compressed, shortening it and thus moving the tank to the left all the time. However I failed in proving this with other setups. So it isn't exactly that but

>>> for some reason there are phantom forces compressing the strut in the horizontal setup (Test 3). Those are perhaps also the reason for the perpetual motion observed in Test 5<<<

I couldn't figure out what is going on in more detail, but there is something wrong. Maybe shear forces or torque is mistaken as compression or something weird.

2.)

The struts have properties that (I think) most people wouldn't have expected. Most importantly, they can be loaded with torque like hell. Not only do they withstand it, they are also very stiff and thus bend very little, even when subject to heavy loads. They are indeed much more stiff, than the "girder segment"(or whatever it is called). I think that will suprise many. Also they are much more stable than I would have expected. None did ever break during all testing.

Ok, enough for today.

c u

Edited by Dieter_G

Share this post


Link to post
Share on other sites
  • 0

I don't have these issues with my rockets. Seems like a Three Little Pigs problem, and you aren't using bricks.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this